Nano PC with Intel only in software rendering mode

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
podmok
Level 1
Level 1
Posts: 2
Joined: Sun Feb 10, 2019 10:47 am

Nano PC with Intel only in software rendering mode

Post by podmok » Sun Feb 10, 2019 11:08 am

I have a Foxconn Nano PC with the following spec:
inxi -Fxz

Code: Select all

System:    Host: Nano Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Cinnamon 3.6.7 (Gtk 2.24.30)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Foxconn product: nT-i2000 Series v: FAB 1.0
           Mobo: Foxconn model: nT-i2000 Series v: PCB 1.0
           Bios: American Megatrends v: 4.6.5 date: 11/28/2012
CPU:       Dual core Intel Celeron 847 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 4389
           clock speeds: max: 1100 MHz 1: 800 MHz 2: 800 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: fbdev,intel (unloaded: vesa)
           Resolution: 1920x1080@77.00hz
           GLX Renderer: llvmpipe (LLVM 6.0, 128 bits)
           GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:  (snip)
Drives:    HDD Total Size: 64.0GB (88.7% used)
           ID-1: /dev/sda model: C3000.6 size: 64.0GB
Partition: ID-1: / size: 55G used: 50G (95%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.18GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 87.0C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 211 Uptime: 3 min Memory: 1284.8/3844.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
I am using Linux Mint 10.3:

Code: Select all

lsb_release -a
No LSB modules are available.
Distributor ID:	LinuxMint
Description:	Linux Mint 18.3 Sylvia
Release:	18.3
Codename:	sylvia
and I have Intel-microcode drivers installed (Intel Celeron 847 @1.1 Ghz)

In /etc/default/grub
the setting

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
is found.

After an upgrade to 18.3 I was unable to boot the system into a graphic interface. Since then the system always notified me of Cinnamon running in software rendering mode. What could I do to switch hardware acceleration back on?

deepakdeshp
Level 12
Level 12
Posts: 4201
Joined: Sun Aug 09, 2015 10:00 am

Re: Nano PC with Intel only in software rendering mode

Post by deepakdeshp » Sun Feb 10, 2019 3:59 pm

Is 18.3 a fresh install? There is no upgrade path to 18.3 from your version.
A system requirements of lesser resources is XFCE.
Boot from the live USB of XFCE and Cinnamon and see which USB works with your configuration.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

podmok
Level 1
Level 1
Posts: 2
Joined: Sun Feb 10, 2019 10:47 am

Re: Nano PC with Intel only in software rendering mode

Post by podmok » Tue Feb 12, 2019 3:14 pm

This issue emerged after an update to 18.3 and messing with the graphic drivers after a blackscreen issue.

The PC works fine with all default Linux Mint installations on usb, I just wonder how to get back to a working install without software rendering and without a manual reinstall.

Post Reply

Return to “Graphics Cards & Monitors”