AMD GPU doesn't work properly with 4K monitor

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: AMD GPU doesn't work properly with 4K monitor

Post by roblm » Wed Aug 21, 2019 2:05 pm

You need to eliminate the software rendering problem first and then the tiled display problem may correct itself. I assume you’re seeing the software rendering if a different lower resolution monitor is connected?

What AMD graphics card is installed and did you update any firmware for it?

Use this command and copy the output: inxi -Fxz

Open the Mint Forum reply window and select </> at the top. Press Ctrl+V to paste the copied lines into a code display window.

Redsandro
Level 3
Level 3
Posts: 149
Joined: Sun Jul 17, 2011 6:40 pm
Contact:

Re: AMD GPU doesn't work properly with 4K monitor

Post by Redsandro » Thu Aug 22, 2019 5:24 pm

Hardware rendering works fine. Tile support does not work because of two bugs in Cinnamon:
Until the issues are fixed, I am looking for a workaround similar to nVidia's TwinView or xorg's Xinerama, but I can't get a proper desktop spanning two "monitors".
🤘 Amp.lol. No bloat, just radio.
Ninite-killer. 1000+ packages.

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: AMD GPU doesn't work properly with 4K monitor

Post by roblm » Thu Aug 22, 2019 7:08 pm

This is what you said in a previous post, so that’s why I assumed you were running in software rendering mode:
But due to bleeding edge hardware I need to run Kernel 5.2 (unofficial), and for TILE support I need to run amdgpu 19.0.1 (unofficial), and with these, Cinnamon crashes:
But the crash must only happen after using an xrandr command.

You need to post the previously requested output of inxi -Fxz, to test Xinerama.

Redsandro
Level 3
Level 3
Posts: 149
Joined: Sun Jul 17, 2011 6:40 pm
Contact:

Re: AMD GPU doesn't work properly with 4K monitor

Post by Redsandro » Fri Aug 23, 2019 5:50 am

@roblm I apologize for not being clear. I meant that with amdgpu 18, everything works fine except MST/Tile. With amdgpu 19, Cinnamon crashes to software mode.

Code: Select all

System:    Host: red Kernel: 5.2.0-050200rc7-generic x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Cinnamon 4.2.3 
           Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop Mobo: ASRock model: A300M-STX serial: <filter> UEFI: American Megatrends v: P3.50 date: 05/15/2019 
CPU:       Topology: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 type: MT MCP arch: Zen rev: 1 
           L2 cache: 2048 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 59199 
           Speed: 1402 MHz min/max: 1400/3700 MHz Core speeds (MHz): 1: 1386 2: 1262 3: 1392 4: 1382 5: 1397 6: 1260 7: 1399 
           8: 1389 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel bus ID: 05:00.0 
           Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa 
           resolution: 3840x2160~30Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.0-050200rc7-generic LLVM 8.0.0) v: 4.5 Mesa 19.0.8 direct render: Yes 
Sensors:   System Temperatures: cpu: 37.4 C mobo: N/A gpu: amdgpu temp: 37 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 375 Uptime: 19h 42m Memory: 29.44 GiB used: 4.38 GiB (14.9%) Init: systemd runlevel: 5 Compilers: 
           gcc: 7.4.0 Shell: bash v: 4.4.20 inxi: 3.0.32 
🤘 Amp.lol. No bloat, just radio.
Ninite-killer. 1000+ packages.

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: AMD GPU doesn't work properly with 4K monitor

Post by roblm » Fri Aug 23, 2019 12:12 pm

Use this command to create an xorg.conf file: sudo touch /etc/X11/xorg.conf
If the file already exists, then it should be removed first.

Open the file for editing: xed admin:///etc/X11/xorg.conf

Add these lines to enable Xinerama:

Code: Select all

Section "ServerLayout"      	
   Identifier     "Layout0"                                 
   Screen      0  "Screen0" 1920 0
   Screen      1  "Screen1" 0 0
EndSection

Section "ServerFlags"
   Option   "Xinerama" "true"
EndSection

Section "Monitor"
   Identifier     "DisplayPort-3"
EndSection

Section "Monitor"
   Identifier     "DisplayPort-4"
EndSection

Section "Device"
   Identifier     "Device0"
   Driver         "amdgpu"
   BusID          "PCI:5:0:0"
   Screen 0
EndSection

Section "Device"
   Identifier     "Device1"
   Driver         "amdgpu"
   BusID          "PCI:5:0:0"
   Screen 1
EndSection

Section "Screen"
   Identifier     "Screen0"
   Device         "Device0"
   Monitor        "DisplayPort-3"
   DefaultDepth    24
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "DisplayPort-4"
    DefaultDepth    24
EndSection
Logout and back in. If that doesn’t work, then remove the line Screen 0 from Section "Device" and try again. Then try removing the line Screen 1.

If there is a problem getting back to the desktop, then press Ctrl+Alt+F1 to enter virtual console tty1. Use this command to remove the xorg.conf file and reboot: sudo rm /etc/X11/xorg.conf; reboot

If you can't enter tty1, then press Ctrl+Alt+Delete to reboot and select Advanced options > Recovery Mode at the GRUB boot menu. If no menu shows, then hold down the Shift key while starting. In the menu, select “root - drop to root shell prompt ” and press ENTER. Press ENTER again.

Use this command to change the file permissions to read and write: mount -o remount,rw /

Remove the xorg.conf file and reboot: rm /etc/X11/xorg.conf; reboot

Post Reply

Return to “Graphics Cards & Monitors”