Screen flicker and black square around windows [Intel HD 520]

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
iRiKi
Level 1
Level 1
Posts: 2
Joined: Wed Jul 03, 2019 6:33 am

Screen flicker and black square around windows [Intel HD 520]

Post by iRiKi » Wed Aug 07, 2019 11:39 am

Hi there,

Just installed Linux Mint 19.1 Cinnamon in my company's laptop because I got tired after many years on winblows.

I'm having the exact same issues of the user in this thread --> viewtopic.php?t=284144
except the fact this lappy has an Intel card as opposed to Nvidia.

I've read the "How To Get Help!" thread, and also disabled all visual effects as well by using the tips in this link -->
https://easylinuxtipsproject.blogspot.c ... t.html#ID5

Here's inzi -Fxz output. Please let me know if you need more information.

Many thanks in advance!

Code: Select all

user@Latitude-E5570:~$ inxi -Fxz
System:    Host: gls-Latitude-E5570 Kernel: 4.18.0-14-generic x86_64 bits: 64 compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.10 
           Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: Dell product: Latitude E5570 v: N/A serial: <filter> 
           Mobo: Dell model: 0R3VX4 v: A00 serial: <filter> UEFI [Legacy]: Dell v: 1.3.8 date: 01/20/2016 
Battery:   ID-1: BAT0 charge: 46.1 Wh condition: 46.1/57.1 Wh (81%) model: Panasonic DELL 79VRK62 status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-6300U bits: 64 type: MT MCP arch: Skylake rev: 3 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19968 
           Speed: 2914 MHz min/max: 400/3000 MHz Core speeds (MHz): 1: 2914 2: 2920 3: 2964 4: 2927 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) v: 4.5 Mesa 19.0.2 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.18.0-14-generic 
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0 
           IF: wlp1s0 state: down mac: <filter> 
           IF-ID-1: vboxnet0 state: down mac: <filter> 
           IF-ID-2: wwp0s20f0u5i12 state: down mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 195.41 GiB (81.9%) 
           ID-1: /dev/sda vendor: LITE-ON model: L8H-256V2G-41 M.2 2280 256GB SED size: 238.47 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 233.73 GiB used: 195.41 GiB (83.6%) fs: ext4 dev: /dev/sda1 
Sensors:   System Temperatures: cpu: 52.0 C mobo: 47.0 C sodimm: 43.0 C 
           Fan Speeds (RPM): cpu: 2419 
Info:      Processes: 259 Uptime: 2d 23m Memory: 15.33 GiB used: 6.44 GiB (42.0%) Init: systemd runlevel: 5 Compilers: 
           gcc: 7.4.0 clang: 6.0.0-1ubuntu2 Shell: bash v: 4.4.20 inxi: 3.0.27 

iRiKi
Level 1
Level 1
Posts: 2
Joined: Wed Jul 03, 2019 6:33 am

Re: Screen flicker and black square around windows [Intel HD 520]

Post by iRiKi » Wed Aug 07, 2019 1:52 pm

Ok so.. I found the wiki regarding this laptop:

https://community.linuxmint.com/hardware/view/27792

which states:
What doesn't work:

Graphical glitches
OK but I will try.

- the issue only occurs in multi-display mode, and only on the right-hand screen.
- changed both hdmi cables (the laptop is connected to a docking station) and that also didn't help, the right-hand screen flickers when moving windows.
- also tried changing the primary display between left and right, no go.

I'll try chacing issues on Ubuntu as well over the next days and see if I can find a proper solution --> https://askubuntu.com/questions/1146236 ... ing-screen

Many thanks.

User avatar
Pjotr
Level 21
Level 21
Posts: 13726
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Screen flicker and black square around windows [Intel HD 520]

Post by Pjotr » Wed Aug 07, 2019 2:13 pm

Try this:

1. Disable all visual effects in Cinnamon:
https://easylinuxtipsproject.blogspot.c ... html#ID5.1
(item 5.1)

2. Update Manager - panel: View - Linux kernels
Install the latest kernel of the 5.0 series. Then reboot.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
absque fenestris
Level 6
Level 6
Posts: 1260
Joined: Sat Nov 12, 2016 8:42 pm
Location: Confoederatio Helvetica

Re: Screen flicker and black square around windows [Intel HD 520]

Post by absque fenestris » Wed Aug 07, 2019 3:13 pm

I attached an external monitor via HDMI/DVI adapter and a DVI cable to a Radeon graphics card.
In order to make the cable tangle clearer, I bought a HDMI to DVI cable: The result was not as good as before.

Experimentally I attached hinged ferrite magnets to both ends of this (very thin) HDMI cable - as with the DVI cable. Still not as good as the DVI cable, but better...

I wonder if some of the HDMI cables are simply inferior.
Linux Mint 18.3 Sylvia (Mate) 32-bit - Acer D250 Netbook (Intel Atom N270, 2 GB RAM, 120 GB SSD)
Linux Mint 17.3 Rosa (Mate) 64-bit - MacBook Pro 15" (Intel Core2 Duo, 8 GB RAM, 240 GB SSD) - with some separation difficulties...

bigdog
Level 1
Level 1
Posts: 3
Joined: Fri Aug 02, 2019 6:17 pm

Re: Screen flicker and black square around windows [Intel HD 520]

Post by bigdog » Thu Aug 15, 2019 4:48 pm

iRiKi wrote:
Wed Aug 07, 2019 1:52 pm



- the issue only occurs in multi-display mode, and only on the right-hand screen.
- changed both hdmi cables (the laptop is connected to a docking station) and that also didn't help, the right-hand screen flickers when moving windows.
- also tried changing the primary display between left and right, no go.

I'll try chacing issues on Ubuntu as well over the next days and see if I can find a proper solution --> https://askubuntu.com/questions/1146236 ... ing-screen

Many thanks.
I have a NVIDIA card and also notice the same problems on the right screen. I'm using DisplayPort or DVI cables and have swapped them both ports and displays and always seems to be the right screen.

Did you ever find a resolution to this? I posted about this too including an image but never got any replies about it.

Post Reply

Return to “Graphics Cards & Monitors”