How to install amdgpu-pro driver?

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
karozagorus
Level 1
Level 1
Posts: 5
Joined: Sat Aug 10, 2019 9:00 am

How to install amdgpu-pro driver?

Post by karozagorus » Sat Aug 10, 2019 10:51 am

Hey, I'm pretty new to driver setups, and I saw Linux Mint does not support AMD Pro drivers out of the box, and I really need that DX11-12 fix. I tried setting it up based on the installation tips from AMD but it have made my computer fail to start with a no signature error for the hardware and refused to boot for me. Had to reinstall and I really want to get the amdgpu-pro-driver to start up properly.

Any idea how I could get the Pro drives set up properly?
Last edited by karlchen on Sat Aug 10, 2019 10:58 am, edited 1 time in total.
Reason: split off from this thread https://forums.linuxmint.com/viewtopic.php?f=90&t=97158

deepakdeshp
Level 15
Level 15
Posts: 5655
Joined: Sun Aug 09, 2015 10:00 am

Re: How to install amdgpu-pro driver?

Post by deepakdeshp » Sat Aug 10, 2019 11:51 am

Please post output of

Code: Select all

 inxi -Fxz
command in code tags.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

karozagorus
Level 1
Level 1
Posts: 5
Joined: Sat Aug 10, 2019 9:00 am

Re: How to install amdgpu-pro driver?

Post by karozagorus » Sat Aug 10, 2019 11:58 am

deepakdeshp wrote:
Sat Aug 10, 2019 11:51 am
Please post output of

Code: Select all

 inxi -Fxz
command in code tags.

Code: Select all

System:
  Host: karo-Z87-D3HP Kernel: 5.0.0-23-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Gigabyte product: Z87-D3HP v: N/A serial: <filter> 
  Mobo: Gigabyte model: Z87-D3HP-CF v: x.x serial: <filter> 
  BIOS: American Megatrends v: F8c date: 03/29/2018 
CPU:
  Topology: Quad Core model: Intel Core i7-4770K bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 55870 
  Speed: 2228 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1782 2: 1722 
  3: 1525 4: 1841 5: 2184 6: 1888 7: 1709 8: 1798 
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X] 
  vendor: Sapphire Limited Nitro+ driver: amdgpu v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati,modesetting 
  unloaded: fbdev,radeon,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.27.0 
  5.0.0-23-generic LLVM 8.0.0) 
  v: 4.5 Mesa 19.0.2 direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-3: AMD Ellesmere [Radeon RX 580] vendor: Sapphire Limited 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-4: Kingston type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 3-9.4:7 
  Sound Server: ALSA v: k5.0.0-23-generic 
Network:
  Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e v: 3.2.6-k 
  port: f080 bus ID: 00:19.0 
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 2.50 TiB used: 1.70 TiB (68.0%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB 
  ID-3: /dev/sdc vendor: Seagate model: ST9500420AS size: 465.76 GiB 
Partition:
  ID-1: / size: 226.58 GiB used: 29.68 GiB (13.1%) fs: ext4 dev: /dev/dm-1 
  ID-2: /boot size: 703.5 MiB used: 227.0 MiB (32.3%) fs: ext4 
  dev: /dev/sda1 
  ID-3: swap-1 size: 979.5 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-3 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 41 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 761 
Info:
  Processes: 369 Uptime: 6h 06m Memory: 31.30 GiB used: 9.21 GiB (29.4%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32
Last edited by karlchen on Sat Aug 10, 2019 12:17 pm, edited 1 time in total.
Reason: enclosed the inxi report in [code] [/code] tags

deepakdeshp
Level 15
Level 15
Posts: 5655
Joined: Sun Aug 09, 2015 10:00 am

Re: How to install amdgpu-pro driver?

Post by deepakdeshp » Sat Aug 10, 2019 3:23 pm

If your card fits the latest cards and os here, you can install the AMD driver. https://www.amd.com/en/support/kb/relea ... -lin-18-20
Otherwise you have to make do with the open source drivers.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

karozagorus
Level 1
Level 1
Posts: 5
Joined: Sat Aug 10, 2019 9:00 am

Re: How to install amdgpu-pro driver?

Post by karozagorus » Sun Aug 11, 2019 2:12 am

deepakdeshp wrote:
Sat Aug 10, 2019 3:23 pm
If your card fits the latest cards and os here, you can install the AMD driver. https://www.amd.com/en/support/kb/relea ... -lin-18-20
Otherwise you have to make do with the open source drivers.
So, last time I followed that one, my card is a RX 580 so it should be supported, and the problem was that after installation it gave back a no signature error when I tried booting up and it didn't let me get in anyhow. And I suspect if I would follow the same method it would again occur to me. So could you point me anywher else with a more safe setup method so I can get the pro drivers going?

deepakdeshp
Level 15
Level 15
Posts: 5655
Joined: Sun Aug 09, 2015 10:00 am

Re: How to install amdgpu-pro driver?

Post by deepakdeshp » Sun Aug 11, 2019 1:06 pm

Try the Ubuntu section. You need to run Mint 19 or higher.
https://www.amd.com/en/support/previous ... eon-rx-580
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

karozagorus
Level 1
Level 1
Posts: 5
Joined: Sat Aug 10, 2019 9:00 am

Re: How to install amdgpu-pro driver?

Post by karozagorus » Sun Aug 11, 2019 1:38 pm

When I try installing the Pro variant, it gives back an "apt" command in the middle of the whole thing and then the installation stops. Any idea how to fix it?

User avatar
roblm
Level 10
Level 10
Posts: 3376
Joined: Sun Feb 24, 2013 2:41 pm

Re: How to install amdgpu-pro driver?

Post by roblm » Sun Aug 11, 2019 2:31 pm

Are you seeing the same output that user sampctech got in this post:
viewtopic.php?f=59&t=272074#p1515270

What command are you using for the AMDGPU-Pro installation? If it has the -y option in it, then that should be removed.

karozagorus
Level 1
Level 1
Posts: 5
Joined: Sat Aug 10, 2019 9:00 am

Re: How to install amdgpu-pro driver?

Post by karozagorus » Sun Aug 11, 2019 4:08 pm

Okay, I fixed it on kernel 5, 19.2

The latest driver for RX580 works the following way: it will screw up your computer either way and you will have to fix it. Here is the method:

Download files from AMD's website, add youself to the graphics group, it's in the main discussion group, and then install up the normal gpu driver and then remove it. Afterwards install via amdgpu-install --pro option and then if it arrives into CLI terminal, delete it with amdgpu-uninstall, delete again, restart and go into potato slow mode and then install the whole thing again and it will work. If you are stuck without signature on boot, reinstall the entire computer. It works for me now apparently, I hope it is the pro line!

Post Reply

Return to “Graphics Cards & Monitors”