Black screen after a .run install script of nvidia driver

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Black screen after a .run install script of nvidia driver

Post by Svetlana » Tue Aug 13, 2019 10:53 pm

Hi

Sorry for mistakes, I'm on my smartphone

So I tried to install nvidia driver with a .run script found on nvidia site. I followed this tutorial:

https://linuxconfig.org/how-to-install- ... linux-mint

Part "Manual Install using the Official Nvidia.com driver"

But now I have a black screen :/

So what can I do to fix that ? And to install correctly a driver for my quadro k610M ?

Thanks for your help

Edit: the .run script is "NVIDIA-Linux-x86_64-418.88.run"

Edit2: I can boot without black screen now thanks after these commands: "sudo apt remove --purge nvidia*", "sudo apt install nvidia-driver-390", "sudo apt remove --purge nvidia*" again and "sudo apt install xserver-xorg-video-nouveau" but my only one available resolution is 960*540

Edit3: Now it's ok for resolution thanks to the thom's answer here: https://askubuntu.com/questions/377937/ ... resolution

Edit4: To save new resolution after reboot, the answer here: https://askubuntu.com/questions/754231/ ... ith-xrandr, in my side, I used Ben Mares's solution
Last edited by Svetlana on Thu Aug 15, 2019 6:18 pm, edited 1 time in total.

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

nvidia driver doesn't work

Post by Svetlana » Wed Aug 14, 2019 12:53 am

Hi,

As you can see, I tried to install nvidia drivers instead of Nouveau ( viewtopic.php?f=208&t=299757 ). But it doesn't seem to work.

Indeed, first I did this command:

Code: Select all

sudo ubuntu-drivers autoinstall
But when I rebooted, I had a black screen

Then, I tried this command to know which driver to install manually:

Code: Select all

$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd000012B9sv0000103Csd00001909bc03sc00i00
vendor   : NVIDIA Corporation
model    : GK208GLM [Quadro K610M]
driver   : nvidia-340 - distro non-free
driver   : nvidia-driver-390 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin


So, I tried to install "nvidia-driver-390" then "nvidia-340" but, again, I had a black screen for the both drivers so I don't have solution anymore :(

Thanks for your help :)

Svetlana
Level 1
Level 1
Posts: 12
Joined: Tue Aug 13, 2019 10:45 pm

Re: Black screen after a .run install script of nvidia driver

Post by Svetlana » Thu Aug 15, 2019 6:18 pm

I found this and it's work for me !

https://ubuntuforums.org/showthread.php ... ia+drivers

Warning: verify your driver's version to install ! ( you can check with "ubuntu-drivers" )
In my case, it was 390 instead of 430

Post Reply

Return to “Graphics Cards & Monitors”