Mint 19.1 MATE stuck at low resolution on VIA graphics

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
mintoo1
Level 1
Level 1
Posts: 7
Joined: Fri Aug 23, 2019 2:28 am

Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by mintoo1 » Fri Aug 23, 2019 2:38 am

Help needed!

I installed Mint mate 19.1 from usb stick to new hdd on kinda old pc medion akoya e5010 which originally had vista installed. All seems to work fine just graphic is stuck at 640x480. It has onboard graphic which details you can see below. Now Im not sure how to fix this issue.


E5010:~$ inxi -G
Graphics:
Device-1: VIA CN896/VN896/P4M900 [Chrome 9 HC] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: fbdev
unloaded: modesetting,vesa resolution: 640x480~73Hz
OpenGL: renderer: llvmpipe (LLVM 8.0 128 bits) v: 3.3 Mesa 19.0.8

User avatar
catweazel
Level 19
Level 19
Posts: 9216
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by catweazel » Fri Aug 23, 2019 3:04 am

mintoo1 wrote:
Fri Aug 23, 2019 2:38 am
Help needed!

I installed Mint mate 19.1 from usb stick to new hdd on kinda old pc medion akoya e5010 which originally had vista installed. All seems to work fine just graphic is stuck at 640x480. It has onboard graphic which details you can see below. Now Im not sure how to fix this issue.


E5010:~$ inxi -G
Graphics:
Device-1: VIA CN896/VN896/P4M900 [Chrome 9 HC] driver: N/A
Display: x11 server: X.Org 1.19.6 driver: fbdev
unloaded: modesetting,vesa resolution: 640x480~73Hz
OpenGL: renderer: llvmpipe (LLVM 8.0 128 bits) v: 3.3 Mesa 19.0.8
viewtopic.php?t=258712
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

mintoo1
Level 1
Level 1
Posts: 7
Joined: Fri Aug 23, 2019 2:28 am

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by mintoo1 » Sun Sep 01, 2019 11:05 am

Had no clue how to do search about it, thanks. Adding vga=792 (which is 1024x768) into grub conf file did partly the trick

well image is still not perfectly clear as is with higher resolution (tried with 1280x1024; image is very clear but ofcourse right and below screen is cut out), since screen is 16:9 image is just a bit horizontaly streched in 1024x768... is it posible to get it stretched for a few pixels somehow or use that higher res. to shorten cut out space since 1024x768 feels to zoomed??

User avatar
roblm
Level 10
Level 10
Posts: 3385
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by roblm » Sun Sep 01, 2019 11:32 am

Install hwinfo to find out if any resolutions with a 16:9 aspect ratio are supported by your GPU using the vesa driver:
apt install hwinfo

Then use this command and post the output: sudo hwinfo --framebuffer
Last edited by roblm on Mon Sep 02, 2019 9:19 am, edited 1 time in total.

mintoo1
Level 1
Level 1
Posts: 7
Joined: Fri Aug 23, 2019 2:28 am

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by mintoo1 » Sun Sep 01, 2019 1:06 pm

Hope this can help!?

Code: Select all

 
 
 root@pc-E5010:~# sudo hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.QstqgPARaQB
  Hardware Class: framebuffer
  Model: ""
  Vendor: ""
  Device: ""
  SubVendor: "VIA N3364"
  SubDevice: 
  Revision: ""
  Memory Size: 0 MB
  Memory Range: 0x00000000-??? (rw)
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0371: 720x480 (+720), 8 bits
  Mode 0x0373: 720x480 (+1440), 16 bits
  Mode 0x0375: 720x480 (+2880), 24 bits
  Mode 0x03b9: 720x540 (+720), 8 bits
  Mode 0x03ba: 720x540 (+1440), 16 bits
  Mode 0x03bb: 720x540 (+2880), 24 bits
  Mode 0x037c: 720x576 (+720), 8 bits
  Mode 0x037e: 720x576 (+1440), 16 bits
  Mode 0x037f: 720x576 (+2880), 24 bits
  Mode 0x042e: 800x480 (+800), 8 bits
  Mode 0x042f: 800x480 (+1600), 16 bits
  Mode 0x0430: 800x480 (+3200), 24 bits
  Mode 0x0303: 800x600 (+800), 8 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits
  Mode 0x0422: 852x480 (+864), 8 bits
  Mode 0x0423: 852x480 (+1728), 16 bits
  Mode 0x0424: 852x480 (+3456), 24 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x0325: 1280x720 (+1280), 8 bits
  Mode 0x0326: 1280x720 (+2560), 16 bits
  Mode 0x0327: 1280x720 (+5120), 24 bits
  Mode 0x0379: 1280x768 (+1280), 8 bits
  Mode 0x037a: 1280x768 (+2560), 16 bits
  Mode 0x037b: 1280x768 (+5120), 24 bits
  Mode 0x03b6: 1280x800 (+1280), 8 bits
  Mode 0x03b7: 1280x800 (+2560), 16 bits
  Mode 0x03b8: 1280x800 (+5120), 24 bits
  Mode 0x033f: 1280x960 (+1280), 8 bits
  Mode 0x034f: 1280x960 (+2560), 16 bits
  Mode 0x036a: 1280x960 (+5120), 24 bits
  Mode 0x0307: 1280x1024 (+1280), 8 bits
  Mode 0x031a: 1280x1024 (+2560), 16 bits
  Mode 0x031b: 1280x1024 (+5120), 24 bits
  Mode 0x0383: 1366x768 (+1376), 8 bits
  Mode 0x0384: 1366x768 (+2752), 16 bits
  Mode 0x0385: 1366x768 (+5504), 24 bits
  Mode 0x033b: 1400x1050 (+1408), 8 bits
  Mode 0x033c: 1400x1050 (+2816), 16 bits
  Mode 0x033e: 1400x1050 (+5600), 24 bits
  Mode 0x0411: 1440x900 (+1440), 8 bits
  Mode 0x0412: 1440x900 (+2880), 16 bits
  Mode 0x0413: 1440x900 (+5760), 24 bits
  Mode 0x0320: 1600x1200 (+1600), 8 bits
  Mode 0x0322: 1600x1200 (+3200), 16 bits
  Mode 0x0324: 1600x1200 (+6400), 24 bits
  Mode 0x032b: 1680x1050 (+1680), 8 bits
  Mode 0x032c: 1680x1050 (+3360), 16 bits
  Mode 0x032d: 1680x1050 (+6720), 24 bits
  Mode 0x0366: 1920x1080 (+1920), 8 bits
  Mode 0x0367: 1920x1080 (+3840), 16 bits
  Mode 0x0368: 1920x1080 (+7680), 24 bits
  Mode 0x0346: 1920x1200 (+1920), 8 bits
  Mode 0x0348: 1920x1200 (+3840), 16 bits
  Mode 0x0349: 1920x1200 (+7680), 24 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown
 
 

User avatar
roblm
Level 10
Level 10
Posts: 3385
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by roblm » Sun Sep 01, 2019 1:23 pm

Change vga=792 in the grub file to vga=283 and then update grub: sudo update-grub

Use this command to create an xorg.conf file: sudo touch /etc/X11/xorg.conf

Open the file for editing: xed admin:///etc/X11/xorg.conf

Add these lines:

Code: Select all

Section "Monitor"
   Identifier    "Monitor0"
   HorizSync       30.0 - 81.0	   
   VertRefresh     56.0 - 76.0
 EndSection

Section "Device"
   Identifier   "Device0"
   Driver   "vesa"   			
EndSection

Section "Screen"
   Identifier   "Screen0"
   Device   "Device0"
   Monitor   "Monitor0"
   DefaultDepth   24
EndSection
Reboot.

If there is a problem getting back to the desktop, then press Ctrl+Alt+F1 to enter virtual console tty1. Use this command to remove the xorg.conf file and reboot: sudo rm /etc/X11/xorg.conf; reboot

mintoo1
Level 1
Level 1
Posts: 7
Joined: Fri Aug 23, 2019 2:28 am

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by mintoo1 » Sun Sep 01, 2019 1:53 pm

roblm wrote:
Sun Sep 01, 2019 1:23 pm
Change vga=792 in the grub file to vga=283 and then update grub: sudo update-grub

Use this command to create an xorg.conf file: sudo touch /etc/X11/xorg.conf

Open the file for editing: xed admin:///etc/X11/xorg.conf

Add these lines:

Code: Select all

Section "Monitor"
   Identifier    "Monitor0"
   HorizSync       30.0 - 81.0	   
   VertRefresh     56.0 - 76.0
 EndSection

Section "Device"
   Identifier   "Device0"
   Driver   "vesa"   			
EndSection

Section "Screen"
   Identifier   "Screen0"
   Device   "Device0"
   Monitor   "Monitor0"
   DefaultDepth   24
EndSection
Reboot.

If there is a problem getting back to the desktop, then press Ctrl+Alt+F1 to enter virtual console tty1. Use this command to remove the xorg.conf file and reboot: sudo rm /etc/X11/xorg.conf; reboot
OK, .done..seems hotizontal stretch is now fixed but somehow verticaly is now stretched for one ~px...

User avatar
roblm
Level 10
Level 10
Posts: 3385
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by roblm » Sun Sep 01, 2019 2:17 pm

mintoo1 wrote:seems hotizontal stretch is now fixed but somehow verticaly is now stretched for one ~px...
Is the image filling the entire screen? Use these commands and post the output: inxi -Gx and xvidtune -show

mintoo1
Level 1
Level 1
Posts: 7
Joined: Fri Aug 23, 2019 2:28 am

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by mintoo1 » Sun Sep 01, 2019 2:53 pm

roblm wrote:
Sun Sep 01, 2019 2:17 pm
mintoo1 wrote:seems hotizontal stretch is now fixed but somehow verticaly is now stretched for one ~px...
Is the image filling the entire screen? Use these commands and post the output: inxi -Gx and xvidtune -show
yeah, screen is filled ok and not cut out anywhere...its just that mentioned vertical stretch...

Code: Select all

pc@pc-E5010:~$ inxi -Gx
Graphics:
  Device-1: VIA CN896/VN896/P4M900 [Chrome 9 HC] vendor: Mitac driver: N/A 
  bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: vesa resolution: 1280x720~N/A 
  OpenGL: renderer: llvmpipe (LLVM 6.0 128 bits) v: 3.3 Mesa 18.0.5 
  direct render: Yes 
pc@pc-E5010:~$ xvidtune -show
"1280x720"      0.00   1280    0    0    0    720    0    0    0



User avatar
roblm
Level 10
Level 10
Posts: 3385
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by roblm » Sun Sep 01, 2019 3:32 pm

mintoo1 wrote:its just that mentioned vertical stretch...
Do you mean the image looks stretched excessively vertically? For example, an icon doesn' t look square?

The inxi output lists a 1280x720 resolution is being used now for the laptop's screen, which is a 16:9 aspect ratio.

mintoo1
Level 1
Level 1
Posts: 7
Joined: Fri Aug 23, 2019 2:28 am

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by mintoo1 » Sun Sep 01, 2019 3:42 pm

roblm wrote:
Sun Sep 01, 2019 3:32 pm
mintoo1 wrote:its just that mentioned vertical stretch...
Do you mean the image looks stretched excessively vertically? For example, an icon doesn' t look square?

The inxi output lists a 1280x720 resolution is being used now for the laptop's screen, which is a 16:9 aspect ratio.
yes exactly...does vertical refresh in xorg.conf file above might change that somehow???

User avatar
roblm
Level 10
Level 10
Posts: 3385
Joined: Sun Feb 24, 2013 2:41 pm

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by roblm » Sun Sep 01, 2019 4:20 pm

mintoo1 wrote:...does vertical refresh in xorg.conf file above might change that somehow???
I don’t think that will help, but you can try changing the line VertRefresh 56.0 - 76.0 to VertRefresh 56.0 - 60.0


One problem is that the 1280x720 mode is not a standard VESA mode. See this article:
https://en.wikipedia.org/wiki/VESA_BIOS ... de_numbers

However, this info is mentioned:
vga=864 [ 352 (0160h)] also appears to select 1,280×800 (8-bit) for various laptops' displays.
So try switching vga=283 to vga=864. But that’s only 8-bit color, so if that corrects the vertical stretching, then try using vga=867 for 24-bit color.

mintoo1
Level 1
Level 1
Posts: 7
Joined: Fri Aug 23, 2019 2:28 am

Re: Mint 19.1 MATE stuck at low resolution on VIA graphics

Post by mintoo1 » Mon Sep 02, 2019 2:49 am

roblm wrote:
Sun Sep 01, 2019 4:20 pm
mintoo1 wrote:...does vertical refresh in xorg.conf file above might change that somehow???
I don’t think that will help, but you can try changing the line VertRefresh 56.0 - 76.0 to VertRefresh 56.0 - 60.0


One problem is that the 1280x720 mode is not a standard VESA mode. See this article:
https://en.wikipedia.org/wiki/VESA_BIOS ... de_numbers

However, this info is mentioned:
vga=864 [ 352 (0160h)] also appears to select 1,280×800 (8-bit) for various laptops' displays.
So try switching vga=283 to vga=864. But that’s only 8-bit color, so if that corrects the vertical stretching, then try using vga=867 for 24-bit color.

tried booth..unfortunatelly issue remains ...hunt for solution continues 😤

images of issue:
Imagepicture1


Imagepicture2

Post Reply

Return to “Graphics Cards & Monitors”