Performance decrease after upgrading to 19.2 from 19.1

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
greendye
Level 1
Level 1
Posts: 1
Joined: Sun Sep 01, 2019 10:25 pm
Location: Canada

Performance decrease after upgrading to 19.2 from 19.1

Post by greendye » Mon Sep 02, 2019 8:18 pm

After upgrading my old laptop to LM 19.2 MATE from 19.1, I've noticed decreased graphics performance. It's especially noticeable in VLC while watching videos stored on the hard drive. Videos that played smoothly in 19.1 are now dropping lots of frames in 19.2. The glmark2 benchmark also shows a decrease to 70 from 114.

I initially suspected an issue with the Intel video driver, so I booted into the previously installed kernel version, but the performance is the same. The only other thing that comes to mind is the Mesa version which was 18.0.5 prior to the update and is now 19.0.8.

If it's possible, should I try downgrading Mesa? Is there anything else I should try before doing a full rollback to 19.1?

Inxi:

Code: Select all

System:
  Host: Toshiba Kernel: 4.15.0-58-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: MATE 1.22.0 Distro: Linux Mint 19.2 Tina 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Other-vm? System: TOSHIBA product: Satellite L300 v: PSLB0C-07P08C 
  serial: <filter> 
  Mobo: Intel model: N/A serial: <filter> BIOS: INSYDE v: 1.40 
  date: 05/28/2008 
Battery:
  ID-1: BAT0 charge: 75.5 Wh condition: 75.5/94.4 Wh (80%) 
  model: PA3534U-1BRS status: Unknown 
CPU:
  Topology: Dual Core model: Intel Core2 Duo T5750 bits: 64 type: MCP 
  arch: Core Merom rev: D L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 bogomips: 7980 
  Speed: 1092 MHz min/max: 1000/2000 MHz Core speeds (MHz): 1: 1092 2: 1011 
Graphics:
  Device-1: Intel Mobile GM965/GL960 Integrated Graphics 
  vendor: Toshiba America Info Systems driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1280x800~60Hz 
  OpenGL: renderer: Mesa DRI Intel 965GM v: 2.1 Mesa 19.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel 82801H HD Audio vendor: Toshiba America Info Systems 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-58-generic 
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Toshiba America Info Systems RTL8102E PCI-E driver: r8169 
  v: 2.3LK-NAPI port: 4000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Intel PRO/Wireless 4965 AG or AGN [Kedron] Network 
  driver: iwl4965 v: in-tree: port: 4000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 232.89 GiB used: 27.52 GiB (11.8%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS542525K9SA00 size: 232.89 GiB 
Partition:
  ID-1: / size: 91.17 GiB used: 27.52 GiB (30.2%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 151 Uptime: 12m Memory: 2.92 GiB used: 696.9 MiB (23.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 

Post Reply

Return to “Graphics Cards & Monitors”