Nvidia Drivers Not Loaded

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Nvidia Drivers Not Loaded

Post by Leonardo159 » Sat Sep 07, 2019 3:39 pm

Hi everyone,
I am having problems with the nvidia drivers. I have a lenovo ideapad 320 that comes with an integrated intel gpu and a geforce 940mx gpu. After installing the nvidia drivers, I get the following message when executing the nvidia-settings from terminal:

Code: Select all

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system
(nvidia-settings:6166): GLib-GObject-CRITICAL **: 16:12:02.278: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 16:12:02.335: PRIME: Requires offloading
** Message: 16:12:02.335: PRIME: is it supported? yes
Typing lsmod | grep nvidia in the terminal:

Code: Select all

nvidiafb               49152  0
vgastate               24576  1 nvidiafb
fb_ddc                 16384  1 nvidiafb
i2c_algo_bit           16384  2 nvidiafb,i915
Typing lsmod | grep nouveau in the terminal gives no output.

Typing sudo lshw -c display in the terminal:

Code: Select all

 *-display                 
       description: VGA compatible controller
       product: HD Graphics 620
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:128 memory:92000000-92ffffff memory:a0000000-afffffff ioport:5000(size=64) memory:c0000-dffff
  *-display
       description: 3D controller
       product: GM108M [GeForce 940MX]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=nvidiafb latency=0
       resources: irq:16 memory:93000000-93ffffff memory:80000000-8fffffff memory:90000000-91ffffff ioport:4000(size=128)
In the nvidia x server settings, there is only the prime select tab and it is set to use the nvidia card. But, the steam games (2d and 3d) only run on intel gpu.

The installed driver is the v435. Before installing it, I have disabled the secure boot and purged nvidia. I also have tried before v430, but I had the same results.

Can you guys help me?

Regards,
Leonardo

User avatar
Pjotr
Level 21
Level 21
Posts: 13248
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Nvidia Drivers Not Loaded

Post by Pjotr » Sat Sep 07, 2019 3:45 pm

How did you install the Nvidia driver?
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sat Sep 07, 2019 4:35 pm

First time I installed using driver manager. After realizing the problem, I installed using terminal commands:

sudo apt-get purge nvidia*
Reboot
sudo add-apt-repository ppa:graphics-drivers
sudo apt-get update
sudo apt-get install nvidia-driver-435
Reboot

User avatar
Pjotr
Level 21
Level 21
Posts: 13248
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Nvidia Drivers Not Loaded

Post by Pjotr » Sat Sep 07, 2019 5:58 pm

What does this command say:

Code: Select all

inxi -Fxz
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sat Sep 07, 2019 10:32 pm

System:
Host: leonardo-Lenovo-ideapad-320-15IKB Kernel: 4.15.0-60-generic x86_64
bits: 64 compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.2.4
Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic
Machine:
Type: Laptop System: LENOVO product: 80YH v: Lenovo ideapad 320-15IKB
serial: <filter>
Mobo: LENOVO model: LNVNB161216 v: SDK0J40679 WIN serial: <filter>
UEFI: LENOVO v: 4WCN39WW date: 02/24/2018
Battery:
ID-1: BAT0 charge: 21.5 Wh condition: 22.6/30.0 Wh (75%)
model: LGC L16L2PB2 status: Discharging
CPU:
Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP
arch: Kaby Lake rev: 9 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21696
Speed: 700 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 700 2: 700
3: 700 4: 700
Graphics:
Device-1: Intel HD Graphics 620 vendor: Lenovo driver: i915 v: kernel
bus ID: 00:02.0
Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Lenovo driver: nvidiafb
v: kernel bus ID: 01:00.0
Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
v: 4.5 Mesa 19.0.8 direct render: Yes
Audio:
Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1f.3
Sound Server: ALSA v: k4.15.0-60-generic
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: 2.3LK-NAPI port: 3000 bus ID: 02:00.0
IF: enp2s0 state: down mac: <filter>
Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
v: kernel port: 3000 bus ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Drives:
Local Storage: total: 931.51 GiB used: 512.44 GiB (55.0%)
ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
RAID:
Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
v: 3.0 bus ID: 00:17.0
Partition:
ID-1: / size: 55.27 GiB used: 41.70 GiB (75.4%) fs: ext4 dev: /dev/sda6
ID-2: /home size: 191.25 GiB used: 32.92 GiB (17.2%) fs: ext4
dev: /dev/sda7
Sensors:
System Temperatures: cpu: 36.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 248 Uptime: 9h 55m Memory: 7.58 GiB used: 3.35 GiB (44.2%)
Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
inxi: 3.0.32

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Drivers Not Loaded

Post by roblm » Sun Sep 08, 2019 11:52 am

Use these commands and post the output:

Code: Select all

1. lspci -nnk | egrep -A3 -i "3D|VGA"
2. ls /lib/modprobe.d
3. dpkg -l | grep -i nvidia
4. mokutil --sb-state

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sun Sep 08, 2019 12:25 pm

lspci -nnk | egrep -A3 -i "3D|VGA"

00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 620 [8086:5916] (rev 02)
Subsystem: Lenovo HD Graphics 620 [17aa:38e2]
Kernel driver in use: i915
Kernel modules: i915
--
01:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 940MX] [10de:134d] (rev a2)
Subsystem: Lenovo GM108M [GeForce 940MX] [17aa:38e2]
Kernel driver in use: nvidiafb
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

ls /lib/modprobe.d

aliases.conf fbdev-blacklist.conf
blacklist_linux_4.15.0-54-generic.conf nvidia-graphics-drivers.conf
blacklist_linux_4.15.0-58-generic.conf nvidia-kms.conf
blacklist_linux_4.15.0-60-generic.conf systemd.conf
blacklist-nvidia.conf

dpkg -l | grep -i nvidia

rc bumblebee 3.2.1-17 amd64 NVIDIA Optimus support for Linux
rc bumblebee-nvidia 3.2.1-17 amd64 NVIDIA Optimus support using the proprietary NVIDIA driver
ii libnvidia-cfg1-435:amd64 435.21-0ubuntu0~18.04.2 amd64 NVIDIA binary OpenGL/GLX configuration library
ii libnvidia-common-435 435.21-0ubuntu0~18.04.2 all Shared files used by the NVIDIA libraries
rc libnvidia-compute-430:amd64 430.40-0ubuntu0~gpu18.04.1 amd64 NVIDIA libcompute package
ii libnvidia-compute-435:amd64 435.21-0ubuntu0~18.04.2 amd64 NVIDIA libcompute package
ii libnvidia-compute-435:i386 435.21-0ubuntu0~18.04.2 i386 NVIDIA libcompute package
ii libnvidia-decode-435:amd64 435.21-0ubuntu0~18.04.2 amd64 NVIDIA Video Decoding runtime libraries
ii libnvidia-decode-435:i386 435.21-0ubuntu0~18.04.2 i386 NVIDIA Video Decoding runtime libraries
ii libnvidia-encode-435:amd64 435.21-0ubuntu0~18.04.2 amd64 NVENC Video Encoding runtime library
ii libnvidia-encode-435:i386 435.21-0ubuntu0~18.04.2 i386 NVENC Video Encoding runtime library
ii libnvidia-fbc1-435:amd64 435.21-0ubuntu0~18.04.2 amd64 NVIDIA OpenGL-based Framebuffer Capture runtime library
ii libnvidia-fbc1-435:i386 435.21-0ubuntu0~18.04.2 i386 NVIDIA OpenGL-based Framebuffer Capture runtime library
ii libnvidia-gl-435:amd64 435.21-0ubuntu0~18.04.2 amd64 NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii libnvidia-gl-435:i386 435.21-0ubuntu0~18.04.2 i386 NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii libnvidia-ifr1-435:amd64 435.21-0ubuntu0~18.04.2 amd64 NVIDIA OpenGL-based Inband Frame Readback runtime library
ii libnvidia-ifr1-435:i386 435.21-0ubuntu0~18.04.2 i386 NVIDIA OpenGL-based Inband Frame Readback runtime library
ii nvidia-compute-utils-435 435.21-0ubuntu0~18.04.2 amd64 NVIDIA compute utilities
ii nvidia-dkms-435 435.21-0ubuntu0~18.04.2 amd64 NVIDIA DKMS package
ii nvidia-driver-435 435.21-0ubuntu0~18.04.2 amd64 NVIDIA driver metapackage
ii nvidia-kernel-common-435 435.21-0ubuntu0~18.04.2 amd64 Shared files used with the kernel module
ii nvidia-kernel-source-435 435.21-0ubuntu0~18.04.2 amd64 NVIDIA kernel source package
ii nvidia-prime 0.8.8.2 all Tools to enable NVIDIA's Prime
ii nvidia-settings 418.56-0ubuntu0~gpu18.04.1 amd64 Tool for configuring the NVIDIA graphics driver
ii nvidia-utils-435 435.21-0ubuntu0~18.04.2 amd64 NVIDIA driver support binaries
rc primus 0~20150328-6 amd64 client-side GPU offloading for NVIDIA Optimus
ii xserver-xorg-video-nvidia-435 435.21-0ubuntu0~18.04.2 amd64 NVIDIA binary Xorg driver

mokutil --sb-state

SecureBoot disabled

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Drivers Not Loaded

Post by roblm » Sun Sep 08, 2019 12:36 pm

Use this command to remove Bumblebee and it’s configuration files, which can prevent the Nvidia driver from loading:
apt purge bumblebee* primus*

Then select the Nvidia GPU and reboot.

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sun Sep 08, 2019 1:03 pm

Still the same problem:

nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system


(nvidia-settings:1799): GLib-GObject-CRITICAL **: 13:58:33.624: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 13:58:33.648: PRIME: Requires offloading
** Message: 13:58:33.648: PRIME: is it supported? yes

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Drivers Not Loaded

Post by roblm » Sun Sep 08, 2019 1:07 pm

Post the output of these commands: prime-select query and ls /lib/modprobe.d

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sun Sep 08, 2019 1:15 pm

prime-select query

nvidia


ls /lib/modprobe.d

aliases.conf fbdev-blacklist.conf
blacklist_linux_4.15.0-54-generic.conf nvidia-graphics-drivers.conf
blacklist_linux_4.15.0-58-generic.conf nvidia-kms.conf
blacklist_linux_4.15.0-60-generic.conf systemd.conf
blacklist-nvidia.conf

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Drivers Not Loaded

Post by roblm » Sun Sep 08, 2019 1:18 pm

Remove the blacklist-nvidia.conf file and reboot: sudo rm /lib/modprobe.d/blacklist-nvidia.conf

If that doesn’t work, then use this command and reboot: sudo update-initramfs -u

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sun Sep 08, 2019 1:58 pm

It did not work. I am still receiving the message that nvidia driver is not loaded when running nvidia settings.

Another issue that appeared after "sudo rm /lib/modprobe.d/blacklist-nvidia.conf" and rebooting is that the mouse cursor movement is not smooth anymore.

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Drivers Not Loaded

Post by roblm » Sun Sep 08, 2019 2:04 pm

Remove this file from the nvidia-driver-430 installation: sudo rm libnvidia-compute-430
Log out and back in.

Post the output of this command: ls /usr/share/X11/xorg.conf.d

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sun Sep 08, 2019 2:16 pm

I changed "430" to "435" since the driver is v435:

sudo rm libnvidia-compute-435

rm: cannot remove 'libnvidia-compute-435': No such file or directory


ls /usr/share/X11/xorg.conf.d

10-amdgpu.conf 10-quirks.conf 11-nvidia-prime.conf 70-wacom.conf
10-nvidia.conf 10-radeon.conf 40-libinput.conf

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Drivers Not Loaded

Post by roblm » Sun Sep 08, 2019 2:47 pm

That was supposed to be libnvidia-compute-430, from the previous Nvidia driver installation but don’t remove it for now.

Post the output of these commands: ls /etc/modprobe.d and ldd /usr/bin/glxinfo

Use these commands to upload the Xorg.0.log and dmesg log to terminal.com pastebin:

Code: Select all

cat /var/log/Xorg.0.log | nc termbin.com 9999
dmesg | nc termbin.com 9999

Post the URL link that displays in the Terminal window.

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sun Sep 08, 2019 4:38 pm

I forgot to mention in the previous post that I also tested with "libnvidia-compute-430" and got basically the same output:

rm: cannot remove 'libnvidia-compute-430': No such file or directory

ls /etc/modprobe.d

alsa-base.conf blacklist-oss.conf
amd64-microcode-blacklist.conf blacklist-rare-network.conf
blacklist-ath_pci.conf dkms.conf
blacklist.conf intel-microcode-blacklist.conf
blacklist-firewire.conf iwlwifi.conf
blacklist-modem.conf

ldd /usr/bin/glxinfo

linux-vdso.so.1 (0x00007ffd4d101000)
libGL.so.1 => /usr/lib/x86_64-linux-gnu/libGL.so.1 (0x00007f578a5a7000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f578a26f000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f5789e7e000)
libGLX.so.0 => /usr/lib/x86_64-linux-gnu/libGLX.so.0 (0x00007f5789c4d000)
libGLdispatch.so.0 => /usr/lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007f5789997000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f5789778000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f5789550000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f578934c000)
/lib64/ld-linux-x86-64.so.2 (0x00007f578aa42000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f5789148000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f5788f42000)
libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f5788d2d000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f5788b25000)

cat /var/log/Xorg.0.log | nc termbin.com 9999

https://termbin.com/w9wc

dmesg | nc termbin.com 9999

https://termbin.com/5x8hn

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Drivers Not Loaded

Post by roblm » Sun Sep 08, 2019 4:53 pm

Post the output of cat /etc/X11/xorg.conf

Leonardo159
Level 1
Level 1
Posts: 15
Joined: Sat Sep 07, 2019 1:34 pm

Re: Nvidia Drivers Not Loaded

Post by Leonardo159 » Sun Sep 08, 2019 4:56 pm

cat /etc/X11/xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 430.40


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

User avatar
roblm
Level 10
Level 10
Posts: 3388
Joined: Sun Feb 24, 2013 2:41 pm

Re: Nvidia Drivers Not Loaded

Post by roblm » Sun Sep 08, 2019 5:14 pm

Remove the xorg.conf file and then log out and back in: sudo rm /etc/X11/xorg.conf

Post Reply

Return to “Graphics Cards & Monitors”