[SOLVED] NVIDIA configuration not remembered on reboot

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
gyozo
Level 1
Level 1
Posts: 6
Joined: Mon Sep 09, 2019 12:28 am

[SOLVED] NVIDIA configuration not remembered on reboot

Post by gyozo » Mon Sep 09, 2019 1:19 am

This is my second day of using Linux and I've found no solution to my problem so far. I'll start with what I'm doing. When I boot up only 1 monitor(HDMI) is active so I open NVIDIA settings through the terminal:

Code: Select all

sudo nvidia-settings
[sudo] password for gyozo:            

[color=#FF0000](nvidia-settings:3534): GLib-GObject-CRITICAL **: 00:34:29.274: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 00:34:29.586: PRIME: No offloading required. Abort
** Message: 00:34:29.586: PRIME: is it supported? no[/color]
With the settings open, I change my second monitor(DP) from 'disabled' to 'X screen 0'. I configure my other settings for each screen, including setting my DP monitor as my primary and my HDMI monitor as my secondary. Next I click 'Save to X Configuration File' and I get the following in the terminal:

Code: Select all

[color=#FF0000]Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found[/color]
Alongside this I get a pop-up:
Long MetaMode string (greater than 900 characters) are not supported by the current X server. Truncating [...] will cause only the first 16 MetaModes to be written to the X configuration file. Writing all the MetaModes [...] may result in failling to start the X server.
I select 'Write all MetaModes' and save the file to '/etc/X11/xorg.conf' then quit the NVIDIA settings. (When I quit the settings, the terminal process ends.) When I reboot, both monitors will be active until I log in. After I log in, my DP monitor will say 'no signal' and be set to 'disabled'. All my settings will have been forgotten. At this point I just repeat the process.

I can't imagine a settings files being less than 900 characters ... but maybe if I fix my two errors this problem will go away. So how do I fix the 'CRITICAL/PRIME' message and how do I add the correct package?

Thank you ahead of time for helping all of us newbies.

My specs:

Code: Select all

System:
  Host: gyozo Kernel: 4.15.0-60-generic x86_64 bits: 64 compiler: gcc 
  v: 7.4.0 Desktop: Cinnamon 4.2.4 wm: muffin dm: LightDM 
  Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A97 LE R2.0 v: Rev 1.xx 
  serial: <filter> UEFI: American Megatrends v: 2501 date: 04/09/2014 
CPU:
  Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP arch: Bulldozer 
  L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 42137 
  Speed: 1400 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1394 2: 1404 
  3: 1403 4: 1405 5: 1403 6: 1398 
Graphics:
  Device-1: NVIDIA vendor: Gigabyte driver: nvidia v: 435.21 bus ID: 01:00.0 
  chip ID: 10de:1f08 
  Display: x11 server: X.Org 1.19.6 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes 
Audio:
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK M5A78L LE driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
  Device-2: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:10f9 
  Sound Server: ALSA v: k4.15.0-60-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK P8 series driver: r8169 v: 2.3LK-NAPI port: d000 
  bus ID: 02:00.0 chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 6.72 TiB used: 59.00 GiB (0.9%) 
  ID-1: /dev/sda type: USB vendor: Seagate model: BUP Portable 
  size: 4.55 TiB serial: <filter> 
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  speed: 6.0 Gb/s serial: <filter> 
  ID-3: /dev/sdc vendor: Western Digital model: WD2002FAEX-007BA0 
  size: 1.82 TiB speed: 6.0 Gb/s serial: <filter> 
  ID-4: /dev/sdd type: USB vendor: PNY model: USB 2.0 FD size: 127.16 GiB 
  serial: <filter> 
Partition:
  ID-1: / size: 227.74 GiB used: 28.89 GiB (12.7%) fs: ext4 dev: /dev/sdb2 
Sensors:
  System Temperatures: cpu: 22.9 C mobo: N/A gpu: nvidia temp: 48 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0% 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://mirrors.evowise.com/linuxmint/packages tina main upstream import backport
  2: deb http://la-mirrors.evowise.com/ubuntu bionic main restricted universe multiverse
  3: deb http://la-mirrors.evowise.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://la-mirrors.evowise.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
  Processes: 225 Uptime: 1h 13m Memory: 15.57 GiB used: 1.52 GiB (9.7%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 
  Shell: upload-system-i running in: gnome-terminal inxi: 3.0.32 
 
Last edited by gyozo on Mon Sep 09, 2019 4:53 pm, edited 1 time in total.

User avatar
roblm
Level 10
Level 10
Posts: 3385
Joined: Sun Feb 24, 2013 2:41 pm

Re: NVIDIA configuration not remembered on reboot

Post by roblm » Mon Sep 09, 2019 2:52 pm

Configure the monitors in the Nvidia Settings utility and click Apply. Don’t try to save the settings to a file. Open the Display program and click the Apply button. The settings will be saved to the monitors.xml file in /home/your-user-name/.config.

gyozo
Level 1
Level 1
Posts: 6
Joined: Mon Sep 09, 2019 12:28 am

Re: [SOLVED] NVIDIA configuration not remembered on reboot

Post by gyozo » Mon Sep 09, 2019 4:54 pm

Thank you!

Post Reply

Return to “Graphics Cards & Monitors”