NVIDIA GP108 [GeForce GT 1030] No acceleration [SOLVED]

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Level 1
Level 1
Posts: 2
Joined: Wed Sep 11, 2019 7:20 pm

NVIDIA GP108 [GeForce GT 1030] No acceleration [SOLVED]

Post by tytus64 » Wed Sep 11, 2019 8:01 pm

Every time I reboot my system I see a dialog stating that hw acceleration does not work and directing me to Driver Manager to try a different driver. I tried all of them with the same effect: no acceleration. I tried nvidia-driver-430, xserver-xort-video-nouveau, and nvidia-dirver-390. Any help would be greatly appreciated.

I also noticed that Xorg.0.log shows the following errors:

Code: Select all

[    20.248] (II) Unloading vesa
[    20.248] (--) Depth 24 pixmap format is 32 bpp
[    20.248] (EE) NOUVEAU(0): Error creating GPU channel: -19
[    20.248] (EE) NOUVEAU(0): Error initialising acceleration.  Falling back to NoAccel
[    20.248] (**) NOUVEAU(0): [COPY] acceleration disabled
[    20.258] (II) NOUVEAU(0): Hardware support for Present enabled
[    20.258] (==) NOUVEAU(0): Backing store enabled
[    20.258] (==) NOUVEAU(0): Silken mouse enabled
[    20.258] (==) NOUVEAU(0): DPMS enabled
[    20.258] (II) NOUVEAU(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[    20.258] (--) RandR disabled
[    20.273] (II) SELinux: Disabled on system
[    20.277] (II) AIGLX: Screen 0 is not DRI2 capable
[    20.277] (EE) AIGLX: reverting to software rendering
[    21.544] (II) IGLX: enabled GLX_MESA_copy_sub_buffer
[    21.544] (II) IGLX: Loaded and initialized swrast
I am attaching full log.

Here is my HW:

Code: Select all

System:    Host: piotr-linux-desktop Kernel: 4.15.0-62-generic x86_64 bits: 64 compiler: gcc 
           v: 7.4.0 Desktop: Cinnamon 4.2.4 wm: muffin dm: LightDM Distro: Linux Mint 19.2 Tina 
           base: Ubuntu 18.04 bionic 
Machine:   Type: Desktop System: Dell product: XPS 8700 v: N/A serial: <filter> Chassis: type: 3 
           serial: <filter> 
           Mobo: Dell model: 0KWVT8 v: A00 serial: <filter> UEFI: Dell v: A01 date: 05/16/2013 
Battery:   Device-1: hidpp_battery_0 model: Logitech K520 serial: <filter> charge: 70% 
           status: Discharging 
           Device-2: hidpp_battery_1 model: Logitech M310 serial: <filter> charge: 55% 
           status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-4770 bits: 64 type: MT MCP arch: Haswell 
           rev: 3 L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54271 
           Speed: 3875 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3515 2: 3592 3: 3510 
           4: 3494 5: 3505 6: 3779 7: 3495 8: 3797 
Graphics:  Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: Gigabyte driver: nouveau v: kernel 
           bus ID: 01:00.0 chip ID: 10de:1d01 
           Display: x11 server: X.Org 1.19.6 driver: nouveau unloaded: fbdev,modesetting,vesa 
           resolution: 3840x2160~30Hz 
           OpenGL: renderer: llvmpipe (LLVM 8.0 256 bits) v: 3.3 Mesa 19.0.8 compat-v: 3.1 
           direct render: Yes 
Audio:     Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Dell 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
           Device-2: NVIDIA GP108 High Definition Audio vendor: Gigabyte driver: snd_hda_intel 
           v: kernel bus ID: 01:00.1 chip ID: 10de:0fb8 
           Sound Server: ALSA v: k4.15.0-62-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell 
           driver: r8169 v: 2.3LK-NAPI port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Dell driver: ath9k 
           v: kernel port: d000 bus ID: 04:00.0 chip ID: 168c:0032 
           IF: wlp4s0 state: down mac: <filter> 
           Device-3: Atheros type: USB driver: btusb bus ID: 3-13:6 chip ID: 0cf3:e004 
Drives:    Local Storage: total: 4.55 TiB used: 53.80 GiB (1.2%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB 
           speed: 6.0 Gb/s serial: <filter> temp: 36 C 
           ID-2: /dev/sdb type: USB vendor: Western Digital model: WD40EZRX-00SPEB0 size: 3.64 TiB 
           serial: <filter> 
Partition: ID-1: / size: 907.59 GiB used: 41.82 GiB (4.6%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 56.0 C mobo: 27.8 C gpu: nouveau temp: 36 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 1736 
Repos:     No active apt repos in: /etc/apt/sources.list 
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list 
           1: deb [arch=amd64] http: //dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/insync.list 
           1: deb http: //apt.insync.io/mint tina non-free contrib
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http: //mirror.unlockforus.com/linuxmint/packages tina main upstream import backport
           2: deb http: //la-mirrors.evowise.com/ubuntu bionic main restricted universe multiverse
           3: deb http: //la-mirrors.evowise.com/ubuntu bionic-updates main restricted universe multiverse
           4: deb http: //la-mirrors.evowise.com/ubuntu bionic-backports main restricted universe multiverse
           5: deb http: //security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http: //archive.canonical.com/ubuntu/ bionic partner
Info:      Processes: 283 Uptime: 21m Memory: 7.72 GiB used: 2.60 GiB (33.7%) Init: systemd v: 237 
           runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Client: Unknown python3.6 client inxi: 3.0.32
Last edited by tytus64 on Fri Sep 13, 2019 7:22 pm, edited 2 times in total.

Hoser Rob
Level 14
Level 14
Posts: 5441
Joined: Sat Dec 15, 2012 8:57 am

Re: NVIDIA GP108 [GeForce GT 1030] No acceleration

Post by Hoser Rob » Thu Sep 12, 2019 10:25 am

According to this ...

https://www.nvidia.com/Download/driverR ... 8524/en-us

... you should be using a 381 series driver. Does this come up in driver manager?

Do NOT just go to the mfr's site and dl the newest driver, that's a WIndows thing ah=nd is very unreliable in Linux. That's because Linux has very little backwards or forwards comatibility.

Level 1
Level 1
Posts: 2
Joined: Wed Sep 11, 2019 7:20 pm

Re: NVIDIA GP108 [GeForce GT 1030] No acceleration

Post by tytus64 » Fri Sep 13, 2019 7:22 pm

I updated my bios from A1 to A14 and the problem disappeared.

Post Reply

Return to “Graphics Cards & Monitors”