How do I enable/disable Xrender in Cinnamon?

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

Or is there even such a thing?

In KDE apps you go to:

Settings > Display and Monitor > Compositor, then

In the Rendering Backend category there are 3 choices:
OpenGL 3.1
OpenGL 2.0
XRender

User avatar
smurphos
Level 17
Level 17
Posts: 7096
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: How do I enable/disable Xrender in Cinnamon?

Post by smurphos »

You can't - Cinnamon needs 3D acceleration which is provided by OpenGL.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

User avatar
roblm
Level 12
Level 12
Posts: 4402
Joined: Sun Feb 24, 2013 2:41 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by roblm »

This is the description of the X Render extension, according to it’s creater, Keith Packard, if you can understand it:
"The X Rendering Extension (Render) introduces digital image composition as the foundation of a new rendering model within the X Window System. Rendering geometric figures is accomplished by client-side tessellation into either triangles or trapezoids. Text is drawn by loading glyphs into the server and rendering sets of them."
According to some articles I’ve read, that extension is only needed when OpenGL is not available.

Sometimes the extensions that are initialized when the X Server starts are listed in the Xorg.0.log file, depending on the driver:

Code: Select all

Initializing extension Generic Event Extension     
[     7.953] (II) Initializing extension SHAPE
[     7.953] (II) Initializing extension MIT-SHM
[     7.953] (II) Initializing extension XInputExtension
[     7.953] (II) Initializing extension XTEST
[     7.953] (II) Initializing extension BIG-REQUESTS
[     7.953] (II) Initializing extension SYNC
[     7.953] (II) Initializing extension XKEYBOARD
[     7.953] (II) Initializing extension XC-MISC
[     7.953] (II) Initializing extension SECURITY
[     7.954] (II) Initializing extension XFIXES
[     7.954] (II) Initializing extension RENDER
[     7.954] (II) Initializing extension RANDR
[     7.954] (II) Initializing extension COMPOSITE
[     7.954] (II) Initializing extension DAMAGE
[     7.954] (II) Initializing extension MIT-SCREEN-SAVER
[     7.954] (II) Initializing extension DOUBLE-BUFFER
[     7.954] (II) Initializing extension RECORD
[     7.954] (II) Initializing extension DPMS
[     7.954] (II) Initializing extension Present
[     7.955] (II) Initializing extension DRI3
[     7.955] (II) Initializing extension X-Resource
[     7.955] (II) Initializing extension XVideo
[     7.955] (II) Initializing extension XVideo-MotionCompensation
[     7.955] (II) Initializing extension SELinux
[     7.955] (II) SELinux: Disabled on system
[     7.955] (II) Initializing extension GLX
[     7.955] (II) Initializing extension GLX
[     7.955] (II) Indirect GLX disabled.
[     7.955] (II) GLX: Another vendor is already registered for screen 0
[     7.955] (II) Initializing extension XFree86-VidModeExtension
[     7.955] (II) Initializing extension XFree86-DGA
[     7.955] (II) Initializing extension XFree86-DRI
[     7.955] (II) Initializing extension DRI2
[     7.955] (II) Initializing extension NV-GLX
[     7.955] (II) Initializing extension NV-CONTROL
Otherwise, use the command xdpyinfo

To disable the X Render extension, use this command to create an xorg.conf file:
sudo touch /etc/X11/xorg.conf

Open the file for editing: xed admin:///etc/X11/xorg.conf

Add these lines. The extension name is case-sensitive:

Code: Select all

Section "Extensions"
   Option "RENDER" "Disable"		
EndSection
After logging out and back in, the result will be different, depending on the loaded driver. If you are using Cinnamon and the Nvidia driver, you will get a message about running in Fallback mode, and the Cinnamon menu and panel will be changed to the MATE menu and panel, and opened app windows had a red border, depending on the theme used.
However, the command glxinfo | grep renderer will show the Nvidia GPU is still doing the graphics rendering, and the desktop graphics performance doesn’t appear to be affected; at least from the brief testing I did, such as running a full-screen video in VLC.

However, if the open-source nouveau driver is loaded, the desktop will be unusable. Opening any app or menu will display an empty white box.

rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

Been trying to attach a gif image to show clearly the issue I've been experiencing when I use a screen capturing app like Kazam, etc.

This forum system says, "File is too large..." when it's only tiny. Really, really, extremely frustrating system to deal with which is bad because it doesn't do anything to help the next newbie or the next generation of users. I mean, how much memory do you want to save in this day and age?

Anyways, I have identified the problem long time ago. The NVDIA drivers when installed are causing the problem. And so I found that when I want to use a screen capturing app, via Kubuntu, for example, whenever I want to draw or paint, is to switch to XRender mode, then go back to default when I'm finished.

I love Mint Cinnamon, but if I can't get this feature, I have no choice but to discontinue using it.

User avatar
smurphos
Level 17
Level 17
Posts: 7096
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: How do I enable/disable Xrender in Cinnamon?

Post by smurphos »

Have you tried Cinnamon's native screen recorder?
Ctrl+Alt+Shift+R to toggle on and off.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

smurphos wrote:
Mon Apr 27, 2020 12:25 pm
Have you tried Cinnamon's native screen recorder?
Ctrl+Alt+Shift+R to toggle on and off.
No. I doubt it has extra features like specifying the size and location of the screen, other than full-screen mode.

It's not about the application. It's about the drivers. You can use any app or any native screen capturing feature and it will have the same issue until NVDIA drivers play well along with the system.

rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

By the way, the issue is about screen tearing, if that's what it's called;
random flashing bands on the screen during screen casting process.
And it's only when NVDIA drivers are installed.

User avatar
roblm
Level 12
Level 12
Posts: 4402
Joined: Sun Feb 24, 2013 2:41 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by roblm »

Use this command in the Terminal and post the output: inxi -SMCGx

rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

roblm wrote:
Mon Apr 27, 2020 6:29 pm
Use this command in the Terminal and post the output: inxi -SMCGx

Code: Select all

System:
  Host: xxxxxx-454ez Kernel: 5.3.0-46-generic x86_64 bits: 64 
  compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:
  Type: Desktop System: Hewlett-Packard product: HP Compaq Pro 6300 SFF 
  v: N/A serial: <root required> 
  Mobo: Hewlett-Packard model: 339A serial: <root required> 
  BIOS: Hewlett-Packard v: K01 v02.05 date: 05/07/2012 
CPU:
  Topology: Quad Core model: Intel Core i5-3470 bits: 64 type: MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25542 
  Speed: 1596 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 1597 2: 1597 
  3: 1596 4: 1597 
Graphics:
  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: ZOTAC driver: nvidia 
  v: 435.21 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.5 driver: nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 
  direct render: Yes
  

User avatar
roblm
Level 12
Level 12
Posts: 4402
Joined: Sun Feb 24, 2013 2:41 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by roblm »

Open NVIDIA X Server Settings to the X Server Display Configuration page and click the Advanced button. Select ForceFullCompositionPipeline. Click Save to X Configuration File. Type: /etc/X11/xorg.conf
You can also try the ForceCompositionPipeline option.

rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

roblm wrote:
Tue Apr 28, 2020 5:39 am
Open NVIDIA X Server Settings to the X Server Display Configuration page and click the Advanced button. Select ForceFullCompositionPipeline. Click Save to X Configuration File. Type: /etc/X11/xorg.conf
You can also try the ForceCompositionPipeline option.
I had hoped that would work. It didn't, unfortunately.
The flickering random bands showing bits and pieces of the background doesn't happen in the screen recording process.
It happens in the resulting saved file.

Anyways, I'm moving on, use Kubuntu meanwhile and apply the workaround I discovered, ie, XRender...

If you want to experiment further, do the same thing using Cinnamon with NVIDIA gfx card.
Run an app like Krita or Gimp, or probably just about any app and see what happens.

I'm probably more disappointed in not being able to attach the file showing the result.
This "File is too large" thing is nonsensical.

User avatar
roblm
Level 12
Level 12
Posts: 4402
Joined: Sun Feb 24, 2013 2:41 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by roblm »

Open NVIDIA X Server Settings to the OpenGL Settings page. Move the Image Settings slider all the way to the left, to High Quality. Then try the other direction all the way to the right, to High Performance.
The setting Allow Flipping should not be enabled.

rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

roblm wrote:
Tue Apr 28, 2020 9:45 am
Open NVIDIA X Server Settings to the OpenGL Settings page. Move the Image Settings slider all the way to the left, to High Quality. Then try the other direction all the way to the right, to High Performance.
The setting Allow Flipping should not be enabled.
Same result:

Image

User avatar
roblm
Level 12
Level 12
Posts: 4402
Joined: Sun Feb 24, 2013 2:41 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by roblm »

rick gen wrote: If you want to experiment further, do the same thing using Cinnamon with NVIDIA gfx card.
Run an app like Krita or Gimp, or probably just about any app and see what happens.
I use GIMP frequently and have never seen the effects you posted, using similar video cards, the GT 720 and 730.

Try enabling and disabling VBlank and Compositing under System Settings > General and disabling Window Effects and disabling the RENDER extension, which is enabled by default.

You can try different drivers, such as nvidia-driver-390 or 440, or downloading an older driver from Nvidia’s website, such as 384, try different kernels and try Mint MATE or Xfce, which have the option to select different Window Managers.

You can also test running a live session using the MATE or Xfce installation USB / DVD and install the Nvidia driver. The driver has to be downloaded from Nvidia’s website and it doesn’t need a reboot after the installation. If you want to try that method, then I can post the instructions.

rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

I didn't see the VBlank and the RENDER extension. (Are you using Cinnamon?)
The others like disabling Windows Effects and Compositing for full-screen Windows didn't do anything.
I don't like/use MATE. This issue doesn't happen in Xfce, but I prefer Cinnamon's workflow/features and Kubuntu as a second choice.
I seem to remember this thing doesn't happen in previous versions of Kubuntu, but it started to come up in the newer versions, and luckily, I found a workaround whenever I want to record my painting sessions.

Thanks for your time, roblm.

PS
I can still use Cinnamon and will have zero issue when recording by not installing the NVIDIA drivers.
Downside is the graphics card will remain un-utilized for certain apps that require it like 3d apps, etc.

User avatar
roblm
Level 12
Level 12
Posts: 4402
Joined: Sun Feb 24, 2013 2:41 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by roblm »

OK, For Mint Cinnamon 19.3, there is a VSync method in System Settings > General, which is set to Presentation Time, whatever that means, along with 3 other selections.

To disable the RENDER extension, you would need to follow the instructions in my first post.

rick gen
Level 3
Level 3
Posts: 104
Joined: Thu May 11, 2017 12:29 pm

Re: How do I enable/disable Xrender in Cinnamon?

Post by rick gen »

Going back to this thread,

I have upgraded to Linux Mint 20 Cinnamon and Xfce.

It is so mind-boggling to me that Cinnamon still has this flickering issue
while Xfce don't. (I don't like Mate, so I won't mention it here.)

I really would like to just use Cinnamon and discard Xfce, but this issue just won't go away.

Post Reply

Return to “Graphics Cards & Monitors”