Laptop Display doesn't work

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
FanicaCurentatu
Level 1
Level 1
Posts: 7
Joined: Tue Jun 30, 2020 2:26 pm

Laptop Display doesn't work

Post by FanicaCurentatu »

My laptop display doesn't work and second monitor (HDMI) is working. Can i do something to work both displays in duplicate?
I have asus tuf fx505dt. Now i have dual boot with windows 10 but i want to go linux mint only.
This is the output for inxi -Fxz

Code: Select all

System:
  Kernel: 5.4.0-39-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0 
  serial: <filter> 
  Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: FX505DT.308 date: 09/19/2019 
Battery:
  ID-1: BAT0 charge: 44.2 Wh condition: 44.2/48.1 Wh (92%) model: FX50442 
  status: Full 
CPU:
  Topology: Quad Core model: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen+ rev: 1 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 36734 
  Speed: 1225 MHz min/max: 1400/2300 MHz Core speeds (MHz): 1: 1223 2: 1265 
  3: 1224 4: 1226 5: 1225 6: 1226 7: 1294 8: 1237 
Graphics:
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: ASUSTeK 
  driver: nvidia v: 440.100 bus ID: 01:00.0 
  Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 05:00.0 
  Display: x11 server: X.Org 1.20.8 driver: nvidia 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
  direct render: Yes 
Audio:
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 05:00.6 
  Sound Server: ALSA v: k5.4.0-39-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: AzureWave driver: N/A port: c000 bus ID: 04:00.0 
Drives:
  Local Storage: total: 1.14 TiB used: 9.66 GiB (0.8%) 
  ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3256GJ3 
  size: 238.47 GiB 
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
Partition:
  ID-1: / size: 284.06 GiB used: 9.63 GiB (3.4%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 53.9 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2700 
  GPU: device: nvidia screen: :0.0 temp: 47 C device: amdgpu temp: 54 C 
Info:
  Processes: 252 Uptime: 7m Memory: 7.28 GiB used: 1.47 GiB (20.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  inxi: 3.0.38 
Now i have dual boot with windows 10 but i want to go linux mint only.

This is the output for xrandr

Code: Select all

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080     60.00*+  71.91    59.94    50.00  
   1680x1050     59.95  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1024x768      70.07    60.00  
   800x600       72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       72.81    59.94  
User avatar
roblm
Level 12
Level 12
Posts: 4407
Joined: Sun Feb 24, 2013 2:41 pm

Re: Laptop Display doesn't work

Post by roblm »

Does the laptop display work with the monitor disconnected?

Use this command and post the output, with the monitor connected: xrandr --listproviders
FanicaCurentatu
Level 1
Level 1
Posts: 7
Joined: Tue Jun 30, 2020 2:26 pm

Re: Laptop Display doesn't work

Post by FanicaCurentatu »

roblm wrote:
Wed Jul 01, 2020 6:52 am
Does the laptop display work with the monitor disconnected?

Use this command and post the output, with the monitor connected: xrandr --listproviders

This is the output from xrandr --listproviders

Code: Select all

xrandr --listproviders
Providers: number : 1
Provider 0: id: 0x1b8 cap: 0x1, Source Output crtcs: 4 outputs: 1 associated providers: 0 name:NVIDIA-0
EDIT: I forgot to respond. Does the laptop display work with the monitor disconnected?
-No.
Last edited by FanicaCurentatu on Wed Jul 01, 2020 9:32 am, edited 1 time in total.
FanicaCurentatu
Level 1
Level 1
Posts: 7
Joined: Tue Jun 30, 2020 2:26 pm

Re: Laptop Display doesn't work

Post by FanicaCurentatu »

Also, when i'm going to Advanced options for Linux Mint 20 Cinnamon in GNU GRUB i have 4 options 2 pairs each one the same but with (recovery mode). In post i described what is going on when i boot Linux Mint 20 Cinnamon, with Linux 5.4.0-39-generic but when i go for the second option with Linux 5.4.0-26-generic both of displays doesn't work.
User avatar
roblm
Level 12
Level 12
Posts: 4407
Joined: Sun Feb 24, 2013 2:41 pm

Re: Laptop Display doesn't work

Post by roblm »

1. I assume the laptop display works with the monitor disconnected?

2. Use these commands and post the output:

Code: Select all

ls /usr/share/X11/xorg.conf.d/
ls /etc/X11/
FanicaCurentatu
Level 1
Level 1
Posts: 7
Joined: Tue Jun 30, 2020 2:26 pm

Re: Laptop Display doesn't work

Post by FanicaCurentatu »

I assume the laptop display works with the monitor disconnected?
-No

Output from ls /usr/share/X11/xorg.conf.d/:

Code: Select all

s /usr/share/X11/xorg.conf.d/
10-amdgpu.conf  10-radeon.conf    70-wacom.conf
10-quirks.conf  40-libinput.conf  nvidia-drm-outputclass.conf
Output from ls /etc/X11/:

Code: Select all

$ ls /etc/X11/
app-defaults             xorg.conf                          Xsession.d
default-display-manager  xorg.conf.nvidia-xconfig-original  Xsession.options
fonts                    Xreset                             xsm
rgb.txt                  Xreset.d                           XvMCConfig
xinit                    Xresources                         Xwrapper.config
xkb                      Xsession
User avatar
roblm
Level 12
Level 12
Posts: 4407
Joined: Sun Feb 24, 2013 2:41 pm

Re: Laptop Display doesn't work

Post by roblm »

Post the output of these commands:

Code: Select all

cat /usr/share/X11/xorg.conf.d/10-amdgpu.conf
cat /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass.conf
cat /etc/X11/xorg.conf 
FanicaCurentatu
Level 1
Level 1
Posts: 7
Joined: Tue Jun 30, 2020 2:26 pm

Re: Laptop Display doesn't work

Post by FanicaCurentatu »

Code: Select all

cat /usr/share/X11/xorg.conf.d/10-amdgpu.conf
Section "OutputClass"
	Identifier "AMDgpu"
	MatchDriver "amdgpu"
	Driver "amdgpu"

Code: Select all

at /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass.conf
# This xorg.conf.d configuration snippet configures the X server to
# automatically load the nvidia X driver when it detects a device driven by the
# nvidia-drm.ko kernel module.  Please note that this only works on Linux kernels
# version 3.9 or higher with CONFIG_DRM enabled, and only if the nvidia-drm.ko
# kernel module is loaded before the X server is started.

Section "OutputClass"
    Identifier     "nvidia"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"
EndSection

Code: Select all

 cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.100

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
FanicaCurentatu
Level 1
Level 1
Posts: 7
Joined: Tue Jun 30, 2020 2:26 pm

Re: Laptop Display doesn't work

Post by FanicaCurentatu »

I just found that my laptop is very hot and all what i did was surfing YT for 1-2 hours.

Code: Select all

sensors
asus-isa-0000
Adapter: ISA adapter
cpu_fan:     3500 RPM

BAT0-acpi-0
Adapter: ACPI interface
in0:          12.80 V  
curr1:         0.00 A  

k10temp-pci-00c3
Adapter: PCI adapter
Tdie:         +67.6°C  (high = +70.0°C)
Tctl:         +67.6°C  

amdgpu-pci-0500
Adapter: PCI adapter
vddgfx:           N/A  
vddnb:            N/A  
edge:         +67.0°C  (crit = +80.0°C, hyst =  +0.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +67.0°C  (crit = +103.0°C)
67.0°C is too much for just YT browsing
User avatar
roblm
Level 12
Level 12
Posts: 4407
Joined: Sun Feb 24, 2013 2:41 pm

Re: Laptop Display doesn't work

Post by roblm »

Remove the xorg.conf file: sudo rm /etc/X11/xorg.conf

Log out and back in. The monitor may not work now if the HDMI port is internally connected to the Nvidia GPU.

If the laptop display is working, then post the output of xrandr --listproviders
FanicaCurentatu
Level 1
Level 1
Posts: 7
Joined: Tue Jun 30, 2020 2:26 pm

Re: Laptop Display doesn't work

Post by FanicaCurentatu »

I removed that conf. So, now hmdi is not working but main laptop display is working like u said but the main laptop thisplay is now blinking once at like 10 sec.

This is the output:

Code: Select all

Providers: number : 1
Provider 0: id: 0x54 cap: 0x9, Source Output, Sink Offload crtcs: 4 outputs: 1 associated providers: 0 name:Unknown AMD Radeon GPU @ pci:0000:05:00.0
User avatar
roblm
Level 12
Level 12
Posts: 4407
Joined: Sun Feb 24, 2013 2:41 pm

Re: Laptop Display doesn't work

Post by roblm »

You mentioned the laptop was very hot in a previous post. I suggest turning if off for a while and then checking for the blinking. If it is still present but was not present when running the live session with the installation USB, then try using the default 5.4.0-26 kernel.
User avatar
BG405
Level 8
Level 8
Posts: 2332
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Laptop Display doesn't work

Post by BG405 »

68°C is not unusual when watching YouTube videos, due to (at least in my experience) YT being a resource hog. You'll probably get the temps down a bit if you restart the browser after a period of YT viewing; certainly the memory footprint should drop back too. It's greedy on that front.

At least we know your laptop monitor's internal cable is OK, which is often the cause of internal display failure (which is mainly why I checked this thread).
Dell Inspiron 1525 - LM17.3 CE 64-------------------Lenovo T440 8GB - Manjaro KDE with Mint VMs
Toshiba NB250 - Manjaro KDE------------------------K7S5A AMD 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Two ROMS don't make a WRITE ...
Post Reply

Return to “Graphics Cards & Monitors”