Page 1 of 1

3D acceleration for TuxRacer

Posted: Sat Dec 16, 2006 1:59 pm
by buster
(Couldn't find any other posts on this.)

Am in the LiveCD. Downloaded ppracer (TuxRacer) and tried to play it. Sort of works in a slow choppy way. Usually I have no problems with this game in other distros.

Card detected properly: Rage 128 PF/PRO AGP 4x TMDS.

1. Will it work better with a hard drive install?
2. All the print is missing from the games menu. (I can run the game because I know what the empty spaces should show.) Is this the same on anyone else's Mint system?

This is usually my test for 3D acceleration

Posted: Sat Dec 16, 2006 4:28 pm
by clem
Well things are usually really slow when run from the CD...

To see if 3d acceleration is activated open a terminal and type: glxinfo | grep rendering

Code: Select all

clem@pluto:~$ glxinfo | grep rendering
libGL warning: 3D driver claims to not support visual 0x4b
direct rendering: Yes

Posted: Sat Dec 16, 2006 4:37 pm
by buster
mint@mint:~$ glxinfo | grep rendering
libGL warning: 3D driver claims to not support visual 0x4b
direct rendering: Yes

This is pasted from my terminal. Is this good? And I have seen the missing words on the screen before in ppracer, but I can't remember where. Maybe Ubuntu.

Thanks for the quick help on this Clem. A lovely distro! Waiting for the Bea final eagerly.

Posted: Sat Dec 16, 2006 5:13 pm
by clem
Hi,

Your 3D acceleration is fine so I suppose it's something to do with the game itself. You shouldn't download and install stuff directly. The package manager is there for that.

Try the ubuntu version. Remove the game, open synaptic and install planetpenguin-racer. Worked fine for me. There's even a package if you want additional tracks.

Clem

Posted: Sat Dec 16, 2006 5:31 pm
by buster
Actually I did download with Synaptic - seemed the easiest way, and it added a few more packages. So I did get the Ubuntu package. Could be the fact that it's a LiveCD I guess.

But the missing print stirs a memory of another distro somewhere in my past.I rebooted into Ubuntu Breezy and ppracer worked fine there.

Anyway, I'll wait for the final in a few days. If the problem is still there when it's on the hard drive, I'll get back to you.

Thanks for your help.

Posted: Tue Dec 19, 2006 8:02 pm
by buster
Found where I've experienced the missing words on the opening page before!!!!!!

Found an install of Ubuntu Dapper on an old hard drive that I haven't used lately. Booted the Ubuntu. Tried the ppracer and it had exactly the same symptoms - no text, and slow, jerky movements.

Ah well. It isn't Mint's fault.

Posted: Tue Dec 19, 2006 11:17 pm
by buster
And according to posts at the Ubuntu forum, problems with ppracer started with the move to Dapper for those with the ATI rage 128 series of video cards. (But the problem isn't in other distros by the way.) Writing this just on the off chance there is a relatively simple fix that can be put into Mint in future releases.

solution

Posted: Mon Dec 25, 2006 7:12 pm
by zolly
Install the "Bea" version of Linux Mint.
Read my post "SUCCESS install ATI driver on Acer Aspire 5101 laptop", and modify the xorg.conf if it is necessary (like resolution) if you work with other kind of laptop or if you work with a desktop computer type. It should work.
TuxRacer works perfectly for me.

Posted: Sat Dec 30, 2006 4:27 pm
by buster
Thanks Zolly, but you have a Radeon. Makes all the difference in the world unfortunately. Mine's a Rage 128 aiw pro. The problem shows up in late Ubuntus and a very few other distros, but not in PCLOS, Mepis, Suse 10, Breezy, or any of the others I tried over the years. The card, good in its time, is getting old. Hard to make every piece of hardware in the world work with Linux. :cry:

Posted: Sat Dec 30, 2006 5:01 pm
by zolly
If I understand, your ati works with other distro, and you can play 3D games. One solution is to install one of that distro and to see what do you have on xorg.conf: fglrx, ati, ... (or even better to use that xorg.conf from that distro, to Linux Mint) and to see how it works.
If it works, you can write the solution in this forum.

Posted: Sat Dec 30, 2006 6:32 pm
by buster
Actually I do that by copying and pasting lines from the other distros I have got installed on the same machine. But sometimes the difference in the xorg file is something I can't pinpoint easily, and after awhile it doesn't seem worth the effort. So many installs, so much tinkering. :)

If I do find a solution, I will certainly post it. But I don't think anyone on the Ubuntu forums found a solution for this same problem - at least a solution for those limited to human intelligence. :wink: I suspect the solution is either built into the release or not. Mepis has managed so far to build it in, though not yet in their latest beta release. (Mepis also uses a lot of Ubuntu stuff as well.)

If I solve it, I would be happy to contribute to Mint by posting it here.

Posted: Sat Dec 30, 2006 6:52 pm
by buster
I must add that TuxRacer (ppracer) works perfectly with the LiveCD on my wife's newer computer that has on-board video and sound. It's definitely the rage 128 drivers needed for my older machine.

Posted: Mon Jan 01, 2007 7:17 pm
by zolly
Then, I think that is a problem that should be fixed in the next release. Maybe you can add a comment in "Bianca" post.