NVIDIA not working after updates

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
Juge
Level 1
Level 1
Posts: 6
Joined: Fri Aug 07, 2020 1:02 am

NVIDIA not working after updates

Post by Juge »

I have nvidia GTX 1050ti mobile. After Mint installation with mild problems I got it up and running. Couple of days ago I updated the packages and now I only get a black screen.

I have output from couple of suggested commands and Xorg.0.log

https://termbin.com/xi4b

https://termbin.com/k55n
User avatar
roblm
Level 13
Level 13
Posts: 4516
Joined: Sun Feb 24, 2013 2:41 pm

Re: NVIDIA not working after updates

Post by roblm »

You are using the nomodeset parameter on the kernel command line. Press Ctrl+Alt+F1 to enter virtual console tty1.
Use this command to open the grub file: sudo nano -t /etc/default/grub

Use the Arrow keys to move the cursor. Remove nomodeset from this line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Press Ctrl+X to save and exit. Update grub and reboot. sudo update-grub; reboot
User avatar
kc1di
Level 16
Level 16
Posts: 6322
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: NVIDIA not working after updates

Post by kc1di »

do the nomodeset thing first. But you may have to reinstall the correct driver.
It should have rebuilt if the kernel was upgraded but sometimes they don't. If it's a kernel upgrade you can usually boot from the old kernel.
By hitting the esc key when your computer begins to boot. then from the grub menu select advanced and select the older kernel version that should get you back to a desktop. Good luck.
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608
Juge
Level 1
Level 1
Posts: 6
Joined: Fri Aug 07, 2020 1:02 am

Re: NVIDIA not working after updates

Post by Juge »

Ok, I removed the nomodeset and it does not work any better. The thing is that actually the /lib/modules shows the compiled libraries - I can purge and reinstall the drivers - I just don't think it will help ...
Juge
Level 1
Level 1
Posts: 6
Joined: Fri Aug 07, 2020 1:02 am

Re: NVIDIA not working after updates

Post by Juge »

Ok, I removed the xorg.conf that I had from somewhere again, removed the 440 drivers and installed the 390. Now the desktop got up - so I won't bother trying to figure out whether it was the xorg.conf or the driver version, I intend to enjoy few days of a running machine first.

Thanks for the help...
User avatar
kc1di
Level 16
Level 16
Posts: 6322
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: NVIDIA not working after updates

Post by kc1di »

Glad you got it working :)
Easy tips : https://easylinuxtipsproject.blogspot.com/ Pjotr's Great Linux projects page.
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608
User avatar
roblm
Level 13
Level 13
Posts: 4516
Joined: Sun Feb 24, 2013 2:41 pm

Re: NVIDIA not working after updates

Post by roblm »

Juge wrote: Ok, I removed the xorg.conf that I had from somewhere again...
That doesn’t make sense. If there was an xorg.conf file, then it would have been listed in the Xorg.0.log you posted, unless you added that file to a different location than the usual /etc/X11 location.
Juge
Level 1
Level 1
Posts: 6
Joined: Fri Aug 07, 2020 1:02 am

Re: NVIDIA not working after updates

Post by Juge »

Sorry, I wasn't specific. I added it again after I posted those log. So the first trial of removing the nomodeset did not work with 440-drivers, after that I simultaneously removed the xorg.conf and switched to 390-drivers, one of those changes (or both) did the trick...At the moment I feel that it would be playing with fire to try to poke which :)
Post Reply

Return to “Graphics Cards & Monitors”