Page 2 of 2

Re: Brightness not working after switching to Nvidia driver

Posted: Sun Aug 23, 2020 1:47 am
by Spectrum75
roblm wrote:
Sat Aug 22, 2020 2:03 pm
Use this command and post the output: ls /sys/class/backlight/*/*

ls: cannot access '/sys/class/backlight/*/*': No such file or directory
This is the output I get, have tried with sudo, non-root and su but the same thing.

Re: Brightness not working after switching to Nvidia driver

Posted: Sun Aug 23, 2020 1:48 am
by Spectrum75
SMG wrote:
Sat Aug 22, 2020 10:19 am
Spectrum75 wrote:
Sat Aug 22, 2020 10:06 am
I tried removing xbacklight, but then too that applet isn't able to control brightness
Is that applet the one which also has power management?

No, its not that applet its another one, which has options for only brightness, gamma value etc.

Re: Brightness not working after switching to Nvidia driver

Posted: Sun Aug 23, 2020 3:26 pm
by roblm
What is the output of this command: ls /proc/acpi/*/*

Check the info in this topic, starting with andisk’s second post:
viewtopic.php?p=1853532#p1853532

Re: Brightness not working after switching to Nvidia driver

Posted: Tue Aug 25, 2020 9:41 am
by Spectrum75
Umm My laptop originally came with windows 7, then after the support ended I had upgraded to windows 10. The brightness key stopped working ever since that.
I have 2 hardisk with me one is running windows 10 and the second one has Linux mint installed. I prefer linux mint whenever I can, because it is faster than windows 10 which is really slow like a snail on my laptop, but still if its really necessary like some application only works on windows and does not on wine or something like that happens which is exclusive to windows then only I use that hardisk.

Anyways I ran the command sudo strings /sys/firmware/acpi/tables/DSDT | grep -i 'windows ' | sort and got the following output:

Code: Select all

Windows 2001
Windows 2001 SP1
Windows 2001 SP2
Windows 2006
Windows 2006
Windows 2006
Windows 2006
Windows 2006
Windows 2006
Windows 2006
Windows 2009
Windows 2009
Windows 2009
Windows 2009
Windows 2009
Windows 2009
Windows 2009

Re: Brightness not working after switching to Nvidia driver

Posted: Tue Aug 25, 2020 5:30 pm
by roblm
The parameter acpi_osi=! \"acpi_osi=Windows 2009\" is the only Windows parameter you will test in the grub file. Use the instructions how to add it in the linked topic:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=! \"acpi_osi=Windows 2009\""

Re: Brightness not working after switching to Nvidia driver

Posted: Wed Aug 26, 2020 10:51 am
by Spectrum75
I tried it but not working :(

Re: Brightness not working after switching to Nvidia driver

Posted: Wed Aug 26, 2020 11:03 am
by roblm
Try the other steps in that linked topic by andisk.

Re: Brightness not working after switching to Nvidia driver

Posted: Wed Feb 03, 2021 12:59 am
by Spectrum75
Sorry for the late reply but with the new release (20.1) I can see the brightness meter inside the battery icon, but like I said before it isn't able to control the brightness :(

Re: Brightness not working after switching to Nvidia driver

Posted: Wed Feb 03, 2021 1:08 am
by Spectrum75
Update: So I found this awesome cinnamon applet called QRedshift, which does the job and also it even has controls for redhsift :D