Nvidia graphic card is not working after upgrade to Mint 20

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
gregori
Level 1
Level 1
Posts: 4
Joined: Tue Sep 15, 2020 3:36 am

Nvidia graphic card is not working after upgrade to Mint 20

Post by gregori »

Code: Select all

gregor@Gregor:~$ inxi -SMCGx 
System:
  Host: Gregor Kernel: 5.4.0-47-generic x86_64 bits: 64 compiler: gcc 
  v: 9.3.0 Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop System: LENOVO product: IdeaCentre K330 v: Lenovo Product 
  serial: <superuser/root required> 
  Mobo: LENOVO model: N/A serial: <superuser/root required> BIOS: LENOVO 
  v: DKKT23AUS date: 06/10/2011 
CPU:
  Topology: Quad Core model: Intel Core i5-2320 bits: 64 type: MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23943 
  Speed: 1967 MHz min/max: 1600/3300 MHz Core speeds (MHz): 1: 1717 2: 1612 
  3: 1650 4: 1813 
Graphics:
  Device-1: NVIDIA GF108 [GeForce GT 530] vendor: Micro-Star MSI 
  driver: nvidia v: 390.138 bus ID: 01:00.0 
  Device-2: NVIDIA G73 [GeForce 7600 GS] vendor: LeadTek Research 
  driver: N/A bus ID: 02:00.0 
  Display: x11 server: X.Org 1.20.8 driver: fbdev,modesetting,nouveau 
  unloaded: vesa resolution: 1280x1024~77Hz 
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.8 
  direct render: Yes 

Code: Select all

gregor@Gregor:~$ lspci -nnk | grep -EA3 "3D|VGA"   
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108 [GeForce GT 530] [10de:0de5] (rev a1)
Subsystem: Micro-Star International Co., Ltd. [MSI] GF108 [GeForce GT 530] [1462:2309]
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
Last edited by Moem on Tue Sep 15, 2020 3:46 am, edited 1 time in total.
gregori
Level 1
Level 1
Posts: 4
Joined: Tue Sep 15, 2020 3:36 am

Re: Nvidia grpaphic card is not working after upgrade to Mint 20

Post by gregori »

Blanking monitor and notice of graphic driver problems are symptoms of the error. Resoluton is only 1280x1024.
User avatar
SMG
Level 5
Level 5
Posts: 774
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Nvidia grpaphic card is not working after upgrade to Mint 20

Post by SMG »

Welcome to the forum, gregori.

You have two graphics cards in your computer and one does not have a device driver listed

Graphics:
Device-1: NVIDIA GF108 [GeForce GT 530] vendor: Micro-Star MSI
driver: nvidia v: 390.138 bus ID: 01:00.0
Device-2: NVIDIA G73 [GeForce 7600 GS] vendor: LeadTek Research
driver: N/A bus ID: 02:00.0

When I looked for the latest driver for the GeForce 7600 GS I see it is the 304.137 which was last updated in September 2017. I would guess it is listed as N/A by Mint because it is old enough that it is no longer supported in the kernel.

Your system is not currently using any proprietary Nvidia drivers which would explain the resolution. Nouveau is the display driver being used and not the Nvidia 390-Driver. Are there any suggested drivers in Driver Manager? If nouveau was the only option in Driver Manager, that may be because the G73 card was not recognized.

Display: x11 server: X.Org 1.20.8 driver: fbdev,modesetting,nouveau
unloaded: vesa resolution: 1280x1024~77Hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0 256 bits) v: 3.3 Mesa 20.0.8
direct render: Yes

There is a section in the release notes regarding installing the Nvidia driver Release Notes for Linux Mint 20 Cinnamon. Scroll to section on 'Solving freezes during the boot sequence' on how to get the Nvidia driver installed. However, you may need to disconnect the G73 card for this to work. I do not have enough experience to know if Mint will just ignore the G73 card and permit you to use only the GF108 if both are connected but only one is recognized by Mint.
LM20.0 Cinnamon
gregori
Level 1
Level 1
Posts: 4
Joined: Tue Sep 15, 2020 3:36 am

Re: Nvidia grpaphic card is not working after upgrade to Mint 20

Post by gregori »

Thanks for youe tips SMG,
I removed NVIDIA G73, folowed the instructions on Nvidia driver Release Notes but couldn't fix it. Got angry and overridid with Ubuntu.
User avatar
SMG
Level 5
Level 5
Posts: 774
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Nvidia grpaphic card is not working after upgrade to Mint 20

Post by SMG »

gregori wrote:
Thu Sep 17, 2020 3:31 am
Thanks for youe tips SMG,
I removed NVIDIA G73, folowed the instructions on Nvidia driver Release Notes but couldn't fix it. Got angry and overridid with Ubuntu.
So you now have things working for you in Ubuntu? Or do you still want help with Mint?
LM20.0 Cinnamon
gregori
Level 1
Level 1
Posts: 4
Joined: Tue Sep 15, 2020 3:36 am

Re: Nvidia graphic card is not working after upgrade to Mint 20

Post by gregori »

So you now have things working for you in Ubuntu? Or do you still want help with Mint?
Yes in Ubuntu works fine. Thanks for you help.
Post Reply

Return to “Graphics Cards & Monitors”