<SOLVED> Disable "check your video drives" *notification*

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
mallard
Level 1
Level 1
Posts: 6
Joined: Thu Oct 01, 2020 5:35 am

Re: Disable "check your video drives" *notification*

Post by mallard »

The issue I'm trying to resolve is not specific to virtualisation, nor specific to my configuration.

Having looked at the Cinnamon's code, I've discovered that the warning is displayed in the following circumstances:

* Software rendering is being used.
* The environment variable CINNAMON_2D is not set.
* The system was not started with the "boot=casper" or "boot=live" kernel parameters.

(Line 479 and following in /usr/share/cinnamon/js/ui/main.js)

The easiest way to disable the warning is therefore to set the CINNAMON_2D environment variable. Since I want this to apply to all users of the system, I've done this by adding the line 'CINNAMON_2D="true"' to /etc/environment. There are probably other ways to set this, but this works for me. The actual value of the variable doesn't seem to have any meaning, it just needs to be set to something.

After a reboot, I've confirmed that this has disabled the warning.
Post Reply

Return to “Graphics Cards & Monitors”