Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Forum rules
Before you post please read this
User avatar
burrezo
Level 1
Level 1
Posts: 7
Joined: Sat Nov 21, 2020 5:48 pm

Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by burrezo »

Hi all,

After getting nvidia-304xx-legacy drivers work in Debian 10 Buster amd64, Antix19.3_x64 and MX Linux 19.3_x64, this is the way to make it in Linux Mint 20 xfce 64.

My PC: Asus P5N73-AM (chipset NForce 610i, integrated nvidia 7050) + Xeon x5450 [775 mod] + 4Gb Ram + SSD

https://www.asus.com/us/Motherboards/P5N73AM/

[1] Fresh install linuxmint-20-xfce-64bit.iso, at first graphical boot, open a terminal (Ctrl + Alt + t):

1a - Choose the highest resolution supported by your monitor in console mode, if unknown to you:

Code: Select all

sudo apt install hwinfo
sudo hwinfo --framebuffer 
Edit /etc/default/grub , edit / un-comment / add:

Code: Select all

[...]
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=3
[...]
GRUB_GFXMODE=1400X1050
GRUB_GFXPAYLOAD_LINUX=keep
Note 1400x1050 is the highest resolution of my GPU, supported by my monitor, yours may be other one.

Save/quit and:

Code: Select all

sudo update-grub
1b - Blacklist nouveau drivers, create the file /etc/modprobe.d/disable-nouveau.conf with this content:

Code: Select all

blacklist nouveau
options nouveau modeset=0
Save/quit and:

Code: Select all

sudo updadate initramfs -u
sudo reboot
[2] When grub boot-menu shows up, press letter ‘e’, move to the end of the line linux /boot/vmlinuz-5.4.0-26-generic root=UUID=………………….. ro quite splash , and add a ‘3’ at the end, like this:

Code: Select all

     linux     /boot/vmlinuz-5.4.0-26-generic root=UUID=………………….. ro quite splash 3
Press ‘F10’ to continue, the system starts in terminal mode, log in normally with your user/password.

[3] Remove Xorg 1.20 (nvidia legacy driver 304xx only works up to Xorg 1.19):

Code: Select all

sudo apt remove xserver-xorg-core
[4] Install git, we will need it later:

Code: Select all

sudo apt install git
[5] Edit /etc/apt/sources.list.d/official-repositories.list , ( Update! from CarlGSR: for Mint 20.1 Edit /etc/apt/sources.list.d/official-repositories.list ) comment everything, and at the end, add:

Code: Select all

deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted

Save/quit and:

Code: Select all

sudo apt-get update
[6] Install Xorg 1.19 and some packages needed:

Code: Select all

sudo apt install xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput
[7] Download the Nvidia official proprietary driver for your old nvidia GPU, in my case is a 7050, but I suppose this method will work with A LOT of old chipsets/cards ( https://www.nvidia.es/Download/driverRe ... px/123847/ <- ‘SUPPORTED PRODUCTS‘ tab )

Code: Select all

wget https://us.download.nvidia.com/XFree86/Linux-x86_64/304.137/NVIDIA-Linux-x86_64-304.137.run
Make the file executable:

Code: Select all

chmod +x NVIDIA-Linux-x86_64-304.137.run
Extract, NOT execute, the file (note the ‘-x’ at the end):

Code: Select all

./NVIDIA-Linux-x86_64-304.137.run -x
Directory ‘NVIDIA-Linux-x86_64-304.137‘ is created.

[8] Get some patches from Jorge Maidana ( https://github.com/jorgem-seq/NVIDIA-Li ... 37-patches ) FOLLOW & LIKE/STAR HIS WORK PLEASE!

Code: Select all

git clone https://github.com/jorgem-seq/NVIDIA-Linux-304.137-patches.git
[9] Navigate into the 'NVIDIA-Linux-x86_64-304.137' directory, and apply the patches, IN ORDER, up to the patch needed, depending on the kernel installed, so, in this case, with a clean install, the kernel is 5.4.0, so, only patches 0001, 0002, 0003, 0004, 0005, 0006, 0007 and 0008 are needed (adjust your path when patching, depending on where the files were downloaded, extracted, cloned, etc...)

Code: Select all

patch -p1 <../NVIDIA-Linux-x86_64-304.137-patches/patches/0001-disable-mtrr-4.3.patch
patch -p1 <../NVIDIA-Linux-x86_64-304.137-patches/patches/0002-pud-offset-4.12.patch
patch -p1 <../NVIDIA-Linux-x86_64-304.137-patches/patches/0003-nvidia-drm-pci-init-4.14.patch
patch -p1 <../NVIDIA-Linux-x86_64-304.137-patches/patches/0004-timer-4.15.patch
patch -p1 <../NVIDIA-Linux-x86_64-304.137-patches/patches/0005-usercopy-4.16.patch 
patch -p1 <../NVIDIA-Linux-x86_64-304.137-patches/patches/0006-do_gettimeofday-5.0.patch
patch -p1 <../NVIDIA-Linux-x86_64-304.137-patches/patches/0007-subdirs-5.3.patch
patch -p1 <../NVIDIA-Linux-x86_64-304.137-patches/patches/0008-on-each-cpu-5.3.patch
[10] Execute the nvidia installer:

Code: Select all

sudo ./nvidia-installer
The installer shows some kind of trouble with 32bits glx libs compatibility, but you can install anyway.

After finish with no errors:

Code: Select all

sudo update-initramfs -u
[11] Mark xserver-xorg-core package as NOT upgradeable :

Code: Select all

sudo apt-mark hold xserver-xorg-core
( Update! from CarlGSR: for Mint 20.1 more packages need to be marked as hold:)

Code: Select all

sudo apt-mark hold xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput
[12] Restore Linux Mint default repositories, comment the last line added, un-comment all the others, and:

Code: Select all

sudo apt-get update
[13] Disable xfce4 compositor, edit: /home/user/.config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml , use_compositing need to be set 'false':

Code: Select all

     <property name=”use_compositing” type=”bool” value=”false”/>
And reboot:

Code: Select all

sudo reboot
[14] For transparencies and other effects In xfce, at main menu, go to Settings -> Sessions and Startup -> Application Autostart, and +Add:

Code: Select all

     Name: Compton
     Description: Compton compositor
     Command: compton
     Start: on login 
[15] Final upgrade and reboot, open a terminal:

Code: Select all

sudo apt-get update && sudo apt-get upgrade
sudo reboot
https://i.ibb.co/82zJfgn/Captura-de-pan ... -39-04.png

The performance increase is huge with proprietary Nvidia drivers with these old GPUs in comparison with nouveua drivers, enjoy your nvidinosaur!!
Last edited by burrezo on Sun May 30, 2021 7:01 am, edited 4 times in total.
hugomenezes
Level 1
Level 1
Posts: 27
Joined: Fri May 08, 2020 10:45 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 x64 xfce

Post by hugomenezes »

:o :o :o Thks dude! You deserve a beer with this post! Please put your paypal! :mrgreen:
User avatar
burrezo
Level 1
Level 1
Posts: 7
Joined: Sat Nov 21, 2020 5:48 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 x64 xfce

Post by burrezo »

Thanks!, glad to know it's useful to you!!

Image

PS: Donations here: https://linuxmint.com/donors.php :wink:
User avatar
CarlGSR
Level 1
Level 1
Posts: 2
Joined: Sun Apr 18, 2021 2:05 am

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 x64 xfce

Post by CarlGSR »

Running like a Bullet Train on Linux Mint 20.1 x64 xfce :D
Thank you so much for the post, now I can fully migrate to Linux Mint, hehe xD.

PC used: Biostar N68S3B (Chipset nForce 630a, Integrated Nvidia GeForce 7025) + AMD Sempron 130.

PS: The only difference I had when doing this in version 20.1, was the nomelature of the repository which is: official-package-repositories.list
PS²: After a second "apt-get upgrade" there was a problem with the graphical environment not working, I had to downgrade again, and this time I placed the 3 packages as NOT upgradeable. :

Code: Select all

sudo apt-mark hold xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput
It has been fixed and now I will have no more problems with future updates :)
User avatar
burrezo
Level 1
Level 1
Posts: 7
Joined: Sat Nov 21, 2020 5:48 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 x64 xfce

Post by burrezo »

Thank's for the update CarlGSR!! , edit the main post.
Josemiguel
Level 1
Level 1
Posts: 1
Joined: Sun May 16, 2021 12:41 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by Josemiguel »

Hello, how are you, but good luck, I did the complete process And there was no problem in the installation, but when I finished the installation I entered sudo reboote, the Linux mint logo appears then the screen goes black and asks for my username and password I enter it and the screen goes black
User avatar
burrezo
Level 1
Level 1
Posts: 7
Joined: Sat Nov 21, 2020 5:48 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by burrezo »

Hi Josemiguel,

I need more info about your computer... did you install the xfce version?, did you turn off the compositor?

--------------------------------------------------------------------------------------------------------------------------------------------

Hola Josemiguel,

Necesito más información sobre tu equipo... has instalado la versión xfce?, has deshabilitado el compositor?
defPeki
Level 1
Level 1
Posts: 5
Joined: Sun May 23, 2021 11:22 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by defPeki »

Thank you burrezo, everything works like a charm!

Edit 2: Got everything working (at least for now) so you may as well just ignore everything I've written below and see this TL;DR instead: updates seem to break OpenGL; I tried holding some more upgrades to no avail, so in the end I just repeated step [10]. And about josemiguel's problem: I've had the same issue the first time I tried following through the process. It SEEMS that the error lies on step [13], as my type was set as "empty" and I just left it that way while defining value as "false" and everything went black once I rebooted. I think he's brazilian by the way, so here goes my attempt to help:

josemiguel, tente seguir o processo do zero novamente, mas dessa vez, no passo [13], mude também o type do use_compositing para "bool"! Quando eu segui o processo tive o mesmo problema que você e quando o refiz com essa etapa ficou tudo certo. Deve ficar assim como está no post original, então para recapitular, ficaria assim:
<property name=”use_compositing” type=”bool” value=”false”/>
Mude o type="empty" para type="bool" e adicione o value="false"!

SOLVED ISSUE BELOW:

Must say I'm having problems with Steam though; it just won't run for some reason. Is there any known workaround? Everything else seems to work well.
And as a sidenote, my monitor is 1366x768 but only 1368x768 is available. Small difference, but I'd like to fix it. The ways to add a custom resolution using xrandr I've seen just give me errors on the --addmode step. Also would like to know if there is any known workaround.
Once again, thank you! You've pretty much saved this fossil I call a computer. :D
Edit 1: May or may not have found the problem. While trying to install some other things I used to run fine on Windows, such as PPSSPP, I ran into this specific error:
Failed graphics backends: OPENGL,ALL
It seems that, while everything recognizes the GPU has no Vulkan support (for instance, the terminal also gave me this: DEBUG: Vulkan is not available, not using Vulkan.) it just doesn't, or rather can't, use OpenGL. I would appreciate some help, if possible to do something at all. :?
User avatar
burrezo
Level 1
Level 1
Posts: 7
Joined: Sat Nov 21, 2020 5:48 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by burrezo »

I've got this error starting steam:

Code: Select all

Restarting~Steam~by~request...
Running~Steam~on~linuxmint~20~64-bit
STEAM_RUNTIME~has~been~set~by~the~user~to:~/home/burrezo/.steam/debian-installation/ubuntu12_32/steam-runtime
Pins~up-to-date!
Steam~client's~requirements~are~satisfied
WARNING:~Using~default/fallback~debugger~launch
/home/burrezo/.steam/debian-installation/ubuntu12_32/steam~-nominidumps~-nobreakpad
[2021-05-28~20:46:01]~Startup~-~updater~built~May~19~2021~01:53:57
SteamUpdateUI:~An~X~Error~occurred
X~Error~of~failed~request:~~GLXBadContext
SteamUpdateUI:~An~X~Error~occurred
X~Error~of~failed~request:~~BadValue~(integer~parameter~out~of~range~for~operation)
Major~opcode~of~failed~request:~~154~(GLX)
Minor~opcode~of~failed~request:~~3~(X_GLXCreateContext)
Value~in~failed~request:~~0x0
Serial~number~of~failed~request:~~44
xerror_handler:~X~failed,~continuing
Major~opcode~of~failed~request:~~154~(GLX)
Minor~opcode~of~failed~request:~~6~(X_GLXIsDirect)
Serial~number~of~failed~request:~~45
xerror_handler:~X~failed,~continuing
SOLVED

Only need to re-install legacy nvidia drivers and Steam need to be installed from official site: https://cdn.akamai.steamstatic.com/clie ... /steam.deb, (NOT sudo apt install steam).

If you already installed Steam from repositories:

Code: Select all

sudo apt remove --purge steam

sudo apt clean

sudo apt autoremove
And delete .steam and Steam folders in your home directory (if still exists).

From first post:

Step [2]: to enter terminal mode

Step [10]: re-install patched nvidia legacy drivers, and very important, answer 'Yes' to everything, 32bits library is needed

Reboot when finish.

https://i.ibb.co/ZVmhVJ3/Captura-de-pan ... -16-55.png

PS: My integrated GPU is not able to play any game XD
defPeki
Level 1
Level 1
Posts: 5
Joined: Sun May 23, 2021 11:22 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by defPeki »

Alright, so, coming back after quite some time because almost everything that uses OpenGL is giving me weird errors. Like Wine crashing with OpenGL, for example, and even WebGL has a "supported with reduced performance" or something like that. Is it because we are basically "breaking the rules" by installing old drivers on new kernels, because I broke something, or because driver support from Nvidia was just really poor back then? Because I, for sure, never had any of these on Windows, but I'm really liking Linux so far and don't plan on coming back to Cortana tracking me 24/7. I've been planning to buy a new GPU anyway, but really wanted to know if there was a way to fix it. glxinfo and glxgears show everything is fine (just like your screenshot) but it definitely isn't for a lot other things.

Other than OpenGL though, everything else is running fine. So thank you again. :)
pmx_lm
Level 1
Level 1
Posts: 7
Joined: Fri Jun 11, 2021 2:06 am

[FIXED] OpenGL pb after restart with new driver

Post by pmx_lm »

Hi all, thanks for the tutorial ! Works on my old HP Pavilion dv9000 (dv9313) : Intel Core2 Duo T5300 @ 1.73GHz with a NVIDIA Go7600.

@defPeki
Alright, so, coming back after quite some time because almost everything that uses OpenGL is giving me weird errors.
Same here. I realised after some times that apps udepending on OpenGL libs (e.g. glxgears demo or Wine) were not working correctly.
I don't know if this was a consequence of an update

I simply reinstalled the driver :
  • Restart in console mode (restart, press "e" at Grub prompt, add "3" at the end of the kernel parameters list)
  • Reinstall the nVidia driver over the previous installation. Say "yes" to DKMS sources installation and opengl libs (IIRC)
glxinfo -B (from package "mesa-utils") shows that OpenGL is managed by the NVIDIA 304.137 driver :


  • ~$ glxinfo -B
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce Go 7600/PCIe/SSE2
    OpenGL version string: 2.1.2 NVIDIA 304.137
    OpenGL shading language version string: 1.20 NVIDIA via Cg compiler

    OpenGL ES profile version string: OpenGL ES 2.0 NVIDIA 304.137 304.137
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.00


Hope this helps !
Pierre.
defPeki
Level 1
Level 1
Posts: 5
Joined: Sun May 23, 2021 11:22 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by defPeki »

Hi Pierre! Thanks for taking your time to help me, but I've tried that countless times before. As you can see, my glxinfo is quite similar to yours:

  • glxinfo -B
    name of display: :0.0
    display: :0 screen: 0
    direct rendering: Yes
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce 7025 / nForce 630a/integrated/SSE2
    OpenGL version string: 2.1.2 NVIDIA 304.137
    OpenGL shading language version string: 1.20 NVIDIA via Cg compiler

    OpenGL ES profile version string: OpenGL ES 2.0 NVIDIA 304.137 304.137
    OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.00

Like I said, it does work on many things, but not all of them; Wine OpenGL on .exe's that previously worked on my Windows 10 for example, just crashed, and I had to change the rendering method for it to work. And then there's Chromium (I installed it for testing purposes; I normally use Firefox, and it gives me the same errors), which gives me this on chrome://gpu

Graphics Feature Status
  • Canvas: Hardware accelerated
    Compositing: Software only. Hardware acceleration disabled
    Multiple Raster Threads: Disabled
    Out-of-process Rasterization: Hardware accelerated
    OpenGL: Enabled
    Rasterization: Hardware accelerated on all pages
    Skia Renderer: Enabled
    Video Decode: Software only. Hardware acceleration disabled
    Vulkan: Disabled
    WebGL: Hardware accelerated but at reduced performance
    WebGL2: Hardware accelerated but at reduced performance
Now, the problem here is WebGL which, by the name, I assume it's related to OpenGL and Nvidia drivers (in fact, I have searched it and the drivers itself point out fixing WebGL errors), and once again, it is something that worked on Windows 10. And even though it says it "works," everything using WebGL crashes. Of course these are only two examples; I've noticed OpenGL issues on some games and software too. Could it be something on my xorg.conf is not configured correctly?
pmx_lm
Level 1
Level 1
Posts: 7
Joined: Fri Jun 11, 2021 2:06 am

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by pmx_lm »

Hi,

OK, I understand your problem, now. In fact, at first, I had lost all OpenGL compatibility, this is different (hence the full reinstallation).

Now, the 304.137 driver is sooooo old...
This driver only offers OpenGL 2.x ABI, this may be related to the crashes ? (Although I expect a well behaving app to check the supported OpenGL ABI).

Now, I can't help much more, because I can't test any game, etc... beacause his laptop goes immediately into heavy thermal throttle.

(I "resurected" this old laptop because my main laptop just died :(
This laptop of 2007 vintage was set aside 7 or 8 years ago because the CPU and Northbridge heathpipes ("caloduc") are dead and the laptop oveheats immediately.
Apparently, a common problem of these HP dv9000 / dv6000 series.)

BTW, I just used "GPUTest", an OpenGL benchmark that runs on Linux, to stress the GPU and check if the GPU's dedicated heathpipe is still working.
GPUTest offers tests for various OpenGL ABI (2.x, 3.x, 4.x).
May be informative for you ?
https://www.geeks3d.com/gputest/

Cheers !
Pierre.
pmx_lm
Level 1
Level 1
Posts: 7
Joined: Fri Jun 11, 2021 2:06 am

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by pmx_lm »

P.S. Is it possible to run a live Linux Mint 18 from USB (no install) with the NVIDIA Driver ? Maybe in a persistant session ?

If at all possible, it would be interesting to see if the problems disapears or not in LM 18 (assuming same applications, same version).
If not solved in LM 18, the problem probably can't be solved in LM 20.

Otherwise, maybe there are more libs that needs downgrading (beside X11) ?
pmx_lm
Level 1
Level 1
Posts: 7
Joined: Fri Jun 11, 2021 2:06 am

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by pmx_lm »

To verify the WebGL functionality in my setup, I opened https://get.webgl.org both with Firefox and Chromium (not Chrome, if this makes a difference ?? ).

WebGL detection is OK with Firefox not Chromium.

In Chrome, chrome://gpu shows the same message you mentioned (reduces performances, etc...).
I tweaked the chrome parameters in chrome://flags, wit no effects. I suppose that Chrome already choose the best options during install.

The WebGL demos here : https://www.khronos.org/webgl/wiki/Demo_Repository
The demos works in Firefox.

At the end of the page chrome://gpu , there is the following repport :

Log Messages

[8589:8589:0612/020254.748708:ERROR:angle_platform_impl.cc(44)] : renderergl_utils.cpp:477 (GenerateTextureFormatCaps): glGetInternalformativ generated error 0x00000500 for format 0x00008231. Skipping multisample checks.
(....)
[8589:8589:0612/020255.407968:ERROR:context_group.cc(457)] : ContextResult::kFatalFailure: too few uniforms or varyings supported.
(....)


There is a fatal error in the OpenGL / GPU somewhere in Chrome....

Clearely, Chrome doesn't like the old driver !
tangry
Level 1
Level 1
Posts: 12
Joined: Mon Dec 14, 2020 10:47 pm
Location: Australia

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by tangry »

kinda off topic but I saw in the OP's screenshot that he had glxgears running in sync with the vertical refresh. Doing so gives you a very limited result and doesn't reflect the proper capability of the GPU.

ie . instead of issuing the command: $ glxgears

Use the command: __GL_SYNC_TO_VBLANK=0 glxgears
(yes, include the 2 underscores)


If you have an AMD card use: vblank_mode=0 glxgears instead
User avatar
CarlGSR
Level 1
Level 1
Posts: 2
Joined: Sun Apr 18, 2021 2:05 am

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by CarlGSR »

__________________________________________________________

Defpeki, I have the same graphic chip model yours and, for me, everything works normally, games like Xonotics (all set in Low), Wine installed by PlayonLinux (I not use for play games), Unreal Tournament 1999 etc.
And the only thing I faced since I installed the graphics driver was libvdpau.so.1, which I will say how to solve after.

Regarding WebGL(3D, specifically) on Linux, Bro... Not much to do, here is also crashing, but I only tested Firefox (poor performance for everything, navigation here is very slow) and i can't make WebGL work in Chromium browsers (best perfomance here) maybe if you get a browser that has better support for the WebGL, the crashing ends, but I find it difficult.

Anyway, overall system performance is extremely satisfactory, and it's great beautify the entire system without suffering from loss of speed. :D
__________________________________________________________

libvdpau.so.1 Resolution

Code: Select all

celluloid: error while loading shared libraries: libvdpau.so.1: cannot open shared object file: No such file or directory
It happened to any video player I installed.
I reinstalled the driver again, but this time (Kernel 5.4.0-74-Generic) did not solve, so I run:

Code: Select all

sudo apt-get install --reinstall libvdpau1
After that, the video player started working again and I can see the video in Full HD again.
__________________________________________________________

If you get the DKMS error when reinstalling the graphics driver, you can solve it like this:

Code: Select all

sudo nvidia-uninstall
* Erase the old installation folder
* Extract the .run and re-patch again.
sudo ./nvidia-installer
And the drivers were successfully (re)installed.
defPeki
Level 1
Level 1
Posts: 5
Joined: Sun May 23, 2021 11:22 pm

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by defPeki »

Hey CarlGSR, I've also run into the libvdpau driver issue and actually found an old thread saying the one that comes with 304.137 is broken and the only way to get it working again is by reinstalling it. But that was only the first problem of the game I tried to run, because once I opened it (the game is based on OpenSceneGraph by the way), even though it was as smooth as somewhere about 60 FPS (more or less), I received some OpenGL warning. Then again once I walked quite a bit and had to load things. It's weird. So yeah, libvdpau isn't a problem anymore as far as I'm aware of.

About your Firefox, mine is not slow at all! It's been my main browser until now. Might be worth noting I did quite a lot of tweaks though; check out https://privacytools.io/browsers/#about_config, they're great. You should customize what you don't like though, as it may break things like media reproduction on Spotify and others. There's also some great addons somewhere around that page.

WebGL though never worked for me in Firefox as Pierre said. I know the link above said to disable it, but that's not the problem, seeing as F12 show me pretty much the same error as Chromium in WebGL websites. I might try that GPUTest quite soon, though, so thanks!

Edit: Other than the GPUTests that were too heavy for this old GPU, the ones using Open GL 2.1 worked properly it seems. Still having errors in Wine, even after another reinstall (might be worth noting I also had the error GL_INVALID_ENUM on a native game).

Code: Select all

0016:err:ntoskrnl:ZwLoadDriver failed to create driver L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\NDIS": 00000001
0009:err:d3d:wined3d_check_gl_call >>>>>>> GL_INVALID_ENUM (0x500) from query sample counts @ utils.c / 3143.
0009:err:winediag:MIDIMAP_drvOpen No software synthesizer midi port found, Midi sound output probably won't work.
Wine wglgears.exe works just as glxgears but with some errors:

Code: Select all

0016:err:ntoskrnl:ZwLoadDriver failed to create driver L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\NDIS": 00000001
Could not find Wine Gecko. HTML rendering will be disabled.
Could not find Wine Gecko. HTML rendering will be disabled.
wine: configuration in L"/home/username/.wine" has been updated.
pmx_lm
Level 1
Level 1
Posts: 7
Joined: Fri Jun 11, 2021 2:06 am

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by pmx_lm »

Hi @defPeki,

did you notice that near the end of the page about Firefox optimisations, there is :

webgl.disabled = true

If you applied all the proposed optimlisations, WebGL is disabeled, this would explain the difference.
pmx_lm
Level 1
Level 1
Posts: 7
Joined: Fri Jun 11, 2021 2:06 am

Re: Nvidia legacy driver 304.137 working with Linux Mint 20 & 20.1 x64 xfce

Post by pmx_lm »

FYI, I just applied all the Firefox optimisations (except the WebGL one) , and WebGL doesn't work anymore in Firefox !
Post Reply