Sony Vaio S series VPCSB Radeon HD 6470M issues

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this
Post Reply
archwndas
Level 1
Level 1
Posts: 8
Joined: Sat Oct 16, 2010 12:33 am

Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by archwndas »

Dear all,
I bought this new Sony Vaio S series laptop VPCSB11FX. It has a dual graphics
card, the integrated intel and the AMD Radeon HD 6470M one.

Control-Center ---> Additional drivers

says that I can activate ATI/AMD proprietary FGLRX graphics driver. Deactivated
by default. When I try to activate it the application glxgears says:

segmentation fault


I am attaching in a single file the output of the commands:

# lspci
# lsusb
# lshw


If you need any more information let me know.

By the way, the mic is not working either but this is because of the

Codec: Realtek ALC275

for which alsa has a known bug they still haven't fixed.

Cheers,
Archwn.

User avatar
nunol
Level 9
Level 9
Posts: 2636
Joined: Sun Mar 06, 2011 9:25 pm
Location: Portugal

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by nunol »


mjoshawa
Level 1
Level 1
Posts: 28
Joined: Wed May 04, 2011 10:12 pm

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by mjoshawa »

I've tried following those steps, but /sys/kernel/debug/vgaswitcheroo does not currently exist.
On the other hand, if I run

$ grep -i switcheroo /boot/config-2.6.*

I get the response:

/boot/config-2.6.39-2-amd64:CONFIG_VGA_SWITCHEROO=y

which seems to imply I do have vgaswitcheroo. So how do I find/use it?

Thank you.

monkiki
Level 1
Level 1
Posts: 6
Joined: Sun Jun 26, 2011 5:26 am

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by monkiki »

Same error with missing switcheroo in kernel 2.6.39 :?

mjoshawa
Level 1
Level 1
Posts: 28
Joined: Wed May 04, 2011 10:12 pm

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by mjoshawa »

Does anyone know if it's possible to patch switcheroo into the 39 kernel, because I haven't found anything for it. Or do we have to wait until a kernel update includes it?

archwndas
Level 1
Level 1
Posts: 8
Joined: Sat Oct 16, 2010 12:33 am

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by archwndas »

Any news on this?

When is the latest 3.0.0 kernel or some rc version of it is going to be included in the repositories so we can test it and report? The 3.0.0 kernel is supposed to fix all these issues with switcheroo and with the support of the latest Sandy bridge 2 Intel processors. Why we haven't seen it yet? Are there any issues?

mjoshawa
Level 1
Level 1
Posts: 28
Joined: Wed May 04, 2011 10:12 pm

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by mjoshawa »

It's been almost a month. Any news?

jamescbjr
Level 1
Level 1
Posts: 4
Joined: Sat Feb 10, 2007 12:10 am

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by jamescbjr »

mjoshawa wrote:It's been almost a month. Any news?
I just bought ASUS K53BY with Radeon HD 6470M Had the same problem. I installed Mint 11 Katys it picked up
the 6470M, graphics work fine--Googleearth.

Hope this helps.
Last edited by jamescbjr on Fri Sep 30, 2011 6:36 pm, edited 1 time in total.

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by AlbertP »

To anyone having this problem: Please post your lspci here.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

zdgreve
Level 1
Level 1
Posts: 1
Joined: Tue Oct 11, 2011 8:11 am

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by zdgreve »

Hello everybody,

Here is my lspci (Sony Vaio VPCSA Radeon HD 6630M, Linux Mint 11 Katya 64 bits) :

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation 2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: ATI Technologies Inc NI Whistler [AMD Radeon HD 6600M Series] (rev ff)
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5209 (rev 01)
04:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

My system also fails to resume after suspend, and I think it is related to the radeon card.

Thank you very much for your feedback !

Regards
Sony Vaio VPCSA ATI Radeon 6630M, dual boot Linux Mint 11 Katya 64 bits/Windows 7 64 bits

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by AlbertP »

This is hybrid graphics.

Did your computer work before installing the ATI driver? In that case uninstalling the driver is probably the easiest way to get Intel graphics working. You can also take a look at this page about hybrid graphics: https://help.ubuntu.com/community/HybridGraphics
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

LcS
Level 1
Level 1
Posts: 5
Joined: Wed Nov 16, 2011 4:48 am

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by LcS »

Hello !

I think i have the same problem but my kernel is 3.0.0-12-generic (i run Mint12) and there is no /sys/kernel/debug/vgaswitcheroo/ directory as mentionned at https://help.ubuntu.com/community/HybridGraphics

archwndas
Level 1
Level 1
Posts: 8
Joined: Sat Oct 16, 2010 12:33 am

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by archwndas »

I have the same problem. I have solved the vgaswitcheroo problems long ago. However one remains. This is that after resume from suspend, the ATI card seems to be on because the battery life drops to half the battery life when the ATI card is off. The reason is that after resume from suspend I get this:

$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS: :Off:0000:01:00.0
1:IGD:+:Pwr:0000:00:02.0

Any attempt to change this situation may result in kernel crash or something similar.

$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: ATI Technologies Inc NI Seymour [AMD Radeon HD 6470M]
02:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
04:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)


Even worse for some reason the ATI Linux Driver doesn't support this card yet.
Last edited by archwndas on Wed Dec 28, 2011 10:59 am, edited 1 time in total.

AlbertP
Level 16
Level 16
Posts: 6714
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: Sony Vaio S series VPCSB Radeon HD 6470M issues

Post by AlbertP »

Please post the output of these commands without any driver installed:

Code: Select all

inxi -Gx
ls -l /sys/kernel/debug/vgaswitcheroo/switch
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

Post Reply

Return to “Graphics Cards & Monitors”