Community website / mintinstall issues

Questions about the project and the distribution - obviously no support questions here please
MikeF90000
Level 2
Level 2
Posts: 86
Joined: Sun Jan 08, 2012 7:54 pm
Location: Southern California, USA

Community website / mintinstall issues

Postby MikeF90000 » Wed Aug 31, 2016 9:19 pm

After encountering some issues with my Mint 18 Xfce install, I decided to post some reviews from the Software Manager (mintinstall).

- First issue, it kept telling me I had a 'Invalid Username'. Login with the same username & pw directly to the community website was successful.
- Second issue, attempts to add a review from the website frequently receive a backend server time out. Embarassing for an LM sponsor, the error redirects directly to their web site - ouch!
- Third issue, attempts to update a previous review are rejected with a '405 Not Allowed' message. Bug or feature?

Won't go into other 'feature issues' with mintinstall here but there are obvious ones.

Is anyone monitoring the Community website ?? :(
Use the Panels, Luke! (not just the Whisker Menu)
XFCE and Linux Mint 18 LTS - stable, easily configurable goodness.

User avatar
xenopeek
Level 24
Level 24
Posts: 21382
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Community website / mintinstall issues

Postby xenopeek » Thu Sep 01, 2016 4:05 am

Thanks for supporting the developers!

We're aware of issues on the community website. Some users have problems when reviewing from Software Manage, the backend sometimes has performance issues, and some security hardening that was done after the attacks on our website in February may still be set too strict for certain pages/actions.

We're trying to figure out why users have sometimes the "invalid username" error when trying to review from within Software Manager. Can you try changing your password on the website and then checking again Software Manager? If still the same error can you try to set as simple a password as possible for testing purpose—say use only a-z and A-Z letters and 0-9 digits?
Image

MikeF90000
Level 2
Level 2
Posts: 86
Joined: Sun Jan 08, 2012 7:54 pm
Location: Southern California, USA

Re: Community website / mintinstall issues

Postby MikeF90000 » Sun Sep 04, 2016 6:23 pm

xenopeek wrote:We're trying to figure out why users have sometimes the "invalid username" error when trying to review from within Software Manager. Can you try changing your password on the website and then checking again Software Manager? If still the same error can you try to set as simple a password as possible for testing purpose—say use only a-z and A-Z letters and 0-9 digits?

Not sure how that can be done. The new pw standard for both the forums and community sites require a 'special' character as well. I changed from '@' to '-' and it made no difference.

Submitting the review directly from the community site got the Timeout error always on the first attempt; after a browser back arrow the second attempt is usually successful. Wondering if some kind of database transaction or network connection has to be pre-established.

Also noticed that 'add' and 'update' review submits from a few days ago that seemed to fail were actually successful. Another database glitch or ?
Use the Panels, Luke! (not just the Whisker Menu)
XFCE and Linux Mint 18 LTS - stable, easily configurable goodness.

JChristensen
Level 2
Level 2
Posts: 62
Joined: Sat Apr 25, 2015 8:52 pm

Re: Community website / mintinstall issues

Postby JChristensen » Tue Sep 06, 2016 8:29 pm

I've also been getting the "Sucuri CloudProxy - Backend Server timeout" message on various community software pages. I had communicated with the admin a month or so ago and understood they were aware and working on it, but I see no improvement, I still get the error pages.
LM18 Cinnamon 64 on Dell Optiplex 745, HP Pavilion dv6, dv7, h8.

keithterrill
Level 1
Level 1
Posts: 3
Joined: Fri Jun 20, 2014 12:02 pm

Re: Community website / mintinstall issues

Postby keithterrill » Sun Mar 05, 2017 1:18 pm

I am trying to rate an app from within the Software Manager. I keep getting:


Invalid username

Your username is incorrect. To change it, click on the 'Edit' menu and select 'Account information'.

I have gone into the Linux Mint site at http:/./comunity.linuxmint.com as well as this Linux Mint Forums and have changed the password, many times. But no matter what I do, it doesn't change the result.

I am using 17.3. Is that a problem?

MikeF90000
Level 2
Level 2
Posts: 86
Joined: Sun Jan 08, 2012 7:54 pm
Location: Southern California, USA

Re: Community website / mintinstall issues

Postby MikeF90000 » Sat Jun 10, 2017 5:17 pm

Just tried submitting a review to the Community from within mintinstall, still get the 'Invalid Username' message. It would be nice if someone would fit this.

While they're at it, how about changing the Review input field from a line to a rectangle used since the dawn of 'dumb terminals'. Perhaps this feature was ported from a TTY33 (dating me pretty badly :D ).
Use the Panels, Luke! (not just the Whisker Menu)
XFCE and Linux Mint 18 LTS - stable, easily configurable goodness.

neglesaks79
Level 1
Level 1
Posts: 1
Joined: Sun Jul 16, 2017 6:57 pm

Re: Community website / mintinstall issues

Postby neglesaks79 » Sun Jul 16, 2017 7:21 pm

I must likewise beg for increased attention given to the mintinstall / Software Manager application. I actively seek out minor, obscure apps that has received no feedback and as such receive no attention. I receive the eternal error message: "Invalid password, go to account info blah blah. "

I really like Linux Mint, but to have the ability to contribute to the community hampered by a bug that has been extant for years, coupled with a user interface for the login that only says "close"? It has no indication of giving user feedback whatsoever; the user has no idea whether the entered user info is accepted or not.

This bug has existed for years. I am plagued by it. It is the exact same login info as on the mint community page. I am absolutely sure that I am entering my info correctly.

I apologize for my insistence, but I cannot contribute to the community when I am walled off from commenting by an unknown bug and an unhelpful package install app. I am frustrated by this.

Costas
Level 1
Level 1
Posts: 1
Joined: Sun Sep 03, 2017 7:07 am

Re: Community website / mintinstall issues

Postby Costas » Sun Sep 03, 2017 7:26 am

Hi all, same problem here. Cannot review apps from the Software Manager due to inability to log in. Latest linux Mint and just registered here :-)

JeremyB
Level 17
Level 17
Posts: 7451
Joined: Fri Feb 21, 2014 8:17 am

Re: Community website / mintinstall issues

Postby JeremyB » Sun Sep 03, 2017 7:52 am

Do you also have an account set up at https://community.linuxmint.com/


Return to “Non-technical Questions”