Mint 19 Opinions and Reviews

Questions about the project and the distribution - obviously no support questions here please
sikejsudjek
Level 4
Level 4
Posts: 212
Joined: Thu Apr 24, 2014 1:53 pm

Re: Mint 19 Opinions and Reviews

Post by sikejsudjek » Thu Jul 19, 2018 6:24 pm

Three systems upgraded (not clean install) no problems after a week or so. One or two programs don't work in wine any more, not a big deal.

carum carvi
Level 3
Level 3
Posts: 156
Joined: Sun Apr 16, 2017 11:44 pm

Re: Mint 19 Opinions and Reviews

Post by carum carvi » Wed Jul 25, 2018 10:06 am

I really love it. Can't think of anything that worked better in LM18.

Timeshift is improved. Vlc Mediaplayer is improved. The looks are improved. The only thing that has to be fixed is the standard setting for level 4 updates. For newbies this should be changed. Other than that I really enjoy Tara. Many thanks to the makers of this wonderful OS.

MrT
Level 3
Level 3
Posts: 122
Joined: Tue Jun 20, 2017 3:21 pm

Re: Mint 19 Opinions and Reviews

Post by MrT » Thu Jul 26, 2018 2:26 am

Did the upgrade as opposed to the clean installation. Clean installations always created issues with GRUB in the past, serious issues as a matter of fact.

Upgrade went smoothly and all I had to do was performing some "autoclean"ing to eliminate stuff that had been replaced but not removed from the 18.3 version.
LM 19 is working smoother than LM 18 or 17 for now. Unless line commands are required past the very basics instructions, any Windows user could be running and well in 1 or 2 hours time. Very impressed with how intuitive the use of LM is for a novice coming from Windows. I have not played around with Wine yet and may not do that. However, that would not be a LM problem per se.

Once the upgrade was completed, for some reason, the machine could not start and went into a GRUB rescue of sort, but I went into BIOS and noticed that the safe boot setting was checked and I unchecked it. After that, the next restart GRUB was back and already showing the LM 19 instead of LM 18.3 entries.

Upgrading saved me a lot of time by not having to toy with settings for the software I use (commercial or free).

Cinnamon looks better and sharper than before. I always create my own backgrounds and they look really nice.

All drivers switched on "out of the box", even the multiple displays, something that did not work in Ubuntu the last time I tried (with the 17.10 version of that distro 3 months ago or so).

The software in the official repositories still tends to be obsolete, although some updates were produced. But that is overall a different story. Thankfully PPAs have already been updated with the latest releases based on Ubuntu Bionic 18.04

I use LaTeX and TexLive was converted for me to the new Ubuntu Bionic... Very grateful to the people who made the upgrade program possible as it saved me lots of time having to roam the internet and downloading stuff.

I have made a point not to upgrade the kernel constantly and stick with the kernel 4.15.0 family In the past I could not as the kernel proposed was not covering the most modern drivers and needed to move to newer families for my machine to work.

Only "item" that surprised me is that in LM 17 and LM 18 I had an Intel microcode, not so in LM 19. However, the machine does not seem to have any issues. Not complaining, just stating that I noticed it.

One software issue that I am having, even if it does not produce any major consequence is with Anaconda. I have created my own launcher because, I will admit to it, I do like launchers and do not want to have to remember the "magic word" to launch a program from terminal. However, regardless of whether I use the launcher or if I start Anaconda from terminal, I get some issues with the terminal environment:
- from launcher I get bash: activate: No such file or directory
- from terminal, after typing anaconda-navigator, I get the message 2018-07-25 23:09:31,311 - ERROR anaconda_api.is_vscode_available:956
# Option “-x” is deprecated and might be removed in a later version of gnome-terminal.#
# Use “-- ” to terminate the options and put the command line to execute after it.#

and terminal environment refuses to open. I did not re-install Anaconda in going from 18.3 to 19. I wonder if that might have caused a problem. However the
message 2018-07-25 23:09:31,311 - ERROR anaconda_api.is_vscode_available:956 had been experienced by several users even under older LM editions.

User avatar
CaptainKirksChair
Level 4
Level 4
Posts: 289
Joined: Sat Feb 18, 2017 9:29 pm

Re: Mint 19 Opinions and Reviews

Post by CaptainKirksChair » Fri Jul 27, 2018 7:59 pm

I upgraded my iMac to Mint 19.0 Cinnamon. I was rebuilding my WD Passport USB external 1TB drive and it seemed to screw up GRUB on the iMac. I have no idea why but when I finally got the external drive working properly (dual boot with macOS and Mint 19) I just upgraded the iMac to Mint 19 to solve the problems.

I did find that if you use Cairo-Dock with Mint 19, there will be a few things wrong. My issue was that the trash bin on the dock was not linked properly to the operating system trash. You have to run the following command from a terminal to fix the existing issues with Mint 19 and Cairo-Dock:

Code: Select all

sudo apt-get install cairo-dock cairo-dock-plug-ins
Everything else is working fine.

Post Reply

Return to “Non-technical Questions”