clock glitch

Questions about the project and the distribution - obviously no support questions here please
Post Reply
User avatar
tinny
Level 2
Level 2
Posts: 99
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

clock glitch

Post by tinny » Mon Nov 26, 2007 8:11 am

This weekend I had the opportunity to give a friend four Linux live CDs. As he is having difficulty burning ISOs, I was glad to loan him some CDs I had prepared, and I will probably just let him keep them since versions are changing soon anyway. I also had the opportunity to show him several distros in action on a computer I had handy. But not Mint.

The other day, I was testing Daryna live CD, and I rebooted my computer back into Puppy (installed), and I noticed that the clock had changed (was wrong). This baffled me for a microsecond as I recalled that Mint tends to do this because its default clock setting is UTC, rather than local time. So here I am expounding on the wonders of Linux to my friend and I must make excuses and explanations for how Mint is gonna mess up the clock, so he must be able to fix the clock on his sister's fancy laptop which he is borrowing. I might as well have said, just skip Mint and try the other three distros.

I would like to be able to recommend Mint, without reservations.

http://www.linuxmint.com/forum/viewtopi ... cal&t=2257

EDIT: I notice that PCLOS 07 live CD has a dialog for the user to select UTC or local time, during boot.
Last edited by tinny on Mon Nov 26, 2007 12:12 pm, edited 1 time in total.

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: clock glitch

Post by Husse » Mon Nov 26, 2007 11:04 am

You have the opportunity to select time during install
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

User avatar
tinny
Level 2
Level 2
Posts: 99
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

Re: clock glitch

Post by tinny » Mon Nov 26, 2007 12:18 pm

Suggestion:

1. Provide a dialog in Mint liveCD to select UTC or local time (during boot).
-or-
2. Make local time the default for Mint liveCD, as do most other distros. If no, please explain why Mint liveCD must use UTC as default.

Husse
Level 23
Level 23
Posts: 18701
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: clock glitch

Post by Husse » Tue Nov 27, 2007 10:20 am

This is because we use Ubiquity, the same installer as Ubuntu and it's the default there that's used. I don't remember 100% but I think local time is the default
Image
Don't fix it if it ain't broken, don't break it if you can't fix it

keithp
Level 3
Level 3
Posts: 124
Joined: Wed Dec 27, 2006 6:17 am
Location: Cheshire, England

Re: clock glitch

Post by keithp » Tue Nov 27, 2007 11:52 am

Tinny.

If you right click on the date/time on the desktop panel, then select 'Preferences', you will see that you can select 'Use UTC'. So I would imagine that if this isn't selected, the time is showing local time, not GMT.

As the clocks went back here in the UK some weeks ago, we are on GMT for the winter. So I can't easily check it.

Hope this is what you were looking for.

Cheers

Keith

User avatar
tinny
Level 2
Level 2
Posts: 99
Joined: Thu Feb 22, 2007 2:35 pm
Location: USA

Re: clock glitch

Post by tinny » Thu Nov 29, 2007 1:19 pm

I just carefully installed Daryna (clean install after wiping hdd), and here is /etc/default/rcS:

Code: Select all

# /etc/default/rcS
#
# Default settings for the scripts in /etc/rcS.d/
#
# For information about these variables see the rcS(5) manual page.
#
# This file belongs to the "initscripts" package.

TMPTIME=0
SULOGIN=no
DELAYLOGIN=no
UTC=yes
VERBOSE=no
FSCKFIX=no
Please note that "UTC=yes". This is undesired.

User avatar
Ede
Level 4
Level 4
Posts: 291
Joined: Thu Jun 14, 2007 7:02 pm
Location: Norway

Re: clock glitch

Post by Ede » Fri Nov 30, 2007 9:58 pm

Must depend on localization during the install. UTC was off by default for me, so I see no problem.

Post Reply

Return to “Non-technical Questions”