No need updating Mint version

Questions about the project and the distribution - obviously no support questions here please
Post Reply
User avatar
boysha
Level 3
Level 3
Posts: 125
Joined: Tue Jul 03, 2007 1:03 pm
Location: Victoria, BC, Canada
Contact:

No need updating Mint version

Post by boysha »

I am afraid that this would be a silly question to ask but I would like to know the answer, nevertheless.
I was wondering if there is a Mint version or at least a way to make Mint that will be installed with a few default applications and that will not need or have any updates afterwards? The reason is: my grandmother would love to have Mint but she doesn't want to have to follow the Mint Update and be bothered with it. She says - if it's working fine when it is once installed, why would she have to always update etc?
So, someone, please tell me how can I make her, say Linux Mint 10 to stay the way it is after it is installed with all the updates/upgrades and then shot those off? Or if there is another way/ distro version or something else that will work just like my grandmother wants?
Thanks in advance.
Cheers!

User avatar
Aging Technogeek
Level 13
Level 13
Posts: 4581
Joined: Sun Jan 11, 2009 9:54 am
Location: Right about here

Re: No need updating Mint version

Post by Aging Technogeek »

Just remove mintUpdate from the Startup Applications menu. This way, the only way to do updates is to start mintUpdate manually. The rest ofthe time it stays quiet and out of the way.

Actually, you do not even have to do that. Mint does not update automatically like Windows. You must run the updater as superuser to install updates. If you do not run the updater, the most intrusive it will get is an icon in the system tray indicating that you have updates available. If this is too much, disable the updater in the Startup Menu as I mentioned above.
Registered Linux User 483387

User avatar
boysha
Level 3
Level 3
Posts: 125
Joined: Tue Jul 03, 2007 1:03 pm
Location: Victoria, BC, Canada
Contact:

Re: No need updating Mint version

Post by boysha »

Thank you very much. I had the same notion only wasn't sure if it will hurt the distro in any way.
Cheers!

baptiste
Level 3
Level 3
Posts: 104
Joined: Sun Jan 22, 2012 12:25 am

Re: No need updating Mint version

Post by baptiste »

those are mostly security updates. as a home user, you run no real risk of being attacked if you don't do them ; but it's always nice to do, it pleases the computer gods :).

on any debian/ubuntu/mint computer I administer I run the apt-get upgrade command as root (or with sudo) once in a while, without thinking too much about it.

User avatar
BigSteve_G
Level 4
Level 4
Posts: 298
Joined: Mon Feb 15, 2010 6:56 pm
Location: ~/a comfy chair
Contact:

Re: No need updating Mint version

Post by BigSteve_G »

Had to smile when I read this as it reminded me of the last time I updated my parents laptop from Mint 8 to Mint 10 & how they complained it had all changed & they didnt think they could use it the new way - all that had changed was the icons & a few layouts.

Realisticaly once a Mint version is no longer supported (but is up-to-date) how good an idea is it to keep it running? (I know I wont be able to install new software) - I know that if I update them to a Mint system running anything other then Gnome 2.32 with a custom menu & layout I will be inundated with calls "I cant use this laptoptop! - wheres this gone? - you've changed it & we cant use it"
I've fixed Windows, tried running with Jackalopes, fought Koalas & now, I'm addicted to Mints

Now with half a decade running Linux mint, still enjoying it & still learning!

http://www.facebook.com/itsbigsteve

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: No need updating Mint version

Post by AlbertP »

You can keep using it, but won't get security updates. Linux doesn't get infected that often - but I have once seen a report on a Linux forum of a computer that got infected because its distro was obsoleted.

Mint 9, by the way, has support till April 2013, so if you downgrade from 10 to 9, you can keep using Gnome 2 yet another year before finally deciding about the future of Linux on your parents' computer.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
BigSteve_G
Level 4
Level 4
Posts: 298
Joined: Mon Feb 15, 2010 6:56 pm
Location: ~/a comfy chair
Contact:

Re: No need updating Mint version

Post by BigSteve_G »

Thanks for that.
AlbertP wrote:Mint 9, by the way, has support till April 2013, so if you downgrade from 10 to 9, you can keep using Gnome 2 yet another year before finally deciding about the future of Linux on your parents' computer.
To be honest I went with Mint 10 because I had a custom version (base Mint 10 with extra software) thanks to remastersys which I couldn't seem to get working right with Mint 9.

As for the future of Linux on my parents computer its not a real deiscion - it will be Mint just not sure what flavour (lxde or mate) unless I can convince them gnome 3 or cinammon isnt that scary

Of course plan B is, as always "if it works, leave it"
I've fixed Windows, tried running with Jackalopes, fought Koalas & now, I'm addicted to Mints

Now with half a decade running Linux mint, still enjoying it & still learning!

http://www.facebook.com/itsbigsteve

baptiste
Level 3
Level 3
Posts: 104
Joined: Sun Jan 22, 2012 12:25 am

Re: No need updating Mint version

Post by baptiste »

a friend upgraded from mint 10 to mint 12 lxde and likes it. no "xeyes" applet though.
I checked MATE out and it seems to lack most gnome 2 applets. time to move forward already from gnome 2.

if your mint 10 is working flawlessly you are not in a hurry though and there may be the option of "old-release" ubuntu repository.

User avatar
Pierre
Level 19
Level 19
Posts: 9462
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: No need updating Mint version

Post by Pierre »

Actually - I have a old laptop that still has Mint-05 Elyssa on it :o

- works just fine - has had no updates for some two years, now.

But - I have <manually> upated FF to FF 4.0 - where upon, it has auto-updated itself.
- same with Opera.

otherwise, - nothing else is really needed :)
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
cc11rocks
Level 1
Level 1
Posts: 14
Joined: Wed Jan 04, 2012 4:57 am

Re: No need updating Mint version

Post by cc11rocks »

You could make a script using cron to update in the background once a day/week/whatever. Then, just remove mintUpdate.

User avatar
BigSteve_G
Level 4
Level 4
Posts: 298
Joined: Mon Feb 15, 2010 6:56 pm
Location: ~/a comfy chair
Contact:

Re: No need updating Mint version

Post by BigSteve_G »

Based off what http://en.wikipedia.org/wiki/Linux_Mint says about a 'backports' repository - is it possable to install an old (unsopported) version of Mint, enable the backported repository then install software from there?

I'm thinking so I can Install Mint 8 on my laptop (ran perfect on the low spec) but install gnome-games & frozen bubbles (for example)
I've fixed Windows, tried running with Jackalopes, fought Koalas & now, I'm addicted to Mints

Now with half a decade running Linux mint, still enjoying it & still learning!

http://www.facebook.com/itsbigsteve

AlbertP
Level 16
Level 16
Posts: 6719
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: No need updating Mint version

Post by AlbertP »

You can enable Mint's backports in Software Manager. However the backport section is generally not used much - for Mint 8 it contains nothing.
Ubuntu has backports repositories, which you can add on Mint, but I don't know if they are also available for obsoleted versions.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
pluraldave
Level 5
Level 5
Posts: 706
Joined: Mon Sep 01, 2008 8:05 am

Re: No need updating Mint version

Post by pluraldave »

This is the sort of situation where a LMDE-stable edition with auto-updating would be useful.

Post Reply

Return to “Non-technical Questions”