FireFox 57 getting slow

Chat about anything related to Linux Mint
User avatar
Pepi
Level 5
Level 5
Posts: 652
Joined: Wed Nov 18, 2009 7:47 pm

FireFox 57 getting slow

Post by Pepi » Mon Nov 27, 2017 10:58 am

Has anyone else noticed that the new FireFox 57 has a lag sometimes. I notice it when I'm typing an email or like typing here. I turned off No-Script because it was driving me crazy :lol: I was hoping it was the problem but I'm still seeing the lag off and on

User avatar
BigEasy
Level 6
Level 6
Posts: 1149
Joined: Mon Nov 24, 2014 9:17 am
Location: Chrząszczyżewoszyce, powiat Łękołody

Re: FireFox 57 getting slow

Post by BigEasy » Mon Nov 27, 2017 11:35 am

I can confirm - there is lags in FF57 sometimes. Seldom, but it is. In my case this happens during the autoupdates of the add-ons. For example when Ublock's origin updates a lot of 3rd-party filters. I have to say it is not FF57 native lags. There was before 57 as well.
Windows assumes I'm stupid but Linux demands proof of it

Royal-Mint
Level 1
Level 1
Posts: 35
Joined: Tue Jul 22, 2014 3:57 am

Re: FireFox 57 getting slow

Post by Royal-Mint » Mon Nov 27, 2017 10:51 pm

This what you get from hype firefox too much.
& the first thing that nobody aware that first ff 57 generation first run screen
used to be super laggy html5 animation water wallpaper video.
which embarrassed mozilla extremely & they quickly turn off into non animation water wallpaper.

but at least to be sure it reduce 30mb of ram usage from old firefox version.

User avatar
Pepi
Level 5
Level 5
Posts: 652
Joined: Wed Nov 18, 2009 7:47 pm

Re: FireFox 57 getting slow

Post by Pepi » Mon Nov 27, 2017 11:25 pm

What :shock:

aes2011
Level 4
Level 4
Posts: 466
Joined: Wed Jul 06, 2011 10:39 pm

Re: FireFox 57 getting slow

Post by aes2011 » Tue Nov 28, 2017 12:25 am

I haven't noticed lags with Firefox 57. But I started off with a new profile and just uBlock origin.

User avatar
bob466
Level 4
Level 4
Posts: 243
Joined: Mon May 15, 2017 5:23 am
Location: Australia

Re: FireFox 57 getting slow

Post by bob466 » Tue Nov 28, 2017 12:36 am

I also get a lag sometimes and it's been slow for a long time...I think the Firefox Team believe their own PR now...and Ugly at best. :shock:
Linux For Ever...Windoze Never

User avatar
Pepi
Level 5
Level 5
Posts: 652
Joined: Wed Nov 18, 2009 7:47 pm

Re: FireFox 57 getting slow

Post by Pepi » Tue Nov 28, 2017 8:52 am

I tried PaleMoon and it is lightning fast but looks like Chrome to me :lol:

User avatar
Night Wing
Level 4
Level 4
Posts: 255
Joined: Wed Dec 25, 2013 10:21 pm
Location: Texas, USA

Re: FireFox 57 getting slow

Post by Night Wing » Tue Nov 28, 2017 10:59 am

Pepi wrote:I tried PaleMoon and it is lightning fast but looks like Chrome to me :lol:
There are two versions of Pale Moon now. You must have tried Basilisk Pale Moon which does have a tendency to look like Chrome or the old Australis Firefox before Quantum. The regular Pale Moon hasn't changed and does not look anything like Firefox Quantum, Chrome or Basilisk. And the regular Pale Moon is more customizable "within" the browser than either Firefox Quantum or Chrome.
Mint 19 (Tara) Xfce

User avatar
Derek_S
Level 6
Level 6
Posts: 1235
Joined: Sat Dec 28, 2013 5:36 pm
Location: Long Island, N.Y.

Re: FireFox 57 getting slow

Post by Derek_S » Tue Nov 28, 2017 3:51 pm

Pepi wrote:Has anyone else noticed that the new FireFox 57 has a lag sometimes. I notice it when I'm typing an email or like typing here. I turned off No-Script because it was driving me crazy :lol: I was hoping it was the problem but I'm still seeing the lag off and on
I have to agree that No Script causes more problems than it solves, at least for me. I gave up using it a long time ago.
"When you rise in the morning, give thanks for the light, for your life, for your strength. Give thanks for your food and for the joy of living. If you see no reason to give thanks, the fault lies in yourself." - Tecumseh

User avatar
jimallyn
Level 18
Level 18
Posts: 8136
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: FireFox 57 getting slow

Post by jimallyn » Tue Nov 28, 2017 6:12 pm

When I first installed FF57, it was faster then the previous version. But now, sometimes it feels slow. No idea why. I also pretty much gave up on NoScript. There are just too many websites out there that use scripts, and you just wind up making exceptions at every site you visit.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

User avatar
Lucap
Level 5
Level 5
Posts: 913
Joined: Tue May 24, 2016 1:40 am

Re: FireFox 57 getting slow

Post by Lucap » Thu Nov 30, 2017 2:01 am

When i first used FF 57 i was deeply impressed but it's slowly starting to annoy me even though i'm trying to be forgiving towards it being the first release of Quantum.

I've had random screen scroll glitches ( including vertical breaks that i have never seen before ) and HTML5 playback is definitely not as smooth as it looks like it's dropping frames and when used heavily for a couple of hours it becomes sluggish as if the machine has run out of memory yet resources say that there is plenty of ram left?

User avatar
Pepi
Level 5
Level 5
Posts: 652
Joined: Wed Nov 18, 2009 7:47 pm

Re: FireFox 57 getting slow

Post by Pepi » Thu Nov 30, 2017 9:10 am

I see that the Hardware accelerator is turned on with FF57. I turned this off and a lot of my lagging is gone. My problem now is ... When I shutdown FF it appears to die but then later the Crash Windows appears. Just annoying really. Not sure if it's uBlock or FireJail doing it? These are the only extras running with FF

Code: Select all

Add-ons: uBlock0%40raymondhill.net:1.14.20,disable-media-wmf-nv12%40mozilla.org:1.1,followonsearch%40mozilla.com:0.9.6,screenshots%40mozilla.org:19.2.0,activity-stream%40mozilla.org:2017.11.07.1100-7f4e3634,shield-recipe-client%40mozilla.org:76.1,firefox%40getpocket.com:1.0.5,webcompat%40mozilla.org:1.1,onboarding%40mozilla.org:1.0,formautofill%40mozilla.org:1.0,aushelper%40mozilla.org:2.0,e10srollout%40mozilla.org:3.05,langpack-en-GB%40firefox.mozilla.org:57.0,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:57.0,langpack-en-ZA%40firefox.mozilla.org:57.0
AddonsShouldHaveBlockedE10s: 0
BuildID: 20171116103757
ContentSandboxCapabilities: 119
ContentSandboxCapable: 1
ContentSandboxLevel: 3
CrashTime: 1512002560
DOMIPCEnabled: 1
E10SCohort: webextensions-multiBucket4
EMCheckCompatibility: true
FramePoisonBase: 9223372036600930304
FramePoisonSize: 4096
InstallTime: 1511022298
MozCrashReason: MOZ_CRASH(Shutdown too long, probably frozen, causing a crash.)
Notes: Linux Mint 18.3 SylviaFP(D00-L1000-W00000000-T000) OpenGL: NVIDIA Corporation -- Quadro FX 1800/PCIe/SSE2 -- 3.3.0 NVIDIA 340.102 -- texture_from_pixmap
WR? WR- 
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 1151
ShutdownProgress: profile-change-teardown
StartupCrash: 0
StartupTime: 1512001636
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86-64","buildId":"20171116103757","version":"57.0","vendor":"Mozilla","platformVersion":"57.0","xpcomAbi":"x86_64-gcc3","hotfixVersion":null,"updaterAvailable":false},"partner":{"distributionId":"mint","distributionVersion":"1.0","partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":["mint "]},"system":{"memoryMB":5945,"virtualMaxMB":null,"cpu":{"count":4,"cores":4,"vendor":"GenuineIntel","family":6,"model":26,"stepping":5,"l2cacheKB":256,"l3cacheKB":8192,"speedMHz":2528,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2"]},"os":{"name":"Linux","version":"4.10.0-40-generic","locale":"en-US"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"ContentBackend":"Skia","adapters":[{"description":"NVIDIA Corporation -- Quadro FX 1800/PCIe/SSE2","vendorID":"NVIDIA Corporation","deviceID":"Quadro FX 1800/PCIe/SSE2","subsysID":null,"RAM":null,"driver":null,"driverVersion":"3.3.0 NVIDIA 340.102","driverDate":null,"GPUActive":true}],"monitors":[],"features":{"compositor":"basic","gpuProcess":{"status":"unused"}}},"appleModelId":null},"settings":{"attribution":{},"blocklistEnabled":true,"e10sEnabled":true,"e10sMultiProcesses":4,"e10sCohort":"webextensions-multiBucket4","telemetryEnabled":false,"locale":"en-US","update":{"channel":"release","enabled":true,"autoDownload":true},"userPrefs":{"browser.cache.disk.capacity":358400,"browser.newtabpage.enabled":false,"browser.newtabpage.enhanced":false,"browser.shell.checkDefaultBrowser":true,"browser.search.widget.inNavBar":true,"browser.startup.homepage":"<user-set>","dom.ipc.processCount":4,"layers.acceleration.disabled":true},"sandbox":{"effectiveContentProcessLevel":3},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":true,"defaultSearchEngine":"yahoo","defaultSearchEngineData":{"name":"Yahoo","loadPath":"jar:[app]/omni.ja!browser/yahoo.xml","origin":"default","submissionURL":"https://search.yahoo.com/yhs/search?hspart=ddc&hsimp=yhs-linuxmint&type=__alt__ddc_linuxmint_com&p="}},"profile":{"creationDate":17488},"experiments":{"e10sCohort":{"branch":"webextensions-multiBucket4"}},"addons":{"activeAddons":{"followonsearch@mozilla.com":{"version":"0.9.6","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":null,"name":"Follow-on Search Telemetry","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"screenshots@mozilla.org":{"version":"19.2.0","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":null,"name":"Firefox Screenshots","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"activity-stream@mozilla.org":{"version":"2017.11.07.1100-7f4e3634","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"A rich visual history feed and a reimagined home page make it easier than ever to find exactly what ","name":"Activity Stream","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"shield-recipe-client@mozilla.org":{"version":"76.1","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"Client to download and run recipes for SHIELD, Heartbeat, etc.","name":"Shield Recipe Client","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"firefox@getpocket.com":{"version":"1.0.5","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"When you find something you want to view later, put it in Pocket.","name":"Pocket","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"webcompat@mozilla.org":{"version":"1.1","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"Urgent post-release fixes for web compatibility.","name":"Web Compat","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"onboarding@mozilla.org":{"version":"1.0","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"Photon onboarding","name":"Photon onboarding","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"formautofill@mozilla.org":{"version":"1.0","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"Autofill forms with saved profiles","name":"Form Autofill","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"aushelper@mozilla.org":{"version":"2.0","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"Sets value(s) in the update url based on custom checks.","name":"Application Update Service Helper","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"e10srollout@mozilla.org":{"version":"3.05","scope":1,"type":"extension","updateDay":17486,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"Staged rollout of Firefox multi-process feature.","name":"Multi-process staged rollout","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17486},"disable-media-wmf-nv12@mozilla.org":{"version":"1.1","scope":1,"type":"extension","updateDay":17492,"isSystem":true,"isWebExtension":false,"multiprocessCompatible":true,"blocklisted":false,"description":"This disables NV12 surface format on Windows for AMD graphic adapters, see bug 1417442","name":"Disable Media WMF NV12 format","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17492,"signedState":3},"uBlock0@raymondhill.net":{"version":"1.14.20","scope":1,"type":"extension","updateDay":17499,"isSystem":false,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"Finally, an efficient blocker. Easy on CPU and memory.","name":"uBlock Origin","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17488,"signedState":2}},"theme":{"id":"46852@personas.mozilla.org","blocklisted":false,"description":null,"name":"Sunset Over Water by MaDonna","userDisabled":false,"appDisabled":false,"version":"0","scope":1,"foreignInstall":false,"installDay":0,"updateDay":0},"activePlugins":[{"name":"Shockwave Flash","version":"27.0.0.187","description":"Shockwave Flash 27.0 r0","blocklisted":false,"disabled":false,"clicktoplay":true,"mimeTypes":["application/x-shockwave-flash","application/futuresplash"],"updateDay":17465}],"activeGMPlugins":{"gmp-gmpopenh264":{"version":"1.7.1","userDisabled":false,"applyBackgroundUpdates":1},"gmp-widevinecdm":{"version":"1.4.8.1008","userDisabled":false,"applyBackgroundUpdates":1}},"activeExperiment":{},"persona":"46852"}}
Theme: classic/1.0
ThreadIdNameMapping: 12:"Gecko_IOThread",13:"Timer",14:"Link Monitor",16:"JS Watchdog",26:"Hang Monitor",29:"Cache2 I/O",32:"GMPThread",33:"SoftwareVsyncThread",34:"Compositor",35:"ImgDecoder #1",36:"ImgDecoder #2",37:"ImgDecoder #3",38:"ImageIO",39:"LoadRoots",40:"SysProxySetting",42:"ProxyResolution",43:"DataStorage",44:"URL Classifier",46:"DataStorage",45:"Classifier Update",47:"DataStorage",49:"HTML5 Parser",50:"IPDL Background",51:"DOM Worker",56:"ImageBridgeChild",64:"localStorage DB",94:"SaveScripts",95:"Cache I/O",96:"mozStorage #1",97:"QuotaManager IO",98:"mozStorage #2",99:"mozStorage #3",101:"mozStorage #4",104:"DOM Worker",107:"DOM Worker",158:"IdentityCrypto",161:"mozStorage #7",351:"Shutdown Hang Terminator",
Throttleable: 1
URL: https://www.yahoo.com/finance/news/apos-senate-republicans-apos-tax-182354205.html
UptimeTS: 924.16064274
Vendor: Mozilla
Version: 57.0
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.

User avatar
sudo apt-get Linux
Level 1
Level 1
Posts: 39
Joined: Sat Oct 22, 2016 9:08 am
Location: LIGNUX LAND
Contact:

Re: FireFox 57 getting slow

Post by sudo apt-get Linux » Thu Nov 30, 2017 9:37 am

You may try the Tor Browser Bundle which is made from a modified version of FF, and always come with NoScript.

User avatar
BigEasy
Level 6
Level 6
Posts: 1149
Joined: Mon Nov 24, 2014 9:17 am
Location: Chrząszczyżewoszyce, powiat Łękołody

Re: FireFox 57 getting slow

Post by BigEasy » Thu Nov 30, 2017 3:46 pm

https://www.mozilla.org/en-US/firefox/5 ... easenotes/
Brace yourself for an all-new Firefox. It’s fast. Really fast. It’s over twice as fast as Firefox from 6 months ago
I really like their "6 months ago".
Windows assumes I'm stupid but Linux demands proof of it

User avatar
InkKnife
Level 5
Level 5
Posts: 709
Joined: Mon Apr 30, 2012 5:24 pm

Re: FireFox 57 getting slow

Post by InkKnife » Tue Dec 05, 2017 3:04 am

Lucap wrote:When i first used FF 57 i was deeply impressed but it's slowly starting to annoy me even though i'm trying to be forgiving towards it being the first release of Quantum.

I've had random screen scroll glitches ( including vertical breaks that i have never seen before ) and HTML5 playback is definitely not as smooth as it looks like it's dropping frames and when used heavily for a couple of hours it becomes sluggish as if the machine has run out of memory yet resources say that there is plenty of ram left?
FF57 has some bugs but I suspect they will sort it out. 57 is almost a v1.0 release really. The 57.0.1 update squashed some bugs I was running into.
After years of spinning their wheels I think Mozilla is back on track...I sure hope so.
My good old PC:
Core2quad@2.33, 8GB Ram, Radeon HD 6850. 64GB SSD boot Drive, 750GB data dump drive, Mint/Cinnamon edition.

aes2011
Level 4
Level 4
Posts: 466
Joined: Wed Jul 06, 2011 10:39 pm

Re: FireFox 57 getting slow

Post by aes2011 » Tue Dec 05, 2017 3:34 am

Pepi wrote:I see that the Hardware accelerator is turned on with FF57. ...
Where do we find this information? Is it in about:support? Would this be the section?

Code: Select all

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none
CairoUseXRender: 0
Decision Log
HW_COMPOSITING:
blocked by default: Acceleration blocked by platform
OPENGL_COMPOSITING:
unavailable by default: Hardware compositing is disabled
WEBRENDER:
opt-in by default: WebRender is an opt-in feature
unavailable by runtime: Build doesn't include WebRender

Ascaris
Level 1
Level 1
Posts: 49
Joined: Sun Jun 19, 2016 11:56 pm

Re: FireFox 57 getting slow

Post by Ascaris » Sat Dec 09, 2017 11:32 am

HW_COMPOSITING: blocked by default: Acceleration blocked by platform
That's it there.
Hardware acceleration is disabled on Linux across the board by default, as far as I know. To enable it, toggle this pref to true in about:config:
layers.acceleration.force-enabled

Also, you might try enabling these too and see how it works:
layers.acceleration.force-enabled
gfx.canvas.azure.accelerated

it used to be that you had to enable the environment variable MOZ_USE_OMTC to 1 to enable this, but I don't think it is necessary anymore. If this doesn't work, you can try starting Firefox with export MOZ_USE_OMTC=1 && firefox
Main PC: Mint 18.3 Cinnamon & Windows 8.1/ Asus P8P67 Deluxe/i5-2500k @ 4.5Ghz
Main Laptop: Mint 18.3 Cinnamon & Windows 8.1/ Asus F8Sn w/GTX220 & C2D T9300
Laptop for when I need battery life: Dell Inspiron 11-3162, Mint 18.3 Cinnamon

User avatar
Lucap
Level 5
Level 5
Posts: 913
Joined: Tue May 24, 2016 1:40 am

Re: FireFox 57 getting slow

Post by Lucap » Thu Dec 21, 2017 1:53 am

My problem seems to have been Debain SID as i've been back on Mint 18.3 the last couple of days without any slow downs.

User avatar
Lucap
Level 5
Level 5
Posts: 913
Joined: Tue May 24, 2016 1:40 am

Re: FireFox 57 getting slow

Post by Lucap » Thu Dec 28, 2017 5:23 am

Here's an interesting observation , i've not had a single case of slow down since being back on 18.3 but a couple of days ago i noticed that Mint Firefox was only using 1 core in options/performance where as my other installs such as Debian Sid defaulted to using 4 cores.

Well i changed Mint firefox to use 4 cores and after a couple of hours i started to have the same slow downs as before as i did with other distro's so i'm guessing some of us must have a bug with firefox using multiple cores?

Since i've gone back to using 1 core i've not had any issues again so others need to try it out to see if they have the same results?

aes2011
Level 4
Level 4
Posts: 466
Joined: Wed Jul 06, 2011 10:39 pm

Re: FireFox 57 getting slow

Post by aes2011 » Thu Dec 28, 2017 5:44 am

Lucap wrote:...
Well i changed Mint firefox to use 4 cores ...

Since i've gone back to using 1 core i've not had any issues again so others need to try it out to see if they have the same results?
How do you change the number of cores used by the browser?

Post Reply

Return to “Chat about Linux Mint”