Mint 19 Upgrade - Error Workarounds

Chat about anything related to Linux Mint
Post Reply
Level 1
Level 1
Posts: 17
Joined: Mon Nov 30, 2015 12:03 pm

Mint 19 Upgrade - Error Workarounds

Post by Kudalufi »

I just upgraded a Linux Mint virtual machine (VirtualBox on Windows host) from Mint 18.3 -> 19. I was able to do it successfully, but it took two tries and I had to work around a couple of install errors and one mintupgrade bug. In my case my Mint VM has a fairly small footprint (only 16G), so restoring from the backup to try again wasn't difficult.

If you are just interested in advice on working around mintupgrade installer errors, skip to the end.

Try #1:
The first time around I noticed the install looping, then it stopped with "too many errors". In my case the root cause was a problem with a package being installed that had a dependency for a later version of dbus-x11 than was installed. For some reason the upgrader/apt was smart enough to know this, but not smart enough to simply upgrade dbus-x11 first. I manually installed dbus-x11 (sudo apt-get install dbus-x11), and then was able to restart mintupgrade.

Next problem was a collision between the local grub config and the one being installed. This was where I ran into the installer bug. It popped up with a curses-like window that had options to use the old config, use the new one, to show a diff, and to show a side-by-side comparison. Incidentally, what was missing from when I've seen this issue in the past was the option to manually edit. I don't know if that is a bug or not, but this certainly is: when I tried to use the side-by-side comparison option I didn't get a side-by-side comparison. All I got was just a box showing the first 20 or so lines of one of the config files, with an ok button at the bottom. Nothing to allow scrolling, and definitely no side-by-side of the two files. So I dismissed that and I simply picked the option to use the new file, figuring the installer would get it right. This was a mistake and grub failed. I didn't want to play around (fight) with grub, so decided to restore from backup and try again.

Try #2:
This time around I tried to preempt the install error. I did "mintupgrade download", and then manually installed dbus-x11 before "mintupgrade upgrade". I ran into the exact same install error with the same cascade failure, just with a different package. This time the root-cause package was libffi6 - some other package was trying to install but libffi6 wasn't the right version yet so it couldn't. So I manually upgraded the dependency (sudo apt-get install libffi6) and reran the upgrade. When I ran into the issue with grub's configs I selected a diff, which worked, and based on that decided to use the old file. This time the upgrade worked and I was able to reboot into Mint 19.

Error Workaround:
If mintupgrade fails, you can't depend on the errors at the end being very informative. It doesn't abort with the first error it sees, it tries to push on through and loops a bunch of times. I think the theory is that if it ignores errors in the early packages being installed, then the later ones will sort out whatever dependency issues that may have caused the early failures. So it tries to press on, and when it does the earlier package failure can cause a whole cascade of subsequent errors that are both spammy and get just plain weird and not a little alarming. The error messages will likely make it look like the sky is falling. Don't give up yet.

To track down what is the root cause requires scrolling back up. Scroll up until you find the last package that seemed to install successfully and look for the first error message you see after that. More often than not you'll find that mintupgrade/apt scheduled a package for installation before its dependency. So at the command-line just do a "sudo apt-get install <dependency>" and try "mintupgrade upgrade" again.

Post Reply

Return to “Chat about Linux Mint”