New machine - Dell Inspiron 5580 + Mint 19.2 = : -)

Chat about anything related to Linux Mint
Post Reply
User avatar
smurphos
Level 12
Level 12
Posts: 4086
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

New machine - Dell Inspiron 5580 + Mint 19.2 = : -)

Post by smurphos » Thu Aug 01, 2019 12:57 am

So on Sunday, my trusty 8 year old 2nd generation Intel HP Pavilion laptop decided enough was enough and spontaneously developed a bright pink cast over the entire display, with ghosting and multicoloured vertical banding. The issue occurred irrespective of flavour of linux running, and on the BIOS and Grub screens, but not with an external display - diagnosis - some failure of the display or the displays cabling to the motherboard. Local repair shop estimated best case £75, worse case £200 to repair.....or I could convince she who must be consulted on major spending decisions that it was time to buy a new machine....to my surprise she agreed immediately.

After trawling the net to find a laptop that was both linux friendly, pretty upto date hardware wise, with a decent screen size and sub £500 I came across this little number on sale at £450 at my local PC bricks and mortar superstore - https://www.dell.com/en-uk/shop/cty/pdp ... op/cn55510

Image

So this is my first experience working with UEFI so I embarked on the install of Mint with a little bit of trepidation. I need't have worried....

From out of the box to Windows wiped and Mint 19.2 Cinnamon beta installed and running took about half an hour, including an initial couple of boots into windows solely to update the BIOS to Dell's latest -it's definitely a Linux friendly machine. The only minor headscratching moment was having to switch from RAID (Intel Optane) to AHCI in the bios to allow the installer to see the machine's SSD. Everything else seems to work fine out of the box with 19.2 and the default 4.15 kernel.

It's quick, and runs so much cooler and quieter than my old machine - I think I've got myself a bargain - :)

The old machine won't go to waste. It will be repurposed as a headless media server running Plex on an Ubuntu Minimal install and take over Plex duties from the 13 year old Toshiba laptop currently undertaking those duties. That machine will be sent for recycling...

Code: Select all

inxi -Fxxxzd
System:
  Host: steve-Inspiron-5580 Kernel: 4.15.0-55-generic x86_64 bits: 64 
  compiler: gcc v: 7.4.0 Desktop: Cinnamon 4.2.3 wm: muffin 4.2.2 
  dm: LightDM 1.26.0 Distro: Linux Mint 19.2 Tina base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Dell product: Inspiron 5580 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0K0DFT v: A00 serial: <filter> UEFI: Dell v: 2.4.0 
  date: 07/02/2019 
Battery:
  ID-1: BAT0 charge: 41.3 Wh condition: 41.3/42.0 Wh (98%) volts: 13.1/11.4 
  model: BYD DELL 1VX1H93 type: Li-poly serial: <filter> status: Full 
CPU:
  Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: B L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28800 
  Speed: 2322 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 617 2: 610 
  3: 601 4: 633 5: 670 6: 603 7: 602 8: 601 
Graphics:
  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:3ea0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2) 
  v: 4.5 Mesa 19.0.2 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel vendor: Dell driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 chip ID: 8086:9dc8 
  Sound Server: ALSA v: k4.15.0-55-generic 
Network:
  Device-1: Intel driver: iwlwifi v: kernel port: 4000 bus ID: 00:14.3 
  chip ID: 8086:9df0 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell 
  driver: r8169 v: 2.3LK-NAPI port: 3000 bus ID: 01:00.0 chip ID: 10ec:8136 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 755.97 GiB (40.5%) 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNS256G NVMe 256GB 
  size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 10410101 
  scheme: GPT 
  ID-2: /dev/sda type: USB model: SABRENT SABRENT size: 698.64 GiB 
  serial: <filter> rev: 0204 scheme: MBR 
  ID-3: /dev/sdb type: USB vendor: Seagate model: Expansion size: 931.51 GiB 
  serial: <filter> rev: 060E scheme: MBR 
  Message: No Optical or Floppy data was found. 
Partition:
  ID-1: / size: 29.21 GiB used: 10.03 GiB (34.3%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-2: /home size: 58.42 GiB used: 747.7 MiB (1.2%) fs: ext4 
  dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 274 Uptime: 10h 56m Memory: 7.51 GiB used: 3.74 GiB (49.8%) 
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Shell: bash 
  v: 4.4.20 running in: gnome-terminal inxi: 3.0.32

Code: Select all

systemd-analyze
Startup finished in 6.079s (firmware) + 2.044s (loader) + 3.404s (kernel) + 2.465s (userspace) = 13.994s
graphical.target reached after 1.313s in userspace
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

deepakdeshp
Level 15
Level 15
Posts: 5655
Joined: Sun Aug 09, 2015 10:00 am

Re: New machine - Dell Inspiron 5580 + Mint 19.2 = : -)

Post by deepakdeshp » Thu Aug 01, 2019 1:07 am

Good to know that it's a painless uneventful install.Now there are a lot of favourable reports for AMD Ryzen processor too. Nice to know that you were able to convince her. I thought only my missus controls the finance.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
Regards,
Deepak

I am using Mint 19.2 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

User avatar
Portreve
Level 8
Level 8
Posts: 2001
Joined: Mon Apr 18, 2011 12:03 am
Location: Florida
Contact:

Re: New machine - Dell Inspiron 5580 + Mint 19.2 = : -)

Post by Portreve » Sat Aug 03, 2019 1:24 am

It's nice to be reminded that the GNU+Linux dev community, up to and including Clem & Co., knew what they were doing! :lol:
I'm so down wit' dat', yo, dass ich unter dem Beton bin.

Presently rocking LinuxMint 19.2 Cinnamon.

Remember to mark your fixed problem [SOLVED].

All in all, you're just another brick in the wall.

Post Reply

Return to “Chat about Linux Mint”