Page 1 of 2

Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Mon Jun 29, 2020 6:05 am
by igmint
Linux Mint 20 Mate.
After the first update, the sound drops off.

Code: Select all

~$ pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: An error occurred during execution pa_pid_file_create().
I have already reinstalled the system three times.

Re: Linux Mint 20 : [pulseaudio] : Daemon already running.

Posted: Mon Jun 29, 2020 6:04 pm
by MrEen
Some details might be useful.

Is sound working?

Where are you seeing that message?

You make it look like you're typing pulseaudio at the command prompt, but pulseaudio starts automatically, so doing that should cause that message.

Assuming your sound doesn't work, run this command and paste the output:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999

Re: Linux Mint 20 : [pulseaudio] : Daemon already running.

Posted: Tue Jun 30, 2020 3:51 am
by igmint

Code: Select all

~$ curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--   100  2039  100  2039    0     0   3176      0 --:--:-- --:--:-- --:--:--  3176
https://termbin.com/hbhz

Code: Select all

~$ inxi -Fxxxrz
Audio:
  Device-1: Intel 82801JI HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:3a3e 
  Sound Server: ALSA v: k5.4.0-39-generic 

Re: Linux Mint 20. The sound fell off. [pulseaudio] : Daemon already running.

Posted: Tue Jun 30, 2020 6:52 am
by igmint
The reason is in the new package pulseaudio _13.99.1-1ubuntu3.3
I deleted it and the sound appeared :!: .

How to install the previous version that needs dependencies?

Re: Linux Mint 20. The sound fell off. [pulseaudio] : Daemon already running.

Posted: Tue Jun 30, 2020 10:01 pm
by MrEen
Install and run Pulseaudio Volume Control. Change the Profile on the Configuration tab. Right now, it's set to output:iec958-stereo, or Цифровой стерео

I'm assuming you want Analog Stereo Duplex, or Аналоговый стерео дуплекс. Or maybe one of the Surround Sound options such as Аналоговый объёмный 5.1 выход + Аналоговый стерео вход

There does seem to be a little weirdness in your output, and it might be fixed with this:

Code: Select all

apt install --reinstall alsa-base alsa-utils pulseaudio linux-sound-base libasound2
And also delete the files in /home/YourUserName/.config/pulse, then run pulseaudio -k in the terminal just for good measure.

I believe there are too many dependency issues with trying to install an older version of PulseAudio. The entire sound base has changed since Mint 19.x, with a lot of cross dependencies with ALSA and the kernel.

Re: Linux Mint 20. The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 01, 2020 9:11 am
by igmint
MrEen wrote:
Tue Jun 30, 2020 10:01 pm
Install and run Pulseaudio Volume Control. Change the Profile on the Configuration tab. Right now, it's set to output:iec958-stereo, or Цифровой стерео

I'm assuming you want Analog Stereo Duplex, or Аналоговый стерео дуплекс. Or maybe one of the Surround Sound options such as Аналоговый объёмный 5.1 выход + Аналоговый стерео вход

There does seem to be a little weirdness in your output, and it might be fixed with this:

Code: Select all

apt install --reinstall alsa-base alsa-utils pulseaudio linux-sound-base libasound2
And also delete the files in /home/YourUserName/.config/pulse, then run pulseaudio -k in the terminal just for good measure.
This does not work with pulseaudio_13.99.1-1ubuntu3.3, there are no selection options in the menu.
Solution: installed next to the N2 LM20 and the update for pulseaudio to 13.99.1-1ubuntu3.3 is disabled.

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Tue Jul 14, 2020 2:02 pm
by igmint
19.2 and 19.3 too
issue is the newest pulseaudio update.

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Tue Jul 14, 2020 5:56 pm
by MrEen
This command will downgrade PulseAudio to the one that is still working:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 5:00 am
by igmint
MrEen wrote:
Tue Jul 14, 2020 5:56 pm
This command will downgrade PulseAudio to the one that is still working:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2

LM 20 it worked!

LM 19.2 does not work.

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 3:09 pm
by MrEen
No, LM 19 uses an 11.x version of pulseaudio. Let's see your output of apt policy pulseaudio on LM 19

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 3:45 pm
by igmint
MrEen wrote:
Wed Jul 15, 2020 3:09 pm
No, LM 19 uses an 11.x version of pulseaudio. Let's see your output of apt policy pulseaudio on LM 19

Code: Select all

$ apt policy pulseaudio
pulseaudio:
  Установлен: 1:11.1-1ubuntu7.9
  Кандидат:   1:11.1-1ubuntu7.9
  Таблица версий:
 *** 1:11.1-1ubuntu7.9 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:11.1-1ubuntu7.7 500
        500 http://archive.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     1:11.1-1ubuntu7 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 3:48 pm
by MrEen
Let's see if downgrading does the same there then:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:11.1-1ubuntu7.7 libpulse0=1:11.1-1ubuntu7.7 libpulsedsp=1:11.1-1ubuntu7.7 pulseaudio=1:11.1-1ubuntu7.7 pulseaudio-module-bluetooth=1:11.1-1ubuntu7.7 pulseaudio-utils=1:11.1-1ubuntu7.7

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 4:00 pm
by igmint
LM 19 pulseaudio=1:11.1-1ubuntu7.7 no sound.

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 4:26 pm
by MrEen
igmint wrote:
Wed Jul 15, 2020 4:00 pm
LM 19 pulseaudio=1:11.1-1ubuntu7.7 no sound.
Okay, run this command and I'll check everything:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
The last line of output will have a URL pointing to your sound setup.

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 4:28 pm
by igmint
~$ curl https://gitlab.freedesktop.org/pulseaud ... line=false | bash | nc termbin.com 9999
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--: 0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--: 0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:100 2039 100 2039 0 0 980 0 0:00:02 0:00:02 --:--:-- 980
https://termbin.com/ht6d

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 4:48 pm
by MrEen
How are you trying to listen? Headphones? Digital output to speakers or sound system?

It looks like most things are the same as your earlier output, but the headphones are muted now. Once again, the output profile is set to IEC958 or S/PDIF (Цифровой стерео (IEC958) выход + Аналоговый стерео вход)

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 4:53 pm
by igmint
Digital speaker output
(Digital stereo (IEC958) output + Analog stereo input.

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 5:06 pm
by MrEen
I'm having trouble finding anything wrong with your output.

Does this produce sound:

Code: Select all

aplay -D hw:0,1 /usr/share/sounds/alsa/Front_Center.wav

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 5:09 pm
by igmint
~ $ aplay -D hw: 0,1 /usr/share/sounds/alsa/Front_Center.wav
aplay: main: 788: error opening audio device: Device or resource in use
main:788: ошибка открытия аудио-устройства: Устройство или ресурс занято

Re: Linux Mint 20 (19.2 and 19.3 too). The sound fell off. [pulseaudio] : Daemon already running.

Posted: Wed Jul 15, 2020 5:11 pm
by MrEen
Hrmmm. Try deleting the file in /home/iv/.config/pulse then run pulseaudio -k in the terminal. Does the aplay command work after that?