Splash screen resolution

Chat about anything related to Linux Mint
Post Reply
User avatar
Stennie
Level 2
Level 2
Posts: 68
Joined: Wed Mar 24, 2010 6:12 am
Location: Namibia Southen Africa

Splash screen resolution

Post by Stennie »

Just wondering why nobody can fix this problem.
Its in all versions of Linuxmint.
vincent
Level 8
Level 8
Posts: 2217
Joined: Tue Feb 09, 2010 4:10 am

Re: Splash screen resolution

Post by vincent »

Ummm...what is the problem? "Splash screen resolution" is a bit too vague...I'm assuming you mean splash screen problems after installing proprietary Nvidia/ATI drivers? In that case, take a look here: http://community.linuxmint.com/tutorial/view/37
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
User avatar
Stennie
Level 2
Level 2
Posts: 68
Joined: Wed Mar 24, 2010 6:12 am
Location: Namibia Southen Africa

Re: Splash screen resolution

Post by Stennie »

Was not asking for a solution to the problem. Thats why I posted here. :D
Was asking why the problem can not be solved in other distributions or with a update so we do not need a solution to the problem in the first place.

Was just thinking... Thanks for responding.
vincent
Level 8
Level 8
Posts: 2217
Joined: Tue Feb 09, 2010 4:10 am

Re: Splash screen resolution

Post by vincent »

It's a problem related to the proprietary Nvidia/ATI drivers, which do not support kernel mode-setting, something which the open source radeon and nouveau drivers are capable of. As these are problems related to proprietary drivers, we can't do anything to fix it; that's the caveat with including closed-source software in a largely open-source system, and something you were warned of when installing your proprietary drivers. The so-called "solution" is, in my opinion, nothing more than a rough hack involving a deprecated Grub Legacy boot option (and doesn't work with some computers...for example, I had to use a vesa framebuffer for Plymouth to show a somewhat decent splash screen, which any amount of Grub tinkering would not accomplish for me), and this does not solve the root problem (the fact that the proprietary drivers don't support KMS).
Debian Testing x64/LM9 Main x64/Windows 7 x64 - LG R580 laptop w/ Intel Core 2 Duo T6500 2.1 GHz, 4 GB DDR2 RAM, Nvidia Geforce G 105M, Ralink rt2860 802.11n, 300 GB WD HD 5400 rpm
Lumenary
Level 1
Level 1
Posts: 32
Joined: Fri Dec 04, 2009 11:55 pm
Location: US-OH-Newton Falls (TZ=EST/EDT)

Re: Splash screen resolution

Post by Lumenary »

Howdy...




Well, it can be fixed, it's just that the major distro packagers don't want to fall into a trap brought about by breaking something to support proprietary video drivers. Writing Plymouth to work with the subset of features common to all of the different manufacturers' proprietary drivers would be a code logistics nightmare, and create too many conflicting test-cases and dependencies. This would in turn limit Plymouth's utility (and by association, Upstart's utility) with regard to its main goal: to get a system from power-button-to-desktop in the shortest time possible.


On the other hand, one of the great things about GNU/Linux (and Free/Libre` Open Source Software in general) is that with some careful search-engine surfing and a bit of patience, you can often fix things that your distro's packagers overlooked or intentionally ignored.


For example, various work-arounds have been provided for the "proprietary drivers" problem; some work better than others. The simplest work-around involves installing Startup-Manager, and using it to manually specify bootsplash settings, but this can cause its own set of problems. A more elegant and complex solution involves forcing Plymouth to use VESA frame-buffering during boot, then passing control to the proprietary driver once GDM2 starts.


Both are discussed in a bit more detail below; for the record, I prefer the "uvesafb" solution.



About Fixing Plymouth with Startup-Manager:

vincent wrote:Ummm...what is the problem? "Splash screen resolution" is a bit too vague...I'm assuming you mean splash screen problems after installing proprietary Nvidia/ATI drivers? In that case, take a look here: http://community.linuxmint.com/tutorial/view/37
The method described in the link provided by Vincent may work just fine, and quite a few have reported varying levels of success with it.


For some users, however, going with this solution could result in a a system that will only boot to console mode (or worse, not boot at all), if the system has a weird EFI (Extensible Firmware Interface) implementation or a BIOS without proper support.


For a more in-depth explanation, you can read Steve Langasek's and others' thoughts on the matter here:

About Fixing Plymouth with the "uvesafb" Driver:


A more elegant (in my opinion) method is to force Plymouth to use the "uvesafb" driver for booting, then switch to the nVidia/ATi/Intel proprietary driver (whichever is in use) once the system transitions from Plymouth to GDM2.


This solution seems to work on more hardware, especially very old and very new machines, but implementing it requires making detailed and manual changes to your system. It may also have trouble handling the non-VESA-standard resolutions used by wide-screen monitors; you should probably stick with a VESA-standard resolution like 1024x768 even if your system is hooked to a large, wide-screen, flat-panel display.


You can find a detailed write-up on how to implement the "uvesafb" solution on IdyllicTux's blog here:
The author even indicates that because "uvesafb" is being used by Plymouth, resuming from suspend/hibernation works, even though the author's workstation is using proprietary ATi drivers (which has historically been a problem, especially on laptops):
  • Excerpted from IdyllicTux.WordPress.com:
    • * And contrary to popular belief, my laptop resume and suspend works with uvesafb! :)

      * Thing you probably will see in dmesg if succeed:

      [ 0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32-21-generic-pae root=UUID=44c7c661-1f5e-49e6-a14e-7a35f1ec3f9f ro quiet splash nomodeset video=uvesafb:mode_option=1366x768-24,mtrr=3,scroll=ywrap
      [ 6.684235] uvesafb: (C) 1988-2005, ATI Technologies Inc. , M92, 01.00, OEM: ATI ATOMBIOS, VBE v3.0
      [ 6.783693] uvesafb: protected mode interface info at c000:a2d4
      [ 6.783695] uvesafb: pmi: set display start = c00ca376, set palette = c00ca434
      [ 6.783727] uvesafb: VBIOS/hardware supports DDC2 transfers
      [ 6.845060] uvesafb: monitor limits: vf = 61 Hz, hf = 48 kHz, clk = 69 MHz
      [ 6.845110] uvesafb: scrolling: ywrap using protected mode interface, yres_virtual=1536
      [ 6.847159] uvesafb: framebuffer at 0xc0000000, mapped to 0xf8380000, using 8256k, total 16384k
      [ 6.854259] uvesafb: mode switch failed (eax=0x34f, err=0). Trying again with default timings.
YMMV (your mileage may vary).



Things to Keep in Mind Before You Start Making Changes:


Distro packagers usually set things up the way they do, out-of-the-box, for a reason: so more things work as expected on the largest possible set of available hardware.


That said, customising how Plymouth interacts with your hardware isn't too painful, but does require a certain amount of comfort with the command shell, and hand-editing text configuration files.


Caution: Please read the instructions (including comments) in the links provided above very carefully and in their entirety before undertaking the modifications described within. You should also:
  1. 1. Make copies of any affected configuration files before you modify them.
    • -- and --
  • 2. Keep a GNU/Linux Live-CD of some kind around, so you can put things back if things go wrong.


Caution: For the "uvesafb" solution, running the
  • sudo hwinfo --framebuffer
command on a system with an ATi IGP mobile chipset can cause a kernel panic (hard crash). This would likely happen on a system with an nVidia nForce mobile chipset as well. If you want to use the indicated procedure on a laptop, it's probably best to skip the
  • sudo hwinfo --framebuffer
command and just use a known "safe" graphics mode, like 1024x768 with 24-bit color depth.


I have used the method on both ATi and nVidia provisioned systems; my laptop is an HP TouchSmart tx2z-series with Radeon HD 3200 graphics, and my desktop has an nVidia GTX460 installed.



Happy hacking! :-)




Best Wishes,

Lumenary
US-OH-Newton Falls
TZ=US-EST/EDT
Post Reply

Return to “Chat about Linux Mint”