New EFI boot manager available: rEFInd

Chat about anything related to Linux Mint
WesternSlope
Level 3
Level 3
Posts: 171
Joined: Mon Mar 11, 2013 10:32 am

Re: Re:

Postby WesternSlope » Thu Jan 01, 2015 10:51 pm

mhbell wrote:
Dngrsone wrote:That's just saying to move the old file to another folder, such as the parent folder of its current location.

Sent from my SPH-L720T using Tapatalk

Here is what I did. It is kind of a kludge but it works for me and Linux mint boots up by default. If I want Windows I can press F9 and choose a EFI File or ReFind to get to windows 8.1

from the Terminal (Linux Mint) I went to /boot/efi/efi and created a Directory called Win8

Code: Select all

mkdir Win8

I then went to The Microsoft Directory

Code: Select all

cd Microsoft

and copied the Windows boot loader to the new Win8 directory

Code: Select all

cp bootmgfw.efi /boot/efi/efi/Win8/

Next I deleted the bootmgfw.efi file in the Microsoft Directory which I am still in

Code: Select all

rm bootmgfw.efi

Now I went to the ubuntu directory which has the mint boot loader

Code: Select all

cd .. /ubuntu

and copied it to the Microsoft directory so that at boot up it will bring up the grub boot loader and let me into mint by default.

Code: Select all

cp grubx64.efi /boot/efi/efi/Microsoft/bootmgfw.efi

Now when the computer boots it will go to that file in the Microsoft directory and boot to Linux grub. This is the way HP pavilion laptops at least the newer one handle booting preinstalled windows 8.1. I can probably now put a path in the Linux mint grub file pointing to the Win8 directory so I can boot window from grub. I can't use the one that grub 2 finds because That will just bring me back to Mint.
Mel

This is an old thread that needs to be looked at a little closer. I have a HP laptop that falls in the same category as Mel's. All that Mel instructed to do works great, but now No Windows 8.1 at all. Using refind, or EFI file doesn't work. It brings the grub up and when I try to boot Win it gos right to Mint. Are there any coders out there that might be able to point to both Win 8.1 and Mint?
Thanks

User avatar
Dngrsone
Level 5
Level 5
Posts: 568
Joined: Thu Nov 29, 2012 12:18 pm

Postby Dngrsone » Thu Jan 08, 2015 1:09 pm

Look up my username and Toshiba, and see what I did with my laptop when dual-booting. Maybe it will help.

You will end up spending some quality time on the rEFInd site, though.

Sent from my SPH-L720T using Tapatalk
Try politeness; people will like you for it.

WesternSlope
Level 3
Level 3
Posts: 171
Joined: Mon Mar 11, 2013 10:32 am

Re: New EFI boot manager available: rEFInd

Postby WesternSlope » Thu Jan 08, 2015 4:59 pm

I looked at yours Thank you, but really got tired of all of the extra work. I bought my HP laptop with win 8.1, so wanted to keep it. I also ripped HP a new one by telling them they might as well just let other OS's to be installed without jumping their mountains in order to install the other OS's, because there are ways of doing it and keeping win too. I did what mhbell said where the grub comes up for Mint, but before it gos to the grub, I held ESC> Boot to EFI File and then:
EFI > boot >bootx64.efi
and win 8.1 boots. A few more steps, but good enough for me. It works and I'm kinda happy.
Thanks again...

reeby
Level 1
Level 1
Posts: 23
Joined: Sat Nov 08, 2014 2:44 pm

Re: New EFI boot manager available: rEFInd

Postby reeby » Fri Jan 30, 2015 2:16 pm

It really is frustrating. I've tried the method mhbell suggested but nothing happens - win8 still boots first. In fact i've been copying and posting files in Nemo, experimenting and again, nothing.
Is there a way to make Mint boot first at all on HP Envy 14 ??

WesternSlope
Level 3
Level 3
Posts: 171
Joined: Mon Mar 11, 2013 10:32 am

Re: New EFI boot manager available: rEFInd

Postby WesternSlope » Fri Jan 30, 2015 2:46 pm

Before changing anything do a backup of your system with win8. Then follow mhbell to the T. You have to do the modifications through the Terminal. Not Nemo. It's the only way without haveing to do a lot of work that I've found and it got my HP going.

User avatar
administrollaattori
Level 12
Level 12
Posts: 4387
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: New EFI boot manager available: rEFInd

Postby administrollaattori » Fri Jan 30, 2015 3:21 pm

reeby wrote:It really is frustrating. I've tried the method mhbell suggested but nothing happens - win8 still boots first. In fact i've been copying and posting files in Nemo, experimenting and again, nothing.
Is there a way to make Mint boot first at all on HP Envy 14 ??

With some computers you need to (re)set boot order from bios-settings after an installation. If you see choices "Windows Boot manager" and "ubuntu", set "ubuntu" as the first bootable device, so that grub menu appears.

reeby
Level 1
Level 1
Posts: 23
Joined: Sat Nov 08, 2014 2:44 pm

Re: New EFI boot manager available: rEFInd

Postby reeby » Fri Jan 30, 2015 3:49 pm

administrollaattori wrote:
reeby wrote:It really is frustrating. I've tried the method mhbell suggested but nothing happens - win8 still boots first. In fact i've been copying and posting files in Nemo, experimenting and again, nothing.
Is there a way to make Mint boot first at all on HP Envy 14 ??

With some computers you need to (re)set boot order from bios-settings after an installation. If you see choices "Windows Boot manager" and "ubuntu", set "ubuntu" as the first bootable device, so that grub menu appears.


Thanks for reply! That's the thing - i don't see it. When i get into the menu (F9) i get this:

OS boot manager
USB diskette on key/USB hard disk
USB CD/DVD Rom Drive
! Network adapter


I just dowloaded a Grub customizer...and it also can't help (or i don't know how to set it) - windows still boots first! ((

User avatar
administrollaattori
Level 12
Level 12
Posts: 4387
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: New EFI boot manager available: rEFInd

Postby administrollaattori » Sat Jan 31, 2015 4:26 am

reeby wrote:
administrollaattori wrote:
reeby wrote:It really is frustrating. I've tried the method mhbell suggested but nothing happens - win8 still boots first. In fact i've been copying and posting files in Nemo, experimenting and again, nothing.
Is there a way to make Mint boot first at all on HP Envy 14 ??

With some computers you need to (re)set boot order from bios-settings after an installation. If you see choices "Windows Boot manager" and "ubuntu", set "ubuntu" as the first bootable device, so that grub menu appears.


Thanks for reply! That's the thing - i don't see it. When i get into the menu (F9) i get this:

OS boot manager
USB diskette on key/USB hard disk
USB CD/DVD Rom Drive
! Network adapter


I just dowloaded a Grub customizer...and it also can't help (or i don't know how to set it) - windows still boots first! ((

Look this: viewtopic.php?f=46&t=188347#p976575

reeby
Level 1
Level 1
Posts: 23
Joined: Sat Nov 08, 2014 2:44 pm

Re: New EFI boot manager available: rEFInd

Postby reeby » Sat Jan 31, 2015 12:38 pm

administrollaattori, Thanks for tip! But I'm not an expert in Linux.
I tried pointing bootmanager to bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi
from Windows, as it said in the linked article, but again - nothing.
I checked - my Mint is Installed in EFI mode (if that's any indicator)... but that's as far as my knowledge goes.

Can anybody help me to make Mint boot first?

User avatar
Dngrsone
Level 5
Level 5
Posts: 568
Joined: Thu Nov 29, 2012 12:18 pm

Re: New EFI boot manager available: rEFInd

Postby Dngrsone » Sun Feb 01, 2015 9:13 am

Don't know if you've tried this or not, maybe from a live boot of Mint:

Use efibootmgr from a terminal. Using just the command, it should give you a list of bootloaders.

Use option -o and the hexadecimal number of your rEFInd bootloader to set it as the primary loader.

For example, my Windows loader is x0003 and rEFInd x0005, so my command looks like this:

sudo efibootmgr -o 0003, 0005


I believe teh Windows equivalent is BCDEdit
Try politeness; people will like you for it.

User avatar
rijnsma
Level 4
Level 4
Posts: 306
Joined: Wed May 06, 2009 7:28 am
Location: NL

Re: New EFI boot manager available: rEFInd

Postby rijnsma » Sun Feb 01, 2015 10:36 am

It all is beautiful to read what you guys are doing.
But is it also possible to do things (very) simple? So booting in EFI- modus or whatever without higher computerknowledge? :lol:

For years now I use PCLOS (with redo mbr for the bootloader) on a smaller parttition as a switch between some partitions (all made with the nice Gparted) for testing or using several distro's. It has worked flawless on several pc's. I hope I don't ever have to do what you are doing. :wink:

reeby
Level 1
Level 1
Posts: 23
Joined: Sat Nov 08, 2014 2:44 pm

Re: New EFI boot manager available: rEFInd

Postby reeby » Sun Feb 01, 2015 11:02 am

Dngrsone wrote:Don't know if you've tried this or not, maybe from a live boot of Mint:

Use efibootmgr from a terminal. Using just the command, it should give you a list of bootloaders.

Use option -o and the hexadecimal number of your rEFInd bootloader to set it as the primary loader.

For example, my Windows loader is x0003 and rEFInd x0005, so my command looks like this:

sudo efibootmgr -o 0003, 0005


I believe teh Windows equivalent is BCDEdit


Dngrsone, thanks! Do i have to do it from the live Mint? and how exactly do i change the settings in the terminal? (sorry for such noob questions)

User avatar
Dngrsone
Level 5
Level 5
Posts: 568
Joined: Thu Nov 29, 2012 12:18 pm

Re: New EFI boot manager available: rEFInd

Postby Dngrsone » Mon Feb 02, 2015 8:52 am

reeby,

When I had to do it, I booted off my Mint disc (or USB drive), opened up a terminal (gterm for the Cinnamon flavor), and I belive I had to install efibootmgr. If so, then I would have had to connect the laptop to the internet and type into the terminal:

Code: Select all

sudo aptget install efibootmgr


If it is already there, then (and I would try this first, to determine whether it is part of the normal Mint installation)

Code: Select all

sudo efibootmgr


You should see a list; here's what I get on my laptop:

Code: Select all

> sudo efibootmgr
[sudo] password for dngrsone:
BootCurrent: 0005
Timeout: 0 seconds
BootOrder: 0005,0000,2003,2001,2002
Boot0000* Windows Boot Manager
Boot0001* EFI Network 0 for IPv6 (7C-05-07-F8-DA-D7)
Boot0002* EFI Network 0 for IPv4 (7C-05-07-F8-DA-D7)
Boot0004* linuxmint
Boot0005* rEFInd Boot Manager
Boot0006* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network


BootCurrent tells us what the default EFI bootloader is. You can see that mine is Boot0005. BootOrder shows the sequence: if rEFInd fails, then Windows, if not that, then Net, USb, then DVD/CDROM.

In order to change your primary bootloader, you would use the command with the switch -o like so:

Code: Select all

sudo efibootmgr  -o 0005, 0000


Which, for my list above would tell it to boot rEFInd first, then failing that, WIndows. Your numbers will be different.

There is a similar command for Windows, but I don't not know how effective it is.
Try politeness; people will like you for it.

reeby
Level 1
Level 1
Posts: 23
Joined: Sat Nov 08, 2014 2:44 pm

Re: New EFI boot manager available: rEFInd

Postby reeby » Mon Feb 02, 2015 10:06 am

Dngrsone wrote:
In order to change your primary bootloader, you would use the command with the switch -o like so:

Code: Select all

sudo efibootmgr  -o 0005, 0000


Which, for my list above would tell it to boot rEFInd first, then failing that, WIndows. Your numbers will be different.

There is a similar command for Windows, but I don't not know how effective it is.


Dngrsone, do I have to do it from the live USB?
Maybe that's where the problem is, because every time I set the boot order with efibootmgr for the Mint (0000 in my case) to boot first it gets back to the original boot order - SolidState Disk (0001) after I reboot my computer:

Code: Select all

sudo efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0001,0000,0003,9999
Boot0000* ubuntu   HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)File(\EFI\ubuntu\shimx64.efi)
Boot0001* Solid State Disk   ACPI(a0341d0,0)PCI(1f,2)03120a000000ffff0000HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)AMBO
Boot0003* Windows Boot Manager   HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)File(\boot\efi\EFI\HP\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot9999* USB Drive (UEFI)   ACPI(a0341d0,0)PCI(1d,0)USB(10,0)AMBO
reeby@reeby-HP-Spectre-Ultrabook-PC ~ $


Whereas, if I point efibootmgr to boot Mint next with this command

Code: Select all

sudo  efibootmgr -n 0

then it does the job and Mint boots first... but only for once. And after that, on next boot I again have Windows booting.

Any way to set the boot order so it does not gets reset?

upd:
Tried the live USB. The boot order did get changed but windows comes first! It's like the system does not let me set MInt at all.

Code: Select all

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0004,0000,0003,9999
Boot0000* ubuntu   HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)File(\EFI\ubuntu\shimx64.efi)
Boot0003* Windows Boot Manager   HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)File(\boot\efi\EFI\HP\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...a................
Boot0004* Solid State Disk   ACPI(a0341d0,0)PCI(1f,2)03120a000000ffff0000HD(1,40,81fff,c580bbcb-131a-4d62-bc63-87eec330c336)AMBO
Boot9999* USB Drive (UEFI)   ACPI(a0341d0,0)PCI(1d,0)USB(10,0)AMBO

User avatar
Dngrsone
Level 5
Level 5
Posts: 568
Joined: Thu Nov 29, 2012 12:18 pm

Re: New EFI boot manager available: rEFInd

Postby Dngrsone » Mon Feb 02, 2015 10:22 pm

If you can boot into Mint, you can definitely do it from there.

Unfortunately, every maker does things differently.

As I recall from the rEFInd site, there may be several copies of the Windows EFI bootloader, and the hardware may be booting from somewhere other than the regular Windows directory. If the bootloader is in the root folder, then that may be what is causing your problems. You can try renaming that file (I usually add a .bak) just to see if it helps any.

Also, you may have to edit the EFI configuration from within Windows. If you are using Win 8, then when you get to the power down menu, hold down the Shift key and select Restart, then (I believe, it's been a while since I did this) go to the Advanced menu and see if you can change the default from there.
Try politeness; people will like you for it.

electroken
Level 1
Level 1
Posts: 17
Joined: Sat Feb 09, 2013 8:57 pm
Location: Minnesota
Contact:

Re: New EFI boot manager available: rEFInd

Postby electroken » Fri Feb 06, 2015 2:33 am

ReFind really worked well for me. I had issues with an hp 2000-2b09 computer where I managed to somehow install ubuntu 14.10 on the hdd almost the same way it does usually without the UEFI on a computer. I let linux control the whole install.
I had found a way to enter bios and get the boot manager there to allow me to boot from the dvd. I am not sure if I had to enable legacy which seems to automatically stop secure boot.
However, I learned that the UEFI boot sequence would necessarily still be used ahead of any boot under legacy. The hdd was not listed in the secure boot list of devices so it could not go there to find the grub.
I would have to hit the esc key as soon as I turned on the computer, then when the message appeared saying that the boot was paused, I would hit the f10 key to get to the menu for boot. Then selecting f9 would enter the grub list and it would all be a normal boot from then on depending on which you selected to boot.

Once I ran the refind program, all was fine with no need to see grub but only to choose what to boot up. It works like a charm.
I might add that I am not so good at linux command line and did the step by step proceedure to get the refind from the repository and then update and install it.
If I can do it, just about anyone should be able to do it too.

rajumukherjee
Level 3
Level 3
Posts: 133
Joined: Sat Nov 08, 2014 11:15 am
Location: varanasi, india
Contact:

Re: New EFI boot manager available: rEFInd

Postby rajumukherjee » Wed Apr 08, 2015 9:17 am

Nice to hear it but would it solve the problem of bios based laptop when booting from another version of lunix or windows not work and bios section in cmos is not accesable
Life can be fun with lots of friends
Http://gaming.netalien.biz

User avatar
Dngrsone
Level 5
Level 5
Posts: 568
Joined: Thu Nov 29, 2012 12:18 pm

Re: New EFI boot manager available: rEFInd

Postby Dngrsone » Wed Apr 08, 2015 2:59 pm

rajumukherjee wrote:Nice to hear it but would it solve the problem of bios based laptop when booting from another version of lunix or windows not work and bios section in cmos is not accesable

So, if I read you correctly, your current operating system (I'm guessing Windows) does not give you access to the UEFI settings?

Try this: go to your power icon, hold down the Shift key, and select Reset. This should give you a power menu, and there may be an Advanced section that will dump you into the UEFI menu.

Otherwise, there are command-line options that one can use to change the default bootloader...

Sent from my SPH-L720T using Tapatalk
Try politeness; people will like you for it.

srs5694
Level 6
Level 6
Posts: 1389
Joined: Mon Feb 27, 2012 1:42 pm

Re: New EFI boot manager available: rEFInd

Postby srs5694 » Thu Apr 09, 2015 8:53 am

rajumukherjee wrote:Nice to hear it but would it solve the problem of bios based laptop when booting from another version of lunix or windows not work and bios section in cmos is not accesable


No. If the computer is truly BIOS-based (has no EFI or UEFI), then rEFInd will be useless on it. (Well, there is the possibility of running a software EFI such as DUET or Clover, but that adds another layer of complexity that won't help with your specific problem.)

User avatar
Dngrsone
Level 5
Level 5
Posts: 568
Joined: Thu Nov 29, 2012 12:18 pm

Re: New EFI boot manager available: rEFInd

Postby Dngrsone » Sat Apr 25, 2015 10:07 pm

I have run into a wall and my head is starting to hurt. I've done this before, but I can't seem to replicate my earlier success.

I have a Toshiba Satellite P55t-B5154 dual-booted with Win 8.1 and Mint 17 KDE. I installed rEFInd using the apt-get install method, then ran the install.sh script for good measure.

I can Shift-restart from Win 8.1 to get rEFInd to load, but Windows is still the default. I used efibootcfg to change the default bootloader to rEFInd, but apparently the machine is ignoring that setting (yes, it is persistent, just being ignored).

Toshiba has Windows EFI boot loaders scattered throughout the \boot folder like pigeon food. I am wondering which one is the default. I don't want to rename each file until I hit on the correct one, but that may be my only choice, unless someone here has a better idea.
Try politeness; people will like you for it.


Return to “Chat about Linux Mint”