There's a reason Linux doesn't support Windows "fast boot"

Chat about Linux in general
Post Reply
User avatar
catweazel
Level 19
Level 19
Posts: 9732
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

There's a reason Linux doesn't support Windows "fast boot"

Post by catweazel » Fri Oct 25, 2019 10:18 pm

Code: Select all

boot@Z390:~$ systemd-analyze
Startup finished in 3.210s (kernel) + 953ms (userspace) = 4.163s
graphical.target reached after 950ms in userspace
It's not needed :mrgreen:
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.

User avatar
catweazel
Level 19
Level 19
Posts: 9732
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: There's a reason Linux doesn't support Windows "fast boot"

Post by catweazel » Fri Oct 25, 2019 10:30 pm

For anyone that's interested, I advised a poster in viewtopic.php?f=46&t=304029&p=1706047#p1705398 to change to a local time server to get past a 20 second delay in the boot sequence. After posting it I wondered if the time server was affecting my boot times so I changed to a local server and shaved a full six seconds off my already fast boot speeds.

Go figure.

Cheers.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.

DAMIEN1307
Level 8
Level 8
Posts: 2204
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: There's a reason Linux doesn't support Windows "fast boot"

Post by DAMIEN1307 » Fri Oct 25, 2019 11:47 pm

Hi catweazel, I know that you are running a much more highly advanced system then me, so how is it my boot time is even faster than yours?
That doesn't make any sense to me that i can cold boot my Peppermint 9 system in just 5 sec....Ive never even changed my local time server either...DAMIEN

Code: Select all

damien@damien ~ $ systemd-analyze
Startup finished in 1.779s (kernel) + 1.585s (userspace) = 3.364s
graphical.target reached after 1.579s in userspace
damien@damien ~ $

Code: Select all

System:    Host: damien Kernel: 4.15.0-66-generic x86_64 bits: 64 gcc: 7.4.0
           Desktop: N/A Distro: Peppermint Nine
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: H81M-A v: Rev X.0x serial: N/A
           BIOS: American Megatrends v: 2201 date: 03/09/2015
CPU:       Quad core Intel Core i5-4460 (-MCP-) arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 25600
           clock speeds: max: 3400 MHz 1: 2314 MHz 2: 1974 MHz 3: 1983 MHz
           4: 2175 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) driver: intel
           Resolution: 1280x1024@60.02hz
           OpenGL: renderer: Mesa DRI Intel Haswell Desktop
           version: 4.5 Mesa 19.0.8 Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-66-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 256.1GB (18.3% used)
           ID-1: /dev/sda model: SPCC_Solid_State size: 256.1GB
Partition: ID-1: / size: 234G used: 44G (20%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 31.0C mobo: 118.0C
           Fan Speeds (in rpm): cpu: 0 fan-1: 1950 fan-2: 1034
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://archive.ubuntu.com/ubuntu bionic main restricted
           deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted
           deb http://archive.ubuntu.com/ubuntu bionic universe
           deb http://archive.ubuntu.com/ubuntu bionic-updates universe
           deb http://archive.ubuntu.com/ubuntu bionic multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-updates multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-security main restricted
           deb http://archive.ubuntu.com/ubuntu bionic-security universe
           deb http://archive.ubuntu.com/ubuntu bionic-security multiverse
           Active apt sources in file: /etc/apt/sources.list.d/brave-browser-release-bionic.list
           deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ bionic main
           Active apt sources in file: /etc/apt/sources.list.d/peppermint.list
           deb http://ppa.launchpad.net/peppermintos/p9-release/ubuntu bionic main
           deb http://ppa.launchpad.net/peppermintos/p9-respin/ubuntu bionic main
Info:      Processes: 196 Uptime: 36 min Memory: 1036.6/7849.3MB
           Init: systemd runlevel: 5 Gcc sys: 7.4.0
           Client: Shell (bash 4.4.201) inxi: 2.3.56 

Ps...I just checked and my fastboot IS enabled in the bios...Should i still disable it?
ORDO AB CHAO

User avatar
catweazel
Level 19
Level 19
Posts: 9732
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: There's a reason Linux doesn't support Windows "fast boot"

Post by catweazel » Sat Oct 26, 2019 12:36 am

DAMIEN1307 wrote:
Fri Oct 25, 2019 11:47 pm
Hi catweazel, I know that you are running a much more highly advanced system then me, so how is it my boot time is even faster than yours?
That doesn't make any sense to me that i can cold boot my Peppermint 9 system in just 5 sec....Ive never even changed my local time server either...DAMIEN

Code: Select all

damien@damien ~ $ systemd-analyze
Startup finished in 1.779s (kernel) + 1.585s (userspace) = 3.364s
graphical.target reached after 1.579s in userspace
damien@damien ~ $
More than likely because I have seven hard disks in RAID that have to fire up.
DAMIEN1307 wrote: Ps...I just checked and my fastboot IS enabled in the bios...Should i still disable it?
Probably not. I can't enable it on my machine because of the aforesaid hard disks. Fast boot bypasses a lot of hardware initialisation and when I turn it on, my hardware RAID isn't initialised.
"There is, ultimately, only one truth -- cogito, ergo sum -- everything else is an assumption." - Me, my swansong.

gm10
Level 19
Level 19
Posts: 9709
Joined: Thu Jun 21, 2018 5:11 pm

Re: There's a reason Linux doesn't support Windows "fast boot"

Post by gm10 » Sat Oct 26, 2019 4:57 am

catweazel wrote:
Fri Oct 25, 2019 10:30 pm
For anyone that's interested, I advised a poster in viewtopic.php?f=46&t=304029&p=1706047#p1705398 to change to a local time server to get past a 20 second delay in the boot sequence. After posting it I wondered if the time server was affecting my boot times so I changed to a local server and shaved a full six seconds off my already fast boot speeds.
Interesting, I cannot reproduce that, but I've always set NTP=pool.ntp.org (a 20 second latency on any time server sounds rather unheard of though but maybe that's due to your geographical location) and I do not additionally have ntp and ntpdate installed like Mint does, that likely speeds it up a little as well.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

HaveaMint
Level 5
Level 5
Posts: 708
Joined: Fri Feb 02, 2018 9:56 pm
Location: Somewhere in the USA
Contact:

Re: There's a reason Linux doesn't support Windows "fast boot"

Post by HaveaMint » Sat Oct 26, 2019 8:31 pm

It takes 19 seconds to turn the clock upside down over there.
"Tune for maximum Smoke and then read the Instructions".

neocorteqz
Level 1
Level 1
Posts: 2
Joined: Wed Oct 09, 2019 9:16 am

Re: There's a reason Linux doesn't support Windows "fast boot"

Post by neocorteqz » Sun Oct 27, 2019 4:17 pm

Here's mine

Code: Select all

george@tiffa:~$ systemd-analyze
Startup finished in 7.698s (kernel) + 54.960s (userspace) = 1min 2.658s
graphical.target reached after 54.950s in userspace
and output of "Blame"

Code: Select all

george@tiffa:~$ systemd-analyze blame
         13.421s dev-sda7.device
         13.413s systemd-journal-flush.service
         12.815s ModemManager.service
         10.776s NetworkManager-wait-online.service
         10.206s networkd-dispatcher.service
         10.037s windscribe-cli.service
          8.701s vboxdrv.service
          8.491s apparmor.service
          7.652s lightdm.service
          7.027s ufw.service
          6.970s NetworkManager.service
          6.557s udisks2.service
          6.396s slapd.service
          6.393s lvm2-monitor.service
          6.119s ubuntu-system-adjustments.service
          6.035s systemd-udevd.service
          5.953s speech-dispatcher.service
          5.673s systemd-resolved.service
          5.015s pppd-dns.service
          4.829s systemd-logind.service
          3.652s accounts-daemon.service
          3.208s gpu-manager.service
          3.075s resolvconf-pull-resolved.service
          2.999s thermald.service
          2.987s wpa_supplicant.service
          2.818s rsyslog.service
          2.632s systemd-tmpfiles-setup.service
          2.389s grub-common.service
          2.377s systemd-tmpfiles-setup-dev.service
          1.900s polkit.service
          1.703s user@1000.service
          1.594s systemd-modules-load.service
          1.589s networking.service
          1.562s lm-sensors.service
          1.376s keyboard-setup.service
          1.361s avahi-daemon.service
          1.241s colord.service
          1.207s systemd-sysctl.service
          1.204s systemd-rfkill.service
          1.154s upower.service
          1.128s swapfile.swap
           751ms systemd-user-sessions.service
           751ms openvpn.service
           614ms systemd-random-seed.service
           475ms systemd-journald.service
           380ms systemd-backlight@backlight:acpi_video0.service
           351ms systemd-update-utmp.service
           280ms console-setup.service
           224ms blk-availability.service
           223ms setvtrgb.service
           221ms hddtemp.service
           220ms plymouth-read-write.service
           213ms sys-kernel-debug.mount
           206ms kerneloops.service
           195ms systemd-remount-fs.service
           182ms clamav-daemon.service
           136ms systemd-backlight@backlight:intel_backlight.service
           136ms virtualbox.service
           130ms dev-hugepages.mount
           105ms kmod-static-nodes.service
           104ms systemd-udev-trigger.service
           100ms dns-clean.service
            99ms rtkit-daemon.service
            95ms vboxweb-service.service
            94ms vboxautostart-service.service
            93ms vboxballoonctrl-service.service
            79ms resolvconf.service
            27ms alsa-restore.service
            22ms dev-mqueue.mount
            13ms ureadahead-stop.service
             9ms sys-kernel-config.mount
             7ms systemd-update-utmp-runlevel.service
             5ms sys-fs-fuse-connections.mount
             2ms plymouth-quit-wait.service
lines 52-74/74 (END)
Any suggestions?

gm10
Level 19
Level 19
Posts: 9709
Joined: Thu Jun 21, 2018 5:11 pm

Re: There's a reason Linux doesn't support Windows "fast boot"

Post by gm10 » Sun Oct 27, 2019 4:23 pm

neocorteqz wrote:
Sun Oct 27, 2019 4:17 pm
Any suggestions?
Yes, buy a faster computer with solid-state storage. :wink:

Also make your own threads for your own questions, no reason to hijack this one.
Tune up your LM 19.x: ppa:gm10/linuxmint-tools

User avatar
MrEen
Level 14
Level 14
Posts: 5452
Joined: Mon Jun 12, 2017 8:39 pm

Re: There's a reason Linux doesn't support Windows "fast boot"

Post by MrEen » Thu Nov 07, 2019 9:48 pm

catweazel wrote:
Fri Oct 25, 2019 10:30 pm
For anyone that's interested, I advised a poster in viewtopic.php?f=46&t=304029&p=1706047#p1705398 to change to a local time server to get past a 20 second delay in the boot sequence. After posting it I wondered if the time server was affecting my boot times so I changed to a local server and shaved a full six seconds off my already fast boot speeds.

Go figure.

Cheers.
Six seconds saved here as well. About a 15% improvement on my spinner.

Thanks very much for the post!

Post Reply

Return to “Chat about Linux”