Unofficial LMDE KDE Live DVD: UP4 / 201208

Chat about Linux in general
Locked
zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by zerozero »

running now the script in my VM install (201208 iso absolutely vanilla and uptodate), goes in stage 2/4 (configuring the upgrade);
one thing caught my eye (pity i don't have the output anymore, konsole was configured to 1000 lines only and it's gone for now, i can catch it later) i saw a lot of pkgs being held back.
nevermind the above: i misread the script :D :mrgreen: and it uses upgrade first and then dist-upgrade (and that's why i saw a lot of held backs)
Image

[ bliss of ignorance ]
BostonPeng
Level 5
Level 5
Posts: 616
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by BostonPeng »

That's what I figured. I guess it's just one more reason I should back things up and alert launch control. 8)

Thanks for the quick reply.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
zerozero
Level 16
Level 16
Posts: 6477
Joined: Tue Jul 07, 2009 2:29 pm

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by zerozero »

Schoelje,
in the end (after having a hard time getting there > but because of my net connection only :mrgreen: ) i get this

Code: Select all

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
(3/4) Install LMDE KDE packages
Hit [ENTER] to continue

dpkg: considering removing mint-artwork-kde in favour of mint-artwork-lmdekde ...
dpkg: no, cannot proceed with removal of mint-artwork-kde (--auto-deconfigure will help):
 mint-artwork-kde-extra depends on mint-artwork-kde
  mint-artwork-kde is to be removed.
dpkg: regarding mint-artwork-lmdekde_1.0.0_all.deb containing mint-artwork-lmdekde:
 mint-artwork-lmdekde conflicts with mint-artwork-kde
  mint-artwork-kde (version 2.0.1) is present and installed.
dpkg: error processing mint-artwork-lmdekde_1.0.0_all.deb (--install):
 conflicting packages - not installing mint-artwork-lmdekde
Errors were encountered while processing:
 mint-artwork-lmdekde_1.0.0_all.deb
dpkg: regarding mint-configuration-lmdekde_1.0.0_all.deb containing mint-configuration-lmdekde:
 mint-configuration-lmdekde conflicts with mint-configuration-kde
  mint-configuration-kde (version 5.0.8) is present and installed.
  mint-configuration-kde provides mint-configuration-kde and is present and installed.
dpkg: error processing mint-configuration-lmdekde_1.0.0_all.deb (--install):
 conflicting packages - not installing mint-configuration-lmdekde
Errors were encountered while processing:
 mint-configuration-lmdekde_1.0.0_all.deb


Image

[ bliss of ignorance ]
User avatar
tdockery97
Level 14
Level 14
Posts: 5060
Joined: Sun Jan 10, 2010 8:54 am
Location: Mt. Angel, Oregon

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by tdockery97 »

I just couldn't resist the challenge. I wiped my LMDE KDE that was pointed at Testing, and downloaded and installed the latest version so that I could try it out with the UP5 upgrade script. Everything went without a hitch, and I have a shiny new installation upgraded to UP5. I think I'll keep it this way so that I'm using the official LMDE.

Thanks for all your hard work on this.


@clem: With the success of this "unofficial" edition of LMDE KDE and the talent demonstrated by Schoelje in not only putting together an excellent community edition, but also his excellent work in providing an easy to use upgrade script to accomplish the upgrade to UP5, I hereby recommend and vote that LMDE KDE be added as an official community addition.
Mint MATE 20.1
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by Schoelje »

If you upgrade with the patch I posted yesterday, you can run the following lines:

Code: Select all

sed -i -e 's/\(style=\).*/\1Oxygen/' /etc/skel/.config/Trolltech.conf
sed -i -e 's/\(style=\).*/\1Oxygen/' $HOME/.config/Trolltech.conf
The Trolltech.conf file sets the QT style and can be edited by qtconfig.
The "style" parameter was set to "GT+" and that conflicted with the gtk2.0 settings.
This is a known KDE glitch (http://forum.kde.org/viewtopic.php?f=17&t=101310) and the above lines should prevent color glitches to happen in the future.

I've changed the patch for this, so if you download it now and run the bash file, your system is upgraded to UP5 testing and you don't have to run the above lines.
Patch: http://www.schoelje.nl/lmdekde/lmdekde- ... ade.tar.gz

@tdockery97
Thanks for the compliment!
arjay
Level 4
Level 4
Posts: 201
Joined: Sat Mar 17, 2007 9:34 am

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by arjay »

@clem: With the success of this "unofficial" edition of LMDE KDE and the talent demonstrated by Schoelje in not only putting together an excellent community edition, but also his excellent work in providing an easy to use upgrade script to accomplish the upgrade to UP5, I hereby recommend and vote that LMDE KDE be added as an official community addition.

+1
arjay
Level 4
Level 4
Posts: 201
Joined: Sat Mar 17, 2007 9:34 am

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by arjay »

Schoelje

Either you are a genius or I have the easiest system to upgrade in the world. You choose which :lol:

I upgraded my LMDE KDE UP4 to UP5 using your script and, apart from a couple of surprises along the way, it all went OK and I cannot find any problems with the update for the usual packages I use.

Here is my feedback about the little hitches along the way:

Ran bash script as normal user first. It appeared to run but ended within 5 seconds (now that is what I call a quick upgrade) - code:

Code: Select all

Upgrade finished, hit [ENTER] to close and reboot your system
lmdekde-up5_upgrade: 49: read: arg count
richard@antec ~/downloads/lmdekde-up5test_upgrade $ 
So I opened the bash file and read it. Found it should echo a request for the root password but it didn't. So I changed to root and reran the script. Downloads started OK and showed 30 minutes for this to complete. So I left the room for a bit. Never saw any of the steps where script asks for "PRESS ENTER TO CONTINUE". Do these autorun after a time delay because I never had to hit ENTER once after starting the script until I came back to find a pause with this at the end and "q to quit" shown?

Code: Select all

Starting with this release the SGML super catalog /etc/sgml/catalog will be
  replaced with a symbolic link to /var/lib/sgml-base/supercatalog. The latter
  file can be regenerated from the contents of the /etc/sgml directory including
  all files ending in .cat using the new update-catalog --update-super option.
  This call will be (dpkg) triggered by packages placing files in /etc/sgml. The
  transition to this way of handling the super catalog will loose user changes to
  /etc/sgml/catalog. Further overwriting of user changes will happen until all
  packages using dh_installcatalogs are built with a fixed version of debhelper.
  Sorry for the inconvenience.
 -- Helmut Grohne <helmut@subdivi.de>  Mon, 30 Apr 2012 16:37:01 +0200
Couldn't scroll back to see what all the text was about even though I have 1000 lines of scroll set. Is that because the script has a series of "CLEAR" statements along the way?

But did find this:

Code: Select all

dpkg: considering removing mint-artwork-kde in favour of mint-artwork-lmdekde ...
dpkg: yes, will remove mint-artwork-kde in favour of mint-artwork-lmdekde.
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ...e - firefox, gimp, amarok 100%(Reading database ... 126716 files and directories currently installed.)
Unpacking mint-artwork-lmdekde (from .../mint-artwork-lmdekde_1.0.0_all.deb) ...
De-configuring mint-artwork-kde-extra, to allow removal of mint-artwork-kde ...
dpkg: error processing /home/richard/downloads/lmdekde-up5test_upgrade/mint-artwork-lmdekde_1.0.0_all.deb (--install):
 trying to overwrite '/usr/share/linuxmint/common/artwork/splash-screens/openoffice.bmp', which is also in package mint-artwork-common 1.3.4-lisa2
dpkg-deb (subprocess): data: internal gzip write error: Broken pipe
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg-deb (subprocess): failed in write on buffer copy for failed to write to pipe in copy: Broken pipe
Errors were encountered while processing:
 /home/richard/downloads/lmdekde-up5test_upgrade/mint-artwork-lmdekde_1.0.0_all.deb
/mint-artwork-lmdekde_1.0.0_all.deb

After this the only warning I got was re the nvdia drivers mentioned by OPs:

Code: Select all

Mismatching nvidia kernel module loaded                                                                                │   
  │                                                                                                                        │   
  │ The nvidia driver that is being installed (version 302.17) does not match the nvidia kernel module currently loaded  (version 295.20).  
etc etc

After first reboot, system booted to prompt. Logged in and ran sgfxi. After another reboot - all was well with my dual monitor nvidia-driven display.

Near the end of the install I also saw this:

Code: Select all

Running depmod.
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 3.2.0-3-486 /boot/vmlinuz-3.2.0-3-486
dkms.conf: Error! No 'BUILT_MODULE_NAME' directive specified for record #0.

Error! Bad conf file.
File: 
does not represent a valid dkms.conf file.
Last observation:
Oxygen theme is very dark (couldn't read text in pager or task manager widgets in panel). Had to switch to Air - still not exactly easy to read and looks really dreary. Presumably I need to try some different themes or make some adjustments somewhere?

Once again - brilliant job.

Richard
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by Schoelje »

It seems that the first step was not executed: removing obsolete packages:

Code: Select all

apt-get -y --force-yes --ignore-hold --ignore-missing purge mint-backgrounds-debian mint-artwork-common mint-artwork-kde-extra mint-artwork-kde kdm-theme-mint-kde ksplash-theme-mint-kde mint-stylish-addon mint-artwork-kde-icons mint-configuration-kde unetbootin* ndiswrapper-dkms
After this, you can install de lmdekde deb files you downloaded and all should be fine.
arjay
Level 4
Level 4
Posts: 201
Joined: Sat Mar 17, 2007 9:34 am

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by arjay »

Schoelje wrote:It seems that the first step was not executed: removing obsolete packages:

Code: Select all

apt-get -y --force-yes --ignore-hold --ignore-missing purge mint-backgrounds-debian mint-artwork-common mint-artwork-kde-extra mint-artwork-kde kdm-theme-mint-kde ksplash-theme-mint-kde mint-stylish-addon mint-artwork-kde-icons mint-configuration-kde unetbootin* ndiswrapper-dkms
After this, you can install de lmdekde deb files you downloaded and all should be fine.
Yeah - sorry, my bad. All thumbs running the script and mistyped command. Anyway - it all runs fine. Works great too, but the panel looks awful to me. Grey, fuzzy, dreary - you name it. I'll see what Google recommends about that :mrgreen:
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by Schoelje »

Just checking: are these your settings?

System Settings > Application Appearance
Style: Widget style = Oxygen
Colors: Scheme = Oxygen Cold
Icons: Theme = Oxygen
GTK+ Appearance: Widget style = oxygen-gtk
GTK+ Fonts: Use another font = Nimbus Sans L (size 11)

Make sure tht you have run these:

Code: Select all

sed -i -e 's/\(style=\).*/\1Oxygen/' /etc/skel/.config/Trolltech.conf
sed -i -e 's/\(style=\).*/\1Oxygen/' $HOME/.config/Trolltech.conf
(See my post above)
arjay
Level 4
Level 4
Posts: 201
Joined: Sat Mar 17, 2007 9:34 am

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by arjay »

Schoelje wrote:Just checking: are these your settings?

System Settings > Application Appearance
Style: Widget style = Oxygen
Colors: Scheme = Oxygen Cold
Icons: Theme = Oxygen
GTK+ Appearance: Widget style = oxygen-gtk
GTK+ Fonts: Use another font = Nimbus Sans L (size 11)

Make sure tht you have run these:

Code: Select all

sed -i -e 's/\(style=\).*/\1Oxygen/' /etc/skel/.config/Trolltech.conf
sed -i -e 's/\(style=\).*/\1Oxygen/' $HOME/.config/Trolltech.conf
(See my post above)
Sorry for not replying earlier - been away for a couple of days. OK - if I try to run

Code: Select all

sed -i -e 's/\(style=\).*/\1Oxygen/' /etc/skel/.config/Trolltech.conf
I get "no such file or directory".

I re-ran the install script and it appeared to run fine - it ran the "remove obselete packages" bit and then seemed to run through the rest OK but something is obviously missing. I have checked that the Appearance settings are as your lists says.

I am going to try an install from scratch on another PC (i.e. install up4, update, then install up5 with your script)
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by Schoelje »

After the patch, when you run this line:

Code: Select all

dpkg -S /etc/skel/.config/Trolltech.conf
It should say:

Code: Select all

mint-configuration-lmdekde: /etc/skel/.config/Trolltech.conf
It's part of the mint-configuration-lmdekde package, provided in the patch you downloaded and it's used when you create a new user.
The second line ($HOME/...) changes the Trolltech.conf file in your home directory.
arjay
Level 4
Level 4
Posts: 201
Joined: Sat Mar 17, 2007 9:34 am

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by arjay »

Just a thought - would it not be better to have an LMDE UP5 thread or is that too early - hate to hijack this UP4 thread with UP5 questions :?:
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by Schoelje »

Clem already started a LMDE UP5 thread:
http://forums.linuxmint.com/viewtopic.p ... 7&t=109005
arjay
Level 4
Level 4
Posts: 201
Joined: Sat Mar 17, 2007 9:34 am

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by arjay »

Schoelje wrote:Clem already started a LMDE UP5 thread:
http://forums.linuxmint.com/viewtopic.p ... 7&t=109005
Sorry - I meant an unofficial lmde kde up5 thread that would parallel this one :wink:
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by Schoelje »

About the UP5 thread: at the moment I don't think that is necessary.
The remarks concerning UP5 on LMDE KDE are few, so I think that this thread suffices.
If more issues arise from the upgrade (when UP5 goes official), I will reconsider a separate LMDE KDE Upgrade thread.

Now for something completely different:
Currently, Plymouth is set to a resolution of 800x600, the lowest possible resolution for Plymouth.
I would like to increase the resolution to 1024x768 considering that most graphics cards (if not all) can handle that resolution.

Do you think that there could be difficulties if I do increase the resolution?
BostonPeng
Level 5
Level 5
Posts: 616
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by BostonPeng »

Every time I try to use Startup-manager to set my initial resolution to 1024x768 I see an error about the mode not being supported. According to the KInfocenter my laptop (lenovo T61) uses an Nvidia Quadro NVS 140M/PCIe/SSE2, and nvidia-settings echoes the NVS 140M.
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by Schoelje »

But startupmanager does not change Plymouth setting, or does it?

What happens if you change the resolution settings in the following files (in the official unofficial LMDE KDE that is):
  • /etc/default/grub
  • /etc/modprobe.d/uvestafb.conf
And replace 800x600 by 1024x768

Then run update grub and initramfs:

Code: Select all

sudo update-grub && sudo update-initramfs -u -k all
Then reboot and pray...
BostonPeng
Level 5
Level 5
Posts: 616
Joined: Mon Aug 02, 2010 8:50 am
Location: Boston, MA
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by BostonPeng »

You're right it doesn't affect Plymouth, but I was making a more general comment since it returns the error regardless what version of Mint I'm running so I wanted to let you know of the possibility. I'm not sure how Plymouth feels about the resolution. I haven't made the switch to your respin but I can try your edit on my LMDE + KDE testing if you want. This is what i have installed:

Code: Select all

$ apt policy plymouth
plymouth:
  Installed: 0.8.5.1-5                                                                    
  Candidate: 0.8.5.1-5                                                                    
  Version table:                                                                          
 *** 0.8.5.1-5 0
        500 http://ftp.debian.org/debian/ testing/main i386 Packages
        100 /var/lib/dpkg/status
J.M. "BostonPeng" Hardin
Now very happily running SolydK
My new Linux blog: Tux + Me
It's time for Dodgers baseball!
Schoelje
Level 5
Level 5
Posts: 784
Joined: Wed Jan 18, 2012 6:25 am
Location: Netherlands
Contact:

Re: Unofficial LMDE KDE Live DVD: UP4 / 201208

Post by Schoelje »

Don't mind, BostonPeng, even if you successfully change resolution, it doesn't say anything about the unofficial LMDE KDE.
So, just leave your settings as they are. That is a lot safer.
Locked

Return to “Chat about Linux”