Debian Keyboard Problem SOLVED

Chat about Linux in general
User avatar
Level 14
Level 14
Posts: 5126
Joined: Mon Dec 01, 2008 11:21 am

Debian Keyboard Problem SOLVED

Postby viking777 » Thu Feb 11, 2010 7:02 am

I recently installed Debian Stable it went pretty well apart from one peculiar keyboard problem - I can't produce the 'Pound' sign. On a UK keyboard this is Shift/3 when I press Shift/3 all I get is 3! Now normally you would jump right in and say - " You have the US keyboard map selected". But I don't, because every other key on the board is in the correct position for a UK keyboard (and that would not be the case with a US keymap).

In keyboard properties I only have the UK map listed, I have deleted all others and UK is set as default. The keyboard type is listed as 'Generic 105 key (Intl)PC'.

Following advice from various internet sites I have tried adding these lines to /etc/X11/xorg.conf (in the 'input' section):

Code: Select all

Option "XkbModel" "pc105"
    Option "XkbLayout" "uk"

I have run:

Code: Select all

dpkg-reconfigure locales

But my locale is set to the uk

I have run:

Code: Select all

dpkg-reconfigure console-data

But that made no difference either.

It is not a big deal, the pound sign is not something I have to type very often but if anyone has any other ideas I would be interested to hear them.

EDIT. I have found that I can get it to produce the £ sign (see!) by running

Code: Select all

setxkbmap gb

but it never survives a reboot.

I am sure that doesn't help much :?

Yes it does!!! Even as I typed that edit I thought what was wrong. I have edited xorg.conf to set the keymap to uk when the actual keymap is gb.

Solved, thanks for all your assistance :lol: :lol:
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

Level 6
Level 6
Posts: 1120
Joined: Mon Nov 16, 2009 12:20 pm
Location: Asheville, NC, USA

Re: Debian Keyboard Problem SOLVED

Postby Kendall » Fri Feb 12, 2010 4:21 pm

EDIT: I had an idea, but didn't notice the "SOLVED" until after I posted. Yay for not paying attention.

Return to “Chat about Linux”