LibreOffice quickstart : doesn't prevent shutdown under Arch

Chat about Linux in general
Post Reply
torturedutopian
Level 1
Level 1
Posts: 18
Joined: Fri Sep 10, 2010 4:45 am
Location: France

LibreOffice quickstart : doesn't prevent shutdown under Arch

Post by torturedutopian » Mon Jan 16, 2012 8:13 am

Hi everyone !

I'm a part time Arch / Ubuntu / Mint / Debian user and I noticed something interesting :

as I use LibreOffice a lot, I love the quickstart applet. We all know that it's not really usable anymore as it prevents Gnome from logging out since a couple of years ago. There is a workaround but you have to manually edit some files (and repeat this with each update which is not a good solution).

I noticed something strange though : there is no such behaviour under Arch Linux : the quickstarter doesn't prevent GNOME from logging out, although it does under Debian, Ubuntu or Mint.

--> would it be possible to patch (or un-patch ?) Libo so that is behaves the same way ? LibreOffice is an essential piece of software, everyone uses it, and it is still a little slow to open. With quickstarter, it's instant, which is amazing.

Cheers !
(BTW : I would love, in future Mint versions, an install option to get a "pure" Gnome shell ; I'm not really interested in forking it...)

User avatar
xenopeek
Level 24
Level 24
Posts: 24181
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: LibreOffice quickstart : doesn't prevent shutdown under

Post by xenopeek » Mon Jan 16, 2012 12:50 pm

Moved here by moderator

Linux Mint uses the stock LibreOffice as provided by Ubuntu or Debian (for LMDE). If somebody has the time, you could download the source from Arch and from Ubuntu/Debian, for the same LibreOffice version, and do a diff on it. I think it might sooner be a problem with the init scripts however.
Image

torturedutopian
Level 1
Level 1
Posts: 18
Joined: Fri Sep 10, 2010 4:45 am
Location: France

Re: LibreOffice quickstart : doesn't prevent shutdown under

Post by torturedutopian » Sat Jan 21, 2012 9:49 am

Thanks for your reply : indeed, as Arch also uses unmodified upstream versions of LibreOffice, this is definitely due to the difference in initscripts. Just have to wait till it's fixed in Llbo !

Post Reply

Return to “Chat about Linux”