[Résolu] Accès dossiers sur NAS Synology

French Forum

Moderators: killer de bug, Laurent85

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

[Résolu] Accès dossiers sur NAS Synology

Post by Vahia » Thu May 10, 2018 8:35 am

Bonjour,
j'ai une petite question de Newbie...

Je possède un NAS Synology connecté à mon réseau local.
Lorsque je veux y accéder, je vais dans "Réseau". Là j'ai 3 icones :
- "Synology (Partage de fichiers)" qui me demande de m'identifier pour accéder à la liste des dossiers du NAS.
- "Synology (Partage de fichiers)" qui me laisse accéder à la liste des dossiers du NAS mais qui me demande de m'identifier à l'ouverture de chaque dossier.
- "Réseau Windows" qui débouche sur une erreur.

Habituellement j'utilise un des 2 premiers (au hasard vu qu'ils sont identiques). On me demande le mot de passe de mon portefeuille de mots de passe puis on me demande de m'identifier et on me demande également si je veux mémoriser les identifiants (ce que je fais).

Le souci, c'est qu'à chaque redémarrage du système il faut de nouveau que je m'identifie comme si c'était la première fois. Y'a-t-il un moyen d'éviter ça ?
Sous Windows je m'identifiais une première fois et jamais par la suite. C'est ce que je voudrais faire sous LM.
Merci d'avance pour votre aide !
Last edited by Vahia on Thu May 17, 2018 6:56 pm, edited 1 time in total.

donalduck
Level 3
Level 3
Posts: 118
Joined: Mon Oct 07, 2013 1:43 pm
Location: there

Re: Accès dossiers sur NAS Synology

Post by donalduck » Thu May 10, 2018 2:38 pm

Salut a toi,

ca devrait fonctionner sans problème aussi sous LM,
personnellement j'ai un nas synology DS216j et je me connecte au(x) repertoire(s) qui m'intérressent sans avoir a indiquer mon mot de passe d'utilisateur synology a chaque fois,
a la fois dans l'environnement mate et dans l'environnement cinnamon.

peut-etre faut il aussi créer un signet/raccourci pour que le mot de passe soit bien conservé entre deux sessions (ce que j'ai fait).

si ça peut t'aider tu peux aussi essayer de saisir directement l'adresse du partage sur le modèle
smb://nom-de-l-utilisateur-synology/nom-du-partage/

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Fri May 11, 2018 5:31 am

Merci pour tes conseils !

Peux-tu me dire comment tu as fais pour créer ton raccourci ?

donalduck
Level 3
Level 3
Posts: 118
Joined: Mon Oct 07, 2013 1:43 pm
Location: there

Re: Accès dossiers sur NAS Synology

Post by donalduck » Fri May 11, 2018 2:54 pm

Euh quel bureau as-tu choisi ?

si tu utilises cinnamon avec nemo c'est très simple Il y a un menu Signet, il suffit de cliquer dans le sous menu "ajouter un signet" quand tu positionné dans ton repertoire :)

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Sat May 12, 2018 4:45 am

J'utilise Cinnamon.
J'ai créé un favori. Mais le truc c'est que ça ne change rien, faut toujours que je me log à la première utilisation.

Autre souci, après avoir démarré mint il faut que je patiente presque 5 minutes avant de pouvoir accéder à mon NAS. Avant ça j'ai ce message d'erreur :
Impossible d'afficher « afp://Synology.local/ ».
Erreur : Erreur de résolution de « Synology.local » : Nom ou service inconnu
Sélectionnez un autre visionneur et essayez à nouveau.

C'est normal ?

donalduck
Level 3
Level 3
Posts: 118
Joined: Mon Oct 07, 2013 1:43 pm
Location: there

Re: Accès dossiers sur NAS Synology

Post by donalduck » Sun May 13, 2018 4:26 am

C'est normal ?
:mrgreen: j'ai pas l'impression non, on dirait que tu cumules plusieurs problèmes, ne te décourage pas !

déjà le message d'erreur avec afp c'est pas trop normal, afp est un protocole de partage obsolète utilisé sur les mac, aucun intéret à mon avis...
il faut peut être le désactiver dans synology, ouvre le panneau de configuration dans l'interface dsm de synology puis "services de fichiers" et décoche AFP !

concernant le mot de passe, j'ai remarqué une chose sur mon ordinateur, c'est qu'il est conservé dans le trousseau de clés.
dans le menu cinnamon recherche clés ou seahorse, ouvre le trousseau et normalement tu dois avoir à gauche une entrée login ou Login avec un symbole de cadenas ouvert a coté,
et dans la partie droite associée une entrée pour ton partage sur le nas, double clique ou clique droit dessus et vérifie que les infos sont correctes, au besoin supprime le (attention ne supprime pas login ...).
trousseau_seahorse.png
cette entrée dans le keyring/trousseau s'est crée automatiquement dans mon cas, mais si tu as fais une fausse manip au début c'est peut être ça une cause de tes soucis.

bon dimanche.

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Sun May 13, 2018 5:02 am

Merci pour ton aide donalduck !

J'ai désactivé AFP. Du coup je n'ai plus qu'une seule entrée réseau pour mon NAS. Je vais tester après un redémarrage du système s'il faut attendre avant de pouvoir y accéder.

Concernant le mot de passe, où tu as login j'ai "connexion" et "trousseau". Au démarrage les 2 sont vides. Quand je me log dans mon NAS, j'ai 3 entrées (comme sur ta photo) qui se créent dans "Trousseau" mais pas dans "connexion".
Par contre on dirait que le contenu du trousseau s'efface à chaque démarrage...

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Sun May 13, 2018 5:37 am

Au redémarrage, même message d'erreur :
Impossible d'afficher « smb://Synology.local/ ».
Erreur : Erreur de résolution de « Synology.local » : Nom ou service inconnu
Sélectionnez un autre visionneur et essayez à nouveau.


Au bout de 5 minutes c'est bon, j'ai accès au réseau...

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Sun May 13, 2018 7:25 am

Mon problème ne pourrait-il pas venir du fait qu'au lancement de Linux Mint, ma session s'ouvre automatiquement ?
Comment fait-on pour changer ce paramètre ?

donalduck
Level 3
Level 3
Posts: 118
Joined: Mon Oct 07, 2013 1:43 pm
Location: there

Re: Accès dossiers sur NAS Synology

Post by donalduck » Sun May 13, 2018 2:54 pm

a propos de l'autologin, j'ai lu a droite et a gauche que c'est une mauvaise idée à plus d'un titre.
suivant ta version de LM tu peux changer ce réglage via le menu "utilisateurs et groupes"... ou pas.
si c'est pas le cas, fais plutot une recherche avec les mots clés "autologin" ou "automatically login", ou bien ouvre un autre sujet sur le forum.

sinon qui est responsable de ce message d'erreur ?
c'est dans une popup ou seulement dans les fichiers logs ?
pourquoi cette adresse Synology.local et pas nom-d-un-utilisateur-synology@nom-du-serveur-synology ?

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Mon May 14, 2018 4:27 am

Bon je n'ai pas trouvé comment virer l'autologin. Du coup j'ai réinstallé Mint (je ne suis plus à 1 fois près).
Maintenant je n'entre plus le mot de passe systématiquement. Je l'ai entré la première fois et c'est tout.
Par contre, au démarrage de LM il faut toujours que j'attende 5 bonnes minutes avant de pouvoir accéder au réseau...

Le message d'erreur me vient d'un popup. Quand je cherche à accéder au réseau via l'explorateur, au bout de quelques secondes ce popup apparaît.
Quant à savoir pourquoi Synology.local et pas nom-d-un-utilisateur-synology@nom-du-serveur-synology, je n'en ai aucune idée...

Ah et pour la petite info, désormais je n'ai plus "connexion" et "trousseau" dans le gestionnaire de mots de passe mais simplement "connexion". Comme quoi y'a bien un truc qui change quand on active l'autologin ou non.

Laurent85
Level 14
Level 14
Posts: 5442
Joined: Tue May 26, 2015 10:11 am

Re: Accès dossiers sur NAS Synology

Post by Laurent85 » Mon May 14, 2018 7:53 am

Bonjour,
Vahia wrote:
Mon May 14, 2018 4:27 am
Par contre, au démarrage de LM il faut toujours que j'attende 5 bonnes minutes avant de pouvoir accéder au réseau...
Installe samba :

Code: Select all

apt install samba --install-recommends
Et ajoute la ligne name resolve order = bcast host lmhosts wins à la section [global] du fichier de configuration /etc/samba/smb.conf :

Code: Select all

sudo xdg-open /etc/samba/smb.conf 

Code: Select all

#======================= Global Settings =====================================

[global]

name resolve order = bcast host lmhosts wins
Redémare l'ordi ou bien redémarre le service de cette façon :

Code: Select all

sudo systemctl restart smbd
sudo systemctl restart nmbd
Image

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Tue May 15, 2018 5:16 am

Bonjour Laurent85,
j'ai suivi tes consignes mais ça ne résoud pas mon problème. Je dois toujours attendre 5 bonnes minutes avant de pouvoir accéder à mon réseau local.

En fait j'ai 2 messages d'erreur qui apparaissent. Celui cité plus haut apparaît quand je clic sur le favori que je me suis créé pour accéder à mon NAS.
Celui-là :
Impossible de monter l'emplacement
L'obtention de la liste des partages du serveur a échoué : Connexion refusée

apparaît quand je passe par Réseau -> Synology.
Je ne sais pas si cette info peut-être utile...

donalduck
Level 3
Level 3
Posts: 118
Joined: Mon Oct 07, 2013 1:43 pm
Location: there

Re: Accès dossiers sur NAS Synology

Post by donalduck » Tue May 15, 2018 5:37 am

de mon coté y'a pas de réglages pointus dans mon smb.conf, et pourtant j'accède au partage sur mon nas pour ainsi dire immédiatement après reboot et login sans aucun message d'erreur.

Synology.local est mentioné dans le guide d'utilisateur fourni par synology (sur le site web) à propos des partages sur les macs, je pense qu'il faut commencer par revoir ta configuration du nas lui-même.
à mon avis linux mint n'est pas vraiment la cause de tes soucis :idea:

Laurent85
Level 14
Level 14
Posts: 5442
Joined: Tue May 26, 2015 10:11 am

Re: Accès dossiers sur NAS Synology

Post by Laurent85 » Tue May 15, 2018 6:37 am

Vérifie dans la configuration de ton NAS que sous la rubrique des services Mac le protocole Bonjour est actif. Linux Mint utilise ce protocole (appellé service Avahi sous LM) pour la résolution de nom des machines présentes sur le réseau local.

En ligne de commande que donnent ces commandes :

Code: Select all

ping -c3 synology.local
avahi-resolve --name -4 synology.local
avahi-browse -at | grep -i ipv4
Image

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Wed May 16, 2018 6:25 am

Bonjour !

J'ai vérifié dans les paramètres de mon NAS, la découverte du service Bonjour est activée ainsi que les services smb et nfs.

Voici ce que renvoient les 3 commandes :

- Juste après un redémarrage :
xxx@xxxxx ~ $ ping -c3 synology.local
ping: unknown host synology.local
xxx@xxxxx ~ $ avahi-resolve --name -4 synology.local
Échec de la résolution du nom d'hôte « synology.local »  : Temps d'attente écoulé
xxx@xxxxx ~ $ avahi-browse -at | grep -i ipv4

- Au bout de quelques minutes, quand j'ai de nouveau accès à mon NAS via l'explorateur :
xxx@xxxxx ~ $ ping -c3 synology.local
PING synology.local (192.168.0.55) 56(84) bytes of data.
64 bytes from 192.168.0.55: icmp_seq=1 ttl=64 time=0.305 ms
64 bytes from 192.168.0.55: icmp_seq=2 ttl=64 time=0.329 ms
64 bytes from 192.168.0.55: icmp_seq=3 ttl=64 time=0.348 ms

--- synology.local ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2024ms
rtt min/avg/max/mdev = 0.305/0.327/0.348/0.022 ms
xxx@xxxxx ~ $ avahi-resolve --name -4 synology.local
Synology.local 192.168.0.55
xxx@xxxxx ~ $ avahi-browse -at | grep -i ipv4
+ eno1 IPv4 Synology _device-info._tcp local
+ eno1 IPv4 Synology Microsoft Windows Network local
+ eno1 IPv4 Synology Web Site local
+ eno1 IPv4 Canon MG8200 series Internet Printer local
+ eno1 IPv4 Canon MG8200 series Web Site local
+ eno1 IPv4 Canon MG8200 series _scanner._tcp local
+ eno1 IPv4 Canon MG8200 series UNIX Printer local
+ eno1 IPv4 Canon MG8200 series _canon-bjnp1._tcp local

(Petite question au passage, que veut dire "eno1", je m'attendais plutôt à voir "eth1" car ma connexion au réseau local se fait via ethernet)

Laurent85
Level 14
Level 14
Posts: 5442
Joined: Tue May 26, 2015 10:11 am

Re: Accès dossiers sur NAS Synology

Post by Laurent85 » Wed May 16, 2018 8:02 am

La résolution de nom pour le réseau local ne fonctionne pas au démarrage. Tu as accès à internet dès l'ouverture de ta session ?
Vahia wrote:
Wed May 16, 2018 6:25 am
(Petite question au passage, que veut dire "eno1", je m'attendais plutôt à voir "eth1" car ma connexion au réseau local se fait via ethernet)
L'attribution de nom des interfaces réseau a évolué, rien d'anormal.

Regarde que le NAS répond à son addresse ip dès le début :

Code: Select all

ping -c3 192.168.0.55
Donne le retour de ces commandes au démarrage :

Code: Select all

ip -4 address list
ip -4 route list
systemctl status avahi-daemon
sudo netstat -tulnp
sudo iptables -L -n
Image

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Wed May 16, 2018 8:51 am

Oui, dès l'ouverture de session j'ai accès à internet sans problème.

Voici les retours de commande au démarrage :
xxx@xxxxx ~ $ ping -c3 192.168.0.55
PING 192.168.0.66 (192.168.0.55) 56(84) bytes of data.
64 bytes from 192.168.0.55: icmp_seq=1 ttl=64 time=0.527 ms
64 bytes from 192.168.0.55: icmp_seq=2 ttl=64 time=0.317 ms
64 bytes from 192.168.0.55: icmp_seq=3 ttl=64 time=0.295 ms

--- 192.168.0.55 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2050ms
rtt min/avg/max/mdev = 0.295/0.379/0.527/0.106 ms
xxx@xxxxx ~ $ ip -4 address list
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
3: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
inet 192.168.0.10/24 brd 192.168.0.255 scope global dynamic eno1
valid_lft 863935sec preferred_lft 863935sec
xxx@xxxxx ~ $ ip -4 route list
default via 192.168.0.254 dev eno1 proto static metric 100
169.254.0.0/16 dev eno1 scope link metric 1000
192.168.0.0/24 dev eno1 proto kernel scope link src 192.168.0.10 metric 100
xxx@xxxxx ~ $ systemctl status avahi-daemon
● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
Loaded: loaded (/lib/systemd/system/avahi-daemon.service; enabled; vendor preset: enabled)
Active: active (running) since mer. 2018-05-16 14:38:34 CEST; 1min 29s ago
Main PID: 1098 (avahi-daemon)
Status: "avahi-daemon 0.6.32-rc starting up."
CGroup: /system.slice/avahi-daemon.service
├─1098 avahi-daemon: running [NopeOneNux.local
└─1248 avahi-daemon: chroot helpe

mai 16 14:38:39 xxxxx avahi-daemon[1098]: New relevant interface eno1.IPv4 for mDNS.
mai 16 14:38:39 xxxxx avahi-daemon[1098]: Registering new address record for 192.168.0.10 on eno1.IPv4.
mai 16 14:38:41 xxxxx avahi-daemon[1098]: Joining mDNS multicast group on interface eno1.IPv6 with address fe80:
mai 16 14:38:41 xxxxx avahi-daemon[1098]: New relevant interface eno1.IPv6 for mDNS.
mai 16 14:38:41 xxxxx avahi-daemon[1098]: Registering new address record for fe80::4076:8e23:ac2b:28e5 on eno1.*
mai 16 14:38:42 xxxxx avahi-daemon[1098]: Leaving mDNS multicast group on interface eno1.IPv6 with address fe80:
mai 16 14:38:42 xxxxx avahi-daemon[1098]: Joining mDNS multicast group on interface eno1.IPv6 with address 2a01:
mai 16 14:38:42 xxxxx avahi-daemon[1098]: Registering new address record for 2a01:e34:ecb8:4690:9fa6:2888:8b35:5
mai 16 14:38:42 xxxxx avahi-daemon[1098]: Withdrawing address record for fe80::4076:8e23:ac2b:28e5 on eno1.
mai 16 14:38:42 xxxxx avahi-daemon[1098]: Registering new address record for 2a01:e34:ecb8:4690:54d2:d555:ac70:a
...skipping...
(cette commande s'est répétée plusieurs fois. J'ai du faire un kill car il ne se passait plus rien)

xxx@xxxxx ~ $ sudo netstat -tulnp
Connexions Internet actives (seulement serveurs)
Proto Recv-Q Send-Q Adresse locale Adresse distante Etat PID/Program name
tcp 0 0 127.0.0.1:5939 0.0.0.0:* LISTEN 1676/teamviewerd
tcp 0 0 127.0.1.1:53 0.0.0.0:* LISTEN 1466/dnsmasq
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 1095/cupsd
tcp 0 0 0.0.0.0:445 0.0.0.0:* LISTEN 1737/smbd
tcp 0 0 0.0.0.0:139 0.0.0.0:* LISTEN 1737/smbd
tcp6 0 0 ::1:631 :::* LISTEN 1095/cupsd
tcp6 0 0 :::445 :::* LISTEN 1737/smbd
tcp6 0 0 :::139 :::* LISTEN 1737/smbd
udp 0 0 0.0.0.0:60679 0.0.0.0:* 1466/dnsmasq
udp 0 0 0.0.0.0:5353 0.0.0.0:* 1098/avahi-daemon:
udp 0 0 0.0.0.0:39323 0.0.0.0:* 1098/avahi-daemon:
udp 0 0 127.0.1.1:53 0.0.0.0:* 1466/dnsmasq
udp 0 0 0.0.0.0:68 0.0.0.0:* 1456/dhclient
udp 0 0 192.168.0.10:123 0.0.0.0:* 1774/ntpd
udp 0 0 127.0.0.1:123 0.0.0.0:* 1774/ntpd
udp 0 0 0.0.0.0:123 0.0.0.0:* 1774/ntpd
udp 0 0 192.168.0.255:137 0.0.0.0:* 1720/nmbd
udp 0 0 192.168.0.10:137 0.0.0.0:* 1720/nmbd
udp 0 0 0.0.0.0:137 0.0.0.0:* 1720/nmbd
udp 0 0 192.168.0.255:138 0.0.0.0:* 1720/nmbd
udp 0 0 192.168.0.10:138 0.0.0.0:* 1720/nmbd
udp 0 0 0.0.0.0:138 0.0.0.0:* 1720/nmbd
udp 0 0 0.0.0.0:631 0.0.0.0:* 1250/cups-browsed
udp6 0 0 :::58922 :::* 1466/dnsmasq
udp6 0 0 :::5353 :::* 1098/avahi-daemon:
udp6 0 0 :::46358 :::* 1098/avahi-daemon:
udp6 0 0 fe80::4076:8e23:ac2:123 :::* 1774/ntpd
udp6 0 0 2a01:e34:ecb8:4690::123 :::* 1774/ntpd
udp6 0 0 2a01:e34:ecb8:4690::123 :::* 1774/ntpd
udp6 0 0 ::1:123 :::* 1774/ntpd
udp6 0 0 :::123 :::* 1774/ntpd
xxx@xxxxx ~ $ sudo iptables -L -n
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
Last edited by Vahia on Wed May 16, 2018 6:50 pm, edited 1 time in total.

Laurent85
Level 14
Level 14
Posts: 5442
Joined: Tue May 26, 2015 10:11 am

Re: Accès dossiers sur NAS Synology

Post by Laurent85 » Wed May 16, 2018 10:34 am

Vahia wrote:
Wed May 16, 2018 8:51 am
xxx@xxxxx ~ $ ping -c3 192.168.0.55
PING 192.168.0.66 (192.168.0.66) 56(84) bytes of data.
64 bytes from 192.168.0.55: icmp_seq=1 ttl=64 time=0.527 ms
64 bytes from 192.168.0.55: icmp_seq=2 ttl=64 time=0.317 ms
64 bytes from 192.168.0.55: icmp_seq=3 ttl=64 time=0.295 ms
Il y a un problème sur le réseau local, le ping de l'ip 192.168.0.55 affiche d'abord une autre adresse ip 192.168.0.66

Il y a d'autres machines sur le réseau ?

Que donne au démarrage et après quelques minutes les commandes :

Code: Select all

ping -c3 192.168.0.55
ping -c3 192.168.0.66
sudo arp -a | sed 's/ ..:..:..:../ /'
Image

Vahia
Level 1
Level 1
Posts: 37
Joined: Sun Apr 08, 2018 6:58 am

Re: Accès dossiers sur NAS Synology

Post by Vahia » Wed May 16, 2018 11:26 am

C'est une erreur de copie de ma part. Désolé.
Il n'y a aucun 66, que des 55.

Post Reply

Return to “Français (French)”