[~résolu] Cinnamon ne démarre pas (plus) tout seul

French Forum

Moderators: Laurent85, killer de bug

Post Reply
leolivier
Level 1
Level 1
Posts: 10
Joined: Fri Aug 15, 2014 4:35 am

[~résolu] Cinnamon ne démarre pas (plus) tout seul

Post by leolivier » Sat Nov 10, 2018 2:25 pm

Bonjour
J'ai rebooté aujourd'hui mon pc après quelques semaines de bons et loyaux services et pour une raison que j'ignore, cinnamon ne démarre plus tout seul (ça marchait nickel avant).
Là, j'ai mon fond d'écran, sans menu ni rien. Pour lancer cinnamon, je fais clic droit 'ouvrir dans un terminal' sur le fond d'écran et je lance juste cinnamon en background et, pop, ça démarre sans souci...
(J'ai qaund même mis 2h à trouver ça, je cherchais bêtement du côté des drivers nvidia qui avaient l'air de donner des erreurs mais finalement ça ne semble pas être ça)
Une idée?

(Je suis sur tara)
Last edited by leolivier on Fri Nov 23, 2018 9:33 am, edited 1 time in total.
Mint Tara - Asus X93S (2011) avec carte NVIDIA GT 540M (drivers 390.77)

Laurent85
Level 15
Level 15
Posts: 5749
Joined: Tue May 26, 2015 10:11 am

Re: Cinnamon ne démarre pas (plus) tout seul

Post by Laurent85 » Sun Nov 11, 2018 7:44 am

Bonjour,
Créé un nouveau compte utilisateur pour savoir si le problème vient de ton profil ou du système.
Image

leolivier
Level 1
Level 1
Posts: 10
Joined: Fri Aug 15, 2014 4:35 am

Re: Cinnamon ne démarre pas (plus) tout seul

Post by leolivier » Fri Nov 16, 2018 4:02 am

Bonjour Laurent et merci de ta réponse.
J'ai créé un nouvel utilisateur et lui n'a pas de souci, quand je me connecte dessus, Cinnamon démarre sans souci.
J'en déduis que c'est lié à mon compte mais y-a-t-il un moyen de régler le problème sans détruire ce compte sur lequel j'ai un gros historique?
Si je crée un nouveau compte et que je recopie dedans le contenu de mon home dir, je vais probablement pourrir le nouveau compte...
Mint Tara - Asus X93S (2011) avec carte NVIDIA GT 540M (drivers 390.77)

Laurent85
Level 15
Level 15
Posts: 5749
Joined: Tue May 26, 2015 10:11 am

Re: Cinnamon ne démarre pas (plus) tout seul

Post by Laurent85 » Fri Nov 16, 2018 5:39 am

Fais un clic droit sur la barre des tâches, dans le menu contextuel il doit y avoir Résoudre les problèmes > Réinitialiser le bureau Cinnamon,
Tu va perdre tes personnalisations de bureau avec cette solution.
Image

leolivier
Level 1
Level 1
Posts: 10
Joined: Fri Aug 15, 2014 4:35 am

Re: Cinnamon ne démarre pas (plus) tout seul

Post by leolivier » Sun Nov 18, 2018 1:30 pm

J'ai fait ça (j'ai perdu mon paramétrage comme prévu) mais ça n'a rien résolu
Mint Tara - Asus X93S (2011) avec carte NVIDIA GT 540M (drivers 390.77)

User avatar
ToutAlu
Level 2
Level 2
Posts: 90
Joined: Tue May 23, 2017 4:14 pm

Re: Cinnamon ne démarre pas (plus) tout seul

Post by ToutAlu » Sun Nov 18, 2018 2:37 pm

leolivier wrote:
Sat Nov 10, 2018 2:25 pm
Pour lancer cinnamon, je fais clic droit 'ouvrir dans un terminal' sur le fond d'écran et je lance juste cinnamon en background et, pop, ça démarre sans souci...
Une idée : ouvre l'application "session et démarrage"
dans l'onglet "démarrage automatique d'applications", ajoute "cinnamon" (sans les guillemets), en cliquant en bas à gauche sur "ajouter"
nom : cinnamon
description : lancer le bureau
commande : cinnamon

Valide et ferme l'application.
Ferme et ré-ouvre ta session pour vérifier si ça marche.
Image
Linux Mint 19.xx Xfce

leolivier
Level 1
Level 1
Posts: 10
Joined: Fri Aug 15, 2014 4:35 am

[résolu] Re: Cinnamon ne démarre pas (plus) tout seul

Post by leolivier » Fri Nov 23, 2018 9:32 am

Merci pour le truc auquel j'avais pensé mais que je n'avais pas essayé, étant persuadé que c'était cinnamon qui gérait ces démarrages...
J'ai donc essayé et ça lance bien cinnamon au début de la session mais il s'arrête au bout de quelques secondes (comme s'il crashait) alors que quand je le lance à la main il ne plante pas.
J'ai remplacé le lancement par cinnamon-launcher avec 3s de délais et ça a l'air de fonctionner pour le moment...

C'est donc à moitié résolu mais ça me laisse un peu sur ma faim, ça ne devrait pas fonctionner comme ça...
Mint Tara - Asus X93S (2011) avec carte NVIDIA GT 540M (drivers 390.77)

User avatar
ToutAlu
Level 2
Level 2
Posts: 90
Joined: Tue May 23, 2017 4:14 pm

Re: [~résolu] Cinnamon ne démarre pas (plus) tout seul

Post by ToutAlu » Fri Nov 23, 2018 4:35 pm

On a exactement la même solution pour le bureau Xfce.
J'utilise :
sh -c "sleep 5s; xfdesktop --reload"
Qu'on peut adapter pour cinnamon ?
sh -c "sleep 10s; cinnamon"
Image
Linux Mint 19.xx Xfce

leolivier
Level 1
Level 1
Posts: 10
Joined: Fri Aug 15, 2014 4:35 am

Re: [~résolu] Cinnamon ne démarre pas (plus) tout seul

Post by leolivier » Sat Nov 24, 2018 12:36 pm

C'est plus ou moins ce que j'ai fait mais au travers des settings "applications au démarrage" ce qui revient au même:
Image
Démarrage automatique de cinnamon avec 3s de délai

Néanmoins, je n'avais pas à faire cela auparavant et je ne comprends pas pourquoi je dois le faire maintenant...
Dans mon fichier ~/.dmrc, j'ai juste:

Code: Select all

[Desktop]
Session=cinnamon
et ça devrait suffire à lancer cinnamon, non?

Edit: je viens de trouver sur https://help.gnome.org/admin/system-adm ... er.html.en que le fichier .dmrc n'est plus utilisé depuis gnome 2 et est remplacé par un fichier dans /var/lib/AccountService/users/<user>.
Moi, j'ai:

Code: Select all

$ more /var/lib/AccountsService/users/<mon user> 
[org.freedesktop.DisplayManager.AccountsService]
BackgroundFile='/usr/share/backgrounds/linuxmint/sele_linuxmint.png'

[User]
XSession=cinnamon
Background=/usr/share/backgrounds/linuxmint/sele_linuxmint.png
SystemAccount=false
et

Code: Select all

$ ls /usr/share/xsessions/
cinnamon2d.desktop  cinnamon.desktop
$ more /usr/share/xsessions/cinnamon.desktop 
[Desktop Entry]
Name=Cinnamon
Comment=This session logs you into Cinnamon
Exec=cinnamon-session-cinnamon
TryExec=/usr/bin/cinnamon
Icon=
Type=Application

donc tout est correctement configuré... (ou pas :?: :?: :?:)
Mint Tara - Asus X93S (2011) avec carte NVIDIA GT 540M (drivers 390.77)

Post Reply

Return to “Français (French)”