(Résolu) Blocage de 15 paquets pour MAJ

Forum de support pour les utilisateurs francophones

Moderator: Laurent85

Post Reply
Lylou896
Level 2
Level 2
Posts: 78
Joined: Mon Mar 18, 2019 10:13 am

(Résolu) Blocage de 15 paquets pour MAJ

Post by Lylou896 »

Bonjour,

Voici mon problème :

Code: Select all

sudo apt update
[sudo] Mot de passe de didier :               
Atteint :1 http://archive.ubuntu.com/ubuntu jammy InRelease
Réception de :2 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [114 kB]
Réception de :3 http://archive.ubuntu.com/ubuntu jammy-backports InRelease [99,8 kB]
Réception de :4 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Ign :5 http://packages.linuxmint.com vanessa InRelease                
Atteint :6 http://packages.linuxmint.com vanessa Release             
324 ko réceptionnés en 1s (402 ko/s)                                 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
15 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.

Code: Select all

apt list --upgradable
En train de lister... Fait
libnss-myhostname/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
libnss-systemd/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
libpam-systemd/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
libspeechd2/jammy-updates 0.11.1-1ubuntu2 amd64 [pouvant être mis à jour depuis : 0.11.1-1ubuntu1]
libsystemd0/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
libudev1/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
python3-speechd/jammy-updates,jammy-updates 0.11.1-1ubuntu2 all [pouvant être mis à jour depuis : 0.11.1-1ubuntu1]
speech-dispatcher-audio-plugins/jammy-updates 0.11.1-1ubuntu2 amd64 [pouvant être mis à jour depuis : 0.11.1-1ubuntu1]
speech-dispatcher-espeak-ng/jammy-updates 0.11.1-1ubuntu2 amd64 [pouvant être mis à jour depuis : 0.11.1-1ubuntu1]
speech-dispatcher/jammy-updates 0.11.1-1ubuntu2 amd64 [pouvant être mis à jour depuis : 0.11.1-1ubuntu1]
systemd-coredump/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
systemd-sysv/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
systemd-timesyncd/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
systemd/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]
udev/jammy-updates 249.11-0ubuntu3.6 amd64 [pouvant être mis à jour depuis : 249.11-0ubuntu3.4]

Code: Select all

sudo apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Calcul de la mise à jour... Fait
Les paquets suivants ont été conservés :
  libnss-myhostname libnss-systemd libpam-systemd libspeechd2 libsystemd0
  libudev1 python3-speechd speech-dispatcher speech-dispatcher-audio-plugins
  speech-dispatcher-espeak-ng systemd systemd-coredump systemd-sysv
  systemd-timesyncd udev
0 mis à jour, 0 nouvellement installés, 0 à enlever et 15 non mis à jour.
J'ai encore des mises à jour qui n'ont pas été faites, avez-vous une idée du problème ?
Last edited by Lylou896 on Thu Sep 29, 2022 3:31 pm, edited 1 time in total.
PC fixe
Intel Core i3-9100F 3.60GHz x4
RAM Corsair 2x8 3200MHz
Nvidia GeForce GTX 1650 Super
User avatar
MikeNovember
Level 6
Level 6
Posts: 1144
Joined: Fri Feb 28, 2020 7:37 am
Location: Nice, Paris, France

Re: Blocage de 15 paquets pour MAJ

Post by MikeNovember »

Bonjour,

Vous êtes peu bavard(e) sur l'historique de votre PC et la survenue de vos problèmes. J'essaie donc de deviner.

Avez-vous fait une mise à jour (de 20.x vers 21) en utilisant mint-upgrade ?

Si oui, les 15 paquets pourraient être bloqués car vous avez installé avant l'upgrade des paquets d'applications étrangers (non diffusés par linux Mint) qui utilisent ces paquets, qui ne peuvent donc pas être mis à jour.

Est-ce le cas ?

Si oui, il vous faut désinstaller les applications qui utilisent ces paquets, faire la mise à jour des paquets, puis réinstaller les applications, dans une version compatible de Linux Mint 21 / Ubuntu 22.04.

Sinon, merci d'expliquer un peu à la suite de quoi ces problèmes sont apparus. Et de publier votre rapport inxi "informations sur le système".

Cordialement,

MN
_____________________________
Linux Mint 20.3 Mate host with 5.4 kernel, Windows 10 Pro guest, ASUS G74SX (i7-2670QM, 16 GB RAM, GTX560M with 3GB RAM, 1TB SSD)
Lylou896
Level 2
Level 2
Posts: 78
Joined: Mon Mar 18, 2019 10:13 am

Re: Blocage de 15 paquets pour MAJ

Post by Lylou896 »

Bonjour MikeNovember,

Voici le cheminement :

Mon problème se retrouve sur mes deux PC (fixe et portable), ils sont effectivement subits une mise à jour (de 20.x vers 21) en utilisant mint-upgrade.

Mais avant toute mise à niveau de la distribution (de 20.x vers 21), je teste sur ma machine virtuelle qui elle n'a pas subi ce problème (blocage de 15 paquets pour MAJ).
Le seul logiciel différent qui n'est pas installé sur la VM et un programme propriétaire "qnap Qsync".

J'ai tenté une restauration de ma distribution sur le PC fixe avec "Timeshift' avec une sauvegarde de 8 jours, toujours en version Linux Mint 21 Cinnamon.
Cela a bien résolu le problème, sans suppression du logiciel "qnap Qsync", les 15 paquets avaient disparu, mais après avoir fait les MAJ, le blocage des 15 paquets sont revenus.

Le fait de désinstaller les paquets avec Synaptic, le système plante.

Merci de l'aide
PC fixe
Intel Core i3-9100F 3.60GHz x4
RAM Corsair 2x8 3200MHz
Nvidia GeForce GTX 1650 Super
Lylou896
Level 2
Level 2
Posts: 78
Joined: Mon Mar 18, 2019 10:13 am

Re: Blocage de 15 paquets pour MAJ

Post by Lylou896 »

Je viens de résoudre le blocage des 15 paquets.

J'ai désinstallé le logiciel "qnap Qsync", cela a supprimé 10 paquets bloqués puis j'ai supprimé les autres avec synaptic.
J'ai réinstallé "qnap Qsync" et pour le moment tout va bien.

Installation bancale, surtout pas en mode graphique sinon joli bug, donc installation par le terminal avec la commande "sudo dpkg -i *.deb".
Une fois installé "sudo dpkg --configure -a" pour corriger le problème, après cela tous fonctionne.

Existe-t-il un programme open source simple à maitre en place pour remplacer "qnap Qsync" pour synchroniser à chaud des fichiers sur un serveur Qnap :?:
PC fixe
Intel Core i3-9100F 3.60GHz x4
RAM Corsair 2x8 3200MHz
Nvidia GeForce GTX 1650 Super
User avatar
MikeNovember
Level 6
Level 6
Posts: 1144
Joined: Fri Feb 28, 2020 7:37 am
Location: Nice, Paris, France

Re: Blocage de 15 paquets pour MAJ

Post by MikeNovember »

Bonjour,

QNAP est un serveur NAS propriétaire, et QNAP SYNC est un logiciel de synchronisation propriétaire... Je doute qu'il existe un logiciel Linux de remplacement.

Il n'existe que pour Ubuntu 20.04, et, tant que ça marchote, utilisez-le comme ça ! Surveillez le site, pour voir si quand la version pour Ubuntu 22.04 arrive.

Et, comme QNAP est un produit que vous avez acheté, n'hésitez pas à demander au fabricant la mise à jour de QNAP SYNC.

Cordialement,

MN
_____________________________
Linux Mint 20.3 Mate host with 5.4 kernel, Windows 10 Pro guest, ASUS G74SX (i7-2670QM, 16 GB RAM, GTX560M with 3GB RAM, 1TB SSD)
Lylou896
Level 2
Level 2
Posts: 78
Joined: Mon Mar 18, 2019 10:13 am

Re: Blocage de 15 paquets pour MAJ

Post by Lylou896 »

Je teste Grsync et FreeFileSync mais cela reste que de la sauvegarde manuelle.

Les MAJ sont courants de "qnap Qsync" pour Linux Ubuntu que j'utilisais avant de passer sur Linux Mint.
Le logiciel fonctionne bien, maintenant reste à surveiller les conflits de MAJ.

Merci des conseils

Belle soirée
PC fixe
Intel Core i3-9100F 3.60GHz x4
RAM Corsair 2x8 3200MHz
Nvidia GeForce GTX 1650 Super
Post Reply

Return to “Français - French”