Probleme de pilote de carte wifi [résolu plus du tout]

French Forum

Moderators: killer de bug, Laurent85

Post Reply
Djay42
Level 1
Level 1
Posts: 8
Joined: Thu Sep 14, 2017 6:59 am

Probleme de pilote de carte wifi [résolu plus du tout]

Post by Djay42 » Thu Sep 14, 2017 7:34 am

Bonjour,
Je suis nouveau sur Linux Mint, j'ai fait la migration ce matin sur un portable depuis win 10 que je souhaiterai utiliser dans le cadre de mon métier (compta tableur, traitement de texte, communication sur les reseaux sociaux).
Je n'ai pas vraiment d'expérience sur linux, à part un court passage sur Ubuntu il y a une quizaine d'année.

Pas de demi-mesure, j'ai écrasé Win10.
Jusqu'ici tout allait bien, installation, mise à jour des pilotes sur internet etc (J'ai même trouvé les logiciel que j'utilisais avant).

Mais j'ai un soucis avec la connexion wifi.

Le gestionnaire de reseau ne me propose pas de connexion wifi.

J'ai un peu farfouillé dans les posts, et j'ai l'impression que je n'ai pas de pilote pour ma carte wifi

En lisant un post j'ai utilisé la commande inxi -xxv2
Voici ce que ça donne:

Code: Select all

System:    Host: Cabane-Mobile Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.3 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
           Distro: Linux Mint 18.2 Sonya
Machine:   System: ASUSTeK (portable) product: TP500LN v: 1.0
           Mobo: ASUSTeK model: TP500LN v: 1.0
           Bios: American Megatrends v: TP500LN.202 date: 05/21/2014
CPU:       Dual core Intel Core i5-4210U (-HT-MCP-) speed/max: 2399/2700 MHz
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0 chip-ID: 8086:0a16
           Card-2: NVIDIA GM108M [GeForce 840M]
           bus-ID: 04:00.0 chip-ID: 10de:1341
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1366x768@60.01hz
           GLX Renderer: GeForce 840M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 375.66 Direct Rendering: Yes
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000
           bus-ID: 02:00.1 chip-ID: 10ec:8168
           Card-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter
           bus-ID: 03:00.0 chip-ID: 14c3:7630
Drives:    HDD Total Size: 1524.3GB (0.7% used) ID-1: model: HGST_HTS541515A9
           ID-2: model: SanDisk_SSD_U100
Info:      Processes: 222 Uptime: 35 min Memory: 2201.2/3834.6MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in gnome-terminal-) inxi: 2.2.35 
J'ai l'impression qu'il devrait y avoir une ligne driver après la ligne "Card-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter"
Le gestionnaire de pilote ne me propose rien pour cela.

Qu'ai-je raté?

J'Ai lu sur certain posts que certain fabriquants n'étaient pas très compatible avec linux, est-ce le cas de ma carte?

Merci du temps que vous passerez à me lire.

Jérôme

PS: je ne suis pas assez à l'aise en anglais pour lire les posts anglophones techniques et en comprendre les subtilités.
Last edited by Djay42 on Fri Mar 30, 2018 6:05 am, edited 3 times in total.

Laurent85
Level 15
Level 15
Posts: 5604
Joined: Tue May 26, 2015 10:11 am

Re: Probleme de pilote de carte wifi

Post by Laurent85 » Thu Sep 14, 2017 3:59 pm

Bonjour et bienvenue,
Cette carte wifi n'est pas prise en charge par défaut. Il y a un pilote à installer soi-même.

Première chose à faire va dans les paramètres de l'ordi (le bios) et désactive Secure Boot.

Ensuite, suis cette procédure, ouvre un terminal et exécute chaque commande une à une, utilise copier coller pour éviter les erreurs de saisie :

Code: Select all

cd
cd Téléchargements
wget https://codeload.github.com/neurobin/MT7630E/zip/release  --output-document MT7630E-release.zip
unzip MT7630E-release.zip
cd  MT7630E-release
sudo make dkms
Puis redémarre.
Image

Djay42
Level 1
Level 1
Posts: 8
Joined: Thu Sep 14, 2017 6:59 am

Re: Probleme de pilote de carte wifi

Post by Djay42 » Fri Sep 15, 2017 4:24 am

Bonjour,

Merci Laurent85, je viens de tester ta solution et j'ai maintenant une connexion wifi.

Petite question pour ma formation personnelle, à quoi correspond la commande make dans la ligne: sudo make dkms ?
Aurai-je obtenu un résultat identique en utilisant l'install présent dans le dossier dézzipé?

Pour le Secure Boot, je l'avais déja désactivé pour pouvoir tester Linuxmint en démarrant depuis une clé usb. ESt-ce iportant, est-ce que je dois le réactiver?.
à priori je ne peux pas démarrer depuis une clé si il est actif dans le bios.

Bonne journée, Jérôme

Laurent85
Level 15
Level 15
Posts: 5604
Joined: Tue May 26, 2015 10:11 am

Re: Probleme de pilote de carte wifi

Post by Laurent85 » Fri Sep 15, 2017 4:26 pm

Djay42 wrote: Petite question pour ma formation personnelle, à quoi correspond la commande make dans la ligne: sudo make dkms ?
Aurai-je obtenu un résultat identique en utilisant l'install présent dans le dossier dézzipé?
Non je ne crois pas, il aurait installé le pilote pour le noyau actuel uniquement. dkms permet de réinstaller le pilote automatiquement en cas d'installation d'un nouveau noyau, c'est mieux puisque qu'il n'y a plus à s'en préocupper.
Pour le Secure Boot, je l'avais déja désactivé pour pouvoir tester Linuxmint en démarrant depuis une clé usb. ESt-ce iportant, est-ce que je dois le réactiver?.
à priori je ne peux pas démarrer depuis une clé si il est actif dans le bios.
Non si tu réactives SB le pilote wifi ne sera pas charger. Secure Boot vérifie que le noyau et les pilotes chargés en mémoire ont été signés par une clé d'authentification autorisée par l'ordi. Par défaut ce sont les certificats de Microsoft qui sont dans les ordis. Ubuntu/Canoncal utilise une clé signée par Microsoft pour signer ses binaires ce qui permet de charger les noyaux et pilotes fournis par Ubuntu/Canonical avec SB actif.

En installant le pilote wifi toi-même à partir des sources, le pilote est compilé localement et donc non signé, ni par Microsoft (forcément), ni par Ubuntu puisque le pilote ne vient pas d'eux. Il faut donc désactiver Secure Boot ou alors solution alternative signer soi-même le pilote et ajouter son propre certificat dans les paramètres de l'ordi.

Concernant la clé usb d'installation, LM n'a pas de clé certifiée Microsoft pour être compatible avec le Secure Boot de Microsoft.

Bonne soirée à toi
Image

Djay42
Level 1
Level 1
Posts: 8
Joined: Thu Sep 14, 2017 6:59 am

Re: Probleme de pilote de carte wifi ça redeconne

Post by Djay42 » Fri Mar 30, 2018 6:03 am

Bonjour,
Je reviens vers vous car j'ai de nouveau le même soucis.
Idéaliste j'ai pensé que la même manipulation réglerai ça, mais lorsque je tape la dernière ligne (sudo make dkms) en copier coller, j'ai le message suivant:

Code: Select all

[sudo] password for jerome: 
cp -v firmware/*/* /lib/firmware/
'firmware/BT/mt76x0.bin' -> '/lib/firmware/mt76x0.bin'
'firmware/Wi-FI/MT7650E234.bin' -> '/lib/firmware/MT7650E234.bin'
cp -R . /usr/src/mt7630e-`sed -n 's/^[[:blank:]]*PACKAGE_VERSION=\([^[:blank:]]*\).*/\1/p' dkms.conf`
dkms add -m mt7630e -v `sed -n 's/^[[:blank:]]*PACKAGE_VERSION=\([^[:blank:]]*\).*/\1/p' dkms.conf`
Error! DKMS tree already contains: mt7630e-2.1.0
You cannot add the same module/version combo more than once.
Makefile:29: recipe for target 'dkms' failed
make: *** [dkms] Error 3
Vu que rien ne marche et que ça finit par error, j'imagine que ce n'est pas la solution.
En relisant je vois que le module est déjà là, donc l'erreur est ailleur.

J'ai le résultat suivant pour inxi -xxv2

Code: Select all

System:    Host: Cabane-Portable Kernel: 4.13.0-37-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
           Distro: Linux Mint 18.2 Sonya
Machine:   System: ASUSTeK (portable) product: TP500LN v: 1.0
           Mobo: ASUSTeK model: TP500LN v: 1.0
           Bios: American Megatrends v: TP500LN.202 date: 05/21/2014
CPU:       Dual core Intel Core i5-4210U (-HT-MCP-) speed/max: 2394/2700 MHz
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics Controller
           bus-ID: 00:02.0 chip-ID: 8086:0a16
           Card-2: NVIDIA GM108M [GeForce 840M]
           bus-ID: 04:00.0 chip-ID: 10de:1341
           Display Server: X.Org 1.18.4 driver: nvidia
           Resolution: 1366x768@60.01hz
           GLX Renderer: GeForce 840M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.111 Direct Rendering: Yes
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000
           bus-ID: 02:00.1 chip-ID: 10ec:8168
           Card-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter
           bus-ID: 03:00.0 chip-ID: 14c3:7630
Drives:    HDD Total Size: 1524.3GB (1.9% used) ID-1: model: HGST_HTS541515A9
           ID-2: model: SanDisk_SSD_U100
Info:      Processes: 190 Uptime: 16 min Memory: 1090.0/3828.9MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in gnome-terminal-) inxi: 2.2.35
Cette fois ci encore, pas de ligne pilote pour Network Card-2

Votre avis?

Bonne journée, Jérôme

Laurent85
Level 15
Level 15
Posts: 5604
Joined: Tue May 26, 2015 10:11 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Laurent85 » Fri Mar 30, 2018 5:16 pm

As-tu essayé de démarrer sur le noyau pour lequel le wifi fonctionnait ?
Image

Djay42
Level 1
Level 1
Posts: 8
Joined: Thu Sep 14, 2017 6:59 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Djay42 » Sat Mar 31, 2018 6:35 am

Laurent85 wrote:
Fri Mar 30, 2018 5:16 pm
As-tu essayé de démarrer sur le noyau pour lequel le wifi fonctionnait ?
Je ne sais pas ce que tu veux dire, je vais chercher.

Djay42
Level 1
Level 1
Posts: 8
Joined: Thu Sep 14, 2017 6:59 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Djay42 » Sat Mar 31, 2018 8:40 am

Bon à priori ça veut dire que je devrais démarrer sous une version précédente du noyau.
Plusieurs points me posent problème:
1: je n'ai pas la moindre idée de comment faire.
2: je ne sais pas quelle version est la bonne (mais au pire je peux partir de la plus vieille et avancer).

Djay42
Level 1
Level 1
Posts: 8
Joined: Thu Sep 14, 2017 6:59 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Djay42 » Sat Mar 31, 2018 1:20 pm

Bon je viens de trouver une solution alternative.
En cherchant les pilotes de ma carte wifi, j'ai trouvé ça.
https://doc.ubuntu-fr.org/wifi_bt_mt7630e
Je viens de mettre en oeuvre la partie wifi, et ça marche!
Est-ce normal ou juste un concours de circonstances?

Je n'arrive pas à faire la partie sur le BT, une idée?

Laurent85
Level 15
Level 15
Posts: 5604
Joined: Tue May 26, 2015 10:11 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Laurent85 » Sat Mar 31, 2018 5:24 pm

Djay42 wrote:
Sat Mar 31, 2018 8:40 am
Bon à priori ça veut dire que je devrais démarrer sous une version précédente du noyau.
Plusieurs points me posent problème:
1: je n'ai pas la moindre idée de comment faire.
2: je ne sais pas quelle version est la bonne (mais au pire je peux partir de la plus vieille et avancer).
Si tu as un menu grub au démarrage de l'ordi il faut sélectionner l'entrée du menu Options avancées. Il y a une liste des noyaux disponibles. Tu n'utilises plus le même noyau, l'info est donnée par inxi.

Si le menu ne s'affiche pas automatiquement il faut maintenir la touche shift enfoncée à la mise sous tension.
Djay42 wrote:
Sat Mar 31, 2018 1:20 pm
Je viens de mettre en oeuvre la partie wifi, et ça marche!
Est-ce normal ou juste un concours de circonstances?
Il y a deux méthodes pour installer le pilote, puisque celle-là a marché c'est bon. L'autre que j'avais expliqué utilise dkms, cela permet de réinstaller automatiquement le pilote lors de l'installation d'un nouveau noyau.
Je n'arrive pas à faire la partie sur le BT, une idée?
Tu as des messages d'erreur ?
Image

Djay42
Level 1
Level 1
Posts: 8
Joined: Thu Sep 14, 2017 6:59 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Djay42 » Sun Apr 01, 2018 4:33 am

Oui, à priori c'est que je n'ai pas les bonnes sources.

Code: Select all

*** Stoping Bluetooth...
*** Installing kernel headers...
Atteint:1 http://archive.canonical.com/ubuntu xenial InRelease
Atteint:2 http://ftp.oleane.net/ubuntu xenial InRelease                        
Ign:3 http://mirror6.layerjet.com/linuxmint/packages sonya InRelease           
Atteint:4 http://ftp.oleane.net/ubuntu xenial-updates InRelease                
Atteint:5 http://mirror6.layerjet.com/linuxmint/packages sonya Release         
Atteint:6 http://ftp.oleane.net/ubuntu xenial-backports InRelease              
Atteint:8 http://repository.spotify.com stable InRelease                       
Atteint:9 http://ppa.launchpad.net/teejee2008/ppa/ubuntu xenial InRelease      
Réception de:10 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
102 ko réceptionnés en 6s (16,0 ko/s)                                          
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
build-essential is already the newest version (12.1ubuntu2).
linux-headers-4.13.0-37-generic is already the newest version (4.13.0-37.42~16.04.1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
*** Downloading kernel source...
Lecture des listes de paquets... Fait
Choix de « linux-hwe » comme paquet source à la place de « linux-image-4.13.0-37-generic »
E: Impossible de trouver une source de paquet pour linux-hwe
J'ai bien lu le lien sur le tuto, mais je ne suis pas arrivé à le transposer sur Mint.
En fait c'est la ligne suivante que je ne saisis pas:

Code: Select all

On active le dépôt correspondant aux codes sources d'ubuntu à l'aide du gestionnaire de paquet 
Avec "sources de logiciels" dans paramètres système je vois comment ajouter manuellement une source (je ne sais pas le faire en ligne de code) mais quelle source dois-je ajouter?

Pour les noyaux, je ne savais pas qu'on pouvait choisir au démarrage en pressant "shift".
Merci pour tes retours

Laurent85
Level 15
Level 15
Posts: 5604
Joined: Tue May 26, 2015 10:11 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Laurent85 » Sun Apr 01, 2018 6:15 am

Dans Sources de logiciels coche "Activer les dépôts de code source" et clique sur "Recharger le cache".
Image

Djay42
Level 1
Level 1
Posts: 8
Joined: Thu Sep 14, 2017 6:59 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Djay42 » Sun Apr 01, 2018 7:58 am

Merci pour ta réponse, jai fait ce que tu as proposé.
Mais le résultat me laisse perplexe.

fichier texte avec le resultat du terminal
(J'ai voulu poser les lignes mais je dépassais allègrement la limite de carractères d'un post. J'en ai fait un fichier texte disponible sur le lien précédent pendant quelques jours).

Et J'ai eu ceci (les 6 dernières lignes) répétée en dessous pour plus de lisibilité:

Code: Select all

scripts/sign-file.c:25:30: fatal error: openssl/opensslv.h: No such file or directory
compilation terminated.
scripts/Makefile.host:101: recipe for target 'scripts/sign-file' failed
make[1]: *** [scripts/sign-file] Error 1
Makefile:587: recipe for target 'scripts' failed
make: *** [scripts] Error 2
Chez moi il y a "fatal error" en rouge ce qui n'est jamais bon signe.
L'icone bleue du BT est apparue, mais lorsque je clic dessus la page reste sur
Image
Pas plus annimée que la capture d'écran (la petite flêche devrait tourner pour indiquer la recherche non?).
Qu'ai-je raté?

Laurent85
Level 15
Level 15
Posts: 5604
Joined: Tue May 26, 2015 10:11 am

Re: Probleme de pilote de carte wifi [résolu plus du tout]

Post by Laurent85 » Sun Apr 01, 2018 6:07 pm

J'ai un message d'erreur "Forbidden" quand j'accède au lien.

Les 6 dernières lignes le message d'erreur c'est parce que le paquet libssl-dev n'est pas installé.

As-tu essayé de démarrer sur un ancien noyau pour lequel le wifi fonctionnait ? Bluetooth fonctionnait aussi ?
Image

Post Reply

Return to “Français (French)”