[résolu] Comment commenter une ligne du grub.cfg

French Forum

Moderators: killer de bug, Laurent85

User avatar
jjcojax
Level 2
Level 2
Posts: 68
Joined: Fri Apr 03, 2015 6:01 am
Location: Belgium

[résolu] Comment commenter une ligne du grub.cfg

Postby jjcojax » Sat Nov 04, 2017 7:43 am

Bonjour,

Sur un ancien PC dont la carte vidéo à claqué (PCI express de 256 Mb), j'ai placé une ancienne carte vidéo PCI ordinaire pour pouvoir faire revivre le PC.

Avant d'acheter une nouvelle carte vidéo (ou carte mère) l'utilisateur souhaite pouvoir récupérer les documents, les Photos et la boite mail (thunderbird)

C'était un XP qui refonctionne, il y a plusieurs utilisateurs (aussi les enfants) et il est saturé de programmes qui se lance tout seul,..

Pour facilité la récupération des données, j'ai ajouté une partition avec Linux Mint Mate 18.2, (aussi pour montrer que Linux est aussi facile à utiliser que Windows)

On peut donc sans problème voir et récupérer les documents, recopier le profil thunderbird, utiliser le Wifi et aller sur internet.

Tout fonctionne sauf qu'avec une veille carte vidéo ...
----
Mon problème est que Linux ne démarre correctement qu'en mode "recovery mode"

ou

en éditant (via e) le menu Grub

-> Si je commente la 3 ème Ligne du menu Grub , Linux démarre correctement.
(celle avec "gfxmode $linux_gfx_mode" )

Pour montrer ce que l'on vois quand j'édite le menu Grub, j'ai installé "grub customizer"
Ce que je vois à l'écran est ... (j'ai ajouté ### pour la ligne à faire disparaître)

Code: Select all

   recordfail
   load_video
###   gfxmode $linux_gfx_mode
   insmod gzio
   if [ x$grub_platform = xxen ]; then insmod xzio; insmod lzopio; fi
   insmod part_msdos
   insmod ext2
   set root='hd0,msdos3'
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos3 --hint-efi=hd0,msdos3 --hint-baremetal=ahci0,msdos3  2497e15a-cd2c-4520-b8d9-9c7b0ccbde40
   else
     search --no-floppy --fs-uuid --set=root 2497e15a-cd2c-4520-b8d9-9c7b0ccbde40
   fi
   echo   'Chargement de Linux 4.10.0-38-generic…'
        linux   /boot/vmlinuz-4.10.0-38-generic root=UUID=2497e15a-cd2c-4520-b8d9-9c7b0ccbde40 ro  quiet splash $vt_handoff
   echo   'Chargement du disque mémoire initial…'
   initrd   /boot/initrd.img-4.10.0-38-generic


Comme il est déconseillé d’éditer /boot/grub/grub.cfg, j'aimerais que la machine démarre sans devoir commenter le menu Grub car l'utilisateur n'a jamais utilisé Linux,

Avez-vous une piste ?

La piste peut être provisoire, mais l'utilisateur a 150 GB de photos à classer et un dossier thunderbird avec plus de 5000 mails :mrgreen:

jjcojax
Last edited by jjcojax on Sat Nov 04, 2017 6:59 pm, edited 1 time in total.

Laurent85
Level 13
Level 13
Posts: 4849
Joined: Tue May 26, 2015 10:11 am

Re: Comment commenter une ligne du grub.cfg

Postby Laurent85 » Sat Nov 04, 2017 8:50 am

Bonjour,
Essaie ça pour voir si ça suffit. Edite /etc/default/grub et retire splash de la ligne GRUB_CMDLINE_LINUX_DEFAULT, puis mets à jour grub.

Code: Select all

sudo update-grub
Image

User avatar
jjcojax
Level 2
Level 2
Posts: 68
Joined: Fri Apr 03, 2015 6:01 am
Location: Belgium

Re: Comment commenter une ligne du grub.cfg

Postby jjcojax » Sat Nov 04, 2017 12:17 pm

Merci pour la réponse, :wink:

Le fichier édité est celui ci (j'ai commenté la ligne d'origine, et remis avec la correction que tu proposes) (peut être mal fait ?)

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
# GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'Mais pas d'amélioration .
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


J'ai fais "sudo update-grub", puis redémarré,

Mais pas d'amélioration !

La carte vidéo que j'ai mise est certainement trop vieille (1996), mais si j'édite le fichier grub au démarrage, cela passe
(les vidéos youtube accrochent un peux quand même)
---
Avant de venir demander de l'aide, via Google (ou /boot/grub/grub.cfg), il semble qu'il y a un autre fichier à modifier dans /etc/grub.d (par ex: 10_linux),
Je ne sais pas si ce fichier peut agir sur grub.cfg
---
Une option ultime est de modifier le fichier /boot/grub/grub.cfg manuellement, mais il faudrait alors empêcher les mises à jours de grub
-> C'est une mauvaise idée, ou une très mauvaise idée?

Merci pour l'aide :wink:

jjcojax

Laurent85
Level 13
Level 13
Posts: 4849
Joined: Tue May 26, 2015 10:11 am

Re: Comment commenter une ligne du grub.cfg

Postby Laurent85 » Sat Nov 04, 2017 1:48 pm

Modifier directement le fichier généré n'est pas une solution. Il faut trouver le bon paramètrage. Essaie avec ce fichier de configuration /etc/default/grub :

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'Mais pas d'amélioration .
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_GFXPAYLOAD_LINUX=text


En plus de GRUB_CMDLINE_LINUX_DEFAULT déjà modifié j'ai décommenté GRUB_TERMINAL=console et ajouté GRUB_GFXPAYLOAD_LINUX=text

Puis mets à jour grub :

Code: Select all

sudo update-grub


C'est quoi comme carte vidéo ?
Image

User avatar
jjcojax
Level 2
Level 2
Posts: 68
Joined: Fri Apr 03, 2015 6:01 am
Location: Belgium

Re: Comment commenter une ligne du grub.cfg

Postby jjcojax » Sat Nov 04, 2017 6:58 pm

Re,

La carte pour dépanner est une S3 trio 32/64 (2MB)

Sous Windows, j'ai ...

Image jusqu'à Image

Sous Linux, j'ai (moins)

Image
---
Ta dernière modification fonctionne. :D

L'ordre du menu grub a changé, et du coup, les accents passent mal.

Le plus important est que cela démarre tout seul !

Merci de ton aide,

J'arrête ici car l’utilisateur souhaite retrouver rapidement sa machine.(normal, ça fait 3 ans qu'elle ne démarre plus)

jjcojax


Return to “Français (French)”