[Résolu] Synaptic se repose ...

French Forum

Moderators: killer de bug, Laurent85

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

[Résolu] Synaptic se repose ...

Post by jpapot » Mon Dec 04, 2017 5:03 pm

Bonjour à nouveau à tous.

Mon gestionnaire de mise à jour fait des siennes.
Quand je sélectionne les mises à jour à effectuer, j'obtiens le message "impossible d'installer les mises à jour de sécurité".
La fenêtre qui me demande mon code admin ne s'ouvre pas.
synaptic.png
Quid ?
Merci pour votre aide.

Belle journée.
JP
Last edited by jpapot on Wed Dec 13, 2017 9:29 am, edited 1 time in total.
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Tue Dec 05, 2017 12:56 pm

Salut,

En ligne de commande tu as des erreurs ?

Code: Select all

apt update
mintupdate-tool list
sudo mintupdate-tool upgrade
Image

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Tue Dec 05, 2017 2:26 pm

Salut Laurent. :D
Merci pour ton aide.

1) Voici les erreurs que j'obtiens avec "apt update":

Code: Select all

  Err:10 http://dl.google.com/linux/earth/deb stable Release.gpg
   Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1397BC53640DB551
  
  Err:24 http://screenshots.getdeb.net sonya-getdeb Release                                                      
  404  Not Found [IP : 104.28.25.125 80]
  
  W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com/linux/earth/deb stable Release: Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 1397BC53640DB551
E: The repository 'http://archive.getdeb.net/ubuntu sonya-getdeb Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
2) avec mintupdate-tool list : la liste complète.

Code: Select all

2 package         appstream-glib                                0.5.13-1ubuntu5
2 package         bind9                                         1:9.10.3.dfsg.P4-8ubuntu1.9
2 package         binutils                                      2.26.1-1ubuntu1~16.04.5
2 security        bluez                                         5.37-0ubuntu5.1
2 package         btrfs-tools                                   4.4-1ubuntu1
2 security        ca-certificates                               20170717~16.04.1
2 package         cifs-utils                                    2:6.4-1ubuntu1.1
2 package         cracklib2                                     2.9.2-1ubuntu1
2 package         cryptsetup                                    2:1.6.6-5ubuntu2.1
2 package         cups                                          2.1.3-4ubuntu0.3
2 security        curl                                          7.47.0-1ubuntu2.5
2 package         dkms                                          2.2.0.3-2ubuntu11.5
2 package         dnsmasq                                       2.75-1ubuntu0.16.04.4
2 package         dpkg                                          1.18.4ubuntu1.3
2 security        eject                                         2.1.5+deb1+cvs20081104-13.1ubuntu0.16.04.1
2 package         exiv2                                         0.25-3.1~jensge1
2 security        ffmpeg                                        7:2.8.11-0ubuntu0.16.04.1
1 security        firefox                                       57.0.1+linuxmint1+sylvia
2 security        freerdp                                       1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2
2 package         fwupdate                                      0.5-2ubuntu5
2 security        game-music-emu                                0.6.0-3ubuntu0.16.04.1
2 package         gcc-5                                         5.4.0-6ubuntu1~16.04.5
2 security        gdb                                           7.11.1-0ubuntu1~16.5
2 package         geogebra5                                     5.0.408.0-582910
2 package         gexiv2                                        0.10.6-0~jensge0~xenial2
2 security        ghostscript                                   9.18~dfsg~0-0ubuntu2.7
2 package         giac                                          1.4.9-37
2 security        git                                           1:2.7.4-0ubuntu1.3
2 package         gnutls28                                      3.4.10-4ubuntu1.4
2 security        graphite2                                     1.3.10-0ubuntu0.16.04.1
2 package         gst-libav1.0                                  1.8.3-1ubuntu0.2
2 package         gst-plugins-bad1.0                            1.8.3-1ubuntu0.2
2 security        gst-plugins-base0.10                          0.10.36-2ubuntu0.1
2 security        gst-plugins-base1.0                           1.8.3-1ubuntu0.2
2 security        gst-plugins-good0.10                          0.10.31-3+nmu4ubuntu2.16.04.3
2 security        gst-plugins-good1.0                           1.8.3-1ubuntu0.4
2 package         gst-plugins-ugly1.0                           1.8.3-1ubuntu0.1
2 package         gstreamer1.0                                  1.8.3-1~ubuntu0.1
2 package         gtk+2.0                                       2.24.30-1ubuntu1.16.04.2
2 package         gtk+3.0                                       3.18.9-1ubuntu3.3
2 package         gvfs                                          1.28.2-1ubuntu1~16.04.2
2 security        heimdal                                       1.7~git20150920+dfsg-4ubuntu1.16.04.1
2 package         hw-detect                                     1.117ubuntu2.2
2 package         ido                                           13.10.0+16.04.20161028-0ubuntu1
2 package         im-config                                     0.29-1ubuntu12.4
2 security        imagemagick                                   8:6.8.9.9-7ubuntu5.9
2 package         indicator-sound-gtk2                          12.10.0.1-0ubuntu5.16.04.1
2 package         iproute2                                      1:4.3.0-1ubuntu3.16.04.2
2 package         isc-dhcp                                      4.3.3-5ubuntu12.7
2 security        jasper                                        1.900.1-debian1-2.4ubuntu1.1
2 security        jbig2dec                                      0.12+20150918-1ubuntu0.1
2 security        kauth                                         5.18.0-0ubuntu2
2 security        kcoreaddons                                   5.18.0-0ubuntu1.1
2 package         krb5                                          1.13.2+dfsg-5ubuntu2
2 package         less                                          481-2.1ubuntu0.2
2 package         libappindicator                               12.10.1+16.04.20170215-0ubuntu1
2 security        libevent                                      2.0.21-stable-2ubuntu0.16.04.1
2 security        libgc                                         1:7.4.2-7.3ubuntu0.1
2 security        libgd2                                        2.1.1-4ubuntu0.16.04.8
2 security        libidn                                        1.32-3ubuntu1.2
2 package         libinput                                      1.6.3-1ubuntu1~16.04.1
2 package         libjpeg8                                      8d-1+deb7u1
2 security        liblouis                                      2.6.4-2ubuntu0.1
2 security        libmspack                                     0.5-1ubuntu0.16.04.1
2 security        libmwaw                                       0.3.7-1ubuntu2.1
2 security        libnl3                                        3.2.27-1ubuntu0.16.04.1
2 security        libplist                                      1.12-3.1ubuntu0.16.04.1
2 security        libraw                                        0.17.1-1ubuntu0.1
2 security        libsndfile                                    1.0.25-10ubuntu0.16.04.1
2 security        libsoup2.4                                    2.52.2-1ubuntu0.2
2 security        libssh2                                       1.5.0-2ubuntu0.1
2 security        libtasn1-6                                    4.7-3ubuntu0.16.04.2
2 package         libva                                         1.7.0-1ubuntu0.1
2 security        libvncserver                                  0.9.10+dfsg-3ubuntu0.16.04.1
2 package         libwacom                                      0.22-1~ubuntu16.04.1
2 security        libxcursor                                    1:1.1.14-1ubuntu0.16.04.1
2 security        libxml-libxml-perl                            2.0123+dfsg-1ubuntu0.1
2 security        libxml2                                       2.9.3+dfsg1-1ubuntu0.4
2 security        libxpm                                        1:3.5.11-1ubuntu0.16.04.1
2 security        libxslt                                       1.1.28-2.1ubuntu0.1
2 security        lintian                                       2.5.43ubuntu0.1
2 package         logrotate                                     3.8.7-2ubuntu2.16.04.2
2 package         lshw                                          02.17-1.1ubuntu3.4
2 package         makedev                                       2.3.1-93ubuntu2~ubuntu16.04.1
2 security        miniupnpc                                     1.9.20140610-2ubuntu2.16.04.1
2 security        mir                                           0.26.3+16.04.20170605-0ubuntu1.1
2 package         multipath-tools                               0.5.0+git1.656f8865-5ubuntu2.5
2 package         nano                                          2.5.3-2ubuntu2
2 package         nautilus                                      1:3.18.4.is.3.14.3-0ubuntu6
2 security        nettle                                        3.2-1ubuntu0.16.04.1
2 package         network-manager                               1.2.6-0ubuntu0.16.04.1
2 package         network-manager-applet                        1.2.6-0ubuntu0.16.04.4
2 package         network-manager-openvpn                       1.1.93-1ubuntu1.1
2 security        nspr                                          2:4.13.1-0ubuntu0.16.04.1
2 security        nss                                           2:3.28.4-0ubuntu0.16.04.3
2 security        ntfs-3g                                       1:2015.3.14AR.1-1ubuntu0.1
2 package         ntp                                           1:4.2.8p4+dfsg-3ubuntu5.7
2 security        openjdk-8                                     8u151-b12-0ubuntu0.16.04.2
2 security        openldap                                      2.4.42+dfsg-2ubuntu3.2
2 package         openssh                                       1:7.2p2-4ubuntu2.2
2 security        openssl                                       1.0.2g-1ubuntu4.9
2 security        openvpn                                       2.3.10-1ubuntu2.1
2 package         os-prober                                     1.70ubuntu3.3
2 security        oxide-qt                                      1.21.5-0ubuntu0.16.04.1
2 package         packagekit                                    0.8.17-4ubuntu6~gcc5.4ubuntu1.2
2 package         pciutils                                      1:3.3.1-1.1ubuntu1.1
2 security        pcsc-lite                                     1.8.14-1ubuntu1.16.04.1
2 security        pillow                                        3.1.2-0ubuntu1.1
2 security        poppler                                       0.41.0-0ubuntu1.5
2 package         pulseaudio                                    1:8.0-0ubuntu3.4
2 security        pyjwt                                         1.3.0-1ubuntu0.1
2 security        python-crypto                                 2.6.1-6ubuntu0.16.04.2
2 package         qtbase-opensource-src                         5.5.1+dfsg-16ubuntu7.5
2 package         resolvconf                                    1.78ubuntu5
2 security        rtmpdump                                      2.4+20151223.gitfa8646d-1ubuntu0.1
2 security        ruby2.3                                       2.3.1-2~16.04.2
2 security        samba                                         2:4.3.11+dfsg-0ubuntu0.16.04.12
2 package         sane-backends                                 1.0.25+git20150528-1ubuntu2.16.04.1
2 package         sni-qt                                        0.2.7+16.04.20170217.1-0ubuntu1
2 package         sphinx                                        1.3.6-2ubuntu1.1
2 security        tcpdump                                       4.9.2-0ubuntu0.16.04.1
2 package         thermald                                      1.5-2ubuntu4
1 security        thunderbird                                   1:52.5.0+build1-0ubuntu0.16.04.1
2 security        tiff                                          4.0.6-1ubuntu0.2
2 package         tomcat8                                       8.0.32-1ubuntu1.4
2 security        tzdata                                        2017c-0ubuntu0.16.04
2 package         ubuntu-meta                                   1.361.1
2 package         unattended-upgrades                           0.90ubuntu0.8
2 package         util-linux                                    2.27.1-6ubuntu3.3
2 security        vim                                           2:7.4.1689-3ubuntu1.2
2 package         vino                                          3.8.1-0ubuntu9.2
2 package         virtualbox                                    5.0.40-dfsg-0ubuntu1.16.04.1
2 security        wayland                                       1.12.0-1~ubuntu16.04.2
2 security        webkit2gtk                                    2.18.3-0ubuntu0.16.04.1
2 security        wget                                          1.17.1-1ubuntu1.3
2 security        wpa                                           2.4-0ubuntu6.2
2 package         wxwidgets3.0                                  3.0.2+dfsg-1.3ubuntu0.1
2 security        x11proto-core                                 7.0.31-1~ubuntu16.04.2
2 package         xdg-utils                                     1.1.1-1ubuntu1.16.04.1
2 package         xfonts-utils                                  1:7.7+3ubuntu0.16.04.2
2 package         xfsprogs                                      4.3.0+nmu1ubuntu1.1
2 security        zziplib                                       0.13.62-3ubuntu0.16.04.1
3) Les erreurs avec sudo mintupdate-tool upgrade :
Après réception de 22 éléments (veux-tu le détail ?), j'obtiens finalement :

Code: Select all

18,9 Mo réceptionnés en 3min 24s (92,0 ko/s)                                                                              
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
(Lecture de la base de données... 459448 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libjpeg8_8d-1+deb7u1_i386.deb ...
Dépaquetage de libjpeg8:i386 (8d-1+deb7u1) sur (8c-2ubuntu8) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_i386.deb (--unpack) :
 tentative de remplacement de « /usr/lib/i386-linux-gnu/libjpeg.so.8 », qui appartient aussi au paquet libjpeg-turbo8:i386 1.4.2-0ubuntu3
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Voilà !
JP
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Tue Dec 05, 2017 2:48 pm

Il y a un conflit avec tes dépôts tiers. Quelle est la liste ?

Code: Select all

inxi -Sr
Et le retour de cette commande :

Code: Select all

aptitude search '? and (? and (~i, !~OUbuntu), !~Olinuxmint)'
Image

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Tue Dec 05, 2017 4:24 pm

inxi -Sr :

Code: Select all

System:    Host: jp-System-Product-Name Kernel: 4.4.0-21-generic i686 (32 bit) Desktop: Xfce 4.12.3
           Distro: Linux Mint 18.2 Sonya
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://www-fourier.ujf-grenoble.fr/~parisse/debian/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/damien-moore-codeblocks-stable-xenial.list
           deb http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/freecad-maintainers-freecad-stable-xenial.list
           deb http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/geogebra.list
           deb http://www.geogebra.net/linux/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-earth.list
           deb http://dl.google.com/linux/earth/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/hugin-hugin-builds-xenial.list
           deb http://ppa.launchpad.net/hugin/hugin-builds/ubuntu xenial main
           deb-src http://ppa.launchpad.net/hugin/hugin-builds/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/inkscape_dev-stable-xenial.list
           deb http://ppa.launchpad.net/inkscape.dev/stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/inkscape.dev/stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/kdenlive-kdenlive-stable-xenial.list
           deb http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/kritalime-ppa-xenial.list
           deb http://ppa.launchpad.net/kritalime/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/kritalime/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/libreoffice-libreoffice-5-3-xenial.list
           deb http://ppa.launchpad.net/libreoffice/libreoffice-5-3/ubuntu xenial main
           deb-src http://ppa.launchpad.net/libreoffice/libreoffice-5-3/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/mscore-ubuntu-mscore-stable-xenial.list
           deb http://ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/nathan-renniewaldock-flux-xenial.list
           deb http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu xenial main
           deb-src http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/nilarimogard-webupd8-xenial.list
           deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial main
           deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/octave-stable-xenial.list
           deb http://ppa.launchpad.net/octave/stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/octave/stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mint-mirror.gwendallebihan.net/packages sonya main upstream import backport
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/official-source-repositories.list
           deb-src http://mint-mirror.gwendallebihan.net/packages sonya main upstream import backport
           deb-src http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb-src http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb-src http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb-src http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb-src http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-gimp-xenial.list
           deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial main
           deb-src http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-lightzone-xenial.list
           deb http://ppa.launchpad.net/otto-kesselgulasch/lightzone/ubuntu xenial main
           deb-src http://ppa.launchpad.net/otto-kesselgulasch/lightzone/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/playdeb.list
           deb http://archive.getdeb.net/ubuntu sonya-getdeb games
           Active apt sources in file: /etc/apt/sources.list.d/rebuntu16-avidemux_unofficial-xenial.list
           deb http://ppa.launchpad.net/rebuntu16/avidemux+unofficial/ubuntu xenial main
           deb-src http://ppa.launchpad.net/rebuntu16/avidemux+unofficial/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/stebbins-handbrake-releases-xenial.list
           deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
           deb-src http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/texworks-ppa-xenial.list
           deb http://ppa.launchpad.net/texworks/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/texworks/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/transmissionbt-ppa-xenial.list
           deb http://ppa.launchpad.net/transmissionbt/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/transmissionbt/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu-wine-ppa-xenial.list
           deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/yg-jensge-shotwell-xenial.list
           deb http://ppa.launchpad.net/yg-jensge/shotwell/ubuntu xenial main
           deb-src http://ppa.launchpad.net/yg-jensge/shotwell/ubuntu xenial main
aptitude search '? and (? and (~i, !~OUbuntu), !~Olinuxmint)' :

Code: Select all

i   adobe-flashplugin                                     - Adobe Flash Player plugin                                      
i   adobeair                                              - Adobe AIR 2                                                    
i A avidemux2.6-common                                    - Free video editor - Common files                               
i   avidemux2.6-gtk                                       - Free video editor - GTK version                                
i   avidemux2.6-qt4                                       - Free video editor - QT version                                 
i   edu.media.mit.scratch2editor                          - <>                                                             
i   fluxgui                                               - f.lux indicator applet is an indicator applet to control xflux,
i   geogebra5                                             - Free mathematics software for learning and teaching            
i   giac                                                  - computer algebra system by Bernard Parisse                     
i   google-earth-stable                                   - Explore, search and discover the planet                        
i   handbrake-gtk                                         - versatile DVD ripper and video transcoder - GTK GUI            
i A libavidemux2.6-6                                      - Free video editor - shared libraries                           
i A libavidemux2.6-ffmpeg                                 - Free video editor - shared libraries                           
i A libavidemux2.6-gtk-6                                  - Free video editor - shared libraries                           
i A libavidemux2.6-qt4-6                                  - Free video editor - shared libraries                           
i A libvidstab1.1                                         - Video stabilization library (runtime)                          
i A libwxbase2.8-0                                        - wxBase library (runtime) - non-GUI support classes of wxWidgets
i A libwxgtk2.8-0                                         - wxWidgets Cross-platform C++ GUI toolkit (GTK+ runtime)        
i   lightzone                                             - Open-source professional-level digital darkroom software       
i   master-pdf-editor                                     - Master PDF Editor is the complete solution for viewing, printin
i   playdeb                                               - PlayDeb repository setup                                       
i   python-giacpy                                         - A Cython frontend to the c++ library giac. (Computer Algebra Sy
i   python-giacpy-qt                                      - Qt extention for graphic outputs                               
i   qcas                                                  - A QT frontend to the c++ library giac. (Computer Algebra System
i   sdl                                                   - Simple DirectMedia Layer                                       
i   xmind                                                 - Professional & Powerful Mind Mapping Software 
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Tue Dec 05, 2017 7:12 pm

Le dépôt Giac/xcas conçu pour Debian est en conflit avec les dépôts officiels de LM. Debian c'est Debian, c'est pas LM/Ubuntu, ça "peut" marcher un temps mais un jour tu risques de mettre ton système en vrac, là c'est une première alerte.

Fais une sauvegarde avant de forcer l'installation du paquet en conflit, méthode ceinture et bretelles. Ça devrait passer sans casse vu que c'est une librairie jpeg mais je peux me tromper, c'est du bricolage, pas une solution...

Code: Select all

sudo dpkg --force-overwrite --install /var/cache/apt/archives/libjpeg8_8d-1+deb7u1_i386.deb
Installe ensuite les mises à jour Firefox etc... via le gestionnaire de mises à jour.
Image

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Wed Dec 06, 2017 3:08 am

Merci pour les infos. Donc Debian=risqué. Et installer des paquets .deb hors dépot ? Même chose ?
Fais une sauvegarde ...
Une question naïve : comment faire la sauvegarde facilement ?
Sur un DD externe j'imagine. Je ne suis pas familier avec le vocabulaire et la méthode pour le faire. :oops:
C'est via l'application linux embarquée (mintbackup) ? Je ne voudrai pas faire d'ânerie :!:

Merci. :wink:
JP
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Wed Dec 06, 2017 7:47 am

C'est la compatibilité qui est en jeu. Un système c'est un ensemble de briques logicielles, et pour que l'ensemble tienne debout il y a des règles fondamentales d'archi à respecter. Le dépôt Giac/xcas ce sont des briques logicielles à la base pour système Debian, pas pour LM.

Les mainteneurs du dépôt Giac/xcas ont un jour fait le test d'utiliser leur dépôt sur Ubuntu et ça marchait, donc il ont indiqué d'utiliser leur dépôt pour Debian/Ubuntu. Etant donné que LM/Ubuntu utilisent la même technologie de gestion des paquets, ce sont aussi des paquet deb, des briques logicielles Debian "peuvent" intégrer LM, le système va l'accepter si les dépendances sont satisfaites et qu'il n'y a pas de conflit.

Sauf que depuis de l'eau a coulé sous les ponts, il y a de nouvelles briques, et si le système LM est toujours cohérent, par contre le dépôt Giac n'est plus compatible avec LM.

C'est au mainteneurs de Giac d'assurer la compatibilité avec Debian et/ou LM/Ubuntu, ce qu'ils ne font pas.

Pour la sauvegarde il y a plusieurs méthodes, disons que la plus solide est le clonage du disque dur, clonezilla live est très bien pour ça par contre pas convivial (une image iso à télécharger pour créer une clé usb). Sinon en sauvegarde du système il y a timeshift qui a été choisi par LM pour la version 18.3 qui semble très bien mais je ne l'ai jamais utilisé. Pour tes données personnelles là ton problème avec giac n'a pas de conséquences sur les données personnelles, tu peux faire une sauvegarde avec mintbackup comme sauvegarde de routine (de ton dossier perso), tu n'auras pas besoin de la restaurer si le système coince plus tard avec giac.
Image

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Thu Dec 07, 2017 9:07 am

OK merci Laurent.

Donc si j'ai bien compris, le dépôt Giac n'est plus compatible avec LM. Je me propose de garder Giac, mais de ne plus faire de mises à jour de ce paquet (et de l’ôter de mes dépôts supplémentaires). Bien sûr, pendant ce temps LM évolue. Si je ne touche plus à la librairie Giac installée, je risque quand même d'avoir des soucis ?

J'ai tenté d'installer Timeshift via ppa, mais ça ne fonctionne pas. J'ai l’icône, mais le lancement ne donne rien :
timeshift.png
timeshift.png (10.27 KiB) Viewed 629 times
.

Par la console, j'obtiens :

Code: Select all

jp@jp-System-Product-Name ~ $ timeshift-launcher
/usr/bin/timeshift-launcher: ligne 15 : [: = : opérateur unaire attendu
==== AUTHENTICATING FOR org.freedesktop.policykit.exec ===
Authentication is needed to run `/usr/bin/env' as the super user
Authenticating as: JP,,, (jp)
Password: 
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.
Ce n'est pas mon jour ...

À +
JP
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Thu Dec 07, 2017 9:57 am

jpapot wrote: Donc si j'ai bien compris, le dépôt Giac n'est plus compatible avec LM. Je me propose de garder Giac, mais de ne plus faire de mises à jour de ce paquet (et de l’ôter de mes dépôts supplémentaires). Bien sûr, pendant ce temps LM évolue. Si je ne touche plus à la librairie Giac installée, je risque quand même d'avoir des soucis ?
Bonne idée, désactive le dépôt giac et mets à jour la liste des paquets, ça devrait suffire.
J'ai tenté d'installer Timeshift via ppa, mais ça ne fonctionne pas. J'ai l’icône, mais le lancement ne donne rien :
timeshift.png.
Timeshift est dans les dépôts officiels, supprime le ppa puis mets à jour la liste des paquets. Supprime le paquet que tu as installé :

Code: Select all

apt puge timeshift
Ensuite via le gestionnaire de logiciels installe timeshift. Et lance timeshift via le menu général du bureau. Sauf que...

En désactivant le dépôt giac la sauvegarde préalable n'est pas nécessaire en dehors du fait que des sauvegardes régulières sont recommandées pour éviter les mauvaises surprises.

Donc après avoir désactiver le dépôt giac et mis à jour la liste des paquets, le gestionnaire de mises à jour devrait à nouveau fonctionner.
Ce n'est pas mon jour ...

C'est pas grave ça, c'est aussi comme ça qu'on apprend :wink:
Image

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Thu Dec 07, 2017 11:25 am

J'ai oté le dépot Giac, supprimé le PPA de timeshift, utilisé apt purge timeshift, puis installé timeshift via le dépot officiel.
Puis sudo apt update, sudo apt-get update (j'imagine qu'il n'était pas nécessaire de faire les deux).

Résultat : lancer timeshift via l'icone ne donne toujours rien :shock:
Le gestionnaire de paquets ne fonctionne toujours pas :shock:

Que se passe-t-il ?
Bref, à suivre ... :(
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Thu Dec 07, 2017 11:33 am

jpapot wrote:J'ai oté le dépot Giac, supprimé le PPA de timeshift, utilisé apt purge timeshift, puis installé timeshift via le dépot officiel.
Puis sudo apt update, sudo apt-get update (j'imagine qu'il n'était pas nécessaire de faire les deux).
As-tu mis à jour la liste des paquets avant comme indiqué :
Timeshift est dans les dépôts officiels, supprime le ppa puis mets à jour la liste des paquets
Redonne les retours commande :

Code: Select all

inxi -Sr
mintupdate-tool list
apt policy libjpeg8
Image

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Thu Dec 07, 2017 12:45 pm

1)

Code: Select all

System:    Host: jp-System-Product-Name Kernel: 4.4.0-21-generic i686 (32 bit) Desktop: Xfce 4.12.3
           Distro: Linux Mint 18.2 Sonya
Repos:     Active apt sources in file: /etc/apt/sources.list.d/damien-moore-codeblocks-stable-xenial.list
           deb http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/freecad-maintainers-freecad-stable-xenial.list
           deb http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/freecad-maintainers/freecad-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/geogebra.list
           deb http://www.geogebra.net/linux/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-earth.list
           deb http://dl.google.com/linux/earth/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/hugin-hugin-builds-xenial.list
           deb http://ppa.launchpad.net/hugin/hugin-builds/ubuntu xenial main
           deb-src http://ppa.launchpad.net/hugin/hugin-builds/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/inkscape_dev-stable-xenial.list
           deb http://ppa.launchpad.net/inkscape.dev/stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/inkscape.dev/stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/kdenlive-kdenlive-stable-xenial.list
           deb http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/kdenlive/kdenlive-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/kritalime-ppa-xenial.list
           deb http://ppa.launchpad.net/kritalime/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/kritalime/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/libreoffice-libreoffice-5-3-xenial.list
           deb http://ppa.launchpad.net/libreoffice/libreoffice-5-3/ubuntu xenial main
           deb-src http://ppa.launchpad.net/libreoffice/libreoffice-5-3/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/mscore-ubuntu-mscore-stable-xenial.list
           deb http://ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/mscore-ubuntu/mscore-stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/nathan-renniewaldock-flux-xenial.list
           deb http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu xenial main
           deb-src http://ppa.launchpad.net/nathan-renniewaldock/flux/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/nilarimogard-webupd8-xenial.list
           deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial main
           deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/octave-stable-xenial.list
           deb http://ppa.launchpad.net/octave/stable/ubuntu xenial main
           deb-src http://ppa.launchpad.net/octave/stable/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mint-mirror.gwendallebihan.net/packages sonya main upstream import backport
           deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/official-source-repositories.list
           deb-src http://mint-mirror.gwendallebihan.net/packages sonya main upstream import backport
           deb-src http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
           deb-src http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
           deb-src http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
           deb-src http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb-src http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-gimp-xenial.list
           deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial main
           deb-src http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/otto-kesselgulasch-lightzone-xenial.list
           deb http://ppa.launchpad.net/otto-kesselgulasch/lightzone/ubuntu xenial main
           deb-src http://ppa.launchpad.net/otto-kesselgulasch/lightzone/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/playdeb.list
           deb http://archive.getdeb.net/ubuntu sonya-getdeb games
           Active apt sources in file: /etc/apt/sources.list.d/rebuntu16-avidemux_unofficial-xenial.list
           deb http://ppa.launchpad.net/rebuntu16/avidemux+unofficial/ubuntu xenial main
           deb-src http://ppa.launchpad.net/rebuntu16/avidemux+unofficial/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/stebbins-handbrake-releases-xenial.list
           deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
           deb-src http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/texworks-ppa-xenial.list
           deb http://ppa.launchpad.net/texworks/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/texworks/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/transmissionbt-ppa-xenial.list
           deb http://ppa.launchpad.net/transmissionbt/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/transmissionbt/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/ubuntu-wine-ppa-xenial.list
           deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
           deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/yg-jensge-shotwell-xenial.list
           deb http://ppa.launchpad.net/yg-jensge/shotwell/ubuntu xenial main
           deb-src http://ppa.launchpad.net/yg-jensge/shotwell/ubuntu xenial main
2)

Code: Select all

2 package         appstream-glib                                0.5.13-1ubuntu5
2 package         bind9                                         1:9.10.3.dfsg.P4-8ubuntu1.9
2 package         binutils                                      2.26.1-1ubuntu1~16.04.5
2 security        bluez                                         5.37-0ubuntu5.1
2 package         btrfs-tools                                   4.4-1ubuntu1
2 security        ca-certificates                               20170717~16.04.1
2 package         cifs-utils                                    2:6.4-1ubuntu1.1
2 package         cracklib2                                     2.9.2-1ubuntu1
2 package         cryptsetup                                    2:1.6.6-5ubuntu2.1
2 package         cups                                          2.1.3-4ubuntu0.3
2 security        curl                                          7.47.0-1ubuntu2.5
2 package         dkms                                          2.2.0.3-2ubuntu11.5
2 package         dnsmasq                                       2.75-1ubuntu0.16.04.4
2 package         dpkg                                          1.18.4ubuntu1.3
2 security        eject                                         2.1.5+deb1+cvs20081104-13.1ubuntu0.16.04.1
2 package         exiv2                                         0.25-3.1~jensge1
2 security        ffmpeg                                        7:2.8.11-0ubuntu0.16.04.1
1 security        firefox                                       57.0.1+linuxmint1+sylvia
2 security        freerdp                                       1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2
2 package         fwupdate                                      0.5-2ubuntu5
2 security        game-music-emu                                0.6.0-3ubuntu0.16.04.1
2 package         gcc-5                                         5.4.0-6ubuntu1~16.04.5
2 security        gdb                                           7.11.1-0ubuntu1~16.5
2 package         geogebra5                                     5.0.408.0-582910
2 package         gexiv2                                        0.10.6-0~jensge0~xenial2
2 security        ghostscript                                   9.18~dfsg~0-0ubuntu2.7
2 security        git                                           1:2.7.4-0ubuntu1.3
2 package         gnutls28                                      3.4.10-4ubuntu1.4
2 security        graphite2                                     1.3.10-0ubuntu0.16.04.1
2 package         gst-libav1.0                                  1.8.3-1ubuntu0.2
2 package         gst-plugins-bad1.0                            1.8.3-1ubuntu0.2
2 security        gst-plugins-base0.10                          0.10.36-2ubuntu0.1
2 security        gst-plugins-base1.0                           1.8.3-1ubuntu0.2
2 security        gst-plugins-good0.10                          0.10.31-3+nmu4ubuntu2.16.04.3
2 security        gst-plugins-good1.0                           1.8.3-1ubuntu0.4
2 package         gst-plugins-ugly1.0                           1.8.3-1ubuntu0.1
2 package         gstreamer1.0                                  1.8.3-1~ubuntu0.1
2 package         gtk+2.0                                       2.24.30-1ubuntu1.16.04.2
2 package         gtk+3.0                                       3.18.9-1ubuntu3.3
2 package         gvfs                                          1.28.2-1ubuntu1~16.04.2
2 security        heimdal                                       1.7~git20150920+dfsg-4ubuntu1.16.04.1
2 package         hw-detect                                     1.117ubuntu2.2
2 package         ido                                           13.10.0+16.04.20161028-0ubuntu1
2 package         im-config                                     0.29-1ubuntu12.4
2 security        imagemagick                                   8:6.8.9.9-7ubuntu5.9
2 package         indicator-sound-gtk2                          12.10.0.1-0ubuntu5.16.04.1
2 package         iproute2                                      1:4.3.0-1ubuntu3.16.04.2
2 package         isc-dhcp                                      4.3.3-5ubuntu12.7
2 security        jasper                                        1.900.1-debian1-2.4ubuntu1.1
2 security        jbig2dec                                      0.12+20150918-1ubuntu0.1
2 security        kauth                                         5.18.0-0ubuntu2
2 security        kcoreaddons                                   5.18.0-0ubuntu1.1
2 package         krb5                                          1.13.2+dfsg-5ubuntu2
2 package         less                                          481-2.1ubuntu0.2
2 package         libappindicator                               12.10.1+16.04.20170215-0ubuntu1
2 security        libevent                                      2.0.21-stable-2ubuntu0.16.04.1
2 security        libgc                                         1:7.4.2-7.3ubuntu0.1
2 security        libgd2                                        2.1.1-4ubuntu0.16.04.8
2 security        libidn                                        1.32-3ubuntu1.2
2 package         libinput                                      1.6.3-1ubuntu1~16.04.1
2 security        liblouis                                      2.6.4-2ubuntu0.1
2 security        libmspack                                     0.5-1ubuntu0.16.04.1
2 security        libmwaw                                       0.3.7-1ubuntu2.1
2 security        libnl3                                        3.2.27-1ubuntu0.16.04.1
2 security        libplist                                      1.12-3.1ubuntu0.16.04.1
2 security        libraw                                        0.17.1-1ubuntu0.1
2 security        libsndfile                                    1.0.25-10ubuntu0.16.04.1
2 security        libsoup2.4                                    2.52.2-1ubuntu0.2
2 security        libssh2                                       1.5.0-2ubuntu0.1
2 security        libtasn1-6                                    4.7-3ubuntu0.16.04.2
2 package         libva                                         1.7.0-1ubuntu0.1
2 security        libvncserver                                  0.9.10+dfsg-3ubuntu0.16.04.1
2 package         libwacom                                      0.22-1~ubuntu16.04.1
2 security        libxcursor                                    1:1.1.14-1ubuntu0.16.04.1
2 security        libxml-libxml-perl                            2.0123+dfsg-1ubuntu0.1
2 security        libxml2                                       2.9.3+dfsg1-1ubuntu0.4
2 security        libxpm                                        1:3.5.11-1ubuntu0.16.04.1
2 security        libxslt                                       1.1.28-2.1ubuntu0.1
2 security        lintian                                       2.5.43ubuntu0.1
2 package         logrotate                                     3.8.7-2ubuntu2.16.04.2
2 package         lshw                                          02.17-1.1ubuntu3.4
2 package         makedev                                       2.3.1-93ubuntu2~ubuntu16.04.1
2 security        miniupnpc                                     1.9.20140610-2ubuntu2.16.04.1
2 security        mir                                           0.26.3+16.04.20170605-0ubuntu1.1
2 package         multipath-tools                               0.5.0+git1.656f8865-5ubuntu2.5
2 package         nano                                          2.5.3-2ubuntu2
2 package         nautilus                                      1:3.18.4.is.3.14.3-0ubuntu6
2 security        nettle                                        3.2-1ubuntu0.16.04.1
2 package         network-manager                               1.2.6-0ubuntu0.16.04.1
2 package         network-manager-applet                        1.2.6-0ubuntu0.16.04.4
2 package         network-manager-openvpn                       1.1.93-1ubuntu1.1
2 security        nspr                                          2:4.13.1-0ubuntu0.16.04.1
2 security        nss                                           2:3.28.4-0ubuntu0.16.04.3
2 security        ntfs-3g                                       1:2015.3.14AR.1-1ubuntu0.1
2 package         ntp                                           1:4.2.8p4+dfsg-3ubuntu5.7
2 security        openjdk-8                                     8u151-b12-0ubuntu0.16.04.2
2 security        openldap                                      2.4.42+dfsg-2ubuntu3.2
2 package         openssh                                       1:7.2p2-4ubuntu2.2
2 security        openssl                                       1.0.2g-1ubuntu4.9
2 security        openvpn                                       2.3.10-1ubuntu2.1
2 package         os-prober                                     1.70ubuntu3.3
2 security        oxide-qt                                      1.21.5-0ubuntu0.16.04.1
2 package         packagekit                                    0.8.17-4ubuntu6~gcc5.4ubuntu1.2
2 package         pciutils                                      1:3.3.1-1.1ubuntu1.1
2 security        pcsc-lite                                     1.8.14-1ubuntu1.16.04.1
2 security        pillow                                        3.1.2-0ubuntu1.1
2 security        poppler                                       0.41.0-0ubuntu1.5
2 package         pulseaudio                                    1:8.0-0ubuntu3.7
2 security        pyjwt                                         1.3.0-1ubuntu0.1
2 security        python-crypto                                 2.6.1-6ubuntu0.16.04.2
2 package         qtbase-opensource-src                         5.5.1+dfsg-16ubuntu7.5
2 package         resolvconf                                    1.78ubuntu5
2 security        rsync                                         3.1.1-3ubuntu1.1
2 security        rtmpdump                                      2.4+20151223.gitfa8646d-1ubuntu0.1
2 security        ruby2.3                                       2.3.1-2~16.04.2
2 security        samba                                         2:4.3.11+dfsg-0ubuntu0.16.04.12
2 package         sane-backends                                 1.0.25+git20150528-1ubuntu2.16.04.1
2 package         sni-qt                                        0.2.7+16.04.20170217.1-0ubuntu1
2 package         sphinx                                        1.3.6-2ubuntu1.1
2 security        tcpdump                                       4.9.2-0ubuntu0.16.04.1
2 package         thermald                                      1.5-2ubuntu4
1 security        thunderbird                                   1:52.5.0+build1-0ubuntu0.16.04.1
2 security        tiff                                          4.0.6-1ubuntu0.2
2 package         tomcat8                                       8.0.32-1ubuntu1.4
2 security        tzdata                                        2017c-0ubuntu0.16.04
2 package         ubuntu-meta                                   1.361.1
2 package         unattended-upgrades                           0.90ubuntu0.8
2 package         util-linux                                    2.27.1-6ubuntu3.3
2 security        vim                                           2:7.4.1689-3ubuntu1.2
2 package         vino                                          3.8.1-0ubuntu9.2
2 package         virtualbox                                    5.0.40-dfsg-0ubuntu1.16.04.1
2 security        wayland                                       1.12.0-1~ubuntu16.04.2
2 security        webkit2gtk                                    2.18.3-0ubuntu0.16.04.1
2 security        wget                                          1.17.1-1ubuntu1.3
2 security        wpa                                           2.4-0ubuntu6.2
2 package         wxwidgets3.0                                  3.0.2+dfsg-1.3ubuntu0.1
2 security        x11proto-core                                 7.0.31-1~ubuntu16.04.2
2 package         xdg-utils                                     1.1.1-1ubuntu1.16.04.1
2 package         xfonts-utils                                  1:7.7+3ubuntu0.16.04.2
2 package         xfsprogs                                      4.3.0+nmu1ubuntu1.1
2 security        zziplib                                       0.13.62-3ubuntu0.16.04.1
3)

Code: Select all

libjpeg8:
  Installé : 8c-2ubuntu8
  Candidat : 8c-2ubuntu8
 Table de version :
 *** 8c-2ubuntu8 500
        500 http://archive.ubuntu.com/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
Désolé, peut-être n'ai-je pas fait les choses dans le bon ordre ! :oops:
Merci.
JP
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Thu Dec 07, 2017 2:28 pm

Si c'est bon. Il y a autre chose alors, ça bloque la mise à jour en ligne de commande ?

Code: Select all

sudo mintupdate-tool upgrade
Image

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Thu Dec 07, 2017 4:07 pm

J'ai fait sudo mintupdate-tool upgrade.

Puis j'ai vu défiler pendant 10 minutes des dépaquetages et autres à n'en plus finir !
(J'ai repéré un Warning no support for locale fr - utf8 (un truc comme ça) à deux reprises.)

Quand j'ouvre le gestionnaire de mise à jour, il me propose toujours toutes les mises à jour habituelles, alors que j'ai vu défiler Firefox, Thunderbird, Geogebra, et une tonne de librairies ... ??? (Et bien sûr il ne fonctionne toujours pas.)

Par contre, Les mises à jour ont bien été faites (mon Geogebra5 est en version 5.0.408, Firefox en 57.0.1), et pourtant le gestionnaire continue à me dire :
geogebra-maj.png
faux puisque je n'ai plus l'ancienne version ...

La mise à jour en ligne de commande fonctionne.
Mystère ! :shock:
JP
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Thu Dec 07, 2017 4:22 pm

Après actualisation du gestionnaire , il ne reste plus que :
Gestionnaire.png
Rien ne dit qu'il fonctionne pour autant (je ne veux pas essayer avec ces paquets).

En attendant, le gestionnaire de paquet Synaptic ne s'ouvre toujours pas, Timeshift non plus.
JP
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Thu Dec 07, 2017 4:44 pm

D'après la dernière image écran du gestionnaire de mises à jour tout semble indiquer qu'il fonctionne puisque les mises à jour affichées sont de niveau 3 et 4, et elles ne sont pas sélectionnées parce qu'à mon avis ça correspond au choix configuré de politique de mise à jour.
En attendant, le gestionnaire de paquet Synaptic ne s'ouvre toujours pas, Timeshift non plus.
il se passe quoi quand tu le démarres en ligne de commande :

Code: Select all

synaptic-pkexec
Et pour timeshift :

Code: Select all

timeshift-launcher
Image

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Thu Dec 07, 2017 4:54 pm

jpapot wrote: La mise à jour en ligne de commande fonctionne.
Il y a peut-être un autre problème lié aux symptômes observés avec synaptic et timeshift mais à la base les gestionnaire de mises à jour et la commande mintupdate-tool utilisent le même algorithme pour exécuter la mise à jour, il n'y a pas de différence dans le traitement des mises à jour entre l'un et l'autre.
Image

User avatar
jpapot
Level 3
Level 3
Posts: 157
Joined: Tue Jun 09, 2015 12:17 am
Location: Angers, France

Re: Synaptic se repose ...

Post by jpapot » Thu Dec 07, 2017 5:25 pm

1) avec synaptic - pkexec, j'obtiens :

Code: Select all

==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: JP,,, (jp)
Password: 
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.
2) avec timeshift - launcher : (même chose)

Code: Select all

/usr/bin/timeshift-launcher: ligne 15 : [: = : opérateur unaire attendu
==== AUTHENTICATING FOR org.freedesktop.policykit.exec ===
Authentication is needed to run `/usr/bin/env' as the super user
Authenticating as: JP,,, (jp)
Password: 
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.
Les poissons volaient dans l'air. Les oiseaux nageaient dans l'eau.
Partout, des flots de lumière déferlaient sur les côteaux [...]

Laurent85
Level 15
Level 15
Posts: 5539
Joined: Tue May 26, 2015 10:11 am

Re: Synaptic se repose ...

Post by Laurent85 » Fri Dec 08, 2017 6:18 am

D'après ce que j'ai trouvé sur internet c'est l'authentification du service policykit qui ne fonctionne pas. Le système est cassé là, pourquoi je ne sais pas trop, as-tu redémarré l'ordi depuis les dernières mises à jour ? pas une mise en veille mais un redémarrage.

Que donne les retours commande :

Code: Select all

systemctl status polkitd
ps auxwf | grep pol
Image

Post Reply

Return to “Français (French)”