Problème de connexion à un réseau Windows

French Forum

Moderators: killer de bug, Laurent85

Post Reply
User avatar
PhilippeH
Level 1
Level 1
Posts: 15
Joined: Thu Jul 20, 2017 3:12 am
Location: Toulon (France)
Contact:

Problème de connexion à un réseau Windows

Post by PhilippeH » Sun Feb 18, 2018 12:51 pm

Bonjour

J'ai un laptop qui tournait sous Linux Mint 18.2 et se connectait sans soucis à mon réseau Windows, constitué d'un seul poste sous Windows 10. À l'occasion de l'achat d'un SSD pour remplacer mon disque dur interne, j'ai fait une installation neuve avec Linux Mint 18.3, réinstallé mes quelques applications supplémentaires, et réimporté mes fichiers personnels et mes réglages.

Tout fonctionne très bien comme d'habitude avec Mint, sauf l'accès au réseau Windows : je vois bien le Réseau Windows dans l'explorateur, mais si je fais un double clic sur l'icône j'obtiens un message d'erreur : "Impossible de monter l'emplacement. L'obtention de la liste des partages du serveur a échoué : aucun fichier ou dossier de ce type"

Le pare feu est désactivé, je n'ai d'ailleurs pas modifié cette configuration depuis l'installation. J'ai aussi, suite à mes lectures sur ce forum et ailleurs, vérifié ces quelques points dans le poste sous Windows 10 :

- le partage de fichiers et la découverte réseau sont activés
- le démarrage rapide et l'hibernation sont désactivés, l'ordinateur a bien été arrêté après ce réglage, et redémarré

Sans trop savoir si c'était utile, j'ai installé Samba sur le laptop, car il ne semblait pas être installé par défaut dans Mint 18.3 (?), mais je n'ai rien configuré.

Quelqu'un saurait-il me dire ce que j'ai négligé ? Merci d'avance pour votre aide :)

User avatar
PhilippeH
Level 1
Level 1
Posts: 15
Joined: Thu Jul 20, 2017 3:12 am
Location: Toulon (France)
Contact:

Re: Problème de connexion à un réseau Windows

Post by PhilippeH » Mon Feb 19, 2018 8:42 am

Je me réponds tout seul, en partie tout au moins : après avoir désactivé le pare-feu (ufw disable) et redémarré, j'ai à nouveau accès aux partages Windows.

Je ne sais pas toutefois si c'est une bonne solution de désactiver le firewall ? L'ordinateur est branché avec un câble Ethernet derrière une box, et n'est jamais connecté en wifi à un réseau public, je crois donc ne pas risquer grand chose, mais je suis loin d'être assez qualifié pour en juger correctement...

Et sinon, donc, y a-t-il moyen de faire fonctionner l'accès aux postes Windows d'un réseau domestique sans désactiver le pare-feu ?

Laurent85
Level 15
Level 15
Posts: 5625
Joined: Tue May 26, 2015 10:11 am

Re: Problème de connexion à un réseau Windows

Post by Laurent85 » Mon Feb 19, 2018 11:41 am

Bonjour,
Tu peux ajouter une règle au pare-feu pour autoriser Samba :

gufw > bouton Règles > onglet Préconfigurée > icône "+"

Politique : Autoriser
Sens : Entrée
Catérogie : Réseau
Sous-catégorie : Services
Application : Samba

Puis clique sur Ajouter
Image

User avatar
PhilippeH
Level 1
Level 1
Posts: 15
Joined: Thu Jul 20, 2017 3:12 am
Location: Toulon (France)
Contact:

Re: Problème de connexion à un réseau Windows

Post by PhilippeH » Mon Feb 19, 2018 2:04 pm

Merci Laurent, j'avais auparavant déjà vu ces options dans la configuration du pare-feu, et essayé cette même manipulation. Désolé, j'aurais du le préciser.

Je viens d'essayer à nouveau et l'accès ne fonctionne plus dès que j'active le pare-feu. Désactivé à nouveau, ça remarche.

Cela n'a pas une importance cruciale pour moi car j'accède peu souvent à ce poste. Je peux donc désactiver le pare-feu le temps d'aller chercher des fichiers ou d'en copier sur le partage. Mais j'aimerais surtout comprendre ce qui cloche chez moi ;)

ouck
Level 1
Level 1
Posts: 21
Joined: Tue Feb 20, 2018 7:26 am

Re: Problème de connexion à un réseau Windows

Post by ouck » Fri Feb 23, 2018 11:17 am

Essaie de faire un ping avec le nom de ta machine Windows puis avec l'IP, si le nom ne fonctionne pas tu as le même problème de résolution de nom que moi sur un autre poste: viewtopic.php?f=63&t=264316

User avatar
PhilippeH
Level 1
Level 1
Posts: 15
Joined: Thu Jul 20, 2017 3:12 am
Location: Toulon (France)
Contact:

Re: Problème de connexion à un réseau Windows

Post by PhilippeH » Wed Feb 28, 2018 2:02 pm

Merci ouck pour la suggestion. Je l'aurais bien suivie pour enquêter plus avant, mais j'ai opté pour une solution plus radicale : j'ai sauvegardé les données du poste sous Windows, je l'ai ensuite migré vers une installation neuve sous Mint.

Depuis la communication entre les deux postes est bien facilitée ;)

Post Reply

Return to “Français (French)”