Utilisation anormale du processeur !

French Forum

Moderators: Laurent85, killer de bug

Post Reply
galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Utilisation anormale du processeur !

Post by galacticus » Wed Apr 04, 2018 3:55 pm

Salut tout le monde !

Comment allez-vous ?

Depuis quelques temps, mon PC devient lent, alors, j'ai voulu jeter un oeil à l'utilisation des ressources.
J'ai vu que mes 4 processeurs étaient utilisés à 30-40% tout le temps, et ce, dès le système totalement chargé.
J'ai cru que c'était peut-être dû à la mise à jour du microcode d'Intel d'il y a quelques jours (un truc pas adapté ou autre), donc, je l'ai supprimé... rien n'a changé !

En regardant les processus en cours, tout juste après que le système ait totalement démarré, j'ai vu qu'il y avait un processus, nommé java, qui prenait plus de 350 Mo de mémoire et faisait bouger le pourcentage d'utilisation du processeur (il reste tout le temps lancé, fait toujours bouger le pourcentage d'utilisation du processeur et est en priorité "très basse")...
30 mn après, les processeurs étaient toujours utilisés à 30-40%...
Je me suis dis que c'était peut être pour ça que mon système était bizarrement lent, dernièrement, alors que sur mes 16 Go de RAM, seulement 2-3-4 Go étaient utilisés... Je ne faisais pas de processus qui requièrait de grands calculs, donc du travail processeur...

Donc, il est parfois lent, par exemple, quand je sélectionne avec la souris ou je fais défiler l'écran, il y a un temps de latence, ça lague...

J'ai un DELL Inspiron avec :
- Intel Core i3 (4th Gen) 4130 / 3.4 GHz comme processeur
- 16 Go DDR3 SDRAM à 1600 Mhz.
- 3 disques durs (bien durs) de 1 Go, 2 Go et 1 Go.

Le processeur n'arrête pas de donc d'être à 30-40% de son utilisation... je ne sais pas si c'est normal, mais en tout cas, j'ai ces latences et lenteurs que je n'avais pas avant (je ne sais pas à quel moment cela intervient...).
Voici une capture d'écran peu de temps après que le système ait fini de chargé :

https://framapic.org/rJPbeIFLj2Ww/k7jodbELJ3ZP?t

Java est le processus qui prend le plus de RAM.

Si vous avez une idée, ce n'est pas de refus ! :)

Merci à vous ! :)
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

donalduck
Level 3
Level 3
Posts: 119
Joined: Mon Oct 07, 2013 1:43 pm
Location: there

Re: Utilisation anormale du processeur !

Post by donalduck » Thu Apr 05, 2018 5:12 am

salut,

bon je me dévoue et je peux déjà te dire que ce n'est pas normal :!:
tu as du installer un programme spécial en plus (volontairement ou non).

il faut arriver à identifier le package auquel appartient le(s) processus qui utilisent ton temps cpu, et ensuite soit desinstaller soit reparamettrer le programme en question.

pour ça le plus simple est dans une fenetre de terminal de commencer par récupérer le numero de process avec top ou htop en regardant les colonnes cpu time ou time+
puis la ligne de commande exacte et l'utilisateur de(s) processus avec ps -ef (avec les arguments de la ligne de commande java, si nécessaire en allant voir les fichiers /proc/XXX)

(a suivre)

galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Re: Utilisation anormale du processeur !

Post by galacticus » Mon Apr 09, 2018 8:42 am

Salut ! Merci pour ta réponse.

Oui, donc, j'ai regardé, il s'agissait de OpenJDK8, quelque chose comme ça. Je l'ai supprimé !

Bordel de nouille : Spectre et Meltdown
Des facteurs peuvent influer sur les résultats. Par exemple, pour les systèmes de 8e génération combinés à des disques SSD, l'impact est plus faible. En revanche, les anciens systèmes dotés de disques SSD sont plus touchés, et certains workloads, telles que les opérations JavaScript complexes, sont plus durement affectées, à hauteur de 10% de la performance.
J'ai supprimé l'application en question, citée dans le post principal, mais ça n'a pas grandement changé...

Quoi qu'il en soit, j'ai bien noté une différence de vitesse sur mon PC après l'installation du microcode d'Intel (mise à jour affichée dans le gestionnaire de mise à jour de Linux Mint).
Le test qui souligne la plus forte dégradation des performances est le SYSMark 2014 SE Responsiveness. Il montre des réductions de performance allant jusqu'à 21% pour des opérations comme les lancements d'applications, les lancements de fichiers, la navigation Web avec plusieurs onglets, le multitâche, la copie de fichiers, la manipulation photo, le cryptage de fichier, la compression, et l'installation d'application en arrière-plan.
Du coup, le pourcentage n'est pas réel maintenant, car, les performances sont changées et vues à la baisse, comme si nous avions un processeur différent et moins puissant...

Bon, "TO BE CONTINUED" !

Merci à vous !
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

User avatar
ToutAlu
Level 2
Level 2
Posts: 88
Joined: Tue May 23, 2017 4:14 pm

Re: Utilisation anormale du processeur !

Post by ToutAlu » Mon Apr 09, 2018 11:14 am

Bonjour,

As tu essayé de changer de noyau ?

On peut le faire en passant par le gestionnaire de mises à jour.
Image
Linux Mint 19.xx Xfce

galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Re: Utilisation anormale du processeur !

Post by galacticus » Mon Apr 09, 2018 2:49 pm

Salut !
Oui, j'ai plusieurs noyaux d'installés et j'ai essayé de remettre le noyaux 4.13 je ne sais plus quoi.
Je vais retenté la chose. Avais-tu une recommandation particulière pour le type ou la version du noyau à essayer ?
Merci !
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

User avatar
ToutAlu
Level 2
Level 2
Posts: 88
Joined: Tue May 23, 2017 4:14 pm

Re: Utilisation anormale du processeur !

Post by ToutAlu » Mon Apr 09, 2018 5:01 pm

Sur mes PC tous les noyaux que j'ai essayé ont tous bien fonctionné.
Certains matériels préfèrent certains noyaux.

Chez moi Mint 18 et noyaux 4.15.0-13
Image
Linux Mint 19.xx Xfce

galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Re: Utilisation anormale du processeur !

Post by galacticus » Tue Apr 10, 2018 4:18 am

D'ac, merci.
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Re: Utilisation anormale du processeur !

Post by galacticus » Tue Apr 10, 2018 8:02 am

Re !
Bon, j'ai testé le noyau 3.18 quelque chose et le dernier noyau Linux stable, le 4.16 quelque chose.

Bon, je n'ai pas assez testé le système encore, mais, avec le 4.16, ça fonctionne bien pour l'instant mais, au niveau des courbes et des statistiques, c'est toujours pareil... J'ai par contre le message suivant directement après avoir lancé le système sur écran de démarrage,
[ 0.000000] [Firmware Bug]: TSC_DEADLINE disabled due to Errata: please update microcode to version: 0x22 (or later)
Mais il démarre et fonctionne. Peut-être dû au fait que j'ai supprimé le microcode après m'être demandé si cela venait de lui...

Ce que j'ai remarqué avec le 3.18, c'est que les coeurs 1 et 2 étaient deux fois moins sollicités qu'avec le noyau 4.16...

Bref, je continue de voir et je reviens.

J'espère qu'il ne va pas me faire une crise cardiaque, car, son électrocardiogramme est quand même anormal ! :D

A+
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

User avatar
ToutAlu
Level 2
Level 2
Posts: 88
Joined: Tue May 23, 2017 4:14 pm

Re: Utilisation anormale du processeur !

Post by ToutAlu » Tue Apr 10, 2018 2:06 pm

Bon moi, je remettrai le micro code intel.
Tu pourrais aussi voir ce fil :

viewtopic.php?f=63&t=246136#p1327596

Laptop-mode-tools permet une bonne gestion des ordinateurs portables, donc à voir ...
Image
Linux Mint 19.xx Xfce

galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Re: Utilisation anormale du processeur !

Post by galacticus » Fri Apr 13, 2018 10:47 am

Salut !

Merci pour ton message.

Mon DELL est un ordinateur de bureau, je ne sais pas si ton lien est approprié.

J'ai testé d'utiliser mon PC avec le LiveUSB de LM 18.3 et bien, parfait !

Que ce soit au démarrage avec 1 Go de RAM utilisée ou avec 4 Go de RAM utilisé, les processeurs ne sont pas à plus de quelques pour cents, voyez ça :

https://framapic.org/3CEOeH35E6MH/gOleDWMibRwk.png

Les courbes, de droite à gauche, pour 60 secondes ! J'ai utilisé plusieurs logiciels, etc, et c'était moins gourmand et déséquilibré qu'avec mon installation décadente qui juste après le démarrage, où il n'y a aucun programme ou action lancée (avec 1 Go de RAM utilisée à peine) et qu'il bouffe 30% de chaque processeur... Donc, ce n'est bien pas normal du tout. Je vous dis pas lorsque l'on commence à faire pas mal de trucs...

Et aussi, il n'y avait pas assez d'espace sur le répertoire racine ! J'en ai fait un peu mais là ça ne change pas vraiment. Il me reste 8,9 Go sur ma partition racine maintenant ! je n'ai que 30 Go dessus en tout.

Je vais peut-être réinstaller et allouer plus d'espace à la racine (je vais voler ça au SWAP qui n'est jamais sollicité, lequel a 6,5 Go).

Je me demande également s'il n'y aurait pas un problème de logiciel ou de processus malsain et caché... bref, je n'ai pas remarqué de truc alarmant dans la partie "processeur" du moniteur système.

Bon, je continue à voir et je vous dis.

En attendant vos retours, je vous dis merci et à plus.
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Re: Utilisation anormale du processeur !

Post by galacticus » Wed Apr 18, 2018 11:31 am

Salut !

Bon, je me suis décidé à tester Glances, un programme de monitoring à utiliser dans le terminal, pour voir ce qu'il se passait, si ça me disait quelque chose de plus, et un processus nommé "iptotal" était là, alors qu'il n'était pas affiché avec le moniteur système graphique !

Il utilisait pas mal le processeur et ce de manière constante ! Je l'ai donc tué et la consommation CPU a immédiatement chuté ! Je l'ai donc supprimé.

Ça fonctionne bien mieux. Mais, ce n'est pas la perfection, car j'ai de petits blocage à l'utilisation de la souris et lorsque je fais de la saisie (quand la consommation CPU monte vers les 50%, pour une installation par exemple)...

Je n'aime pas trop quand ça fait ça, j'ai l'impression que le PC est malade. :D

Ça vous le fait également ?

Merci à vous tous !
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

User avatar
ToutAlu
Level 2
Level 2
Posts: 88
Joined: Tue May 23, 2017 4:14 pm

Re: Utilisation anormale du processeur !

Post by ToutAlu » Wed Apr 18, 2018 12:33 pm

Synaptic dit :

iptotal est encore un moniteur de trafic IP. Il écoute une interface réseau en mode non-promiscuous, et mesure l'utilisation de la bande passante IP. Après un nombre spécifié de secondes, le débit moyen est imprimé.

L'utilitaire peut être utilisé pour mesurer l'utilisation de la bande passante sans avoir besoin du démon SNMP. En combinaison avec un script simple et rrdtool, il peut être utilisé pour
présenter les données mesurées sous forme graphique, par ex. à travers une interface web.
Le paquet contient des exemples de fichiers www + CGI.



Tu as un bon processeur et beaucoup de Ram, je ne vois pas ce qui pêche au niveau matériel.

As tu essayé une interface graphique moins gourmande ? J'avais un fort ralentissement avec Mate que j'ai abandonné pour Xfce et depuis tout marche impecc.

Même si tu n'es pas sous Mate, l'exemple reste valable.
Image
Linux Mint 19.xx Xfce

galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Re: Utilisation anormale du processeur !

Post by galacticus » Wed Apr 18, 2018 1:27 pm

Ouais, j'avais installé divers programmes de mesure du trafic IP (je ne sais plus lesquels :D)... j'ai viré là, car je ne m'en servais pas de toute façon.

Mais ouais, ça bouffait grave la RAM, c'est étrange !

Ouep, j'ai songé tout à l'heure à mettre XFCE, je vais voir comment se comporte mon PC avec cet environnement bureau.

Quoi qu'il en soit, quand je tournais avec le LiveUSB (18.3 Cinnamon), c'était très fluide et tout, bien bien rapide, même avec 5Go de RAM utilisés (le processeur était encore moins sollicité ; mais bon, pas de Docky installé sur la session live et le système n'était pas sur un disque dur ni n'avait beaucoup de programmes installés).

J'utilise donc Cinnamon, sans les effets de bureau.

J'utilise Docky aussi.

Voilà. :) Faut voir ça.

Merci à toi !
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

galacticus
Level 2
Level 2
Posts: 82
Joined: Wed Jun 28, 2017 11:25 am
Location: PACA, France

Re: Utilisation anormale du processeur !

Post by galacticus » Wed Apr 18, 2018 4:58 pm

Bordel, j'ai réinstallé java9-runtime, et c'était encore pareil... ah ah ah... un bordel...
Sauf que là, le disque dur chargeait à fond. Ça ralentissait le système...
Je l'ai viré et tout est rentré dans l'ordre.

Sinon, mon processus Cinnamon est en commande "Cinnamon --replace", normal et/ou pas grave ?

Merci.
Processor: Dual core Intel Core i3-4150
Graphics: Intel 4th Generation Core Integrated Graphics Controller
Memory: DDR3 15958.4MB
Audio: Card-1 Intel 8 Series/C220 Series High Def.
Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD

Slyvester
Level 1
Level 1
Posts: 9
Joined: Sun Dec 30, 2012 6:02 am

Re: Utilisation anormale du processeur !

Post by Slyvester » Thu Apr 19, 2018 8:36 am

Bonjour,

J'ai également connu beaucoup de problèmes de CPU, plantages, ... avec Linux Mint 18.3 LTS Cinnamon, et ce depuis le début. J'ai finalement décidé - faute de mieux - d'installer un environnement de bureau plus léger = LXDE. Depuis, plus de soucis (cela fait +/- un mois) ... Cette solution de changer/ajouter un bureau comme celui de "Mate" semble également porter ses fruits. Cfr. ce sujet : "Cinnamon charge la CPU @ 350%..."
https://www.forum-francophone-linuxmint ... f=7&t=4848

Post Reply

Return to “Français (French)”