[Résolu] Kernel 4.15.0-20 : Le son ne fonctionne plus

French Forum

Moderators: Laurent85, killer de bug

Post Reply
phil995511
Level 4
Level 4
Posts: 268
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

[Résolu] Kernel 4.15.0-20 : Le son ne fonctionne plus

Post by phil995511 » Wed May 09, 2018 4:42 am

Pour information.

Intel i7-5960X avec Nvidia 1070Ti (derniers drivers Nvidia), hauts-parleurs intégrés dans mon écran, son et image transmis par Display Port.

https://bugs.launchpad.net/ubuntu/+sour ... ug/1770115

Si comme indiqué dans le post viewtopic.php?f=63&t=269037 par Laurent85
"J'ai reçu un message de JeremyB, le problème est que les noyaux viennent d'Ubuntu, qu'Ubuntu a apporté des modifications à leur système récemment, et que LM utilise leurs noyaux SANS suivre la même politique de mise à jour du système, d'où ce bug."
Il serait peut-être sage de revoir votre politique de mise-à-jour histoire de nous éviter de tels problèmes à l'avenir...

Meilleures salutations et bien à vous :)
Last edited by phil995511 on Wed May 09, 2018 8:39 am, edited 1 time in total.
Mint 19 64 bits Cinnamon

phil995511
Level 4
Level 4
Posts: 268
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

Re: Kernel 4.15.0-20 : Le son ne fonctionne plus

Post by phil995511 » Wed May 09, 2018 8:38 am

Problème réglé avec l'installation du dernier MintUpdate 5.3.2.3 qui a ensuite réinstallé le kernel 4.15.0-20, depuis le son fonctionne à nouveau.

Il reste juste un problème quand je met mon casque Logitech G35 sur un port USB et que je le retire. En faisant cette opération 2x de suite (brancher et débrancher le casque 2x), je me retrouve avec le son réglé sur "Sortie numérique S/PDIF Audio interne" à la place de HDMI / Display Port 3 HDA Nvidia" et je n'ai à nouveau plus de son. Je dois re-sélectionner manuellement le bon périphérique, ce qui est beaucoup moins grave, car précédemment je n'avais aucuns autre choix qu'un "périphérique audio générique" qui en fonctionnait pas du tout...

Bien à vous.
Mint 19 64 bits Cinnamon

Laurent85
Level 15
Level 15
Posts: 5750
Joined: Tue May 26, 2015 10:11 am

Re: [Résolu] Kernel 4.15.0-20 : Le son ne fonctionne plus

Post by Laurent85 » Wed May 09, 2018 3:44 pm

LM reprend les briques logicielles d'Ubuntu pour construire son propre système. Ce modèle de développement a ses avantages (avec quelques développeurs seulement LM est une excellente distribution grand public), et ses inconvénients, Ubuntu qui modifie une des briques essentielles du système de base et cela peut provoquer un bug avec les briques logicielles de LM.

Là en l’occurrence même avec une politique de mise à jour dans le gestionnaire sélectionnée à Toujours tout mettre à jour (même politique qu'Ubuntu) cela ne marchait pas. Un nouveau paquet noyau regroupe les pilotes pour certains matériels et l'outil de LM qui gère l'installation des noyaux ne l'installait pas. La nouvelle version en ligne de mintupdate corrige ce bug (quelle que soit la politique de mise à jour active).

Et comme le suggère clem viewtopic.php?f=49&t=269028&start=20#p1467429 c'est l’occasion de mettre en avant l'intérêt de l'outil timeshift qui permet de revenir en arrière à un état opérationnel du système.
Image

Post Reply

Return to “Français (French)”