[Résolu] Scanner Epson V300 Photo non reconnu

French Forum

Moderators: killer de bug, Laurent85

Post Reply
phil995511
Level 4
Level 4
Posts: 249
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

[Résolu] Scanner Epson V300 Photo non reconnu

Post by phil995511 » Mon Jul 09, 2018 10:51 am

Bonjour,

Depuis ma migration sous Mint 19 je n'arrive plus à utiliser mon scanner Epson V300 Photo.

J'ai bien les bons drivers qui fonctionnaient préalablement :

http://support.epson.net/linux/en/iscan ... sion=1.0.1

Une fois installés mon scan n'est pas détecté par Simple Scan ou un autre soft de numérisation d'image.

Je ne sais pas si cela vient de Ububtu qui a changé le dossier des drivers ou pas... (viewtopic.php?f=63&t=269133).

Bien à vous.
Last edited by phil995511 on Wed Jul 11, 2018 7:23 am, edited 1 time in total.
Mint 19 64 bits Cinnamon

MenthaSuaveolens
Level 2
Level 2
Posts: 59
Joined: Wed Apr 25, 2012 3:43 pm
Location: Belgium

Re: Scanner Epson V300 Photo non reconnu

Post by MenthaSuaveolens » Tue Jul 10, 2018 8:02 am

Même problème ici.
Last edited by MenthaSuaveolens on Tue Jul 10, 2018 1:17 pm, edited 2 times in total.

phil995511
Level 4
Level 4
Posts: 249
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

Re: Scanner Epson V300 Photo non reconnu

Post by phil995511 » Tue Jul 10, 2018 10:07 am

J'ai bien trouvé l'article ci-dessous qui aurait pu m'aider :

https://forum.ubuntu-fr.org/viewtopic.p ... #p21823842

mais le répertoire /usr/lib64/sane n'exite pas sous Mint...

@Laurent85 pourrais-tu stp me dire ou s'installent les drivers Epson (et autres drivers propriétaires) sous Mint que je puisse les copier dans /usr/lib/x86_64-linux-gnu/sane (si c'est le bon répertoire) et que je puisse utiliser à nouveau mon scanner dont j'ai absolument besoin. Ou mieux pouvez vous sortir un correctif rapidement ??

Tout cela semble venir de Ubuntu qui ont piqué une crise en changeant les drivers de place ce qui rend notre matos inutilisable !! C'est tout juste incroyable qu'ils mettent tout les gens ayant besoin de drivers propriétaires pour des imprimantes, etc, dans le caca de la sorte... J’hallucine, c'est manque de professionnalisme évident de leur part. J'ose rêver d'une LMDE3 100% fonctionnelle qui me libère des bêtises des gens de Ubuntu, j'espère qu'elle arrivera vite.
Last edited by phil995511 on Tue Jul 10, 2018 12:35 pm, edited 2 times in total.
Mint 19 64 bits Cinnamon

phil995511
Level 4
Level 4
Posts: 249
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

Re: Scanner Epson V300 Photo non reconnu

Post by phil995511 » Tue Jul 10, 2018 10:13 am

@ MenthaSuaveolens

Mon scanner ne fonctionne pas même avec Xsane d'installé ce qui était plus que prévisible vu que les drivers ne s'installent pas au bon endroit...
Mint 19 64 bits Cinnamon

MenthaSuaveolens
Level 2
Level 2
Posts: 59
Joined: Wed Apr 25, 2012 3:43 pm
Location: Belgium

Re: Scanner Epson V300 Photo non reconnu

Post by MenthaSuaveolens » Tue Jul 10, 2018 1:19 pm

phil995511 wrote:
Tue Jul 10, 2018 10:13 am
@ MenthaSuaveolens

Mon scanner ne fonctionne pas même avec Xsane d'installé ce qui était plus que prévisible vu que les drivers ne s'installent pas au bon endroit...
Vous avez raison. J'ai corrigé ma réponse. Elle a été mal traduit par Google Translate.
Voyez aussi https://bugs.launchpad.net/ubuntu/+sour ... ug/1728012

phil995511
Level 4
Level 4
Posts: 249
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

Re: Scanner Epson V300 Photo non reconnu

Post by phil995511 » Tue Jul 10, 2018 1:42 pm

MenthaSuaveolens wrote:
Tue Jul 10, 2018 1:19 pm
phil995511 wrote:
Tue Jul 10, 2018 10:13 am
@ MenthaSuaveolens

Mon scanner ne fonctionne pas même avec Xsane d'installé ce qui était plus que prévisible vu que les drivers ne s'installent pas au bon endroit...
Vous avez raison. J'ai corrigé ma réponse. Elle a été mal traduit par Google Translate.
Voyez aussi https://bugs.launchpad.net/ubuntu/+sour ... ug/1728012
Merci pour le liens, je l'avais déjà vu. Des dizaines de personnes ont signalé un bug +/- similaire depuis le 27.10.2017 et rien ne semble avoir été fait pour le corriger depuis. Les gens de Ubuntu me semblent vraiment peu sérieux...

Malheureusement dans ce post les gens utilisent bugs.launchpad.net comme si c'était un forum d'aide alors qu'il est réservé à la déclaration de pannes... et puis les solutions proposées ne fonctionne pas, pour celles que j'ai essayé en tout cas. J'espère qu'un correctif va arriver en urgence, j'ai du travail que je ne peux pas réaliser sous Mint à cause de mon scanner qui n'est plus reconnu et je n'ai pas l'envie de devoir réinstaller la version 18.3 pour pouvoir utiliser mon scanner ou de migrer vers un autre OS, j'ai perdu assez de temps et d'énergie comme ça avec ce problème...
Mint 19 64 bits Cinnamon

Laurent85
Level 15
Level 15
Posts: 5685
Joined: Tue May 26, 2015 10:11 am

Re: Scanner Epson V300 Photo non reconnu

Post by Laurent85 » Tue Jul 10, 2018 6:08 pm

phil995511 wrote:
Tue Jul 10, 2018 10:07 am
@Laurent85 pourrais-tu stp me dire ou s'installent les drivers Epson (et autres drivers propriétaires) sous Mint que je puisse les copier dans /usr/lib/x86_64-linux-gnu/sane (si c'est le bon répertoire) et que je puisse utiliser à nouveau mon scanner dont j'ai absolument besoin. Ou mieux pouvez vous sortir un correctif rapidement ??
Le bug enregistré sur launchpad est connu depuis plus de 6 mois par Ubuntu il n'y a toujours pas de correctif ni de solution de dépannage temporaire d'après les retours des personnes affectées. J'ignore pourquoi ça traîne mais dans l'urgence la seule solution me semble de rester sur 18.3, LM ne propose pas de paquet alternatif à ceux d'Ubuntu pour ce type de bug.

Si tu as un instantané Timeshift de 18.3 avant migration vers 19 c'est une affaire de quelques minutes.
Image

phil995511
Level 4
Level 4
Posts: 249
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

Re: Scanner Epson V300 Photo non reconnu

Post by phil995511 » Wed Jul 11, 2018 6:58 am

Bonjour Laurent,

Merci pour ton retour d'informations.

Je n'ai pas installé TimeShift, je ne m'attendais pas à ce type de problèmes avec une version finale et encore moins avec une LTS. Vous n'avez pas moyen d'entrer en contact avec les gus de Ubuntu pour leur signifier qu'il faut faire qqch ?? Franchement c'est casse pieds comme situation. En temps de guerre certains parleraient sabotage... Ce n'est pas comme ça que Mint et Ubuntu vont attirer de nouveaux utilisateurs, on choisit ce type de distributions pour ne pas se casser la nénette, pas pour se prendre plus la tête que sur une Debian brute :(

Si non tu sais dans quel répertoire les drivers étaient préalablement installés vs là ou ils sont installés maintenant ?? Vous ne pouvez pas juste faire un alias entre les deux que le système sache ou aller les chercher ??

On a l'impression de revenir de plusieurs années en arrière quand on ne peut plus installer nos périphériques sans se prendre la tête pendant un très long moment...

Bonne journée.
Mint 19 64 bits Cinnamon

phil995511
Level 4
Level 4
Posts: 249
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

Re: Scanner Epson V300 Photo non reconnu

Post by phil995511 » Wed Jul 11, 2018 7:23 am

Résolu en suivant les recommandations du post ci dessous #25 suivi d'un reboot.

https://bugs.launchpad.net/ubuntu/+sour ... ug/1728012

https://bugs.launchpad.net/ubuntu/+sour ... omments/25
Mint 19 64 bits Cinnamon

Laurent85
Level 15
Level 15
Posts: 5685
Joined: Tue May 26, 2015 10:11 am

Re: [Résolu] Scanner Epson V300 Photo non reconnu

Post by Laurent85 » Wed Jul 11, 2018 8:04 am

En fait ce bug n'est pas a attribuer à Ubuntu, les fabricants de scanner fournissent des paquets pilotes qui ne sont plus compatibles avec les derniers développements de SANE. On peut voir sur launchpad que le bug n'est attribué à aucun développeur, c'est aux fabricants de mettre à jour leurs paquets pilotes.
Image

phil995511
Level 4
Level 4
Posts: 249
Joined: Sat Feb 01, 2014 4:06 am
Location: Geneva

Re: [Résolu] Scanner Epson V300 Photo non reconnu

Post by phil995511 » Thu Jul 12, 2018 7:38 am

Oui sauf que le miens est d'ancienne génération et n'est plus vendu, comme c'est le cas pour bien d'autres utilisateurs d'ailleurs. Du coup mon scanner risque de ne pas bénéficier de nouveaux drivers et c'est déjà tellement rare d'en trouver un qui soient compatibles linux... Cette nouvelle version de Sane rend nos appareils obsolètes ce qui n'est franchement pas top. Me concernant je ne suis vraiment pas satisfait du tout. Ce genre de pilote sont intégrés de base dans d'autres OS vous devriez faire de même. Au minimum vous devriez assurer la compatibilité avec les pilotes existants.
Mint 19 64 bits Cinnamon

Laurent85
Level 15
Level 15
Posts: 5685
Joined: Tue May 26, 2015 10:11 am

Re: [Résolu] Scanner Epson V300 Photo non reconnu

Post by Laurent85 » Thu Jul 12, 2018 5:00 pm

Sur Linux des développeurs travaillent pour intégrer un maximum de pilotes et les mises à jour. La difficulté avec les périphériques est aussi lié aux licences des fabricants, certains n'autorisent pas la distribution de leur pilote, certains refusent de fournir les spécifications/code du matériel, certains fournissent des pilotes et font le service minimum, et souvent aussi aucun développeur ne fait de rétro ingénierie sur des matériels qu'ils n'utilisent pas.

Si Epson fournissait un paquet pilote compatible avec Ubuntu 18.04 le problème aurait été réglé. Il faut tenir compte des avertissements et recommandations avant de se décider à migrer, justement parce que les développeurs savent que pour certains utilisateurs il y aura des régressions. A l'avenir méthode ceinture et bretelles :idea:
Image

Christian_B
Level 2
Level 2
Posts: 83
Joined: Mon May 12, 2014 6:06 pm

Re: [Résolu] Scanner Epson V300 Photo non reconnu

Post by Christian_B » Fri Aug 10, 2018 9:56 am

Bonjour, j'ai un scanner Epson 2450 Photo.
Quelqu'un sait-il s'il est concerné par la bogue en v.19 ?
J'hésite à réinstaller en passant à la v.19 à cause de ça et pourtant mon système est assez "fatigué" et ce serait l'occasion de tout remettre à neuf.
Quand à cela, :
Laurent85 wrote:En fait ce bug n'est pas a attribuer à Ubuntu, les fabricants de scanner fournissent des paquets pilotes qui ne sont plus compatibles avec les derniers développements de SANE.
Je suis dubitatif. Si c'est Sane qui a changé, c'est plutôt lui qui n'est plus compatible avec les pilotes existants, non ? Et j'ai lu quelque part que cela ne marchait pas non plus avec Simple Scan.
Que ce soit des pilotes libres ou propriétaires, pourquoi faudrait-il multiplier les version selon les fantaisies des applis ou des distri.? J'aurais pensé qu'il existait des normes d'interfaçage des pilotes depuis longtemps. :?
Egalement j'ai lu ici et là d'autres choses (concernant une bogue plus ancienne) sur un changement de répertoire des pilotes ajoutés sous Ubuntu et une mise à jour qui aurait été faite différemment sous LM. Tout ça ne me paraît pas très clair.
EDIT : ce réflexe ne me vient pas encore naturellement, mais si personne n'a la réponse, je ferai le test avec une clé USB.
Linux Mint 19 Maté 64 Intel Core i7-4770 4x2 coeurs + Xeon E3-1200 ( = circuit 4600, sans carte graphique).
Mémoire 8 Go Dual channel, SSD 120Go, HD 2To.
1984 est passé, les émules de Big Brother nous surveillent.

Laurent85
Level 15
Level 15
Posts: 5685
Joined: Tue May 26, 2015 10:11 am

Re: [Résolu] Scanner Epson V300 Photo non reconnu

Post by Laurent85 » Tue Aug 14, 2018 10:39 am

Christian_B wrote:
Fri Aug 10, 2018 9:56 am
Bonjour, j'ai un scanner Epson 2450 Photo.
Quelqu'un sait-il s'il est concerné par la bogue en v.19 ?
Même marque et si c'est la même source pour le paquet pilote c'est très probable.
Laurent85 wrote:En fait ce bug n'est pas a attribuer à Ubuntu, les fabricants de scanner fournissent des paquets pilotes qui ne sont plus compatibles avec les derniers développements de SANE.
Je suis dubitatif. Si c'est Sane qui a changé, c'est plutôt lui qui n'est plus compatible avec les pilotes existants, non ? Et j'ai lu quelque part que cela ne marchait pas non plus avec Simple Scan.
Je peux l'expliquer par analogie, quand Windows sort une nouvelle version les fabricants mettent à jour leurs pilotes. Epson devrait aussi le faire pour la sortie de la nouvelle version d'Ubuntu 18.04 sur laquelle est basée Linux Mint 19, c'est pour cette raison que j'utilise l'expression servce minimum, ils sortent un pilote et ensuite il n'y a plus de suivi, c'est débrouillez-vous :x
Image

Post Reply

Return to “Français (French)”