Question Logiciels pré-installés

French Forum

Moderators: Laurent85, killer de bug

Post Reply
Aaron_Lacroix
Level 2
Level 2
Posts: 61
Joined: Fri Jan 26, 2018 3:43 pm

Question Logiciels pré-installés

Post by Aaron_Lacroix » Sat Aug 11, 2018 9:48 am

Bonjour,

Lorsqu'on installe LM et quelques soit la version, il y a des logiciels de pré-installés comme Thunderbird. La version 60 vient de sortir avec tout un tas de changements très perturbants. Par conséquent, je voudrais savoir comment dire à Linux Mint que je veux utiliser uniquement la version 52.9.1 et qu'il ne me propose aucune mise à jour à venir concernant ce logiciel.

Est-ce que la solution consiste à supprimer Thunderbird comme logiciel pré-installé et de télécharger manuellement la version que l'on désire et de l'installer dans /opt en désactivant la mise à jour et en faisant un lien manuellement dans le menu ?

Merci par avance.
LM 18.3 Cinnamon - 4.15.0-39-generic x86_64

gm10
Level 12
Level 12
Posts: 4136
Joined: Thu Jun 21, 2018 5:11 pm

Re: Question Logiciels pré-installés

Post by gm10 » Sat Aug 11, 2018 10:19 am

Dans les préférences du logiciel de mise à jour (Update Manager) tu trouveras la "Blacklist", cliques sur le + pour ajouter thunderbird à la liste. Tu ne recevras donc plus de mises à jour pour Thunderbird.

Aaron_Lacroix
Level 2
Level 2
Posts: 61
Joined: Fri Jan 26, 2018 3:43 pm

Re: Question Logiciels pré-installés

Post by Aaron_Lacroix » Sat Aug 11, 2018 1:26 pm

Merci, c'est vrai, je n'y avais pas pensé à la blacklist. Maintenant reste à savoir comment installer une version spécifique par l'intermédiaire de synaptic.
LM 18.3 Cinnamon - 4.15.0-39-generic x86_64

gm10
Level 12
Level 12
Posts: 4136
Joined: Thu Jun 21, 2018 5:11 pm

Re: Question Logiciels pré-installés

Post by gm10 » Sat Aug 11, 2018 1:28 pm

par exemple :

Code: Select all

apt install thunderbird=1:52.9.1+build3-0ubuntu0.18.04.1
ou dans Synaptic faut cliqer sur le paquet et après Ctrl+E et tu peux choisir la version selon ceux qui sont disponibles.

donalduck
Level 3
Level 3
Posts: 119
Joined: Mon Oct 07, 2013 1:43 pm
Location: there

Re: Question Logiciels pré-installés

Post by donalduck » Sun Aug 12, 2018 2:17 pm

a noter que dans l'interface synaptic, un clic droit sur le paquet donne des infos utiles.
il y a aussi le menu [ paquet | forcer la version ]

sinon pour retrouver le detail des versions installés sur ton ordi un petit grep dans /var/log, par exemple:

Code: Select all

zgrep 'upgrade thunderbird' /var/log/dpkg.log*
en dernier recours pour connaitre les différentes versions disponibles, penser à aller voir directement a la source sur le site d'ubuntu :idea:
deux liens a connaitre en lien avec les mises a jour de sécurité:

https://usn.ubuntu.com/


https://people.canonical.com/~ubuntu-security/cve/

Aaron_Lacroix
Level 2
Level 2
Posts: 61
Joined: Fri Jan 26, 2018 3:43 pm

Re: Question Logiciels pré-installés

Post by Aaron_Lacroix » Wed Aug 22, 2018 9:17 am

gm10 wrote:
Sat Aug 11, 2018 10:19 am
Dans les préférences du logiciel de mise à jour (Update Manager) tu trouveras la "Blacklist", cliques sur le + pour ajouter thunderbird à la liste. Tu ne recevras donc plus de mises à jour pour Thunderbird.
N'ayant pas encore installé LM 19, je me demande comment blaclister un logiciel étant donné que la mise à jour est automatique ???
LM 18.3 Cinnamon - 4.15.0-39-generic x86_64

gm10
Level 12
Level 12
Posts: 4136
Joined: Thu Jun 21, 2018 5:11 pm

Re: Question Logiciels pré-installés

Post by gm10 » Wed Aug 22, 2018 9:37 am

Aaron_Lacroix wrote:
Wed Aug 22, 2018 9:17 am
gm10 wrote:
Sat Aug 11, 2018 10:19 am
Dans les préférences du logiciel de mise à jour (Update Manager) tu trouveras la "Blacklist", cliques sur le + pour ajouter thunderbird à la liste. Tu ne recevras donc plus de mises à jour pour Thunderbird.
N'ayant pas encore installé LM 19, je me demande comment blaclister un logiciel étant donné que la mise à jour est automatique ???
La mise à jour n'est pas automatique par défaut, ce n'est qu'une option. La mise à jour automatique utilise /etc/mintupdate.blacklist.

Aaron_Lacroix
Level 2
Level 2
Posts: 61
Joined: Fri Jan 26, 2018 3:43 pm

Re: Question Logiciels pré-installés

Post by Aaron_Lacroix » Wed Aug 22, 2018 10:24 pm

@gm10, Ok merci de ta réponse, ça me rassure, je pourrais blacklisterThunuderbird comme indiqué et passer éventuellement en automatique, ensuite.
LM 18.3 Cinnamon - 4.15.0-39-generic x86_64

Post Reply

Return to “Français (French)”