Activer l'écriture NTFS HDD externe

French Forum

Moderators: Laurent85, killer de bug

Post Reply
michael34990
Level 1
Level 1
Posts: 5
Joined: Mon Oct 01, 2018 1:32 pm

Activer l'écriture NTFS HDD externe

Post by michael34990 » Mon Oct 01, 2018 1:53 pm

Bonjour à tous,
Je viens de réinstaller Linux Mint 19 MATE 64 bits sur mon NUC (Core i3 4400, 4 Go RAM, 128 Go SSD).
J'ai des disque durs interne que j'utilise habituellement sur une autre tour sous windows mais comme je ne peux pas la brancher pour l'instant (cause déménagement) je me contente d'utiliser mon petit pc avec un Dock usb, ca me permet de lire et d'enregistrer du contenu.

Avant, sous la 18.3, l'enregistrement sur du NTFS était présent (j'avais du faire la manip, je ne m'en souviens plus).
Puis la mise à jour vers la 19 n'as pas été satisfaisante, j'ai eu quelques soucis désagréable et j'ai décidé de repartir d'une install propre.

J'ai tout sauvegardé via FTP sur un autre pc sous linux mint afin de ne rien perdre
Je reconfigure tout progressivement sur le NUC.

Mon soucis :
J'arrive à lire nativement le contenu d'un disque dur en NTFS mais j'ai tout les choix en grisé pour y coller, supprimer des fichiers...
Comment faire pour réactiver cette fonction ?

J'ai essayé avec d'autres disque durs vierge en Ext4 et c'était pareil...
Je ne sais pas comment faire, je ne m'y connais pas trop en ligne de commande (je n'ai que les baees).
Merci pour votre aide !

Laurent85
Level 15
Level 15
Posts: 5752
Joined: Tue May 26, 2015 10:11 am

Re: Activer l'écriture NTFS HDD externe

Post by Laurent85 » Wed Oct 03, 2018 8:06 am

michael34990 wrote:
Mon Oct 01, 2018 1:53 pm
Mon soucis :
J'arrive à lire nativement le contenu d'un disque dur en NTFS mais j'ai tout les choix en grisé pour y coller, supprimer des fichiers...
Comment faire pour réactiver cette fonction ?
C'est une question de droits. Tu la montes comment la partition ntfs (les manipulations pour y accéder)
J'ai essayé avec d'autres disque durs vierge en Ext4 et c'était pareil...
Même raison, question de droits.

Accède au hdd ntfs puis donne le retour commande, pour cela ouvre un terminal c'est l'icône écran avec fond noir, copie colle dedans la commande :

Code: Select all

mount | grep ^/
Image

michael34990
Level 1
Level 1
Posts: 5
Joined: Mon Oct 01, 2018 1:32 pm

Re: Activer l'écriture NTFS HDD externe

Post by michael34990 » Thu Oct 04, 2018 6:35 am

Bonjour Laurent,
Suite à ta demande, voici le résultat du terminal :

Code: Select all

michael@michael-NUC:~$ mount | grep ^/
/dev/sda2 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/sdb2 on /media/michael/3To_DD1 type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
Merci pour ton aide !

Laurent85
Level 15
Level 15
Posts: 5752
Joined: Tue May 26, 2015 10:11 am

Re: Activer l'écriture NTFS HDD externe

Post by Laurent85 » Thu Oct 04, 2018 10:01 am

Tu n'as pas de message quand tu montes le disque ntfs ? Il a été monté en lecture seule par le système, et par défaut c'est en lecture/écriture.
Image

michael34990
Level 1
Level 1
Posts: 5
Joined: Mon Oct 01, 2018 1:32 pm

Re: Activer l'écriture NTFS HDD externe

Post by michael34990 » Thu Oct 04, 2018 11:35 am

Je n'ai pas de message d'erreur, non.

Par contre, pour que le disque dur externe soit visible sur le bureau, il me faut allumer le dock usb au démarrage du pc car si je l'allume une fois que je suis sur le bureau, l'icone d'accès ne se monte pas.

Voici ce que j'utilise comme Dock usb si ca peut t'aider :
https://www.materiel.net/produit/201505060004.html

Je comprend mieux pourquoi je n'arrive pas à écrire s'il est en lecture seule.
Merci pour tes conseils

Laurent85
Level 15
Level 15
Posts: 5752
Joined: Tue May 26, 2015 10:11 am

Re: Activer l'écriture NTFS HDD externe

Post by Laurent85 » Fri Oct 05, 2018 9:29 am

Branche le dock usb, accède au disque, et tout de suite après entre cette commande dans un terminal et donne le retour :

Code: Select all

dmesg | tail -30
Image

michael34990
Level 1
Level 1
Posts: 5
Joined: Mon Oct 01, 2018 1:32 pm

Re: Activer l'écriture NTFS HDD externe

Post by michael34990 » Fri Oct 05, 2018 11:29 am

Bonjour Laurent,

Voici le retour de la commande :

Code: Select all

michael@michael-NUC:~$ dmesg | tail -30
[    4.935984] input: HDA Intel HDMI HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:03.0/sound/card0/input11
[    4.936123] input: HDA Intel HDMI HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:03.0/sound/card0/input12
[    4.947581] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC283: line_outs=1 (0x21/0x0/0x0/0x0/0x0) type:hp
[    4.947586] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.947590] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.947593] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    4.947595] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    4.947598] snd_hda_codec_realtek hdaudioC1D0:      Mic=0x19
[    4.977882] intel_rapl: Found RAPL domain package
[    4.977886] intel_rapl: Found RAPL domain core
[    4.977888] intel_rapl: Found RAPL domain uncore
[    4.977889] intel_rapl: Found RAPL domain dram
[    4.985653] audit: type=1400 audit(1538753210.092:2): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=631 comm="apparmor_parser"
[    4.985659] audit: type=1400 audit(1538753210.092:3): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=631 comm="apparmor_parser"
[    4.985664] audit: type=1400 audit(1538753210.092:4): apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=631 comm="apparmor_parser"
[    4.989684] audit: type=1400 audit(1538753210.096:5): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=629 comm="apparmor_parser"
[    4.989690] audit: type=1400 audit(1538753210.096:6): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=629 comm="apparmor_parser"
[    4.989694] audit: type=1400 audit(1538753210.096:7): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=629 comm="apparmor_parser"
[    4.989697] audit: type=1400 audit(1538753210.096:8): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=629 comm="apparmor_parser"
[    4.990129] audit: type=1400 audit(1538753210.096:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-oopslash" pid=632 comm="apparmor_parser"
[    4.992095] audit: type=1400 audit(1538753210.096:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session" pid=628 comm="apparmor_parser"
[    4.997464] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card1/input13
[    4.997561] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card1/input14
[    5.525093] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[    5.720308] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[    8.207213] e1000e: eno1 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
[    8.207217] e1000e 0000:00:19.0 eno1: 10/100 speed: disabling TSO
[    8.207249] IPv6: ADDRCONF(NETDEV_CHANGE): eno1: link becomes ready
[   19.326180] random: crng init done
[   19.326183] random: 7 urandom warning(s) missed due to ratelimiting
michael@michael-NUC:~$ 
J'ai peut être un début de piste, on m'as dit je cite "Si c'est du ntfs et que t'as debranché ton disque usb sans le demonter sur windows, le systeme de fichier est marqué "dirty" et est monté en read only. Il faut faire un checkdisk sur windows pour qu'il soit plus marqué dirty".

Si la personne a raison, je n'ai pas d'ordi sous windows sous la main.

Dans l'attente de te lire
Avec mes remerciements

Laurent85
Level 15
Level 15
Posts: 5752
Joined: Tue May 26, 2015 10:11 am

Re: Activer l'écriture NTFS HDD externe

Post by Laurent85 » Fri Oct 05, 2018 3:41 pm

michael34990 wrote:
Fri Oct 05, 2018 11:29 am
J'ai peut être un début de piste, on m'as dit je cite "Si c'est du ntfs et que t'as debranché ton disque usb sans le demonter sur windows, le systeme de fichier est marqué "dirty" et est monté en read only. Il faut faire un checkdisk sur windows pour qu'il soit plus marqué dirty".
Ça doit être ça.
ntfsfix sous Linux peut réparer certains états en défaut de ntfs dont le drapeau dirty, essaie toujours:

Code: Select all

sudo umount /dev/sdb2
sudo ntfsfix /dev/sdb2
sudo ntfsfix --clear-dirty /dev/sdb2
Image

michael34990
Level 1
Level 1
Posts: 5
Joined: Mon Oct 01, 2018 1:32 pm

Re: Activer l'écriture NTFS HDD externe

Post by michael34990 » Sat Oct 06, 2018 4:55 am

Bonjour Laurent,

Voici le rapport des opérations...

Code: Select all

michael@michael-NUC:~$ sudo umount /dev/sdb2
[sudo] Mot de passe de michael : 
michael@michael-NUC:~$ sudo ntfsfix /dev/sdb2
Mounting volume... The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
FAILED
Attempting to correct errors... 
Processing $MFT and $MFTMirr...
Reading $MFT... OK
Reading $MFTMirr... OK
Comparing $MFTMirr to $MFT... OK
Processing of $MFT and $MFTMirr completed successfully.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb2 was processed successfully.
michael@michael-NUC:~$ sudo ntfsfix --clear-dirty /dev/sdb2
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
Checking the alternate boot sector... OK
NTFS volume version is 3.1.
NTFS partition /dev/sdb2 was processed successfully.
michael@michael-NUC:~$ 
Je vais redémarrer l'ordinateur pour faire réapparaitre le disque dur externe.

RESOLU !!
Après redémarrage du PC, je peux à nouveau coller sur le disque dur externe et supprimer les fichiers.

Je vais garder précieusement de coté les lignes de commande dans un bloc note pour m'en resservir si besoin !
Merci pour ton aide

Post Reply

Return to “Français (French)”