[Résolu] Erreur avec dpkg error code (1)

French Forum

Moderator: Laurent85

Post Reply
waca
Level 1
Level 1
Posts: 13
Joined: Sat Dec 10, 2011 12:29 am

[Résolu] Erreur avec dpkg error code (1)

Post by waca » Fri Nov 09, 2018 7:55 pm

Bonjour à tous,
LinuxMint18.3 Cinnamon 64bit (3.6.7)

Hier j'ai voulu installer 2/3 logiciels...
ce matin mon "pinta" qui fonctionnait trés bien auparavant ne veut plus s'executer.
du coup, j'ai fouillé un peu partout:

Code: Select all

dpkg --configure -a
Paramétrage de libgtk2.0-cil (2.12.10-6) ...
! Assembly /usr/share/cli-common/policies.d/libgtk2.0-cil/policy.2.8.pango-sharp.dll does not exist
dpkg: erreur de traitement du paquet libgtk2.0-cil (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
libgtk2.0-cil
j'ai tenté des
apt-get update puis upgrade dist-upgrade autoremove autoclean avec ou sans libgtk2.0-cil

et aussi

Code: Select all

sudo apt-get install --reinstall libglib2.0-cil
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 1 réinstallés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/41,7 ko dans les archives.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
(Lecture de la base de données... 324313 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libglib2.0-cil_2.12.10-6_amd64.deb ...
Removing libglib2.0-cil from Mono
Dépaquetage de libglib2.0-cil (2.12.10-6) sur (2.12.10-6) ...
Paramétrage de libglib2.0-cil (2.12.10-6) ...
* Installing 1 assembly from libglib2.0-cil into Mono
Paramétrage de libgtk2.0-cil (2.12.10-6) ...
! Assembly /usr/share/cli-common/policies.d/libgtk2.0-cil/policy.2.8.pango-sharp.dll does not exist
dpkg: erreur de traitement du paquet libgtk2.0-cil (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
libgtk2.0-cil
E: Sub-process /usr/bin/dpkg returned an error code (1)

Code: Select all

sudo apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
1 partiellement installés ou enlevés.
Après cette opération, 0 o d'espace disque supplémentaires seront utilisés.
Paramétrage de libgtk2.0-cil (2.12.10-6) ...
! Assembly /usr/share/cli-common/policies.d/libgtk2.0-cil/policy.2.8.pango-sharp.dll does not exist
dpkg: erreur de traitement du paquet libgtk2.0-cil (--configure) :
le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
Des erreurs ont été rencontrées pendant l'exécution :
libgtk2.0-cil
E: Sub-process /usr/bin/dpkg returned an error code (1)
Je ne m'en sors pas... svp.
Merci d'avance.
Last edited by waca on Sat Nov 10, 2018 3:10 am, edited 1 time in total.
Mint19
Cinnamon 3.8.9
Noyau 4.15.0-58-generic
CPU: Core i3-4160
RAM: 4Go

Laurent85
Level 16
Level 16
Posts: 6073
Joined: Tue May 26, 2015 10:11 am

Re: Erreur avec dpkg error code (1)

Post by Laurent85 » Fri Nov 09, 2018 9:15 pm

Bonjour,
Le paquet libgtk2.0-cil d'Ubuntu est bogué, il ne contient plus les fichiers pango-sharp, pourquoi je ne sais pas.
Image

waca
Level 1
Level 1
Posts: 13
Joined: Sat Dec 10, 2011 12:29 am

Re: Erreur avec dpkg error code (1)

Post by waca » Sat Nov 10, 2018 2:28 am

Merci pour ta réponse rapide et instructive.

Ceci dit, comment 'contourner' mon soucis pour installer pinta (j'ai bien sûr essayé
avec le .deb)
Pour pinta, je peux tjrs le faire fonctionner en prenant celui de windows+wine...
mais j'appréhende surtout que ce soucis de libgtk2.0-cil, me créé d'autres soucis dans l'avenir avec le système lui-même ou pour installer d'autres applis !
Mint19
Cinnamon 3.8.9
Noyau 4.15.0-58-generic
CPU: Core i3-4160
RAM: 4Go

gm10
Level 18
Level 18
Posts: 8737
Joined: Thu Jun 21, 2018 5:11 pm

Re: Erreur avec dpkg error code (1)

Post by gm10 » Sat Nov 10, 2018 2:44 am

Laurent85 wrote:
Fri Nov 09, 2018 9:15 pm
Bonjour,
Le paquet libgtk2.0-cil d'Ubuntu est bogué, il ne contient plus les fichiers pango-sharp, pourquoi je ne sais pas.
Mais c'est tout là : https://packages.ubuntu.com/xenial/amd6 ... l/filelist ?
waca wrote:
Sat Nov 10, 2018 2:28 am
Ceci dit, comment 'contourner' mon soucis pour installer pinta (j'ai bien sûr essayé
avec le .deb)
Essaies d'abord

Code: Select all

sudo dpkg --remove --force-remove-reinstreq --force-depends libgtk2.0-cil
Si cela ne marche pas, fais

Code: Select all

sudo rm /var/lib/dpkg/info/libgtk2.0-cil.*
et après encore la première commande. Finalement

Code: Select all

apt clean
apt install -f

waca
Level 1
Level 1
Posts: 13
Joined: Sat Dec 10, 2011 12:29 am

Re: Erreur avec dpkg error code (1)

Post by waca » Sat Nov 10, 2018 3:05 am

Super, merci, mon

dpkg --configure -a
ne me retourne plus rien....

Install de pinta = OK

Merci encore, et belle journée.
Mint19
Cinnamon 3.8.9
Noyau 4.15.0-58-generic
CPU: Core i3-4160
RAM: 4Go

Post Reply

Return to “Français (French)”