Page 1 of 1

Scanner epson xp-255 pas reconnu

Posted: Fri Feb 08, 2019 2:50 pm
by Palcopie
Je viens d'installer peniblement une imprimante multifonction epson xp-255.
Je m'attaque au scanner inclus en suivant ce tuto : http://doc.ubuntu-fr.org/tutoriel/insta ... ifonctions
Sauf que.... ben, y a rien qui marche !
le fichier /lib/udev/rules.d/40-libsane.rules n'existe pas. Je fait quoi ? je le crée ? je met quoi dedans ? :(

merci.

Re: Scanner epson xp-255 pas reconnu

Posted: Fri Feb 08, 2019 6:28 pm
by Laurent85
Bonjour,
Tu as manqué ce passage :
A partir d'Ubuntu 18.04 suivez ce post du forum ubuntu.

Re: Scanner epson xp-255 pas reconnu

Posted: Sat Feb 09, 2019 12:32 pm
by Palcopie
Bonjour,

Je viens de regarder tranquilement.
Dans /usr/lib/ je n'ai pas de répertoire /sane.
En revanche dans /usr/lib/x86_64-linux-gnu, j'ai un repertoire /sane. et à l'interieur, j'ai un paquet de fichiers en "libsane quelquechose" (libsane-epson.so 1.0.27 par exemple.)

Incidemment j'ai aussi, pour chaque fichier, le même fichier (même nom ou presque) avec une fleche dessus. J'imagine que c'est un lien symbolique ? l'equivalent des raccourcis de windows et des alias de Mac ? mais est ce normal ?

Ensuite, dans /etc/udev/rules.d je n'ai absolument rien. Le vide, nada, walou. :mrgreen: (je devrais peut etre m'en inquieter, non ?)

Je veux bien essayer la commande indiquée (sudo cp /usr/lib/sane/libsane-epkowa.* /usr/lib/x86_64-linux-gnu/sane/). Mais si j'ai bien compris la syntaxe, il ne devrait rien se passer.
Si j'ai bien compris la commande, on copie le repertoire "/usr/lib/sane/libsane-epkowa.*" vers " /usr/lib/x86_64-linux-gnu/sane/" .

Mais je veux bien essayer.

Re: Scanner epson xp-255 pas reconnu

Posted: Thu Feb 14, 2019 7:06 am
by Palcopie
Très curieusement, ça n'a pas marché.

Re: Scanner epson xp-255 pas reconnu

Posted: Mon Mar 04, 2019 1:19 pm
by phil995511
Salut,

Les mecs de Ubuntu s’amusent vraisemblablement à personnaliser leur noyau linux de manière non standard.

On a eu des problèmes avec Steam qui ne s'installait plus dans les mêmes répertoires de l'utilisateur, d'une version à une autre, ce qui a cassé les pieds à tout le monde car on s'est retrouvé face à une panne à cause d'eux.

Depuis peu ils ont changé le répertoire d'installation de certains drivers dont ceux pour scanner... et ils n'ont même pas créer un liens symbolique pour assurer la compatibilité avec les drivers propriétaires. Il me semble avoir lu qqch de leur part comme quoi les fabricants de matériel/pilotes n'avaient qu'à mettre à jour leurs pilotes !! Sachant comme il est difficile de trouver des drivers pour Linux et qu'en général quand on en trouve y a guère de mises-à-jour, on se demande vraiment sur quelle planète vivent les développeurs de Ubuntu !!

Du coup faut faire la manip suivante pour que ça marche :

Code: Select all

a) 'sudo ln -sfr /usr/lib/sane/libsane-epkowa* /usr/lib/x86_64-linux-gnu/sane'
b) generate '/etc/udev/rules.d/79-udev-epson.rules'
content:
# chmod device EPSON group
ATTRS{manufacturer}=="EPSON", DRIVERS=="usb", SUBSYSTEMS=="usb", ATTRS{idVendor}=="04b8", ATTRS{idProduct}=="*", MODE="0777
Personnellement comme j'en avais plus que raz le bol de leurs modifications continuelles sur le dos des utilisateurs, j'ai viré Mint 19.x qui est basé sur Ubuntu (de toute manière je n'ai jamais aimé Ubuntu) et j'ai installé Mint LMDE 3 à la place qui est basé sur Debian 9.x sans surcouche Ubuntu à la noix. Et là tout fonctionne sans embrouilles, sans devoir faire des mises-à-jours majeures du système tout les 6 mois, etc.

Bref ma machine tourne au poil avec Mint LMDE 3, plus de problèmes de drivers ou quoi que ce soit d'autre.

Bien à toi.

Re: Scanner epson xp-255 pas reconnu

Posted: Tue Mar 19, 2019 3:32 pm
by Palcopie
Merci pour le retour, cela confirme ce que je m'imaginais.