LM 19.1 et carte ATI Raedon HD 6450

French Forum

Moderator: Laurent85

Post Reply
mbedard
Level 1
Level 1
Posts: 3
Joined: Tue Jul 30, 2019 8:37 am

LM 19.1 et carte ATI Raedon HD 6450

Post by mbedard » Tue Jul 30, 2019 8:42 am

Bonjour,

Je tente désespérément d'installer les pilotes ATI Raedon HD 6450 afin de faire fonctionner certains logiciels qui exigent "openGL 3.3" minimum.

J'ai tout de même tenté ma chance avec une certaine marche à suivre avec le dernier paquet fournis par AMD, mais l'installation a échoué en disant que je doit aussi m'assurer d'avoir la dernière version de Xorg.

Connaissez-vous un bon "how-to" qui explique la marche à suivre?

Merci!

Laurent85
Level 16
Level 16
Posts: 6075
Joined: Tue May 26, 2015 10:11 am

Re: LM 19.1 et carte ATI Raedon HD 6450

Post by Laurent85 » Tue Jul 30, 2019 4:18 pm

Bonjour,
mbedard wrote:
Tue Jul 30, 2019 8:42 am
J'ai tout de même tenté ma chance avec une certaine marche à suivre avec le dernier paquet fournis par AMD, mais l'installation a échoué en disant que je doit aussi m'assurer d'avoir la dernière version de Xorg.
Tu as fait quoi dans le détail ?
Connaissez-vous un bon "how-to" qui explique la marche à suivre?
Vois ce ppa https://launchpad.net/~oibaf/+archive/u ... cs-drivers
Image

mbedard
Level 1
Level 1
Posts: 3
Joined: Tue Jul 30, 2019 8:37 am

Re: LM 19.1 et carte ATI Raedon HD 6450

Post by mbedard » Tue Jul 30, 2019 9:35 pm

J'ai ajouté la PPA, effectué les mises à jour, etc, etc.

J'ai par la suite vérifié la version de X, voici le résultat:

X.Org X Server 1.19.6
Release Date: 2017-12-20
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-148-generic x86_64 Ubuntu
Current Operating System: Linux ohwell-GA-970A-DS3 4.15.0-55-generic #60-Ubuntu SMP Tue Jul 2 18:22:20 UTC 2019 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz-4.15.0-55-generic root=/dev/mapper/mint--vg-root ro quiet splash vt.handoff=1
Build Date: 03 June 2019 08:10:35AM
xorg-server 2:1.19.6-1ubuntu4.3 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.34.0


J'ai vérifié la version du openGL par la suite:

OpenGL vendor string: X.Org
OpenGL renderer string: AMD CAICOS (DRM 2.50.0 / 4.15.0-55-generic, LLVM 8.0.1)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.2.0-devel (git-2d2abb0 2019-07-30 bionic-oibaf-ppa)
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 19.2.0-devel (git-2d2abb0 2019-07-30 bionic-oibaf-ppa)
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 19.2.0-devel (git-2d2abb0 2019-07-30 bionic-oibaf-ppa)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:


Je tente par la suite d'installer le pilote "AMD-Catalyst-Linux-installer-15.201.1151-x86.x86_64.run".....voici le résultat:

error: Detected X Server version 'XServer 1.19.6_64a' is not supported. Supported versions are X.Org 6.9 or later, up to XServer 1.10 (default:v2:x86_64:lib32:XServer 1.19.6_64a:none:4.15.0-55-generic:)
Installation will not proceed.


Je suis au point mort une seconde fois

Laurent85
Level 16
Level 16
Posts: 6075
Joined: Tue May 26, 2015 10:11 am

Re: LM 19.1 et carte ATI Raedon HD 6450

Post by Laurent85 » Wed Jul 31, 2019 4:31 am

mbedard wrote:
Tue Jul 30, 2019 9:35 pm
Je tente par la suite d'installer le pilote "AMD-Catalyst-Linux-installer-15.201.1151-x86.x86_64.run".....voici le résultat:
AMD a abandonné le développement de Catalyst sur Linux depuis des années, il n'est plus compatible avec LM (ni les autres distributions).

Et à moins d'être développeur c'est pas une bonne idée d'installer des logiciels sur LM en lançant un exécutable. Il faut laisser ça aux Mainteneurs qui font les ajustements nécessaires pour la compatibilité avec la distribution. L'utilisateur l'installe ensuite par les dépôts officiels ou par des dépôts tiers comme les ppa. Tu risques de casser ton système sinon.

AMD en remplacement de Catalyst développe à présent les pilotes AMDGPU et AMDGPU PRO pour Linux, ces pilotes sont développés pour les générations récentes des puces graphiques AMD. La série HD6000 n'en fait pas partie. Ce qui signifie que les possesseurs de cartes graphiques antérieures n'ont que le pilote libre radeon et le support 3d mesa fournit par les distributions.

Tu ne trouveras pas de version plus récente que le ppa que je t'ai donné je pense. Si ce n'est pas suffisant la seule solution est de changer le processeur graphique. Les cpu Intel de génération récente avec puce graphique intégrée suffisent largement pour des besoins standards.
Image

mbedard
Level 1
Level 1
Posts: 3
Joined: Tue Jul 30, 2019 8:37 am

Re: LM 19.1 et carte ATI Raedon HD 6450

Post by mbedard » Wed Jul 31, 2019 4:55 am

Il est claire qu'un investissement dans une nouvelle carte vidéo serait une bien meilleur solution :)

Merci pour ton aide!!!

Post Reply

Return to “Français (French)”