plus de connexion session après LVM

French Forum

Moderator: Laurent85

Post Reply
Boonobip
Level 1
Level 1
Posts: 1
Joined: Tue Mar 10, 2020 1:09 pm

plus de connexion session après LVM

Post by Boonobip »

Bonjour à tous :D
j'ai mon premier soucis après plus de deux ans d'utilisation de cette belle distro (un record...) et viens ici chercher de l'aide :|

Je précise d'entrée que mon problème concerne la connexion à ma session, et pas la connexion internet.

Pour résumer, j'ai crée un volume logique (vl) de 8 To à l'aide de LVM pour concaténer deux HDD. Le vl s'est bien crée à la taille atendue (du moins 7.2 To ou pas loin), se monte...mais deux programmes, Luckybackup et nemo, ne reconnaissent pas l'espace libre, et , après redémarrage, je suis désormais bloqué sur la fenêtre de connexion à ma session. J'entre mon login et mon mot de passe (en veillant au layout du clavier qui semble t-il est passé en qwerty), et la fenêtre se recharge en me demandant à nouveau mes identifiants.

En plus détaillé:
- mes disques:
/dev/sdd, le système, on n'y touchera pas dans la suite
/dev/sdc, un HDD de data, on n'y touchera pas par la suite
/dev/sdb, un HDD 4 To tout neuf dans lequel je crée une partition unique en ext4 à l'aide de gparted au préalable
/dev/sda, un HDD 4To avec données

Je veux fusionner sda et sdb.
Peu importe les données sur sda1, elles sont dupliquées ailleurs.
Je suis le tuto ubuntu https://doc.ubuntu-fr.org/lvm ainsi que celui-ci: https://www.linuxtricks.fr/wiki/lvm-sou ... s-logiques
Je crée deux volumes physiques, le groupe de volume logique correspondant (nommé mvg), puis le volume logique volume1 qui comprend les deux /dev/sda1 et /dev/sdb1 en utilisant cette syntaxe:
lvcreate -n mvg -l 100%VG volume1
En effet, je veux que le volume logique utilise 100% de l'espace disponible du groupe mvg.

Puis je formate et crée un point de montage comme suit:
mkfs -t ext4 /dev/mvg/volume1
mkdir /media/stephane/volume1
mount /dev/mvg/volume1 /media/stephane/volume1
mount -a

Tout semble parfait:
- sdd et sdc n'ont pas bougé
- il apparait dans mes favoris (panneau latéral de némo) un "volume de 8 To"
- "propriétés" dans némo m'indique un espace libre de quelque 7.2 To (quelque chose comme ça)

Premier incident: avec luckybackup. Je veux rappatrier des données de mon NAS. Luckybackup trouve bien /media/stephane/volume1 mais plante ...faute d'espace disponible.
Deuxième incident: némo lui aussi ne voit pas 8To mais 4 To et m'interdit le transfert.

Je reboote, et depuis, je suis bloqué sur la fénêtre de connexion comme décrit plus haut.

Depuis une clé live usb, celle avec laquelle je vous écris, j'ai pu sans soucis transférer dans la nuit les 5 To de données depuis mon NAS.

Qu'en pensez vous ?
J'ai dû louper quelque chose qui fait un conflit dans la taille du volume logique pour mon système installé, mais pas pour la clé usb live.
Mais je ne vois pas où chercher ...

Merci de votre aide
Laurent85
Level 16
Level 16
Posts: 6862
Joined: Tue May 26, 2015 10:11 am

Re: plus de connexion session après LVM

Post by Laurent85 »

Bonjour,
Lance une vérification des systèmes de fichiers depuis un Live.

Donne les retours de :

Code: Select all

sudo blkid
sudo fdisk -l
sudo vgscan
sudo lvscan
Le contenu /etc/fstab du système aussi
Image
Post Reply

Return to “Français (French)”