Aucun périphériques audio reconnus

French Forum

Moderator: Laurent85

Post Reply
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Aucun périphériques audio reconnus

Post by LeWeeky »

Bonjour ! Depuis quelques jours mon pc ne détecte plus mes périphériques audio sous Linux Mint 19.3, j'ai testé :

Code: Select all

sudo apt-get remove --purge alsa-base pulseaudio
puis

Code: Select all

sudo apt-get install alsa-base pulseaudio
, ce fût un succès, cependant, après quelques redémarrage, le son ne fonctionnait à nouveau plus, j'ai réessayé, aucun moyen de résoudre cela, le pc détectait alors le pilote pour la prise en charge son en hdmi mais je suis sur portable !

Puis depuis hier, même l'hdmi ne s'affiche plus donc même plus d'animation quand je monte ou baisse le son étant donné que que ce soit sous haut parleur, hdmi, ou jack le pc ne détecte plus rien !
Last edited by MrEen on Thu Aug 13, 2020 7:01 pm, edited 1 time in total.
Reason: Sujet déplacé dans la section de langue appropriée
User avatar
MrEen
Level 21
Level 21
Posts: 13428
Joined: Mon Jun 12, 2017 8:39 pm

Re: Aucun périphériques audio reconnus

Post by MrEen »

Bonjour LeWeeky

Veuillez exécuter cette commande et coller la sortie afin que nous puissions avoir un aperçu de votre configuration audio:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
La dernière ligne aura une URL pointant vers les informations.
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Re: Aucun périphériques audio reconnus

Post by LeWeeky »

Bonjour, voici ce qu'il en suit : https://termbin.com/p6vq

J'ai testé quelques commandes qui m'ont permis en partie de réparer ce bug, actuellement l'audio fonctionne mais pour cela je dois brancher un jack plus le retirer
User avatar
MrEen
Level 21
Level 21
Posts: 13428
Joined: Mon Jun 12, 2017 8:39 pm

Re: Aucun périphériques audio reconnus

Post by MrEen »

Je soupçonne que l'ajout de ceci au bas de /etc/pulse/default.pa pourrait lui permettre de toujours fonctionner:

Code: Select all

set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
De plus, vous avez effectué une modification qui ne vous aide pas:

Code: Select all

options snd_hda_intel dmic_detect=0
Vous devriez probablement supprimer cela. Je peux vous aider à trouver cela si vous en avez besoin.

Il est possible que nous devions ajouter une ligne à la première, mais nous attendrons de voir comment cela fonctionne pour vous.
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Re: Aucun périphériques audio reconnus

Post by LeWeeky »

d'accord, merci d'avoir répondu je vais tenter ça de suite, je vais voir si le son fonctionne après le redémarrage
User avatar
MrEen
Level 21
Level 21
Posts: 13428
Joined: Mon Jun 12, 2017 8:39 pm

Re: Aucun périphériques audio reconnus

Post by MrEen »

Bonne chance.

Si cela ne fonctionne pas après le redémarrage, j'ai une autre suggestion à ajouter.
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Re: Aucun périphériques audio reconnus

Post by LeWeeky »

J'ai tester d'ajouter

Code: Select all

set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
dans /etc/pulse/default.pa lors que shutdown j'ai entendu un "pop" (comme lorsque l'ont branche/débranche une prise de certaines enceintes)

Je n'ai cependant pas compris que dois-je faire avec

Code: Select all

options snd_hda_intel dmic_detect=0
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Re: Aucun périphériques audio reconnus

Post by LeWeeky »

voici la fin du fichier

Code: Select all

### Make some devices default
#set-default-sink output
#set-default-source input
set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
User avatar
MrEen
Level 21
Level 21
Posts: 13428
Joined: Mon Jun 12, 2017 8:39 pm

Re: Aucun périphériques audio reconnus

Post by MrEen »

D'accord. Certaines personnes ont ces pops.

Pour faire l'autre changement, voyons la sortie de grep dmic /etc/modprobe.d/*
User avatar
MrEen
Level 21
Level 21
Posts: 13428
Joined: Mon Jun 12, 2017 8:39 pm

Re: Aucun périphériques audio reconnus

Post by MrEen »

S'il y a encore des problèmes par la suite, je pense changer le bas du fichier comme suit:

Code: Select all

### Make some devices default
#set-default-sink output
#set-default-source input
set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo
set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Re: Aucun périphériques audio reconnus

Post by LeWeeky »

Alors, il n'y a pas d'amélioration moi voici la sortie de la commande demandé

Code: Select all

/etc/modprobe.d/alsa-fix.conf:options snd-hda-intel dmic_detect=0
User avatar
MrEen
Level 21
Level 21
Posts: 13428
Joined: Mon Jun 12, 2017 8:39 pm

Re: Aucun périphériques audio reconnus

Post by MrEen »

OK, supprimez cette entrée avec sudo rm /etc/modprobe.d/alsa-fix.conf

Après cela, redémarrez puis réexécutez ceci:

Code: Select all

curl https://gitlab.freedesktop.org/pulseaudio/pulseaudio/raw/master/src/utils/pa-info?inline=false | bash | nc termbin.com 9999
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Re: Aucun périphériques audio reconnus

Post by LeWeeky »

Voici le lien du résultat : https://termbin.com/ee9p5

au passage pour resituer dans le contexte l'os en elle même (retour en mode par défaut, quoi que je fasse tout bug, les applications n'ont plus de permissions, impossible de personnalisé quoi que ce soit) tout a été plus ou moins réglé à part ça et quelque chose que je pense réglable en une seul commande :

quel que soit l'aptitude utilisé je reçois une erreur de ce type :
(exemple ci-dessous lorsque je fais apt-get update)

Code: Select all

Atteint :1 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu bionic InRelease     
Atteint :2 https://repo.skype.com/deb stable InRelease                         
Atteint :3 http://ppa.launchpad.net/webupd8team/java/ubuntu bionic InRelease   
Atteint :4 http://archive.canonical.com/ubuntu bionic InRelease                
Atteint :5 http://dl.google.com/linux/chrome/deb stable InRelease              
Ign :6 http://dl.google.com/linux/earth/deb stable InRelease                   
Atteint :7 http://dl.google.com/linux/earth/deb stable Release                 
Réception de :9 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Ign :10 https://deb.nodesource.com $ InRelease                                 
Err :11 https://deb.nodesource.com $ Release                                   
  404  Not Found [IP : 23.223.245.72 443]
Atteint :12 http://archive.ubuntu.com/ubuntu bionic InRelease            
Réception de :13 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88,7 kB]
Ign :14 http://packages.linuxmint.com tricia InRelease                         
Réception de :15 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74,6 kB]
Atteint :16 http://packages.linuxmint.com tricia Release                       
Ign :18 https://ookla.bintray.com/debian tricia InRelease                      
Err :19 https://ookla.bintray.com/debian tricia Release                        
  404  Not Found [IP : 52.36.128.157 443]
Atteint :20 https://dl.winehq.org/wine-builds/ubuntu bionic InRelease          
Lecture des listes de paquets... Fait                                          
E: Le dépôt https://deb.nodesource.com $ Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
E: Le dépôt https://ookla.bintray.com/debian tricia Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
User avatar
MrEen
Level 21
Level 21
Posts: 13428
Joined: Mon Jun 12, 2017 8:39 pm

Re: Aucun périphériques audio reconnus

Post by MrEen »

D'accord, j'espère que cela résout le problème maintenant:

Code: Select all

pacmd set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo
Vous pouvez également utiliser PulseAudio Volume Control pour résoudre ce problème dans l'onglet Configuration.

Bonne chance.
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Re: Aucun périphériques audio reconnus

Post by LeWeeky »

Cela a parfaitement fonctionné merci à vous ! (si jamais vous savez quoi faire pour les erreurs d'apt je veux bien cette dernière aide haha, les logs sont dans mon dernier message, des 404 quoi que je fasse)
User avatar
MrEen
Level 21
Level 21
Posts: 13428
Joined: Mon Jun 12, 2017 8:39 pm

Re: Aucun périphériques audio reconnus

Post by MrEen »

Je suis content que cela a fonctionné pour vous! :D

Pour les erreurs apt, je soupçonne que le second ne devrait pas avoir de "tricia" attaché.

Il peut être préférable de démarrer un nouveau thread et d'inclure la sortie de inxi -r et apt update. Cela devrait suffire pour obtenir une meilleure aide pour ce problème.
LeWeeky
Level 1
Level 1
Posts: 22
Joined: Thu Aug 13, 2020 10:43 am

Re: Aucun périphériques audio reconnus

Post by LeWeeky »

Très bien, merci encore, nous pouvons donc clore ce thread :3
Post Reply

Return to “Français (French)”